Scratchpad for M16 release notes

VERIFIED FIXED in M16

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: verah, Assigned: verah)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

19 years ago
Please put your additions and corrections for the M16 release notes here.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: --- → M16

Comment 1

19 years ago
Bug 41057 should be added to the release notes.  Mozilla needs to be installed
in a directory writeable by the user in order to work properly.  If not it will
crash on startup, leaving new mozilla users frustrated and thinking that it sucks.
bug 41090: no longer able to view a page's source.

bug 32372: unable to turn off style sheets.

bug 30813: unable to select fontsize smaller than 12.

bug 37471: download progress dialog ("Saving file") needs to be converted to new
xul widgets. it's mostly functional, but quite ugly at present.

bug 36381, Mac only: you might crash if you go to http://java.sun.com/

Comment 3

19 years ago
bug 36046 : Quicktime movies play offset from original position. No workaround.
bug 35915 : Cannot install shockwave player using mozilla. Workaround is to use 
4.x browser to install shockwave player.
bug 33105: Crash quitting browser when movie is playing. 
bug 40349: unable to go to secure pages.

Comment 5

19 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 6

19 years ago
Please add these to M16 release notes:
bug 41143: Mail compose only allows 4 addresses
Bug 39858: All platforms messenger crashes when do a File|Quit

Comment 7

19 years ago
The link to deja.com article on why Mozilla dosen't work with older versions of 
glibc is dead.(3rd paragraph of 
http://www.mozilla.org/projects/seamonkey/release-notes/)

On S.E.V. Liberman's Lists, bug 41090 has been fixed. 
bug 40349 is a dupe of bug 41680 which is fixed

Comment 8

19 years ago
bug 39423- ProfileManager- rename profile fails

Comment 9

19 years ago
Change in behavior for -CreateProfile option :

mozilla -CreateProfile has been used to create a profile and launch the browser.  
This is now changed (from M16 onwards) to create a profile and quit the 
application. This is the original behavior planned for -CreateProfile flag.
For all those who want use mozilla as tool to just create a user profile (in a 
chosen directory if wanted : regular -CreateProfile syntax). 

Another thing to note here is that the user needs to add -nosplash command line 
argument in order to avoid the spalsh screen from showing up.

Examples :

* mozilla -nosplash -CreateProfile <profileName> (create profile named 
<profileName> under default profile directory and do not display splash screen)

* mozilla -nosplash -CreateProfile "<profileName> <profileDir>" (create profile 
in the chosen directory and no splash screen).

Note : -createprofile flag is case insensitive.
bug 42058: Open Web Location dialog won't allow opening URLs in New Navigator
window.

Comment 11

19 years ago
Please delete the following notes that refer to bugs that are fixed:

----DELETE THIS----
  Under certain circumstances when you load a web page, the GFX scrollbar
  is not properly repainted, and traces of the previous position of the
  scrollbar are left behind. (bug 34218)
  
----DELETE THIS----
  If you collapse the personal toolbars at the top of the browser window,
  the toolbar will be completely hidden -- no grippy remains for you to
  expand the toolbar. Workaround: Open a new browser window or restart the
  browser to recover the grippy. (bug 35181)
  
----DELETE THIS----
  (Linux only) The "barber pole" of the progress meter sometimes paints
  outside of its boundaries, particularly if you resize the browser window
  while a page is loading. (bug 32331)
  
----DELETE THIS----
  (Linux only) In certain situations the scrollbar does not scroll the
  browser's contents. Workaround: Open a new browser window. The new window's
  scrollbars will work. (bug 26658)
  
----DELETE THIS----
  The left and right arrow keys don't scroll horizontally. Use the
  horizontal scrollbar instead. (bug 7404)

Thanks. 

Comment 12

19 years ago
Please add the following to the release notes:

----ADD THIS----
  (Mac OS 9.0) If you delete the folder 'Documents:Mozilla', which contains
  the user profiles, and restart mozilla, then user prefences, history, and
  other profile information will continue to be updated while this folder
  is in the Trash (bug 40180). If you choose to throw this folder in the
  Trash, then you should empty the Trash before restarting mozilla.
  
----ADD THIS----
  The onload handler for a FRAMESET can be fired before all the child
  FRAMES have finished loading. This may result in javascript errors for
  sites that attempt to manipulate the contents of child FRAMES from
  javascript attached to a FRAMESET (bug 30627).
  
----ADD THIS----
  The font family 'MS Sans Serif' does not work on Windows [text will be
  displayed in the default font instead] (bug 22031).
  
----ADD THIS----
  The XUL tree element does not properly clip its children to its view.
  This means that in some circumstances tables of data displayed in the
  user interface will overflow outside widget boundaries. This is a
  cosmetic defect only (bug 28244).
Here are some more release notes for Mozilla M16. I have not included any for
bugs that are likely to be fixed very soon, since there are hundreds of those...

* Standards Compliance

** HTML4

Bug 40545: The "label" attribute of the "OPTION" element is not
supported. This is unlikely to be fixed by FCS.

Bug 14445: Multiple "INPUT" buttons with the "type" attribute set to
"radio" do not work outside forms. You can work around this by placing
any radio buttons within dummy "FORM" elements. This is unlikely to be
fixed by FCS.

Bug 9100: The "dir" attribute is not yet supported in all cases. This
is unlikely to be fixed by FCS.

Bug 2055: The "compact" attribute of the list elements is not yet
supported. Support for this attribute relies on support of the CSS2
'compact' display type, and full CSS2 compliance will not be achieved
by FCS.

Bug 1995: Various metadata attributes, including "lang", "title",
"summary", "cite", "datetime", "hreflang", "longdesc", "rel" and "rev"
are not yet displayed to the user. Some of these (particularly "title"
and "summary") may be made available by FCS.


** CSS1

Bug 26039: Certain combinations of borders and backgrounds will result
in the background spilling outside the border. This is unlikely to be
fixed by FCS.

Bug 20163: The 'text-decoration' property in CSS should not apply to
elements that contain no text, but at the moment there are cases where
we do not do this correctly. This is unlikely to be fixed by FCS.

Bug 19963: Borders of differing styles look ugly at corners of boxes.
This is unlikely to be fixed by FCS.


** Quirks Mode

Bug 31932: Mozilla currently uses heuristics which look at the DOCTYPE
of the document to decide how to render the document. All XML
documents and HTML4 Strict documents are rendered as close to the
specifications as possible. Any other HTML document will be treated in
NavQuirks mode, which attempts to render the document as intended by
the author and as was done in the past, even if this is against the
specifications. This has not yet been well documented.


* User Interface

Bug 6061: Changing the bit depth (number of colours) while Mozilla is
running can cause corruption of the graphics used in the interface.
This is unlikely to be fixed by FCS.
XML section....

**REMOVE THIS**

"Simple link" based on the XLink specification is not yet implemented. (bug 
15086)


**ADD THIS**

Open Link in New Window not implemented for Simple XLink (bug 41908).

Embedding Simple XLinks not implemented (bug 39598).

Automatically fired Simple XLinks and "show link in new window" do not work in
all cases (bugs 39597 and 41772).

DOM 2: getElementById() only finds elements that are in the HTML namespace. 
Works for XUL documents, though, using the special XUL and HTML elements. Will 
probably be fixed at the same time as bug 10292.

DOM 2: document.doctype not implemented (bug 15118).

xml:lang attribute not implemented (bug 41978).
bug 41376, Mac only: when using the Installer you might encounter "error 340."
to work around this, just go thru the installer again. it might take several
attempts. ;-)

Comment 16

19 years ago
Pls. add the following:

All platforms:
HTTP 1.1 support is now fully functional and is enabled by default (this 
includes keep-alives, pipelining, content and transfer encodings/etc.). Please 
see defaults/pref/all.js for additional configurable preferenes.

Disk cache is now fully functional and is enabled by default.

Comment 17

19 years ago
Bug 41260: Takes two clicks to get ADD button to highlight in Sidebar. 
Workaround: Summary itself is the workaround.
bug 37243: unable to open URL from History tool. recent regression.

Comment 19

19 years ago
My bad. I should have added this note (it's fixed in the trunk, but not in the 
M16 branch; it's quite harmless, just ugly). 

-------ADD THIS---------
http://bugzilla.mozilla.org/show_bug.cgi?id=37766
 When you collapse both the personal toolbar and the navigation toolbar at the 
top of the browser, or collapse the taskbar toolbar at the bottom of the 
browser, the collapsed height is 50px. Workaround: use 'View->Toolbars' menu
item to completely hide these toolbars instead of collapsing them (bug #37766).
Can this be added:

Mozilla M16 often crashes on XHTML pages served as text/html (bug 39520).
Setting `ENABLE_STRICT' to `1' in your environmen before running mozilla avoids
these crashes. This is fixed in M17.

We have been getting various bug reports on this in m16.

thanks

Comment 21

19 years ago
Where is says 'Use the Full Circle builds' on the first page of the release 
notes it mentions the M15 Milestone.  Should be changed to M16.

Also, just a thought.  Maybe move the 'READ THIS Before You Install' section to 
the top as a lot of people are complaining about crashes and the cause was that 
they didn't delete their old profile.  Maybe even go so far as to put a small 
notice on the milestone download page about removing old registries and 
profiles.

Comment 22

19 years ago
Cryptographic Functionality

Bug 36007: If you experience a crash while trying to install PSM, make sure 
that you have write permissions to the directory where you installed mozilla.

Comment 23

19 years ago
After building M16 MOZ_DEBUG=1 on WinNT 4.0 SP3 with MSVC++ 6.0 SP3 it won't 
run unless I 

touch 
D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\chrome\skins\modern\communicator\skin\m
enu.css.

Comment 24

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 25

19 years ago
Marking Resolved/Fixed.  The release notes for M16 are posted.  Will leave for 
verah to marke Verified.  need to confirm that we are done here.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

19 years ago
Verified. On to the next one!
Status: RESOLVED → VERIFIED

Comment 27

19 years ago
Sorry to reopen, but the following text was removed from the release notes, and
should should be put back (people are still susceptible to this bug):
(1) if they don't have msvcirt.dll and try to run from the .zip installation
(2) the installer is fixed in current builds, but the M16 installer does not
    fix this problem (but ssu has suggested a method to leaf to get this to 
    work, so that people don't need to get PR1 and then install M16).


----ADD THIS----
Windows: You must have msvcirt.dll installed on your system. Workaround: 
install Netscape 6 PR1, which adds this dll, and then install M15. (bug 27601)
----------------

(Assignee)

Comment 28

19 years ago
CC: Sammy -- can you add this back in to the M16 release notes?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.