Closed Bug 680164 Opened 9 years ago Closed 6 years ago

Several subtests in test_reftests_with_caret.html fail on Windows

Categories

(Core :: Layout, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 961919
mozilla9

People

(Reporter: jgriffin, Assigned: ehsan)

References

Details

Attachments

(3 files)

Due to a bug in this test, failures in this test were not being reported in TBPL, perhaps since as long ago as 2010-11-23.  This problem was fixed in bug 678420, which allowed these other problems to become visible.

There are three subtests which nearly always fail on Win 7 opt:

Reftest http://mochi.test:8888/tests/layout/base/tests/bug613807-1.html FAILED
Reftest http://mochi.test:8888/tests/layout/base/tests/bug646382-2.html FAILED
Reftest http://mochi.test:8888/tests/layout/base/tests/bug664087-2.html FAILED

There are additional failures which are intermittent:

Reftest http://mochi.test:8888/tests/layout/base/tests/bug646382-1.html FAILED
Reftest http://mochi.test:8888/tests/layout/base/tests/bug597519-1.html FAILED

and possibly others.

The patch for bug 678420 was backed out until this is addressed in order to avoid a perma orange.  I'd like to comment out the always-fail subtests, file bugs for them and for the intermittent failures, so I can land the patch for bug 678420 again.  Until we do that, all failures in this test case are invisible.
Comment on attachment 554143 [details] [diff] [review]
comment out perma failing tests until they're fixed

r=me if you file one bug for each of these failures, CC me on them, and mark each test with the corresponding bug.  Sorry for the total mess.  :(
Attachment #554143 - Flags: review?(ehsan) → review+
Depends on: 680574
Depends on: 680577
Depends on: 680578
Depends on: 680579
Duplicate of this bug: 679924
Depends on: 680581
Subtests bug613807-1.html, bug646382-2.html, and bug664087-2.html disabled in http://hg.mozilla.org/mozilla-central/rev/6009974c1e1c, and bugs filed.

Bugs have been filed for the intermittent failures as well, but those haven't been disabled.

I'll land bug 678420 again on Monday, when I have time to watch the tree.
Depends on: 681032
Depends on: 681035
Depends on: 681038
Depends on: 681076
Depends on: 681138
Depends on: 681144
Depends on: 681146
Summary: Several subtests in test_reftests_with_caret.html fail on Win 7 opt → Several subtests in test_reftests_with_caret.html fail on Windows
Depends on: 681152
Depends on: 681162
Depends on: 681167
Depends on: 681331
Depends on: 681332
Depends on: 681334
This should look familiar, since I copy-pasted your xpcomabi :)
Attachment #555566 - Flags: review?(jmaher)
A little tough to stomach disabling this many on every platform just for one problem OS, so I made the test a little less pretty to be able to only skip them on Windows.
Attachment #555569 - Flags: review?(ehsan)
Attachment #555566 - Flags: review?(jmaher) → review+
Attachment #555569 - Flags: review?(ehsan) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/656f7fbcdb12
http://hg.mozilla.org/integration/mozilla-inbound/rev/9225d92382b8

Not entirely sure whether this is a tracking bug that happened to get some disabling patches in it, and should stay open when those merge, or a "Disable the tests that are failing and file bugs on them" bug and it should be closed.
http://hg.mozilla.org/mozilla-central/rev/656f7fbcdb12
http://hg.mozilla.org/mozilla-central/rev/9225d92382b8

As per comment 8, not sure if this should remain open or not, please close if more appropriate.
Target Milestone: --- → mozilla9
Depends on: 682836
Depends on: 682837
Depends on: 683042
Depends on: 683048
No longer depends on: 683042
Depends on: 683163
Depends on: 688575
Depends on: 689435
Blocks: 746993
Assignee: nobody → ehsan
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961919
You need to log in before you can comment on or make changes to this bug.