[Linux] Lightning 2.6 + Thunderbird 24.0.1, Lightning 2.6.1 + Thunderbird 24.0 not working [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found]

RESOLVED FIXED

Status

defect
--
blocker
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: walts48, Unassigned)

Tracking

Lightning 2.6
All
Linux
Dependency tree / graph

Details

(Whiteboard: [workaround:install TB24.0], )

Updated Thunderbird to 24.0.1.

Restarted Thunderbird.

Downloaded a fresh version of TB 24.0.1, created a new profile, configured email, installed Lightning 2.6, and restarted Thunderbird.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.0.1
Application Build ID 	20131010053258

Thunderbird opened and the Today pane and calendar had no data, couldn't change views, and there are two tool bars.

Failed to load native module at path '~/.thunderbird/canixawi.test/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) ~/applications/thunderbird/libxul.so: version `xul24.0' not found (required by ~/.thunderbird/canixawi.test/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so)
Also experiencing same problem, Same screenshot. Here's the console.  

roger@rogerhp:~$ thunderbird
[calBackendLoader] Using libical backend at /home/roger/.thunderbird/y1h2640k.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical.manifest
TypeError: Components.classes[cid] is undefined
-- Exception object --
+ fileName (string) 'chrome://calendar/content/calUtils.js'
+ lineNumber (number) 22
+ columnNumber (number) 0
*
-- Stack Trace --
_calIcalCreator/<@chrome://calendar/content/calUtils.js:22
now@chrome://calendar/content/calUtils.js:385
switchToView@chrome://calendar/content/calendar-views.js:325
ltnSwitch2Calendar@chrome://lightning/content/messenger-overlay-sidebar.js:402
calendarTabType.modes.calendar.openTab@chrome://lightning/content/messenger-overlay-sidebar.js:45
openTab@chrome://messenger/content/tabmail.xml:554
oncommand@chrome://messenger/content/messenger.xul:1
roger@rogerhp:~$
Duplicate of this bug: 925840
Same issue here. Calendar is empty, toolbar shows up twice until tab is switched, can't interact in any way, since update to Thunderbird 24 and Lightning 2.6.
I'm also experiencing the same problem: I can see my calendar "[x] home" is checked (though text is greyed out) but there are no appointments nor tasks, is completely empty.

Running Debian Wheezy (64 bits) and this happened yesterday after the last update was applied (from 24.0 β†’ 24.0.1).
Same issue here. Thunderbird 24.0.1 and Lightning 2.6 on OpenSuse 12.1. Problem since last update from 24.0 β†’ 24.0.1.
Error console in Thunderbird says 

"Failed to load native module at path '/home/user/../.thunderbird/...default/extensions/{..}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) /usr/lib64/thunderbird/libxul.so: version `xul24.0' not found (required by /home/user/.../.thunderbird/....default/extensions/{..}/components/Linux_x86_64-gcc3/libcalbasecomps.so)"

My naive guess concerning this problem is that "version `xul24.0'" is now called "version `xul24.0.1'"

Is this only a problem with the Linux version?
Ditto in Debian testing (Jessie), 64-bit.
Same on 32-bit Debian testing.
Duplicate of this bug: 926057
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Lightning 2.6 not working with TB 24.0.1 [Linux] → Lightning 2.6 not working with TB 24.0.1 [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found]
Mark, Phillipp, could you take a look? Aren't the 24.0.* bugfix releases supposed to keep a stable application interface and binary interface?
Yes, I agree it should stay stable. As we will be doing a 2.6.1 release it might not be that bad though. Mark, any thoughts?
Severity: critical → blocker
Duplicate of this bug: 926165
It seems this is a platform specific issue. Using Thunderbird 24.0.1 and Lightning 2.6 on Mac works without problems.
The cause for this may be bug 809430, which added specific version dependencies. Lightning 2.6.1 requires a libxul.so that defines xul24.0.1, as Lightning 2.6 requires one that defines xul24.0.

I think the correct fix would be to change this script to define/require "xul24" for all minor versions. Otherwise we are stuck with doing one Lightning release per minor version, which will be hell for both us and the users.
I just heard on the blog that it works fine on Windows, so this is definitely a Linux-only issue.
Hardware: x86_64 → All
Is there a workaround for this bug? Is it safe to reinstall an old plugin version?
(In reply to To Ti from comment #15)
> Is there a workaround for this bug? Is it safe to reinstall an old plugin
> version?

Revert to version 24.0 of Thunderbird, at https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/24.0/
Summary: Lightning 2.6 not working with TB 24.0.1 [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found] → Lightning 2.6 not working with TB 24.0.1 on Linux [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found]
Whiteboard: [workaround:install TB24.0]
Experiencing same issue here. Running Lightning 2.6 (09/19/2013 last update) isn't displaying any calendars at all. Running TBird 24.0.1 on Linux. This is the error in the console when I try to view a calendar:


Timestamp: 10/14/2013 09:22:51 AM
Error: TypeError: Components.classes[cid] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 22



Timestamp: 10/14/2013 09:23:18 AM
Error: [Exception... "'[JavaScript Error: "Components.classes[cid] is undefined" {file: "resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js" line: 22}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1265"  data: yes]
STACK: undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1267


Updating to 24.0.0 from link above resolves problem.
Duplicate of this bug: 926291
Duplicate of this bug: 926470
I've filed bug 927073 to fix the toolkit part of this.
Duplicate of this bug: 926240
I see there is a 2.6.1 version of lightniong since Oct. 13th. Is it Ok to install it with TB 24.0.1 ?
Just for the record, 2.6.1 works fine with 64 bits Thunderbird builds and also with those which are localized (ie., using a language other than English). I say this because is hard to find updated documents about this and the few I found seem to be pretty outdated (section "Extensions and themes"):

http://kb.mozillazine.org/64_bit_builds
Hello, I see the same problems with 2.6.1 and Thunderbird 24.0. So I had to rollback to 2.6.0.
In case you did not click the launchpad link above, here my "me too":

As of today, Ubuntu Saucy is still shipping Thunderbird 24.0.0. But the extentions are of course updated nevertheless.

That left me with a Thunderbird 24.0.0 and Lightning 2.6.1 which shows exactly the same issue as running TB 24.0.1 with Lightning 2.6.0.

Manually installing TB 24.0.1 to my ~/opt/ fixed the problem, but it took me ages to puzzle that out.
(In reply to Daniel from comment #26)

So to summarize your findings:

Thunderbird 24.0.0 / Lightning 2.6.0 works
Thunderbird 24.0.0 / Lightning 2.6.1 doesn't work
Thunderbird 24.0.1 / Lightning 2.6.0 doesn't work
Thunderbird 24.0.1 / Lightning 2.6.1 works

There seems to be a correlation.
It works iff ('t' == 'l') where 't' is the last digit in the Thunderbird version and 'l' is the last digit in the Lightning version.
The previous comments describe the currently expected behavior. 

The Mozilla toolkit developers introduced a strict dependencies mechanism on Linux that affects extensions with binaries components like Lightning.

Therefore each Thunderbird release currently requires its own Lightning release.
Use Lightning 2.6 for Thunderbird 24.0
Use Lightning 2.6.1 for Thunderbird 24.0.1
Use Lightning 2.6.2 for the soon to be released Thunderbird 24.1

There is work going on to loosen up this dependencies mechanism but it will take some time until this patch is available in Thunderbird.
Same problem here. Have Thunderbird 24.0 on Ubuntu 12.10 64bit. Reverting Lightning 2.6.1 back to 2.6 solved the problem.
Thanks Stefan for the clarification.

I think this tight correlation between Thunderbird and Lightning versions is a real issue for linux distributions.
When Thunderbird is distributed through the package manager of the distro, and Lightning installed (and updated) through the add-on manager of Lightning, these versions do not evolve at the same speed.
At least on Ubuntu, it seems to be frequently installed like that, because the lightning ubuntu package does not include localization (this is an ubuntu-specific issue : https://bugs.launchpad.net/ubuntu/+source/lightning-extension/+bug/930589)

Upgrading to Thunderbird 24.0.1 in every distro appears to be only a temporary solution : if I understood correctly, the incompatibility should re-appear as soon as Lightning 2.6.2 is released?
I've got this on 64Bit Xubuntu 13.04 TBird 24 Lightning 2.6.1
So to clarify, what is the expected fix here?

For users that have TB24.0, and downgraded to lightning 2.6.0, say on Ubuntu 12.04 LTS,
what is the "going forward" path to remove ourselves from this workaround state?
This bug also occurred on Win7(64-bit)and was resolved by updating to TB 24.0.1 & Lightning 2.6.1.

See http://gsfn.us/t/49qoj
Summary: Lightning 2.6 not working with TB 24.0.1 on Linux [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found] → [Linux] Lightning 2.6 + Thunderbird 24.0.1, Lightning 2.6.1 + Thunderbird 24.0 not working [Failed to load native module libcalbasecomps.so: libxul.so version 'xul24.0' not found]
Duplicate of this bug: 931347
Duplicate of this bug: 931786
Duplicate of this bug: 931829
Duplicate of this bug: 931709
(In reply to fermulator from comment #32)
> So to clarify, what is the expected fix here?
> 
> For users that have TB24.0, and downgraded to lightning 2.6.0, say on Ubuntu
> 12.04 LTS,
> what is the "going forward" path to remove ourselves from this workaround
> state?

On Linux Ubuntu 12.04 there is Thunderbird 24.0.
So I've desactivate Lightning 2.6.1 and installed 2.6 from this page:
https://addons.mozilla.org/fr/thunderbird/addon/lightning/versions/?page=1#version-2.6

And desactivated too the thunderbird automatic module update ...
(In reply to Cyrille from comment #38)
> (In reply to fermulator from comment #32)
> > So to clarify, what is the expected fix here?
> > 
> > For users that have TB24.0, and downgraded to lightning 2.6.0, say on Ubuntu
> > 12.04 LTS,
> > what is the "going forward" path to remove ourselves from this workaround
> > state?
> 
> On Linux Ubuntu 12.04 there is Thunderbird 24.0.
> So I've desactivate Lightning 2.6.1 and installed 2.6 from this page:
> https://addons.mozilla.org/fr/thunderbird/addon/lightning/versions/
> ?page=1#version-2.6
> 
> And desactivated too the thunderbird automatic module update ...

That isn't a going forward path.  Think -- when TB 25.0 is released, or when lightning 2.6.2 is released...

How do users automatically get fixed onto the auto-updates train again?
Remember that not all users are computer gurus here ... I have many clients who don't know how to manage this
The versions on AMO should be fixed now, autoupdates should work as expected.
Fix for Thunderbird is in work as mentioned in comment #20 above. Until this fix is available a dedicated Lightning release must be done for each Thunderbird release. Bug 931420 should take care that you don't automatically update to an unsupported version.
For your information: If you update Thunderbird to 24.1.0 you need to install Lightning 2.6.2: https://addons.mozilla.org/thunderbird/addon/lightning/versions/2.6.2
Duplicate of this bug: 932686
Hi,
I had the same problem, and still had it with 24.1.0. Then I found this workaround which solves the problem. USE AT YOUR OWN RISK!
a. mv ~/.thunderbird in ~/.thunderbird.old
b. update thunderbird (I had to do it as root)
c. run the new version of thunderbird (as user), skipping all the suggestions to create an email account
d. install lightning (I also installed google calendar provider; you may need to reinstall more)
e. restart thunderbird
f. copied back everithing from ~/.thunderbird.old/<some random string> ~/.thunderbird to the new ~/.thunderbird/<some other random string> besides the following:
_CACHE_CLEAN_  chrome  extensions  extensions.ini  TestPilotExperimentFiles

Note that I COPIED and not MOVED them back, because in case of problems I wanted to be able to delete the new ~/.thunderbird directory without losing anything. Maybe I could have copied back some more file, but everything seems to work.
So in my opinion, there is some file left from old installs in those directories, that disturbs the new version of Lightning. Anyway, now everything works fine for me
Aere Greenway added the following comment to Launchpad bug report 1244619:

On 11/01/2013 12:25 PM, C2e9b7 wrote:
> Hi,
> I had the same problem, and still had it with 24.1.0. Then I found this workaround which solves the problem. USE AT YOUR OWN RISK!
> a. mv ~/.thunderbird in ~/.thunderbird.old
> b. update thunderbird (I had to do it as root)
> c. run the new version of thunderbird (as user), skipping all the suggestions to create an email account
> d. install lightning (I also installed google calendar provider; you may need to reinstall more)
> e. restart thunderbird
> f. copied back everithing from ~/.thunderbird.old/<some random string> ~/.thunderbird to the new ~/.thunderbird/<some other random string> besides the following:
> _CACHE_CLEAN_  chrome  extensions  extensions.ini  TestPilotExperimentFiles
>
> Note that I COPIED and not MOVED them back, because in case of problems I wanted to be able to delete the new ~/.thunderbird directory without losing anything. Maybe I could have copied back some more file, but everything seems to work.
> So in my opinion, there is some file left from old installs in those directories, that disturbs the new version of Lightning. Anyway, now everything works fine for me
>
Thank you for taking the time to give me this information.

I may resort to doing it that way.

I currently don't use the calendar feature a great deal, so I'm hoping 
within a month or two there will be an update from the repository that 
will fix it.

If it goes too long, I will make good use of the excellent information 
you took the time to put together and send me.

-- 
Sincerely,
Aere



-- 
http://launchpad.net/bugs/1244619
I'll inform you that the newer update Thunderbird 24.1.0 with Lightning 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been fixed. I recommend giving it a try.
Aere Greenway added the following comment to Launchpad bug report 1244619:

On 11/02/2013 12:42 PM, Daniel Giest wrote:
> I'll inform you that the newer update Thunderbird 24.1.0 with Lightning
> 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been
> fixed. I recommend giving it a try.
>
Daniel:

Thank you for alerting me to this.

I just checked my calendar, and everything is working again, as if 
nothing ever went wrong.

As I recall, I applied updates yesterday, noticing no changes, but the 
next time I booted, I got a reminder for an event that had passed last 
week.

I was busy at the time, so I just dismissed the reminder, but it was 
definitely an indication that things had changed.

As far as I can tell, the problem is now fixed.

Many thanks to all the people who made this happen.

-- 
Sincerely,
Aere



-- 
http://launchpad.net/bugs/1244619
Nice work guys, thanks!! I just updated to Tbird 24.1.0 and Lighting 2.6.2 and all is working again.
Hi Guys! 
Was just reading this post... STill i have a related problem using TB 24.1.0 and Lightning 2.6.2: When i install Lightning the next start of TB will lead to a total freeze in TB. When i deactivate Lightning in the TB safe mode, TB alone works fine, but with Lightning it freezes every time i start TB. Any help?

(Using Opensuse 12.3. i586)
Total freeze doesn't sound like this bug. Could you try with a new profile? Please don't post results on this bug though, either email me or use the blog comments.
(In reply to Daniel from comment #46)
> I'll inform you that the newer update Thunderbird 24.1.0 with Lightning
> 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been fixed. I
> recommend giving it a try.

Worked for me.
Blocks: 922777
Yet I'm experiencing the same issue again using TB 24.1.1 and L 2.6.2
Same here (ArchLinux, 64-bit, TB 24.1.1 and L 2.6.2).
(In reply to mment #52 and comment #53)

Lightning 2.6.3 compatible with Tb 24.1.1 has been already released on AMO.
Hi,
updated to Thunderbird 24.1.1 and Lightning 2.6.3 and had the same problem again. This time I just deleted the content of 
~/.thunderbird/random.string/extensions
reinstalled Lightning and everything was ok again. In the next days, if I'll have enough time, I will recover the the content of the directory from the backups and see what changed.
As far as i got to know i did also the copying procedur and lightning works, but when i install the Provider for google calendar addon tb hangs. So it seems it has to do with the other addon Provider for google calender!
In fact, I'm also using the google calendar addon. By removing the extensions directory content, I removed both, and then reinstalled both (without losing the configuration)
Problem still here.
I'm using Thunderbird 24.1.1 and Lightning 2.6.3 on a Ubuntu 12.04 (precise) 64-bit maschine and the problem still persists, the terminal gives the error message:
[calBackendLoader] Using libical backend at /home/jakob/.thunderbird/we61f6e6.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical.manifest
Error: TypeError: aListener.onOperationComplete is not a function

Removing extensions and re-installing didn't solve the problem...

Will this be fixed with the next lightning version?
No longer blocks: 922777
I'm using seamonkey 2.22.1 and Lightning 2.6.3 - same error:
Failed to load native module at path '/home/me/.mozilla/seamonkey/ezstlpc4.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) /usr/lib64/seamonkey/libxul.so: version `xul24' not found (required by /home/me/.mozilla/seamonkey/ezstlpc4.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so)

All Seamonkey components are working correctly and all other extensions are working. Only affects Lightning.
Jacek, SeaMonkey 2.22.* requires Lightning 2.7.* - unfortunately there is no 2.7 build available that is compatible to SeaMonkey 2.22.1. Lightning 2.7b1 only works with SeaMonkey 2.22. See Bug 941217. The next SeaMonkey Beta build should contain the fix.
Stefan, I had Seamonkey 2.21 before I upgrade and there was exactly the same error. It is why I upgraded to Seamonkey 2.22.1.
So could you suggest which versions Seamonkey and Lightning are working together correctly?
Lightning 2.8b1 isn't working with SeaMonkey 2.23. Has the same look as the screen shot for this bug, but not the error message.

I do see several calendar errors in the SM error console.

Timestamp: 12/13/2013 11:11:00 AM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 496

Timestamp: 12/13/2013 11:11:00 AM
Error: TypeError: Components.classes[cid] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/wls15202/.mozilla/seamonkey/w97glyp9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 22

Timestamp: 12/13/2013 11:11:00 AM
Error: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/wls15202/.mozilla/seamonkey/w97glyp9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDateTimeFormatter.js
Line: 25

Timestamp: 12/13/2013 11:11:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 98
Lightning 2.8b1 doesn't work with SeaMonkey 2.23 because it was not rebuild after landing the two fixes for Bug 927073. According to objdump the file libcalbasecomps.so still depends on "xul26.0" but the fixed libxul.so shipped with SeaMonkey announces only "xul26".

A later Lightning 2.8b1 test build doesn't show the problem anymore. I tested the one from <https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-beta-linux/1386568018/> build on 09-Dec-2013.

In my opinion a Lightning 2.8b2 release would be required to support SeaMonkey 2.23 on Linux.
thunderbird-lightning-2.6.2-3.fc19.x86_64
thunderbird-24.2.0-2.fc19.x86_64


And I see the issue!
(In reply to udo from comment #64)
You are using an old Lightning release supporting an old Thunderbird release. Please upgrade to Lightning 2.6.4 and retest.
downgrading to thunderbird 24.1.0 does also help.
(In reply to udo from comment #64)
> thunderbird-lightning-2.6.2-3.fc19.x86_64
> thunderbird-24.2.0-2.fc19.x86_64

Udo, you can get:

  thunderbird-24.2.0-2.fc19.x86_64
  thunderbird-lightning-2.6.4-7.fc19.x86_64

from updates now, which fixes this issue (for me anyway).
(In reply to Bill McGonigle from comment #67)
> Udo, you can get:
> 
>   thunderbird-24.2.0-2.fc19.x86_64
>   thunderbird-lightning-2.6.4-7.fc19.x86_64
> 
> from updates now, which fixes this issue (for me anyway).

Works for me too. Thanks!
Depends on: 927073
Target Milestone: --- → 1.9
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: 1.9 → ---
Duplicate of this bug: 887160
Duplicate of this bug: 968115
My system:
Ubuntu 14.04
Thunderbird 31.7
lightning 3.3.3

A couple of days ago, after updating thunderbird, the caldav calender and tasks do not work any more, same error as described by Daniel:

"Same issue here. Calendar is empty, toolbar shows up twice until tab is switched, can't interact in any way, since update to Thunderbird 24 and Lightning 2.6."

For each calendar the error console shows:
Timestamp: 01.06.2015 01:32:37
Error: [Exception... "[JavaScript Error: "Components.classes[cid] is undefined" {file: "resource://calendar/modules/calUtils.jsm -> file:///media/Daten/Mozilla/tb/9bfub35h.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js" line: 17}]'[JavaScript Error: "Components.classes[cid] is undefined" {file: "resource://calendar/modules/calUtils.jsm -> file:///media/Daten/Mozilla/tb/9bfub35h.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js" line: 17}]' when calling method: [calIObserver::onLoad]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///media/Daten/Mozilla/tb/9bfub35h.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1212"  data: yes]
STACK: undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///media/Daten/Mozilla/tb/9bfub35h.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1214
You need to log in before you can comment on or make changes to this bug.