Closed Bug 802882 (html5test) Opened 7 years ago Closed 4 months ago

[meta] Improve score on html5test.com

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dbaron, Unassigned)

References

(Depends on 21 open bugs, Blocks 1 open bug, )

Details

(Keywords: meta)

Attachments

(1 file)

This bug exists to track things we can do to improve our score on http://html5test.com/ , the source of which exists at https://github.com/NielsLeenheer/html5test/ .

While presence in this test doesn't necessarily change the priority of our work, it is interesting enough to track.
Depends on: 631218
No longer depends on: 80713
Depends on: 760140
This should also depends on bug #344614.
(In reply to Fabio from comment #3)
> This should also depends on bug #344614.

I think it already has all the individual dependencies marked, so we don't also need to depend on the meta-bug for HTML5 forms (which depends on other things that aren't relevant to html5test.com).
(In reply to David Baron [:dbaron] from comment #4)
> (In reply to Fabio from comment #3)
> > This should also depends on bug #344614.
> 
> I think it already has all the individual dependencies marked, so we don't
> also need to depend on the meta-bug for HTML5 forms (which depends on other
> things that aren't relevant to html5test.com).

At least 446510 is still missing.
I had bug 773205 instead, but that indeed looks like a duplicate of bug 446510.
Depends on: 446510
No longer depends on: 773205
Depends on: 825294
Files bug #828974 which is related to this tracking bug.
Depends on: 828974
Depends on: 833385
No longer depends on: 891287
There's a new version coming (http://beta.html5test.com/) that adds many new tests like WebRTC and WebGL2.
I don't know how to add dependencies with this new Bugzilla interface, these are the ones I found for the new version of the test:
Bug #493857 (Security/CSP)
Bug #600919 (2D/WebP)
Bug #750010 (P2P/WebRTC on Android)
Bug #778617 (Video/Media Source extensions)
Bug #833023 (Video/VP9 Support)
Bug #878828 (Input/Gamepad)
Bug #889977 (3D/WebGL 2)
Bug #910138 (2D/Ellipse)
Bug #923590 (Video/DRM Support (not!) )

I couldn't found bugs for Audio/Speech Recognition, Video/Codec Detection, 2D/Path, 2D/Dashed Line, 2D/Hit Testing, 2D/High Resolution, Security/Web and Cryptography API.
You may not have the permissions to make these changes. You only can add dependencies while you create a new one.
May be it make sense to create a separated tracking bug for the new test?
(In reply to sjw from comment #10)
> May be it make sense to create a separated tracking bug for the new test?

No real need for a new tracking but since beta.html5test.com will become html5test.com
2D/High resolution as currently tested is going away, so no bug needed here: http://lists.whatwg.org/htdig.cgi/whatwg-whatwg.org/2013-September/040735.html

Bug filed: https://github.com/NielsLeenheer/html5test/issues/286
The developer just confirmed [1] that DRM support does not change the score, so Bug 923590 (and related) should not be tracked by this bug. If this ever changes in the future, we can add it back. 

[1] https://github.com/NielsLeenheer/html5test/issues/287
Canvas Path is Bug 830734. Dashed support is Bug 768067 (and/or one of the bugs I mentioned in Bug 768067 Comment 7). 

I linked some discussions about the features here: https://github.com/NielsLeenheer/html5test/issues/287#issuecomment-26158091 – so there may be changes coming up. I voted for not counting these, too, which would make the bugs uninteresting for this bug.
(In reply to Alexandre Folle de Menezes from comment #9)
> I couldn't found bugs for […] Video/Codec Detection

That's Bug 884275. Please add as dependancy.


Enough bugspam for now, sorry!
No longer depends on: 923590
Depends on: 884275
Often at beta.html5test.com I get the Javascript message "Test has failed: Permission denied to access property 'encrypt'" and no score. Usually takes several page refreshs until everything works fine.

I observed this with versions 24.0 up to 27.0, all on Linux64 (though not necessarily limited to Linux64). This doesn't seem to occur with other browsers though, so I assume it's some imperfect feature implementation in Firefox, which I don't know.
(In reply to Markus Popp from comment #16)
> Often at beta.html5test.com I get the Javascript message "Test has failed:
> Permission denied to access property 'encrypt'" and no score. Usually takes
> several page refreshs until everything works fine.
> 
> I observed this with versions 24.0 up to 27.0, all on Linux64 (though not
> necessarily limited to Linux64). This doesn't seem to occur with other
> browsers though, so I assume it's some imperfect feature implementation in
> Firefox, which I don't know.

It's filled as: https://bugzilla.mozilla.org/show_bug.cgi?id=927901
Per https://github.com/NielsLeenheer/html5test/issues/297, moar dependancies (this is not yet visible on the test page).
Depends on: 897102
Tom's Hardware Guide's "Web Browser Grand Prix" (tracking bug 933949) includes html5test.
Blocks: WBGP
No longer blocks: WBGP
Blocks: WBGP
Depends on: pointerevent
How about #693083 and #966591?
Bug 693083 / CSS Selectors Lvl 4 is not tested by HTML5Test.
Depends on: 966591
Depends on: datetime
I've set up Win 8.1 x64 Enterprise Eval as a VM with VMWare and installer Firefox Aurora and later Firefox Beta to see, how the results on html5test.com will improve in a future version.
However: The result is actually 447 points in both, which is 1 point less, than the current release version. Can anybody tell me, what went wrong?

UA: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Christian: the html5test results page shows a break down of the individual features, so you should be able find the regression by comparing the subsections' points.

On OS X, however, I don't see a regression:

* Firefox 28 = 448
* Firefox Beta 29 = 467
* Firefox Aurora 30 = 467
* Firefox Nightly 31 = 475
* Chrome 34 = 505
(In reply to Chris Peterson (:cpeterson) from comment #26)
> * Firefox Nightly 31 = 475
> * Chrome 34 = 505

Are there plans to implement the missing form input types, especially the date/time types, any time soon? That should lift Firefox's score up to about where Chrome is now.
(In reply to Christian Stadler from comment #25)
> I've set up Win 8.1 x64 Enterprise Eval as a VM with VMWare and installer
> Firefox Aurora and later Firefox Beta to see, how the results on
> html5test.com will improve in a future version.
> However: The result is actually 447 points in both, which is 1 point less,
> than the current release version. Can anybody tell me, what went wrong?

Are you sure you have the latest versions installed? My results on Win7 (32-bit):

Firefox 28 = 444
Firefox Beta 29 = 463
Firefox Aurora 30 (2014-04-22) = 463
Firefox Nightly 31 (2014-04-22) = 475

(In reply to Markus Popp from comment #27)
> (In reply to Chris Peterson (:cpeterson) from comment #26)
> > * Firefox Nightly 31 = 475
> > * Chrome 34 = 505
> 
> Are there plans to implement the missing form input types, especially the
> date/time types, any time soon? That should lift Firefox's score up to about
> where Chrome is now.

You may want to follow bug 888320 and related ones. Though from having a look at their history it doesn't seem there was big progress on them lately.

Sebastian
(In reply to Chris Peterson (:cpeterson) from comment #26)
> Christian: the html5test results page shows a break down of the individual
> features, so you should be able find the regression by comparing the
> subsections' points.
> 
> On OS X, however, I don't see a regression:
> 
> * Firefox 28 = 448
> * Firefox Beta 29 = 467
> * Firefox Aurora 30 = 467
> * Firefox Nightly 31 = 475
> * Chrome 34 = 505

The problem was, that firefox seems to blacklist the VMWare video driver by default.
Setting webgl.force-enabled to true in about:config fixed the issue with WebGL being disabled. Now I've got 467 points on Beta 29 and Aurora 30

See also: https://support.mozilla.org/de/questions/865633
html5test on Firefox for Android says input type=[month, week, datetime] are not supported even if they are supported. Is this an issue on their testing method, or anything missing on the Firefox for Android side?
(In reply to merihakar from comment #30)
> html5test on Firefox for Android says input type=[month, week, datetime] are
> not supported even if they are supported. Is this an issue on their testing
> method, or anything missing on the Firefox for Android side?

This should pass on Android. Which version were you testing with? Can you test again with a currently Nightly, please?
(In reply to Florian Bender from comment #31)
> (In reply to merihakar from comment #30)
> > html5test on Firefox for Android says input type=[month, week, datetime] are
> > not supported even if they are supported. Is this an issue on their testing
> > method, or anything missing on the Firefox for Android side?
> 
> This should pass on Android. Which version were you testing with? Can you
> test again with a currently Nightly, please?

It's the same in today's Nightly, see http://img.mpopp.net/fx32html5test.png
What's your result on http://modernizr.github.io/Modernizr/test/index.html, inputtypes section?
Oh, and what inputs don't work here: https://miketaylr.com/pres/html5/forms2.html
On modernizr test page only date and time input types passes the test (see screenshot).

All date/time inputs work properly on https://miketaylr.com/pres/html5/forms2.html
Please file a bug then so we can investigate this further: How do the tests determine support, and why do they fail on Android? I don't have an Android device so I can't really help there. Thanks.
Look at the code sample, this is extracted from how html5test.com verifies support for input elements (month in this example):

http://jsfiddle.net/mpopp75/YWwC6/

For some reason, on Firefox Android the element.field.type value is not month (as in this example) as one would expect.
Filed bug #1005268
Depends on: 1005268
Depends on: 1157724
Depends on: dialog-element
Component: Tracking → DOM: Core & HTML
Component: DOM: Core & HTML → General
Depends on: 1185106
Depends on: harmony:modules
Depends on: streams
Summary: improve score on html5test.com → Improve score on html5test.com
This issue is about improving the score, but some of the issues added recently do not impact the score:

    [Bug 500500] Add support for JPEG-XR/HD Photo
    [Bug 577084] Implement HTTP Live Streaming (HLS) for audio and video on Android
    [Bug 1263150] Adding native support for MPEG-DASH
    [Bug 1294490] Implement experimental WebP image support
The "About HTML5test" section of the test implies that all tested features can reward points so maybe this is just a bug. I have send an email to them to get clear of this.
Depends on: csp-w3c-2
Depends on: 1445061
Summary: Improve score on html5test.com → [meta] Improve score on html5test.com

The HTML5test website doesn't work reliably anymore. I created an issue to let Niels Leenheer, the owner of that website, know about that, but the project obviously hasn't seen any update for more than a year now.

So I am wondering whether this issue still has any value or whether it should be closed.

Sebastian

Flags: needinfo?(dbaron)

I think it still has some value, but I also don't think it matters that much whether the bug is open or closed.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(dbaron)
Resolution: --- → WORKSFORME

That said, the website does work fine for me.

fwiw my max score w/ Firefox nightly 73 is a score of 540 with these about:config flags enabled. Also, to note, privacy.resistfingerprinting set to true lowers your score a little.

anyways, setting at least some of these to true will bump up the score

dom.dialog_element.enabled (1 point)
dom.forms.datetime.others (12 points)
dom.payments.request.enabled (5 points)
dom.registerContentHandler.enabled (1 point)
media.track.enabled (4 points)
media.webspeech.recognition.enable (3 points)
and media.webspeech.test.enable

on stable you might also need to enable dom.vr.enabled and a few others but you'll have to review the html5test page

Personally, I mess with other flags that would lower it further than normal but if you don't get at least a 540 on v73 nightly you might need to review your about:support as well as the html5 test page and see what could be affecting your scores.

The max I have w/ Chrome Version 78.0.3904.108 is a score of 543 but I haven't reviewed all of the flags
the flags under chrome://flags that upped its score were these enabled:
#enable-experimental-web-platform-features
#enable-webvr

Chrome gets their bump from the Web Components: custom elements

I can also bump up my score on https://css3test.com/ enabling a few other flags

You need to log in before you can comment on or make changes to this bug.