Can't add bookmark folder from personal toolbar

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: pawel.worach, Assigned: p_ch)

Tracking

({regression, useless-UI})

Trunk
x86
All
regression, useless-UI

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:
1) right click on the "Personal Toolbar"
2) click on "New Folder..." in the context menu
3) nothing happens

This appears in the JS console:

Error: this.getBestItem is not a function
Source File: chrome://communicator/content/bookmarks/bookmarksOverlay.js
Line: 384

Comment 1

17 years ago
works for me. win98 build 2002032803.

please, always add your build id with every bug that you submit.
(Reporter)

Comment 2

17 years ago
ops, missed that. buildid: 2002040111
(Reporter)

Comment 3

17 years ago
same problem om win32 nigtly mozilla-win32.zip from 01-Apr-2002 11:58
buildid: 2002040103

js console:
Error: this.getBestItem is not a function
Source File: chrome://communicator/content/bookmarks/bookmarksOverlay.js
Line: 384

Comment 4

17 years ago
Confirming on 2002040103 on WinXP.

OS -> All
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All

Comment 5

17 years ago
confirm on win2k build 2002041711

Comment 6

17 years ago
I have a fix for this bug.  
I have a fix for bug 138523, which also fixes this bug.  I'm trying to figure
out how to check my fix in.  I'm having trouble creating a patch diff on Win
2000, any help with that would be appreciated.


Comment 7

17 years ago
*** Bug 135336 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
have you tried using windiff?
Alternatively, download a decent text editor like www.textpad.com which produces
document diffs

Comment 9

17 years ago
*** Bug 140872 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
I posted a fix patch for this bug.  See bug 138523.

Comment 11

17 years ago
*** Bug 141185 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 142761 has been marked as a duplicate of this bug. ***
*** Bug 143495 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Looks like a dup of bug 138523 by bug 143962.

Comment 15

16 years ago
This bug appears all over. I've found at least three instances [<A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=138523" TITLE="Personal
Toolbar context menu for the empty area does not work"></A>, <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=146692" TITLE="personal
toolbar folder doesn't work">bug 146692</A> and <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=147249" TITLE="New Folder...
menuitem in personal toolbar context menu is broken">bug 147249</A>]. I don't
know how to set dup's, but these are all the same - 138523 seems to be the most
all-encompassing though.

-bZj
*** Bug 150000 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

16 years ago
*** Bug 147249 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Keywords: useless-UI
To Nav triange team: we should at least remove the non-working UI, doing so
should be trivial and safe
Keywords: nsbeta1
this one is a bit worse then just not working. If you have the bookmarks sidebar
open and do "New Folder" in the personal toolbar you end up creating the folder
at the position currently selected in the sidebar. 

Comment 20

16 years ago
Nav triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
(Assignee)

Comment 21

16 years ago
taking
Assignee: ben → pierrechanial
(Assignee)

Comment 22

16 years ago
Created attachment 93628 [details] [diff] [review]
Patch v1.0

getBestItem is a remnant from bookmarksTree.js
This file should be removed (please, please r/rs bug 142236) along with
bookmarksDD.js (bug 140414)
r/sr, please.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 23

16 years ago
Comment on attachment 93628 [details] [diff] [review]
Patch v1.0

sr=blake
Attachment #93628 - Flags: superreview+
(Assignee)

Comment 25

16 years ago
nominating for the m1.0 branch
Keywords: mozilla1.0.1

Comment 26

16 years ago
Comment on attachment 93628 [details] [diff] [review]
Patch v1.0

a=asa (on behalf of drivers) for checkin to 1.1. This will need to land on the
1.1 branch as soon as it is created.
Attachment #93628 - Flags: approval+
(Assignee)

Comment 27

16 years ago
checked in by timeless on trunk and the m1.1final branch
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 28

16 years ago
*** Bug 161114 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
*** Bug 162111 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 30

16 years ago
*** Bug 163115 has been marked as a duplicate of this bug. ***
vrfy'd fixed, 2003.02.19 comm trunk builds.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.