Closed Bug 1737161 Opened 3 years ago Closed 1 year ago

[meta] Implement Site Permissions addon type

Categories

(WebExtensions :: General, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1790621

People

(Reporter: mixedpuppy, Unassigned)

References

(Depends on 8 open bugs)

Details

(Keywords: meta, Whiteboard: [addons-jira])

WebMIDI will be enabled through per-site addons.

Depends on: 1737162
Depends on: 1737163
Depends on: 1736902
Depends on: 1737165
Depends on: 1737167
Depends on: 1740634
Depends on: 1741534
Depends on: 1741544
Depends on: 1741545
Depends on: 1741546
Depends on: 1741547
Depends on: 1741750
Depends on: 1741752
Depends on: 1741908
Depends on: 1741909
Depends on: 1741963

Where can I find information about this new type of add-on? There's no information in this bug, in implementation bugs, or in JIRA. I struggle to understand how MIDI would be connected to "site permissions".

Was the content team involved at any point?

Flags: needinfo?(mixedpuppy)

There are docs linked to in the jira ticket here https://mozilla-hub.atlassian.net/browse/FIDE-605

The content team is involved, but not all the text has been passed to them yet (at the time of this comment). I'm waiting to be sure I get all the text entries I need first.

Flags: needinfo?(mixedpuppy)

Thanks, currently my main struggle is fully understanding "Site permissions", and how it fits into the current about:addons sidebar (which has categories like extensions, dictionaries, etc.).

Should it be interpreted (and translated) as "Permissions granted to specific sites", "Permissions per site", or something else completely? How is that a category at the same level of extensions, themes, etc?

(In reply to Francesco Lodolo [:flod] from comment #3)

Thanks, currently my main struggle is fully understanding "Site permissions", and how it fits into the current about:addons sidebar (which has categories like extensions, dictionaries, etc.).

Should it be interpreted (and translated) as "Permissions granted to specific sites", "Permissions per site", or something else completely?

"Permissions granted to specific sites" is an appropriate description of what these addons do, but in terms of translation I'm not sure. As an FYI I've requested a second round of thought from content on the term "Site Permissions"

How is that a category at the same level of extensions, themes, etc?

The categories are all types of addons and this is a new type as well. This type has a singular functionality: to enable a set of permissions (currently limited to webmidi) to a single specific website. It can do nothing else. Aside from "extensions" all the other categories are similar, they are addons that deliver very specific functionality rather than being general extensions.

Depends on: 1742471
Depends on: 1742478
Depends on: 1742516

Hi! We're trying to learn more about the new addon+permission stuff, but the details appear to be in Jira. Using bugzilla credentials don't seem to work. How do we access these issues?

Depends on: 1744569
Depends on: 1752359
Depends on: 1757794
Depends on: 1757795
Depends on: 1799090
Depends on: 1799401
Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1790621
Resolution: --- → DUPLICATE
Assignee: mixedpuppy → nobody
You need to log in before you can comment on or make changes to this bug.