Context Menus dont close after choosing other menu

VERIFIED FIXED in Firebird0.8

Status

()

VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: jacksmall, Assigned: hyatt)

Tracking

unspecified
Firebird0.8
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030227 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030227 Phoenix/0.5

I will simply explain the steps to the problem, it will be obvious.

Reproducible: Always

Steps to Reproduce:
1. Click Bookmarks in the menu bar
2. Browse bookmarks and select a folder (i use my imported ie bookmarks)
3. Browse bookmark folder and select a subfolder (in my case 'news').  The
contents of the subfolder should now be displayed.
4. Right click 'news' and choose manage bookmarks.

Actual Results:  
The manage bookmarks window opens.
The bookmarks menu closes
BUT
but the box showing the contents of 'news' remains open.
It remains ontop of all windows including other applications that may be opened.

Expected Results:  
The manage bookmarks window opens.
The bookmarks menu closes.
The box showing the contents of subfolder closes.

I have a screen shot which i will attach if i can.
(Reporter)

Comment 1

16 years ago
Created attachment 117020 [details]
Screenshot

Comment 2

16 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

16 years ago
Confirmed here too.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030313 Phoenix/0.5

Comment 4

16 years ago
This occurs with the Open in Tabs menu item as well. (could someone tweak the
summary?)

Comment 5

16 years ago
*** Bug 206002 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
-> Menus

Updating summary. This affects other menus as well. For example, right-click the
toolbar to show the "Customize..." menu, and then click the Bookmarks menu.
Component: Bookmarks → Menus
Summary: bookmarks sub menus dont close after choosing 'manage folder' → Context Menus dont close after choosing other menu

Comment 7

16 years ago
*** Bug 206057 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 206069 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 206138 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 206193 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 206377

Comment 11

16 years ago
I have a similar issue.  Worse though, them menu stays visible on top of
everything even after switching to another app.

An easier way to reproduce this:
1) Right-click on a web page.
2) After the context menu appears, click on any menu on the menu bar.  The menus
flash up and disappear.  The context menu incorrectly remains.
3) Switch to another window/application either by clicking on it, or clicking on
its icon on the task bar.

I'm using Win2K AS and Mozilla Firebird 0.6.  Mozilla 1.3.1 doesn't behave like
this - it behaves correctly.

Comment 12

16 years ago
The scenario from comment 11 has shown up in the main Mozilla branch as well,
bug 206919.

Comment 13

16 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030523 Mozilla
Firebird/0.6

Didn´t work with 0.6 Release, working now after installing todays nightly.

Comment 14

16 years ago
Comment 11 is WFM in 20030523 PC/WinXP but comment 1 is still broken.

Comment 15

16 years ago
i can confirm comment #1 with 20030526

this bug appears not only in a subfolder, but with the "parent" (comment #1
imported ie) folder aswell.
Try right-clicking on a folder an then move the mouse away.
The menu will stay.

Comment 16

16 years ago
About Comment #15, menus are supposed to be open until the next mouse-click.
It's when they don't that ppl file bugs like this.

Comment 17

16 years ago
Sorry about the bugspam but I left out a smiley at the end of my last comment
and it totally changed the tone.

Updated

16 years ago
No longer blocks: 206377

Comment 18

16 years ago
*** Bug 208895 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 208552 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
I have a similar problem on Windows.

  1) Click on the URL drop-down.
  2) Click on a menu button ("Bookmarks")

Problem: both menus are open at once.  It becomes very difficult to close the
URL drop-down!  You have to know to hit ESC twice, or click on a blank spot on
the web page.  Clicking on a blank spot on the menu bar does not work.

What I expected: when clicking on Bookmarks, the URL menu should close.  Only
one menu should be open at one time.

Comment 21

16 years ago
*** Bug 210892 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 213426 has been marked as a duplicate of this bug. ***
*** Bug 214131 has been marked as a duplicate of this bug. ***
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

15 years ago
Blocks: 214881

Comment 25

15 years ago
Created attachment 129537 [details] [diff] [review]
Closes open bookmark folder menus manually before dispatching a command

Do the same thing as in loadBookmarkMiddleClick().

Comment 26

15 years ago
Comment on attachment 129537 [details] [diff] [review]
Closes open bookmark folder menus manually before dispatching a command

I know hyatt's been in here recently...review?
Attachment #129537 - Flags: review?(hyatt)

Comment 27

15 years ago
The patch fixes http://bugzilla.mozilla.org/show_bug.cgi?id=210910 but this bug
still remains. However kudos goes out to hyatt for fixing that bug!
Jamez is right, we figured that out together on IRC. The weird thing is, that
this patch intended fixes bug 210910, but not bug 197112 :-|

And Jamez, the patch was not from Hyatt, it was from paxunix.

Comment 29

15 years ago
Comment on attachment 129537 [details] [diff] [review]
Closes open bookmark folder menus manually before dispatching a command

Doh!  I confused the two bugs...thanks for pointing it out.  Dropping review
request and obsoleting patch.  I've attached the patch to bug 210910 for
review.
Attachment #129537 - Attachment is obsolete: true
Attachment #129537 - Flags: review?(hyatt)

Comment 30

15 years ago
I can reproduce this with 

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030811 Mozilla
Firebird/0.6.1+

After patching with the patch I obsoleted, I can't reproduce it.  Does anyone
else notice different results when patched with this patch?  I tried with
X-Mouse functionality enabled and disabled and, with the patched version, all
menu popups always went away.  I could be missing something...
(Assignee)

Comment 31

15 years ago
--> me
Assignee: chanial → hyatt
Target Milestone: --- → Firebird0.8

Comment 32

15 years ago
After updating to build 20030811, this patch fixed both bug 210910, and Bug 197112.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030811 Mozilla
Firebird/0.6.1+

Comment 33

15 years ago
why the hell is this still not changed in firebird 0.7???

Comment 34

15 years ago
please stop spamming the bugs.

why the hell don't you write a patch instead of bitching? if you don't have
anything valuable to contribute to this bug, don't leave any comment.

Comment 35

15 years ago
*** Bug 226632 has been marked as a duplicate of this bug. ***
Looks to me like this has been fixed. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
verified fixed
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.