If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failure of notification with bookmark updates ("check this location for updates" has no effect in some cases)

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED INVALID
15 years ago
2 months ago

People

(Reporter: Jeff Mercer, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Since at least Mozilla 0.9.5 the bookmark scheduler functionality of Mozilla has
not been triggering notifications correctly. Many bugs have previously been
opened about this issue:

	bug 44282
	bug 90148
	bug 121168
	bug 118128
	bug 110914
	bug 123323
	bug 113447
	bug 126605
	bug 147029
	bug 148084
	bug 150772
	bug 160699
	bug 180989
	bug 191225
	bug 193983

In addition, the bug 107268 was opened and acted as the master tracking bug for
the issue. Bug 107268 was erroneously marked as closed as a duplicate of bug
203992. Bug 203992 is NOT the same issue, though it relates.

Notification failures include:
  o Notification never occurs
  o Notification duplicates (i.e. after initial dialog appears, keeps re-appearing)


Reproducible: Always

Steps to Reproduce:
1. Bookmark a site which frequently changes, or which you can directly update.
2. Modify the bookmark properties to alert on updates via icon change
3. Set scheduling properties to monitor from midnight to 11pm, and check every 2
minutes.
4. Update monitored website if possible.
5. Wait at least one hour.

Actual Results:  
No visual change in bookmarks icon.

Expected Results:  
Icon for bookmark should change to the icon indicating a new bookmark.

Bug 107268 was effectively orphaned by the original owner. Please do not re-open
it. This bug report should be considered the new owner of this issue, if at all
possible.

Notification problem is NOT related to profiles, bookmark file or theme used.
I've never been able to get notifications to work correctly under Windows OR
Linux with any Mozilla version you can name since 0.9.5. Yes, it worked fine
with earlier versions.

Whether there is any issues with the bookmark SCHEDULING or not should not be
the focus of this bug.
(Reporter)

Updated

15 years ago
Keywords: clean-report, nsCatFood, regression

Comment 1

15 years ago
An example:

this bookmark file:

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
<TITLE>Bookmarks</TITLE>
<H1>Bookmarks</H1>

<DL><p>
    <DT><A HREF="http://www.heise.de/newsticker/" ADD_DATE="1054380424" LAST_VIS
IT="1054380490" LAST_MODIFIED="1054380456" ICON="http://www.heise.de/favicon.ico
" SCHEDULE="0123456|0-24|1|icon,alert" LAST_PING="1054383596" LAST_CHARSET="ISO-
8859-1" ID="rdf:#$6MXsf">heise online: 7-Tage-News</A>
</DL><p>

contains only one bookmark, a well-known german IT newsticker, which frequently
changes. If you save this as bookmarks.html, the site is configured to be
checked every day, at all times, every minute, and notifications are alert, and
bookmark icon change.

Expected results: Bookmark scheduler should report a change of the site
Actual results: nothing happens

Bookmark scheduling has not worked for me in *any version* of Mozilla, and I use
Mozilla since about M18, which was releases in late 2000. 

I tried this feature using various Linuxes (SuSE 7.0, 7.1, 8.0, 8.1, Red Hat 8),
Windows versions (Windows 98, 2000) versions and different hardware. So, it is
most likely not just an error in my system setup.

Comment 2

15 years ago
I have done a bit of reading in the bugs mentioned above. Seems moszt of them
were assigned to ben@netscape.com (Ben Goodger), but it seems no wokr ever got
done...

I think that based on all the bugs above, this can be set to CONFIRMED. Earliest
reports seem to be from sometime in 2000.

I also want to add the problem is not just with the "change bookmark icon"
method, but with *any* notification method, meaning "alart", "open in new
window" and "play a sound" don't work either. I guess the problem is in the
"check for update" code and not in the "alert user" code, but that's just a guess.
(Reporter)

Comment 3

15 years ago
I've set-up a test webpage that can be used in checking the functioning of
bookmark scheduling and alerts.

The URL is http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html

Every three minutes a new, slightly different version of the webpage will be
generated. That's at 1 minute, 4 minutes, 7 minutes, etc past the hour.

Please only use this page for testing and not incessant clickety-clicking. It's
not a CGI script, it's just a plain HTML file. A cron job generates the new
versions.

Comment 4

15 years ago
I tried something I guess I could have thought of earlier: I configured my
system to open a dial-up internet connection as soon as a program tried to
access the internet, and set Mozilla to check a bookmark for updates every minute. 

The internet connection should have come online after a minute, but nothing happens.

So, Mozilla doesn't even try to ping the sites. 

(Using 1.4 RC1 here, on SuSE Linux 8.0)

Can anyone recommend any build that has this feature working?
(Reporter)

Comment 5

15 years ago
Bookmark scheduling and notification worked for me with versions as far back as
0.9.7. Those were Win32 builds running under Windows98.

Some folks have reported NOT having it work with versions as old as 0.9.5 but
i'm not sure what platforms those were on.

Comment 6

15 years ago
Thanks, I'll try 0.9.5 out again.

In the meantime, I tried the page you set up with the latest nightly, and now I
get a "this page has changed" alert every minute, even when the page has not
changed.

So, maybe some of the changes made for bug 203992 has an effect.

Comment 7

15 years ago
OK, I tried M18 and 0.9.4.

In M18, notifications didn't do anything (but it was nice to be reminded how
much faster & uglier the browser was back then ;-))

In 0.9.4, I got notifications every minute, even though the website changes only
every three minutes. When 0.9.4 was the current version, I didn't get any
notifications at all, but I was using a different Linux back then (Suse 7.1), as
well as some Windows version.

Comment 8

15 years ago
I have looked into the sourcecode a bit (this is my first attempt at actually
finding any bug in Mozilla source), and I found some interesting things.

The file we're interested in is

http://lxr.mozilla.org/seamonkey/source/xpfe/components/bookmarks/src/nsBookmarksService.cpp

I found things like:

1911     // XXX Do we need to do this?
1912     PR_NormalizeTime(&nowInfo, PR_LocalTimeParameters);

Maybe this isn't a good idea. I believe this is converting the time string to
some local time format. I noticed with recent builds (no 1.4 release candidate,
but daily builds after bug 203992 was marked fixed) I can get some servers in
the USA (like cnn.com) to fire alerts (every minute, though - it seems no
checking if page has changed is actually happening), but none in my own timezone
(Germany). So maybe we should just stop this.

More:

2070     // pick a random entry from the list of bookmarks to check
2071     PRUint32    numBookmarks;
2072     if (NS_SUCCEEDED(rv = bookmarkList->Count(&numBookmarks)) &&
(numBookmarks > 0))
2073     {
2074         PRInt32     randomNum;
2075         LL_L2I(randomNum, PR_Now());
2076         PRUint32    randomBookmark = (numBookmarks-1) % randomNum;

To just check a "randon bookmark" doesn't seem to make much sense to me. 

Anyway, I found that with setting DEBUG_BOOKMARK_PING_OUTPUT, we can get some
debug output about what Mozilla is doing with the bookmark schedule. I'll ry to
enable that flag and compile Mozilla here (will take ages on my slow machine) -
I'll let you know if I find anything.

Maybe some other person who is more familiar with Mozilla data structures can
have a look at the code. The relevant lines in the file I mentioned above seem
to be 1877 to 2148, but most likely there is relevant code elsewhere.

Comment 9

15 years ago
Hi,

I tried what I mentioned above - two problems:

1) Mozilla wouldn't compile with the mentioned flag enabled.

The problem was this line:

printf("eTag: '%s'\n", NS_LossyConvertASCIItoUCS2(eTagValue).get());

The method NS_LossyConvertASCIItoUCS2 couldn't be found, so I outcommented that
line (shouldn't be a problem, since this was just enable for debug output).

2) After this, Mozilla compiled, but when I tried to start it, I got this message:

Type Manifest File: /daten/mozilla_compile/mozilla/dist/bin/components/xpti.dat
+++ JavaScript debugging hooks installed.
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: Config file not parsed successfully: 'NS_SUCCEEDED(rv)', file
nsPrefService.cpp, line 786
Break: at file nsPrefService.cpp, line 786
###!!! ASSERTION: <platform>.js was not parsed successfully: 'NS_SUCCEEDED(rv)',
file nsPrefService.cpp, line 800
Break: at file nsPrefService.cpp, line 800
WARNING: Error occured reading cookie preferences, file nsCookies.cpp, line 164
###!!! ASSERTION: Couldn't get nsIDocumentLoader: 'Error', file
nsCookieService.cpp, line 141
Break: at file nsCookieService.cpp, line 141
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
WEBSHELL+ = 1
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(uriLoader->
GetDocumentLoaderForContext(static_cast< nsIDocShell * >(this), getter_AddRefs
(docLoader)))) failed, file nsDocShell.cpp, line 393
WARNING: NS_ENSURE_TRUE(req && baseWin && item && nav && scrollable &&
textScroll && progress) failed, file nsWebBrowser.cpp, line 1544
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(SetDocShell(docShell))) failed, file
nsWebBrowser.cpp, line 1058
WEBSHELL- = 0
WARNING: NS_ENSURE_TRUE(mDocShell) failed, file nsWebBrowser.cpp, line 736
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../../dist/include/xpcom/nsCOMPtr.h, line 691
Break: at file ../../../dist/include/xpcom/nsCOMPtr.h, line 691
./run-mozilla.sh: line 72: 30531 Segmentation fault      "$prog" ${1+"$@"}

I was using the recent nightly source, building on SuSE Linux 8.0. I've had some
compiler problems in the past, so I'll try to compile on another machine and see
what happens...

Comment 10

15 years ago
Created attachment 125192 [details]
Debug log from bookmark scheduler at work

Debug output from Mozilla illustrating what happens when the bookmark scheduler
is at work. One bookmark is never reported changed although it does change,
another is reported too often.

Comment 11

15 years ago
Hi,

I compiled the most recent CVS version of Mozilla, with enabled debug flag (this
version compiled without errors).

I set up two bookmarks, the page Jeff set up for testing and a Heise news-ticker
entry. 

I got notifications from Jeff's page every minute, although it only changes
every three minutes. The first, third and sixth notifications were correct, the
others incorrect.

From the heise page, I didn't get any updates at all, although it had changed
since the last visit. Below is the edited debug log - I removed some lines i was
sure didn't have anything to do with the issue here. I also removed some
messages coming multiple times without any other message between. The full
(unedited) debug log is in the attachment.

Lines starting with // are comments by me. 

Now, here's the interesting stuff:

Every time a change is reported wrongly, I got the message

###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436

This never happened when the change was reported correctly, so this most likely
is in some way related to the problem of false reports.

Here's the surrounding code from the reported file nsInputStreamPump:

421             if (NS_SUCCEEDED(rv) && NS_SUCCEEDED(mStatus)) {
422                 // test to see if this ODA failed to consume data
423                 if (seekable) {
424                     PRUint32 offsetAfter;
425                     seekable->Tell(&offsetAfter);
426                     if (offsetAfter > offsetBefore)
427                         mStreamOffset += (offsetAfter - offsetBefore);
428                     else if (mSuspendCount == 0) {
429                         //
430                         // possible infinite loop if we continue pumping data!
431                         //
432                         // NOTE: although not allowed by nsIStreamListener, we
433                         // will allow the ODA impl to Suspend the pump.  IMAP
434                         // does this :-(
435                         //
436                         NS_ERROR("OnDataAvailable implementation consumed no
data");
437                         mStatus = NS_ERROR_UNEXPECTED;
438                     }
439                 }

Maybe someone who is familiar with nsInputStreamPump can take a look at this?

Here's the edited log:

Document http://www.mozilla.org/start/ loaded successfully
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-159-3ee36141"'
Last-Modified: 'S'
URL has changed!
// First time checked, change reported correctly.

Document http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html loaded
successfully
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
###!!! ASSERTION:
XPConnect is being called on a scope without a 'Components' property!

This is pretty much always bad. It usually means that native code is
making a callback to an interface implemented in JavaScript, but the
document where the JS object was created has already been cleared and the
global properties of that document's window are *gone*. Generally this
indicates a problem that should be addressed in the design and use of the
callback code.
: 'Error', file xpcwrappednativescope.cpp, line 549
Break: at file xpcwrappednativescope.cpp, line 549
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-159-3ee36141"'
Last-Modified: 'S'
Content-Length: '3'
URL has changed!
// Second time checked, change reported wrongly.

we don't handle eBorderStyle_close yet... please fix me
Document http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html loaded
successfully
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-222-3ee361f5"'
URL has changed!
// third time checked, change reported correctly.

Document http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html loaded
successfully
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-222-3ee361f5"'
Last-Modified: 'S'
URL has changed!
// fourth time checked, change reported wrongly.

Document http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html loaded
successfully

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-222-3ee361f5"'
Last-Modified: 'S'
Content-Length: '5'
URL has changed!
// fifth time checked, change reported wrongly.

Document http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html loaded
successfully
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-1a0-3ee362a9"'
URL has changed!
// sixth time checked, change reported correctly.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
WEBSHELL- = 4
WEBSHELL- = 3
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
Skipping URL, its too soon.
nsBookmarksService::FireTimer - Pinging
'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
Finished polling 'http://www.heise.de/newsticker/data/jk-08.06.03-003/'
URL has not changed status.

Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'icon,alert'
Skipping URL, its too soon.
Start Hour: 0    End Hour: 24    Duration: 1 mins    Method: 'alert'
nsBookmarksService::FireTimer - Pinging
'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
Finished polling 'http://www.vaxer.net/~riffer/mozilla-explodes-with-delight.html'
eTag: '"b7c76-1a0-3ee362a9"'
Last-Modified: 'S'
URL has changed!

// seventh time checked, change reported wrongly.
(Reporter)

Comment 12

15 years ago
Thanks for all the extremely useful input Henry. Wish I had the time to do as
much, :)

Under RedHat Linux 8.0 I'm running Mozilla 1.3. I found that all the
notification methods appear to work, including the bookmark icons. However, I
see the behavior mentioned before where I get a notice about a change every time
Mozilla checks (currently set to 1 minute), even if the webpage hasn't changed.
I thought at first this was dependent on whether I visited the changed page, but
that is not the case.

Now with Mozilla 1.4RC1 under Windows 2000, the bookmark notification doesn't
work. I know for sure now it's not a theme issue, as I've used both the default
themes and the SkyPilot theme with both installations. With 1.4RC1 under Win2K I
 do get dialog pop-ups about the page change, but the same problem with it
re-notifying constantly occurs.
(Reporter)

Comment 13

15 years ago
This seems to be getting close to fixed now. I've just installed Mozilla 1.4 RC2
and did a test with the Mozilla Bookmark Scheduling Playground. After waiting a
couple of minutes, I checked my bookmarks from the Bookmarks menu and lo, a
shiny icon appeared indicating the bookmark was updated! The same is true for
the Bookmarks toolbar button.

Unfortunately, this shiny icon does NOT appear when viewing bookmarks with the
Bookmark manager. So very close...

I'll re-check all my old scheduled bookmarks, which are probably rather stale,
and see if they are working now.

Comment 14

15 years ago
Unfortunately, this bug here is not closer to be fixed than anytime in the past
18 months. What you are seeing is most likely the result of the fix for Bug
203992. But this only means you are getting notifications now, not that the
feature is working.

Testcase: Try seetting the bookmark for your testcase to a check every minute.
You'll see notifications every minute, although the page only updates every
three minutes. Same thing with http://www.cnn.com, I also get updates every minute.

Actually, I thonk there hasn't been any work done on this bug. I wish I had more
time, then I would try to compile Mozilla myself again and play around with the
debug output, my theory is there's something wrong with the string format of the
date: The debug output from some of the dates was just one letter, if you do a
"old date != new date" check on that one, you'll get a false notification every
time. However, this does not explain why I never get any notification from
http://www.spiegel.de.

If the feature is working for you, could you try to set up a bookmark to
http://www.spiegel.de with notification and check if any notifications fire?

Comment 15

15 years ago
I just installed the brand-new Mozilla 1.4 RC3, and this bug is still present -
I'm still getting notifications from the test site every minute. 
(Reporter)

Comment 16

14 years ago
In regards to the www.spiegel.de site and failure to get notifications, the
issue lies with the webserver for www.spiegel.de. Bookmark scheduling only works
when the last modification date/time for a URI document can be determined. Most
webservers return a "Last-Modified" attribute for a document if you do a HEAD
request. Example:


HEAD /~riffer/mozilla-explodes-with-delight.html HTTP/1.1
Host: www.vaxer.net

HTTP/1.1 200 OK
Date: Wed, 09 Jul 2003 03:15:47 GMT
Server: Apache/1.3.26 (Unix) PHP/4.2.3 mod_ssl/2.8.10 OpenSSL/0.9.7-beta3
Last-Modified: Wed, 09 Jul 2003 03:13:01 GMT
ETag: "b7c76-166-3f0b883d"
Accept-Ranges: bytes
Content-Length: 358
Content-Type: text/html


For some reason the webserver for www.spiegel.de does not give that attribute in
a HEAD request:


HEAD / HTTP/1.1
Host: www.spiegel.de

HTTP/1.0 200 OK
Date: Wed, 09 Jul 2003 03:22:43 GMT
Server: Apache/1.3.26 (Unix) mod_fastcgi/2.2.12
Cache-Control: max-age=120
Expires: Wed, 09 Jul 2003 03:24:43 GMT
P3P: policyref="http://www.spiegel.de/w3c/p3p.xml", CP="NOI DSP CURa ADMa DEVa
TAIi PSAi PSDi OUR STP IND UNI COM NAV INT STA PRE"
Content-Type: text/html; charset=iso-8859-15
Via: 1.1 www.spiegel.de
X-Cache: MISS from www.spiegel.de
X-Cache: MISS from lnxc-039.srv.mediaways.net


So there will never be any way for Mozilla to determine when the website last
changed. You'd have to rely on some sort of checksumming method of the actual
webpage contents.
(Reporter)

Comment 17

14 years ago
In regards to notification not functioning correctly, I've verified that with
versions as recent as 1.4RC2 that notifications are repeated every "interval"
time regardless of whether a webpage has changed in that interval or not.

Bookmark icon notification additionaly does not work when accessing the
Bookmarks manager.

And recent tests of Mozilla under MacOS X result in absolutely no bookmark icon
changes, though other notifications do work sporadically. Using MacOS 10.1.5 and
10.2.6, with Mozilla v1.4RC1

Comment 18

14 years ago
>For some reason the webserver for www.spiegel.de does not give that attribute in
>a HEAD request:

Last-modified is a completely optional response header.

>So there will never be any way for Mozilla to determine when the website last
>changed. You'd have to rely on some sort of checksumming method of the actual
>webpage contents.

Why don't you just use the cache expiration time to determine when it makes
sense to check for new content?

Comment 19

14 years ago
(In reply to comment #16)

> So there will never be any way for Mozilla to determine when the website last
> changed. You'd have to rely on some sort of checksumming method of the actual
> webpage contents.

Yes. For example, take slashdot.org's frontpage. There are a lot of changes
every minute that one usually does not care for when using that mozilla feature,
eg. the numbers of comments and so on. The user should be able to set something
like a threshold-level.

Comment 20

14 years ago
(In reply to comment #19)

I found at least a partial and very nice solution. Most update notification
problems come from large news servers like slashdot, cnn or faz.net. At least
two of them provide RSS-feeds. So why not let the user assign an RSS-feed with a
bookmark und let mozilla use the RSS-feed to check for new content? See 
http://bugzilla.mozilla.org/show_bug.cgi?id=148777#c11.

Comment 21

14 years ago
As this seems to be the main tracking bug for bookmark notification, I thought
I'd say here I've filed a bug with a fix for one of the bookmark notification
problems in bug 243679.

Comment 22

13 years ago
Just to say bug still exits in Firefox 0.9 for windows (I assume it uses the
Mozilla code).  Version Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9
(Reporter)

Comment 23

13 years ago
HOLY COW!

The icon display bug appears to be gone as of Mozilla 1.7. I've tested on two
different Windows 2000 installs with Mozilla 1.7. Not only is the new bookmark
icon displayed in the Bookmarks pulldown menu of the browser window, it is also
displayed in the Bookmarks editor.

I did note that with at least one theme, the new bookmark icon did not appear
(Smoke). That is probably because the theme uses the same resource for both
types of icons. However, proper icon is shown with the Modern theme. With the
Skypilot theme, the icon used in the Bookmark editor view is different than the
one used in the pulldown menu view. However, it does render differently.

I also tested the pop-up notification, and it seems to function correctly. I
think there's been confusion on how pop-up notices work, since people expect it
to never re-appear when they choose to NOT visit an updated website...
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 24

13 years ago
Jeff: Excellent news, and good work on resolving it as WONTFIX rather than
FIXED.  (Without knowing what fixed it, that was the correct method of handling
the bug.)  However, if anybody *can* track down the checkin that might have
fixed this it would be nice to know.  (At which point it could be re-resolved.)
 It doesn't appear to be bug 243679, since comment 22 was filed with a build
after the date of its check in - unless this is now only working with Mozilla?

Comment 25

13 years ago
BTW: I've verified this as working for me in a 6/25-08 build of Mozilla running
under XP - so it was also working over a week ago, if not earlier.

Comment 26

13 years ago
Sorry, this bug is not fixed yet - I have set up a bookmark to Jeff's test page,
and I get notifications every minute, instead of every three minutes, when the
page is updated.
(Reporter)

Comment 27

13 years ago
Henning, you need to provide information on the platform you tested with. What
version/build of Mozilla, what OS, etc. That's important for others (both
developers and testers).

Comment 28

13 years ago
Of course, sorry I forgot that.

I'm using Mozilla 1.7 final on SuSE Linux 9.1, kernel 2.6.5-7-75 (Suse standard
kernel). UA string is Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

See you,
   Henning

Comment 29

13 years ago
Just ran some tests to try and understand what's going wrong with bookmark notification and 
I've found that mozilla/firefox gives *two* notifications (no more) each time a pages updates. 
 
I've set a cron job to update the page at 
http://bigred.homelinux.org/~paulc/bookmarks/index.html every 10 minutes (slightly less 
frenetic than Jeff's test page). 
 
Bookmark this page and change bookmark settings to check "Every day", "Midnight" to 
"Midnight", every "1" minute and notification "Display alert".  Then wait.  When the page 
updates you get a notification.  Click Ok, and approximately 1 minute after accepting the 
notification you'll get a second notification even though the page hasn't changed.  Click "Okay" 
on this and you won't get any more notifications for the remaining time until the page really 
updates.  Cancelling the notifications (click on 'Cancel' instead of 'Okay') and you still get two 
notifications. 
 
I've checked this behaviour on: 
Firefox 0.9.1 (Debian testing/unstable) 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040719 Firefox/0.9.1 
 
Mozilla 1.7.1 (Debian testing/unstable) 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.1) Gecko/20040726 Debian/1.7.1-4 
 
Firefox 0.9.2 (Windows 98) 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2 
 
Firefox 0.9.2 (Windows XP) 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2 
  

Comment 30

13 years ago
> 2074         PRInt32     randomNum;
> 2075         LL_L2I(randomNum, PR_Now());
> 2076         PRUint32    randomBookmark = (numBookmarks-1) % randomNum;

Can anybody enlighten me why it's this way and not randomNum % (numBookmarks-1)
(or even randomNum % numBookmarks ?). I just don't get it.

Krzysztof
(Reporter)

Comment 31

13 years ago
I've reproduced the behavior Paul Cook describes in comment #29. Interesting.
I've verified this variant bug in:

Mozilla 1.7 under Windows 2000
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

Comment 32

13 years ago
Stumbled across another issue with bookmarks.  After running the tests above 
(comment #29) I started to get some nasty errors on the machine running Debian 
GNU/Linux, e.g.  "bash: fork: Resource temporarily unavailable" or "KLauncher 
unable to contact DCOP".  Using ps I tried to find out what was going on and 
found lots of defunct mozilla-bin jobs. 
 
e.g. ps aux | grep moz 
 
machineX     1207  0.8 16.0 176668 30852 ?      S    22:02   
0:37 /usr/lib/mozilla/mozilla-bin -UILocale en-US -ContentLocale US 
machineX     1241  0.0 16.0 176668 30852 ?      S    22:02   
0:00 /usr/lib/mozilla/mozilla-bin -UILocale en-US -ContentLocale US 
machineX     1242  0.0 16.0 176668 30852 ?      S    22:02   
0:00 /usr/lib/mozilla/mozilla-bin -UILocale en-US -ContentLocale US 
machineX     1249  0.0 16.0 176668 30852 ?      S    22:03   
0:00 /usr/lib/mozilla/mozilla-bin -UILocale en-US -ContentLocale US 
machineX     1353  0.0  0.0     0    0 ?        Z    22:23   0:00 [mozilla-bin] 
<defunct> 
machineX     1360  0.0  0.0     0    0 ?        Z    22:24   0:00 [mozilla-bin] 
<defunct> 
machineX     1367  0.0  0.0     0    0 ?        Z    22:25   0:00 [mozilla-bin] 
<defunct> 
 
... and so on approximately every minute ... 
 
machineX     1724  0.0  0.0     0    0 ?        Z    23:12   0:00 [mozilla-bin] 
<defunct> 
machineX     1736  0.0  0.0     0    0 ?        Z    23:14   0:00 [mozilla-bin] 
<defunct> 
machineX     1737  0.0  0.0     0    0 ?        Z    23:14   0:00 [mozilla-bin] 
<defunct> 
machineX     1746  0.0 16.0 176668 30852 ?      S    23:15   
0:00 /usr/lib/mozilla/mozilla-bin -UILocale en-US -ContentLocale US 
machineX     1751  0.0  0.3  3100  584 pts/0    S+   23:15   0:00 grep moz 
 
I guessed from their frequency that they were to do with bookmark notification.  
I'd left a mozilla bookmark still checking my test page every minute (set to only 
change the icon).  I closed mozilla to clear the defunct processes and restarted it 
immediately turning notification off on all bookmarks.  Over the next 20 minutes no 
defunct children appeared.  Then I started notification checking every minute and 
they began to appear.  It looks like the bookmark code isn't reaping its children. 
 
I'm currently running 'Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) 
Gecko/20040810 Debian/1.7.2-2' on 'Debian GNU/Linux 2.4.20 i686 
testing/unstable' 
 
To Reproduce:  
(i) start mozilla on a linux box 
(ii) bookmark any web page; set bookmark notification to Everyday, Midnight to 
Midnight, every minute 
(iii) sit back and wait 
(iv) type 'ps aux | grep moz' to see mozilla processes 

Comment 33

13 years ago
Im curious to know why this bug is marked as "RESOLVED/WORKS FOR ME", when 
scheduled bookmarks still arent working: Bug 266723

Additionally, bug 216319 says that pch fixed this problem back in Aug 2003.

Im confused ...

Comment 34

13 years ago
*** Bug 266723 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 35

13 years ago
*** Bug 248019 has been marked as a duplicate of this bug. ***

Comment 36

13 years ago
I'm afraid the WORKSFORME resolution is incorrect. Bookmark notifications
clearly *do not* work for many us:

Bug 207814
Bug 216319
Bug 216659
Bug 248019
Bug 267452

Re-opening.

Prog.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

13 years ago
Summary: Failure of notification with bookmark updates → Failure of notification with bookmark updates ("check this location for updates" has no effect in some cases)

Comment 37

13 years ago
In my environment (Windows98SE, Mozilla 1.7.5), bookmark update check does not
work also.

Comment 38

13 years ago
Not directly relevant to this bug but for the random person looking into why
bookmarked page change notification isn't happening for him and thinking the
answer might lie in this bug:

If your clock was at some point set into the future (to time T, say a time in
2006 when it should be 2005) when you run the browser, it will change the date
of when a bookmark was last checked to that date in the future.  If you correct
your clock, you won't get any notification of changed pages until you pass time T.

At least this is the way that it seemed to happen to me.  To fix it for
yourself: Shut down the browser, edit your bookmarks file, find the LAST_PING
bookmarks, and set the LAST_PING (and LAST_VISIT) times to be the same as
ADD_DATE (assuming your clock wasn't messed up when you added the bookmark).


Suggestion for the code to avoid this ugliness:  If the current browser time is
earlier than the LAST_PING (perhaps by more than some delta?), then check the
page (resetting LAST_PING).   If the current browser time is in the real past
(for example, some time in 1904 (due to dead battery), rather than the previous
LAST_PING time being in the real future), then all you've done is an extra query
on the page.  


By the way, Mozilla 1.7.6, Mac OSX, still has the double notifications when a
page changes.

Comment 39

13 years ago
Seems to be the bookmark schedular is absent in Firefox, and therefore I fear no
work will be done on this, as the Suite seems dead :-(

Henning
(Reporter)

Comment 40

13 years ago
The bookmarks scheduler doesn't exist in Firefox, however there's an extension
called Bookmarks LinkChecker that does a fair job of replacing it. Doesn't offer
all the nice notification options, but it'll at least let you audit your bookmarks.

http://www.extensionsmirror.nl/index.php?s=79eb8582dd8fea328ca60cef8678f31b&showtopic=14

Comment 41

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
Status: REOPENED → NEW

Comment 42

5 years ago
Unfortunately, bookmarks update check is no longer present in SeaMonkey making this bug obsolete, so closing.
Status: NEW → RESOLVED
Last Resolved: 13 years ago5 years ago
Resolution: --- → INVALID
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.