Last Comment Bug 2654 - localPath(change of Server Settings/Local directory) does not take effect until restart
: localPath(change of Server Settings/Local directory) does not take effect unt...
Status: RESOLVED WORKSFORME
[resolved by bug 224831]
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: All All
: P2 normal with 10 votes (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 209585 222646 263195 288417 298326 308476 349335 359905 376347 739077 (view as bug list)
Depends on: 224831
Blocks: 339564
  Show dependency treegraph
 
Reported: 1999-01-26 15:13 PST by lchiang
Modified: 2016-03-03 13:35 PST (History)
27 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description lchiang 1999-01-26 15:13:57 PST
<Contents pasted from bugsplat bug 311903.>

Customer is Paul Carroll (paul.carroll@east.sun.com)

The customer views the lack of notification that preferences set in Mail &
Groups, Mail Server do not take effect until Communicator is restarted, as a
bug, because the behavior differs from that on PC.

Additional Details :
When you change the "Local mail directory" or the "IMAP4 mail directory" in
Edit-> Preferences-> Mail&Groups-> Mail Server, the change does not take effect
until the next time you start Navigator.  However, no message is given at
Navigator must be restarted for this change to take effect on Solaris.  The PC
version of Navigator 4.5 does give this notice.
To reproduce:
1) Bring up the Preferences dialog from the Edit
menu in Navigator
2) Go to the Mail&Groups-> Mail Server section
3) Click More Options
4) Change local mail directory to another directory with different mail folders/
directories, click OK
5) Go to Mail&Groups -> Messages and look at the 'Automatically copy outgoing
message to folder, Mail Messages:' list box, its contents (the items in the
drop-down list) should not have changed.
6) Exit Netscape and restart.  Go to the location in the last step and look at
the drop-down list again, it should now reflect the changes you made in step 4.
Comment 1 leger 1999-02-03 08:08:59 PST
Setting all current Open/Normal to M4.
Comment 2 lchiang 1999-02-09 10:54:59 PST
This may no longer apply in 5.0, but we'll check it once we have a product to
test.
Comment 3 Phil Peterson 1999-03-22 16:22:59 PST
Improved bug summary. Assigning to scottip since I think the right thing is for
the data source to catch this pref changing and rebuild the RDF graph.
Comment 4 scottputterman 1999-05-31 14:51:59 PDT
reassigning to alecf.  I doubt this will be fixed for M7 so I'm going to remove
the taget mileston.  I think the underlying design of this will be similar to
what you have to do for rename server/account assuming we keep that in.
Comment 5 Alec Flett 1999-05-31 16:45:59 PDT
oh goodness. This is going to be ugly. I'd kind of like to force a restart of
messenger for this to work. (We can restart messenger without restarting the
browser)
Comment 6 sol 1999-08-12 12:07:59 PDT
Spoke to AlecF about this - this bug affects all platforms and is hard to fix.
OK to fix this bug after PR1, but we will need to describe this behavior in
release notes.
Comment 7 Alec Flett 1999-09-07 22:36:59 PDT
This requires some architecture changes that I've been working on for a while.

I'm pushing this past PR1 because not all the architecture will land by PR1, and
even so I'm still not sure if this is really possible.
Comment 8 Alec Flett 2000-04-12 16:29:56 PDT
moving non-critical bugs to M20
Comment 9 lchiang 2000-06-07 22:49:11 PDT
Moving target milestone to "future" to be reviewed at a later time
Comment 10 timeless 2000-08-14 10:29:11 PDT
Last I checked there was no relnote3, but we should describe this in all future
release notes until it is fixed. I'm nominating for nsbeta3 with a request that
if the real fix can't be done for nsbeta3 that a simple alert dialog be
included.  Setting platform/os All/All per sol.  Adding CC.  Actually... I don't
suppose this was already fixed?
Comment 11 Alec Flett 2000-08-14 12:40:43 PDT
we've had this behavior since 4.x, and the fix is non-trivial because we 
currently cache each folder's path in the folder itself. 

I really don't think it's worth fixing for beta3 or even RTM...you generally 
don't change your server path unless you know what you're doing. And if you know 
what you're doing, you're certainly going to try restarting.

as for the alert dialog, there also isn't a great way of adding this and I also 
don't think it's worth doing for beta3...
Comment 12 Alec Flett 2000-11-02 11:11:35 PST
reassign to sspitzer..this will have to somehow update all the folder objects as
well..
Comment 13 Alec Flett 2000-11-07 14:32:15 PST
argh, actually assigning to sspitzer
Comment 14 David Tenser [:djst] 2002-09-15 19:21:52 PDT
This one's still in the release notes for 1.2a. It's been almost two years since
anything happened in this bug. Any chance of fixing this before we release 2.0? :)
Comment 15 Seth Master 2003-08-16 14:08:23 PDT
and now it has been an other year, as well.
Comment 16 Mike Cowperthwaite 2004-04-04 13:37:33 PDT
*** Bug 209585 has been marked as a duplicate of this bug. ***
Comment 17 Matyas Eorsi 2004-06-26 13:01:01 PDT
Changes of settings do not take effect at all, the program does not remember any
changes in names, email address, bcc, attach signature, etc
Comment 18 WADA 2004-10-05 04:27:29 PDT
UI of Mozilla Mail&New and Thunderbird refers to "localPath" as "Local Directry".
Please change summary for ease of search or understanding bug, in order to avoid
too many similar Thunderbird bugs in addition to many Mozilla's DUP bugs (I have
no privilege of summary change).

For example ;
> localPath change(change of "Local directry" in "Server Settings") does not
take effect until restart
Comment 19 David :Bienvenu 2004-11-25 11:58:44 PST
*** Bug 263195 has been marked as a duplicate of this bug. ***
Comment 20 Mike Cowperthwaite 2005-04-03 11:23:51 PDT
*** Bug 288417 has been marked as a duplicate of this bug. ***
Comment 21 Mike Cowperthwaite 2005-06-21 14:19:38 PDT
*** Bug 298326 has been marked as a duplicate of this bug. ***
Comment 22 Adam Guthrie 2005-08-01 21:28:59 PDT
*** Bug 302630 has been marked as a duplicate of this bug. ***
Comment 23 Mike Cowperthwaite 2005-09-14 06:55:09 PDT
*** Bug 308476 has been marked as a duplicate of this bug. ***
Comment 24 Frederic Da Vitoria 2005-09-27 04:52:39 PDT
*** Bug 222646 has been marked as a duplicate of this bug. ***
Comment 25 Mike Cowperthwaite 2006-08-20 10:07:19 PDT
*** Bug 349335 has been marked as a duplicate of this bug. ***
Comment 26 Magnus Melin 2006-11-08 11:55:58 PST
*** Bug 359905 has been marked as a duplicate of this bug. ***
Comment 27 Robin Monks 2007-04-03 09:15:26 PDT
*** Bug 376347 has been marked as a duplicate of this bug. ***
Comment 28 Gary Kwong [:gkw] [:nth10sd] 2008-12-18 09:37:10 PST
Nominating wanted-thunderbird3 due to the sheer number of dupes. It'll be up to drivers to decide if it will make tb3 though.
Comment 29 Lennard Wasserthal 2012-03-26 05:03:12 PDT
*** Bug 739077 has been marked as a duplicate of this bug. ***
Comment 30 Mark Banner (:standard8) (afk until 26th July) 2012-06-20 03:23:27 PDT
Removing relnote keyword from bugs that are no longer significant or not needing to be mentioned in the release notes.
Comment 31 :aceman 2014-07-15 13:16:24 PDT
Since bug 224831 TB forces a restart if you change the Local Directory. So this problem is almost solved if you use the GUI account manager. The problem remains if you change it via the programatically.
Comment 32 Magnus Melin 2016-03-03 13:35:01 PST
I think we can say this is as resolved as it can be, by bug bug 224831. 
Making things work on the fly without a restart is not gonna happen.

Note You need to log in before you can comment on or make changes to this bug.