Closed Bug 28174 Opened 20 years ago Closed 13 years ago

Shortcut icon dialog in installer (desktop / start menu / quick launch bar icons should be optional)

Categories

(SeaMonkey :: Installer, enhancement, P5)

x86
Windows 98
enhancement

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: bugzilla, Unassigned)

References

()

Details

(Keywords: meta, platform-parity, Whiteboard: See comment 23 and URL field.)

Attachments

(2 files)

In the installer there should be an seperate Shortcut Icons dialog.
The dialog should be presented after or together with the "Program Folder" 
option in the custom install.

This dialog should give the user the following options:
- Add icon to Desktop
- Add icon to Quick Launch bar
- Add icon to Start Menu Programs - current user
- Add icon to Start Menu Programs - all users (Windows NT/2000 only)
massively setting bugs to Assigned and M15.
Status: NEW → ASSIGNED
Target Milestone: M15
mass change to M16
Target Milestone: M15 → M16
*** Bug 28173 has been marked as a duplicate of this bug. ***
This is as designed.  No need to add unecessary new dialog to the install dialog 
sequence.  Shortcuts will be created as necessary.  Marking this invalid.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
I really dont like that Mozilla just adds icons to fx my desktop.

I really think that if the user selects "Custom", he/she should be presented 
with a "Shortcut Icon" dialog giving the user the options list in the bug 
report.

As a Win2K user I like to be able to install Mozilla without Mozilla creating 
icons in the "All Users" start menu.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
This applies to all OSes, not just Windows. For example, on Mac OS, you may want 
to put shortcuts in the Launcher and/or in the Apple menu. GNOME and KDE probably 
have similar repositories for frequently-used programs.

This also needs to offer shortcuts not only for the program itself, but also for 
various components in the program -- e.g. in Mozilla that would be Navigator, 
Messenger, Composer, etc. Will file that as a separate depending bug shortly.

Suggested UI:

If you wish, you may add shortcuts for components in this package
to various places on your system.
+---------------+-------------+---------------+---------------+-------------+-+
|Component      |   Desktop   |  Start Menu   |QuickLaunch bar| System tray | |
+---------------+-------------+---------------+---------------+-------------+-+
|{} Mozilla           [*]            [*]             [ ]            [ ]     |A|
|{} Navigator         [ ]            [*]             [*]            [ ]     |:|
|{} Messenger         [ ]            [*]             [*]            [ ]     |:|
|{} Composer          [ ]            [*]             [*]            [ ]     |:|
|{} Chatzilla         [ ]            [*]             [*]            [ ]     |:|
|                                                                           |:|
|                                                                           |V|
+---------------------------------------------------------------------------+-+

(`{}' is the icon for the component.)
Blocks: 28172, 28332
enhancement for future release.
Severity: normal → enhancement
Target Milestone: M16 → M30
--> All/All. But pp, because this will need different implementations on each 
platform ...
Keywords: pp
OS: Windows 98 → All
Hardware: PC → All
Changing fictional "M30" to reality
Target Milestone: M30 → Future
QA Contact: gbush → gemal
Keywords: ui
Depends on: 52052
*** Bug 54779 has been marked as a duplicate of this bug. ***
Status: REOPENED → ASSIGNED
Priority: P3 → P5
No longer depends on: 52052
Just a comment on mpt's spec, I don't think we should offer the users the
opportunity to put shortcut links to each app in the system tray. The system
tray is to represent application that are currently running but are not visible
on the screen (running in the background). The Windows quick launch bar is for
this purpose and so we shouldn't encourage bad practice.

Now we have turbo mode implemented and that does use a system tray icon we
should offer a menu that can be right-clicked to launch a mozilla application as
well as the default which is currently offered of double clicking to launch the
default start up app. Adding a menu to choose which mozilla app to launch from
the systray is another bug I'm sure is already filed.
I agree: System tray should be kept out of this "shortcut icon dialog". Perhaps 
just a "Enable quick launch (turbo) mode"....
No longer blocks: 28172
over to Curt.
Assignee: ssu → curt
Status: ASSIGNED → NEW
Summary: Shortcut icon dialog in installer → [rfe]Shortcut icon dialog in installer
Gregg, letting me know where this falls in the UI rework you've been contemplating.
Assignee: curt → greggl
*** Bug 131132 has been marked as a duplicate of this bug. ***
*** Bug 143393 has been marked as a duplicate of this bug. ***
*** Bug 144117 has been marked as a duplicate of this bug. ***
*** Bug 123301 has been marked as a duplicate of this bug. ***
*** Bug 123309 has been marked as a duplicate of this bug. ***
*** Bug 113834 has been marked as a duplicate of this bug. ***
*** Bug 144341 has been marked as a duplicate of this bug. ***
In mpt's ASCII art in comment #6, what is the (functional) difference between
"Mozilla" and "Navigator"?

Perhaps there should also be a UI in this screen to determine in which subfolder
the Mozilla folder goes. The default could be "Programs/Mozilla". This UI should
also allow to place the Mozilla folder *directly into the "Start" menu* (as
opposed to in the "Programs" folder) as well as a subfolder in the start menu
(*other than* "Programs"). Whatever is selected should be passed on to the
"uninstaller" to allow a clean uninstall.

The UI should also offer *sensible default values* for icons placement.

+-------------------------+-------------+---------------+---------------+-+
|Component                |  Start Menu |    Desktop    |QuickLaunch bar| |
+-------------------------+-------------+---------------+---------------+-+
|{} Mozilla Browser             [*]            [*]             [*]      |A|
|{} Mozilla Mail & Newsgroups   [*]            [*]             [*]      |:|
|{} Mozilla IRC Chat            [*]            [ ]             [ ]      |:|
|{} Mozilla Composer            [*]            [ ]             [ ]      |:|
|{} Mozilla Address Book        [*]            [ ]             [ ]      |:|
|{} Link to Mozilla's Homepage  [*]            [ ]             [ ]      |:|
|                                                                       |:|
|                                                                       |V|
+-----------------------------------------------------------------------+-+
| Select the location and name of the Mozilla folder in the Start menu:   |
|                                                                         |
|   Folder Location: [ Directly in "Start" menu     ]  [ Browse... ]      |
|                                                                         |
|   Folder Name:     [  Mozilla - Nightly Build     ]                     |
|                                                                         |
+-------------------------------------------------------------------------+

mpt: I sure hope this wasn't "the kiss of death". ;)
*** Bug 145605 has been marked as a duplicate of this bug. ***
*** Bug 163011 has been marked as a duplicate of this bug. ***
*** Bug 28332 has been marked as a duplicate of this bug. ***
On a Mac the default should be not to put a shortcut anywhere. It's a filthy PC
habbit to clutter the desktop with icons. It's the developer thinking that their
app is *so* important to the user that they must see it at all times. In MacOS X
you might (and I only say might) add it to the dock, but the standard is not to.
It's easy enough for the user to drag it there if they wish to...
meta bug...:)
Keywords: meta
*** Bug 158409 has been marked as a duplicate of this bug. ***
*** Bug 162858 has been marked as a duplicate of this bug. ***
Henrik Gemal - please explain why bug 162858 is a duplicate of this one. That
bug (which has a patch ready!) is about a typo in the Installer when creating a
registry entry. This bug is about a dialog box to specify where icons are created. 
*** Bug 172642 has been marked as a duplicate of this bug. ***
Summary: [rfe]Shortcut icon dialog in installer → Shortcut icon dialog in installer
*** Bug 182039 has been marked as a duplicate of this bug. ***
*** Bug 182461 has been marked as a duplicate of this bug. ***
*** Bug 168322 has been marked as a duplicate of this bug. ***
*** Bug 183268 has been marked as a duplicate of this bug. ***
I personally find this bug quite annoying.  I freqently update to the latest
nightly, and Mozilla always creates a desktop icon, shortcut icon, and an entire
folder for itself in the Program Files folder.  It gets a bit aggravating. 
There should be an option to only make certain shortcuts (quicklink, desktop),
or none at all.  But above all, there should be an option to just not make any
shortcuts, because at least I, have my own shortcuts that I use.

I vote for this bug.
This bug was filed almost three years ago.  Why hasn't it been fixed yet?  
Hundreds of other programs do this.  Why can't Mozilla?
*** Bug 192412 has been marked as a duplicate of this bug. ***
I suggest including the word "desktop" in the summary for this someplace so it
will be easier to search for, reducing the number of dupes.
*** Bug 192694 has been marked as a duplicate of this bug. ***
No longer blocks: 28332
Summary: Shortcut icon dialog in installer → Shortcut icon dialog in installer (desktop / start menu icons should be optional)
I'm also voting for this bug (surprised to see it is already 3 years old and
still open)

I just upgraded to 1.3beta, and again the first thing I had to do after
finishing the install was removing the mozilla icon from the desktop.

This really should be an option in the installer, it should not assume that
every user wants such an icon (enough clutter already).

Adding icons to the quicklaunch bar would be a useful option too, but less
important IMHO. Contrary to the desktop icon that has to be removed *every
time*, creating an icon in the quicklaunch bar only needs to be done once and it
will continue to work for future upgrades.

By the way, shouldn't this issue be split, i.e. a bug for the missing "create
desktop icon" check box in the installer, and an enhancement request for the
full-fledged desktop/quicklaunch-bar/start-menu thing?
I just installed 1.3 and this still isn't fixed.  This bug is over three years
old.  When is it going to be fixed?  Is there some big conspiracy going on here?
there is no conspiracy anywhere, there just is nobody that wants to work on this
bug. feel free to fix it yourself. if you don't want to or can't fix it
yourself, then please shut up. thank you.
*** Bug 182461 has been marked as a duplicate of this bug. ***
*** Bug 209578 has been marked as a duplicate of this bug. ***
*** Bug 225439 has been marked as a duplicate of this bug. ***
For whoever evetually finds the time to work on this - I suggest that defaults
will differ for new installs and for reinstalls (in which most likely the user
will not want any new shortcut icons).
Since this is still NEW I guess this is the place for this comment, although it
should be RESOLVED as the option is now presented.  It's still a bug, because
even though I unchecked desktop icon, it went ahead and created one!! So the
dialog is added but the actual optionality is still nonexistent.  Likewise, I
unchecked use Firefox start as home, and allowed import of my current IE
settings including home - but I got Firefox start anyway.  I may be a nobody,
but I notice the Washington Post's reviewer - in his otherwise rave which caused
me to install - also noted with some chagrin the failure to import his home page
setting as well as saved passwords, which I seem also to be missing. Fabulous
job overall and I will keep it, already changed to set it as default browser,
but wanted to chime in with these little issues too.
This bug is for the Mozilla installer and that still doesn't prompt for adding
shortcuts (verified with build 2004111404). The Firefox installer does prompt
for creating shortcuts so it's problem should be a separate bug report (see bug
245392).
Product: Browser → Seamonkey
mac has no installer and the linux installer does not install icons to system
locations
OS: All → Windows 98
Hardware: All → PC
Lots of votes, lots of dupes, and this bug corresponds with a bug we're facing
in our corporate product.  Hm.  This one sounds like one I am working on.

I'm not going to try to create the appropriate work for Linux/Mac right now. 
But I can try to make it work for Windows.
Status: NEW → ASSIGNED
Assignee: greggl → ajvincent
Status: ASSIGNED → NEW
I've added the start to a roadmap for fixing this bug to the URL field:
http://weblogs.mozillazine.org/weirdal/archives/008946.html

Please, offer commentary to the blog entry on ways we can achieve this.
Whiteboard: See comment 23 and URL field.
With five years hindsight, comment 6 scares me. :-) "System tray" is indeed 
a bad idea. "Start menu" can be compulsory (it's the canonical way of 
starting a program), and people can do "Quick Launch bar" themselves. That 
would leave only the "Desktop" checkboxes, making a listbox unnecessary.
> "Start menu" can be compulsory

Hardly.  Almost any app these days will ask if you want it installed to the
start menu - they default to it, but you can unselect it.  We should have parity
with other applications.
Does someone know of a good example or spec for taking values from the installer
into JS/XPI land?  I really need that.
Summary: Shortcut icon dialog in installer (desktop / start menu icons should be optional) → Shortcut icon dialog in installer (desktop / start menu / quick launch bar icons should be optional)
*** Bug 275981 has been marked as a duplicate of this bug. ***
dveditz and I talked a few months ago about ways we could pass checkbox values from the installer into the appropriate package.  I'm posting this now, so we don't lose it.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915

Since bug #275981 has been marked as a duplicate of this one, some comments I made there are now relevant here.  

The term "Quick Launch" should not be used to mean "Turbo Mode" in the installation options.  "Quick Launch" is a Windows term, referring to a toolbar of applications that are readily available to start.  The installation option should instead refer to "Turbo Mode".  (In Windows 98SE, "Quick Launch" applications have icons in [C:\WINDOWS\Application Data\Microsoft\Internet Explorer\Quick Launch].  This toolbar is neither the Tray, Desktop, nor Office toolbar.)

Except for a few Micro$oft applications, no application that I have installed ever automatically places an icon in the Windows Quick Launch toolbar without first asking -- except for Mozilla Suite.  This is not inherent in doing an installation in Windows.  It is being forced by Mozilla, and its a damned annoyance.  

While this bug report is a RFE, I consider both the misuse of the term "Quick Launch" and the unwanted placing of the Mozilla icon in the Windows Quick Launch toolbar to be errors.  
Not that this has a lot of relevance, but there's lots of non-Microsoft applications that install their icons in the Quick Launch Bar without asking---especially the media players such as Quicktime, iTunes, Real, etc. Mozilla isn't unique in this regard, though it doesn't make it less frustrating.
QA Contact: bugzilla → general
Our corporate product will no longer be building Mozilla installers, so that removes any work from me on this.  Sorry.

Reassigning back to default owner/QA.
Assignee: ajvincent → nobody
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

This is still a problem.  When I installed SeaMonkey/1.0.2 this morning, the checkboxes for icons on the desktop and in the Quicklaunch toolbar were both unchecked.  Nevertheless, I got icons in both areas.  

Ref comment #60:  The user is given options for this during installation.  If you give the option, make it work.  

Regarding "Turbo Mode" versus "Quick Launch", I believe I saw a graphic on the options window depicting the icon in the Windows Quick Launch toolbar with a portion of the Windows Tray toolbar to the right.  (I might be confused about this, since I saw the same problem while installing Thunderbird 1.5.0.4; see bug #340254.)
(In reply to comment #62)
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060516
> SeaMonkey/1.0.2
> 
> This is still a problem.  When I installed SeaMonkey/1.0.2 this morning, the
> checkboxes for icons on the desktop and in the Quicklaunch toolbar were both
> unchecked.  Nevertheless, I got icons in both areas.  
> 
> Ref comment #60:  The user is given options for this during installation.  If
> you give the option, make it work.  
> 
> Regarding "Turbo Mode" versus "Quick Launch", I believe I saw a graphic on the
> options window depicting the icon in the Windows Quick Launch toolbar with a
> portion of the Windows Tray toolbar to the right.  (I might be confused about
> this, since I saw the same problem while installing Thunderbird 1.5.0.4; see
> bug #340254.)
> 

I don't see check boxes in the nightly trunk builds of Seamonkey. Every time I run an install, the first thing I have to do is delete that pesky desktop icon. 

Isn't this fixed in Firefox already? Branch? Is there going to be a new installer soon?
Flags: blocking-seamonkey1.1a?
OS=Windows XP not 98 for me, so that field should be changed.
We're not blocking a release because of an enhancement...
Flags: blocking-seamonkey1.1a? → blocking-seamonkey1.1a-
BTW, won't sm be moving to NSIS once toolkitization is complete? In that case, maybe it isn't worth our while to solve this now.
As per comment 66, this has now been fixed by the new SeaMonkey installer.  Icons are now optional, and can be de-selected during installation.
Status: NEW → RESOLVED
Closed: 20 years ago13 years ago
Resolution: --- → FIXED
In which version of SeaMonkey is this fixed?  The problem still existed when I installed SeaMonkey/1.1.2.  
It's fixed for builds which make use of the NSIS-based installer, which, as I understand things, is currently only the trunk (what will become SM 1.5). I have no idea if there are plans to backport the new installer to SM 1.1, but I doubt it.
Blocks: 387858
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.