Last Comment Bug 398381 - Yahoo mail beta is broken - NS_ERROR_DOM_WRONG_DOCUMENT_ERR
: Yahoo mail beta is broken - NS_ERROR_DOM_WRONG_DOCUMENT_ERR
Status: VERIFIED FIXED
[Please see comment 32 and 73; no fur...
: relnote
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: -- normal
: Apr
Assigned To: Kev Needham [:kev]
:
Mentors:
: 399637 404188 404481 404561 404571 405002 405117 405780 407609 409036 409101 409127 409219 409332 409438 410350 411485 412121 413653 416490 417022 417057 417349 417492 417666 417792 418094 418112 419805 (view as bug list)
Depends on:
Blocks: 47903 121228 407636 413630
  Show dependency treegraph
 
Reported: 2007-10-03 04:34 PDT by u88484
Modified: 2015-04-19 23:39 PDT (History)
80 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot of errors (117.86 KB, image/png)
2007-10-03 04:34 PDT, u88484
no flags Details
run firefox -safe-mode (9.17 KB, text/plain)
2008-07-07 22:27 PDT, larytet
no flags Details

Description u88484 2007-10-03 04:34:42 PDT
Created attachment 283335 [details]
Screenshot of errors

Yahoo yesterday (10/2) updated its yahoo mail beta but it appears only for its paying customers since my gf's account is still the same.  Anywho there are two errors after logging in after the page loads and no emails ever open in the viewing pane and always get the message about the page taking too long to load and that I should switch to yahoo mail classic...that is currently the only way I can read my emails.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-10-03 20:49:29 PDT
Can you find a regression range?
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-10-03 20:49:47 PDT
(See also bug 396683)
Comment 3 u88484 2007-10-04 04:56:48 PDT
Works
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006112204 Minefield/3.0a1

Broken
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006112304 Minefield/3.0a1

Regression range: http://tinyurl.com/ynqxno

My bet is bug 47903

Comment 4 u88484 2007-10-04 05:30:18 PDT
Judging by bug 47903 dependencies, this is not a regression but supposed to happen because of some technical stuff and bugs filed because of it are marked tech evangelism so I'm changing this ones product and component.

Hopefully the second error is also related?
Comment 5 Dão Gottwald [:dao] 2007-10-04 06:03:53 PDT
(In reply to comment #4)
> Hopefully the second error is also related?

Oh, can you please test this with 2006112204 vs. 2006112304?
Comment 6 Peter Van der Beken [:peterv] 2007-10-04 06:17:52 PDT
Yahoo already fixed a similar problem once (see bug 361709).
Comment 7 u88484 2007-10-04 06:43:08 PDT
Dao yeah same regression range just there were a bunch of checkins that day...slight possibility of a coincidence but who knows. I can't find the archived hourlies to narrow down the regression range even further.
Comment 8 Kevin Johnston 2007-10-04 14:29:10 PDT
Yes, although I haven't diagnosed it, it seems like a new instance of bug 361709.  Most likely new code in the new release.  I'm sorry but we have not been actively testing against FF3.  I filed a bug internally for us to track it.
Comment 9 Chris Lawson (gone) 2007-10-07 19:43:55 PDT
Is it safe to assume this affects any trunk-based browsers (i.e., Camino and Seamonkey trunk builds), not just Minefield?
Comment 10 Jeff Walden [:Waldo] (remove +bmo to email) 2007-10-07 20:02:19 PDT
Yes.
Comment 11 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-10-12 15:38:29 PDT
*** Bug 399637 has been marked as a duplicate of this bug. ***
Comment 12 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-10-24 14:46:18 PDT
note: this affect not only paying user from Yahoo, this affects also users in germany of the free service, since we don`t have the exact same premium system here with yahoo mail.
Comment 13 -fullmetaljacket- 2007-10-24 16:41:17 PDT
yup, im a user of yahoo mail free and i am seeing this bug.

hoping this will be fixed (by yahoo) before beta.



Comment 14 u88484 2007-11-07 08:43:48 PST
I think its now out of beta and final for yahoo mail so this will be more of a problem for firefox 3.0 beta 1 users now.
Comment 15 Shankar Unni 2007-11-08 10:23:11 PST
Yup - confirming that I'm seeing this with FF 3.0b1 RC1 candidate.  I've been forced to go back to the classic ui.

Can we please update the severity of this one?  Lots of free users have also moved to the new UI, and all will be affected. If it's tech evangelism, someone needs to push Yahoo to fix their UI. Else a workaround is needed..
Comment 16 juan becerra [:juanb] 2007-11-08 10:42:18 PST
I have a free account and when I login to yahoo I get the beta UI. In Fx3b1rc1 it does not work. I think many more users will be seeing this if they are using the beta interface.

As Shankar points out, you need to switch to the classic UI to check your mail, otherwise frustration will ensue. Can someone put some oil in the machinery so this gets resolved on either end as soon as possible? 
Comment 17 Dão Gottwald [:dao] 2007-11-08 11:32:22 PST
I think it's save to assume that Yahoo will fix this after Beta 1 is released. The error is descriptive and all.
Comment 18 Chris Lawson (gone) 2007-11-08 13:53:47 PST
(In reply to comment #17)
> I think it's save to assume that Yahoo will fix this after Beta 1 is released.

Thus far, Yahoo has averaged a fix for about one-third of the total TE bugs filed against them (I'm giving them the benefit of the doubt and assuming that WORKSFORME bugs were actually fixed). This is not exactly a stellar track record, nor is it any grounds for "safe assumptions" by any stretch of the imagination.

The only reason I have any hope that they might fix this is that it affects *all* Gecko consumers (including Firefox), and to ignore Firefox is effectively financial suicide for an Internet company. I certainly wouldn't get any hopes up about a fix prior to Firefox 3 being released, though.
Comment 19 Tony Chung [:tchung] 2007-11-08 13:59:11 PST
Just received word an hour ago from the Yahoo Mail team.  Darren James and his team have a fix ready.  Current state is its being tested in their staging servers by QA.  (a few layout issues still pending)   Cc'ing darren to the thread.
Comment 20 Marcia Knous [:marcia - use ni] 2007-11-08 14:59:12 PST
During Litmus testing, I hit this bug when running ctalbert's litmus test case. This is the error that showed up for me in the console: 

Error: junk after document element
Source File: http://us.mg2.mail.yahoo.com/dc/launch?consentLW=1
Line: 1, Column: 416
Source Code:
<menu id="themes" title="Colors" beforeshow="beforeThemeMenu"><item cmd="theme" id="_blue" cmdData="blue">Ocean</item><item cmd="theme" id="_sand" cmdData="sand">Chrome</item><item cmd="theme" id="_gold" cmdData="gold">Tangerine</item><item cmd="theme" id="_plum" cmdData="plum">Violet</item><item cmd="theme" id="_lime" cmdData="lime">Grass</item><item cmd="theme" id="_pink" cmdData="pink">Bubblegum</item></menu><divider id="theme_divider"></divider>

ctalbert suggested I add this info to the bug. Also, his test case at http://people.mozilla.com/~ctalbert/test-mailto-yahoo.html may have to be adjusted if Yahoo makes changes on their end, just mentioning this for tracking purposes for our Litmus test cases.
Comment 21 Darren 2007-11-09 14:53:59 PST
We do not have any outstanding NS_ERROR_DOM_WRONG_DOCUMENT_ERR errors that I'm aware of (in our latest development builds).  There was one that happened during launch that I fixed a couple of weeks back, but the bug did not prevent the launch from proceeding. I'll have someone on the team follow up.
Comment 22 Corwin K. Watts 2007-11-12 11:08:47 PST
I have lots of NS_ERROR_DOM_WRONG_DOCUMENT_ERR accessing Yahoo! Mail.
I thought at first it was because of the Yahoo! Mail Notifier Extension, but it happens when I visit the web page. The specific error code is:
Error: uncaught exception: [Exception... "Access to property denied"  code: "1010" nsresult: "0x805303f2 (NS_ERROR_DOM_PROP_ACCESS_DENIED)"  location: "<unknown>"]
Comment 23 Tony Chung [:tchung] 2007-11-12 12:05:34 PST
This is 100% reproducible for me on: 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

I get the same error as comment #20 in the error console. 

I also get a Loading Yahoo! Mail message in the upper right hand corner, with text saying 

"Mail appears to be taking longer to load than usual.

This could be a temporary glitch. Try refreshing your page. Or for this session only, click here to see if Mail Classic loads faster."
Comment 24 Corwin K. Watts 2007-11-12 12:24:57 PST
(In reply to comment #23)

> I also get a Loading Yahoo! Mail message in the upper right hand corner, with
> text saying 
> 
> "Mail appears to be taking longer to load than usual.
> 
> This could be a temporary glitch. Try refreshing your page. Or for this session
> only, click here to see if Mail Classic loads faster."
> 
Yeah, the Yahoo! Mail beta and Minefield do not play well together and I was getting that error with a5 builds. Oddly enough at about the same time that attachments stopped working between Mail and Minefield. I am under the impression that Yahoo! is working on the problem on their end, but not very seriously as I wrote an error message and complaint over a month ago... 
Comment 25 Tony Chung [:tchung] 2007-11-14 10:13:35 PST
relnote for beta 1.   fix is external dependent
Comment 26 Bill Gianopoulos [:WG9s] 2007-11-17 11:18:35 PST
*** Bug 404188 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Baron 2007-11-20 02:29:09 PST
*** Bug 404481 has been marked as a duplicate of this bug. ***
Comment 28 Jeremy Baron 2007-11-20 09:32:01 PST
*** Bug 404571 has been marked as a duplicate of this bug. ***
Comment 29 Kevin Brosnan 2007-11-20 09:36:09 PST
*** Bug 404561 has been marked as a duplicate of this bug. ***
Comment 30 Ria Klaassen (not reading all bugmail) 2007-11-20 09:58:03 PST
*** Bug 404437 has been marked as a duplicate of this bug. ***
Comment 31 Chris Lawson (gone) 2007-11-20 11:03:25 PST
Darren or Kevin, have either of you been able to investigate this further? Even though it's relnoted, there are a LOT of people complaining about this, including CNet's Stephen Shankland:

http://www.news.com/underexposed/8301-13580_3-9820775-39.html

Yes, people should be reading relnotes, but it's been a couple weeks since we heard anything from the Yahoo guys on this one.

cl
Comment 32 Darren 2007-11-20 12:31:34 PST
Chris/Tony,

As I mentioned in a previous comment, all of the NS_ERROR_DOM_WRONG_DOCUMENT_ERR errors have been fixed in the Y! Mail trunk build (i can launch the beta from my dev build without problems.).  This fix however, is *not* in production.  It will be incorporated into our next release which will be rolling out sometime Q1.

thx,

- darren
Comment 33 Chris Lawson (gone) 2007-11-20 12:36:26 PST
Thanks Darren. It wasn't clear from your earlier comment whether that was the case or not, but I'm glad to hear you guys have it fixed on your end and will be rolling the fix out soonish (probably around the same timeframe that Firefox 3 will be shipping, as I understand it).

cl
Comment 34 Chris Lawson (gone) 2007-11-20 17:59:42 PST
Target Milestone: April, per comment 32.
Comment 35 dan 2007-11-21 07:32:26 PST
so 'around' April is when FF2 will be shipping or when Y! Mail will have the next release to fix the errors or both?
Comment 36 Chris Lawson (gone) 2007-11-21 07:40:49 PST
April would be the end of Q1, so per comment 32, this should be fixed on Yahoo's end by then. Last I heard (June 2007; I can't seem to find an up-to-date roadmap anywhere on mozilla.org), Firefox 3 was planned for "early 2008", which might mean that Yahoo has this fixed before Firefox 3 ships.
Comment 37 (mostly gone) XtC4UaLL [:xtc4uall] 2007-11-22 10:29:00 PST
*** Bug 405002 has been marked as a duplicate of this bug. ***
Comment 38 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-11-23 07:51:02 PST
*** Bug 405117 has been marked as a duplicate of this bug. ***
Comment 39 Ria Klaassen (not reading all bugmail) 2007-11-28 10:09:39 PST
*** Bug 405780 has been marked as a duplicate of this bug. ***
Comment 40 Simon Howes 2007-11-28 14:06:37 PST
(In reply to comment #12)
> note: this affect not only paying user from Yahoo, this affects also users in
> germany of the free service, since we don`t have the exact same premium system
> here with yahoo mail.
> 

Seems to effect paying customers in the UK as well, such as myself.
Comment 41 Andreas 2007-12-02 09:43:13 PST
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120205 Minefield/3.0b2pre

Bug still occurs using the laters version of Minefield
Comment 42 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-12-09 20:02:45 PST
*** Bug 407609 has been marked as a duplicate of this bug. ***
Comment 43 Vern Howard 2007-12-10 06:01:39 PST
Rcvd following error messages trying to get yahoo web mail.

Yahoo! Mail experienced a login error: 

name:NS_ERROR_DOM_WRONG_DOCUMENT_ERR
message:Node cannot be used in a document other than the one in which it was created
lineNumber:463


Yahoo! Mail experienced a login error: Login error:

name:TypeError
message:j has no properties
lineNumber:648
fileName:http://mail.yimg.com/us.js.yimg.com/combo?/pim/r/dclient/g/js/core/40ed4e2d8d7c4fedfd40ff2da621022e_1.js&/pim/r/dclient/g/js/launch/8f7e5aa4beb78311833eddc3334a14e5_1.js

I can get in with Flock which I must do.
Comment 44 Al Billings [:abillings] 2007-12-18 13:15:09 PST
Andreas, Vern, and others: This bug will not go away until Yahoo rolls out the next version of their Mail web application.
Comment 45 juan becerra [:juanb] 2007-12-18 13:25:45 PST
I haven't seen this problem anymore for about a week. Maybe the changes on their side were rolled out already?
Comment 46 Tony Chung [:tchung] 2007-12-18 13:37:13 PST
This still repros for me on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2.  dont think its fixed yet.
Comment 47 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-12-19 10:13:09 PST
*** Bug 409036 has been marked as a duplicate of this bug. ***
Comment 48 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-12-19 15:21:23 PST
*** Bug 409101 has been marked as a duplicate of this bug. ***
Comment 49 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-12-19 17:58:04 PST
*** Bug 409127 has been marked as a duplicate of this bug. ***
Comment 50 Steve England [:stevee] 2007-12-20 08:42:47 PST
*** Bug 409219 has been marked as a duplicate of this bug. ***
Comment 51 Jeremy Baron 2007-12-20 20:27:51 PST
*** Bug 409332 has been marked as a duplicate of this bug. ***
Comment 52 Matthias Versen [:Matti] 2007-12-21 13:58:43 PST
*** Bug 409438 has been marked as a duplicate of this bug. ***
Comment 53 mchargue 2007-12-21 14:38:25 PST
Still happens with beta2.
Comment 54 Al Billings [:abillings] 2007-12-21 14:41:35 PST
Yes because the fix has to be done by Yahoo. They have it fixed internally but have no rolled out this change to their live site. There is nothing that Mozilla can do here.
Comment 55 Andrea Monni 2007-12-25 21:29:54 PST
This bug is very annoying, as everytime I need to use my Y! Mail account I have to wait that the Y! servers realizes that I can't access the new version and asks me if I want to try with the old version.

Is there a way I can force Y! Mail to open in the old version? Or I can tell Firefox to open the old one?
Comment 56 -fullmetaljacket- 2007-12-25 23:20:37 PST
(In reply to comment #55)
> This bug is very annoying, as everytime I need to use my Y! Mail account I have
> to wait that the Y! servers realizes that I can't access the new version and
> asks me if I want to try with the old version.
> 
> Is there a way I can force Y! Mail to open in the old version? Or I can tell
> Firefox to open the old one?
> 

you can try this after the NS_ERROR_DOM_WRONG_DOCUMENT_ERR error dialog box:

1. click "Trouble logging in?" link at the upper left corner beside the yahoo mail logo.
2. on the "Trouble logging in?" page, click "Switch back to Yahoo! Mail Classic by opting out of Yahoo! Mail"

now next time you login, yahoo mail will now be open in the classic mode. 

to switch back to the new yahoo mail just click "All-New Mail" link at the upper right corner (of your yahoo mail classic) screen.




Comment 57 Reed Loden [:reed] (use needinfo?) 2007-12-31 11:17:16 PST
*** Bug 410350 has been marked as a duplicate of this bug. ***
Comment 58 Andrea Monni 2008-01-03 19:51:26 PST
> now next time you login, yahoo mail will now be open in the classic mode. 

It doesn't work, it keeps on going to the new version every time I login.

For the time being I solved the problem using IE, let's hope that the Y! guys fix the problem soon.
Comment 59 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-01-09 04:49:06 PST
*** Bug 411485 has been marked as a duplicate of this bug. ***
Comment 60 Phil Ringnalda (:philor) 2008-01-12 17:06:07 PST
*** Bug 412121 has been marked as a duplicate of this bug. ***
Comment 61 Manuel Deschamps 2008-01-14 09:47:41 PST
Darren is not with Y! anymore. I am adding my self to CC list and just wanted to let you know that we have fixed these issue and just waiting to roll them out. Thank you for your patience.
Comment 62 Manuel Deschamps 2008-01-14 09:48:01 PST
Darren is not with Y! anymore. I am adding myself to CC list and just wanted to let you know that we have fixed these issue and just waiting to roll them out. Thank you for your patience.
Comment 63 Paul 2008-01-22 20:48:15 PST
This bug still exists as of 22 January 2008.  I have Fire Fox 3.0b2.  I am assuming comment 62 refers to the next beta release.
Comment 64 Chris Lawson (gone) 2008-01-22 20:54:44 PST
No; comment 62 refers to Yahoo's mail interface. There is no need to comment in this bug unless you are working at Yahoo and informing the Mozilla community that the fixes are live, at which point the bug can be RESOLVED FIXED.
Comment 65 Dave Townsend [:mossop] 2008-01-23 06:01:41 PST
*** Bug 413653 has been marked as a duplicate of this bug. ***
Comment 66 sonda90 2008-01-29 11:48:27 PST
also for me for yahoo mail box appears this strange error, and with the stable firefox 2.0.0.11 there aren't any problems
Comment 67 Raymie Humbert 2008-02-02 13:44:47 PST
If the error mentions NS like it did, it might be a Cocoa issue on Mac OS X. (The NS comes from NeXTSTEP, the predecessor to OS X.)
Comment 68 Mike Lierman 2008-02-09 11:39:56 PST
*** Bug 416490 has been marked as a duplicate of this bug. ***
Comment 69 dan 2008-02-09 15:31:01 PST
maybe it's just me, but for some reason, the 'new' yahoo mail is working for me using F3B2
Comment 70 u88484 2008-02-10 08:19:48 PST
Working for me now also.
Comment 71 u88484 2008-02-10 08:23:25 PST
Might have to wait a few days/a week until they roll it out to all servers though so don't comment unless this still is not working for you after a week or two.
Comment 72 u88484 2008-02-12 09:55:14 PST
*** Bug 417022 has been marked as a duplicate of this bug. ***
Comment 73 Chris Lee 2008-02-12 10:26:44 PST
I'm the product manager for the all new Yahoo! Mail.  The latest build we began rolling out last week fixes this bug (hooray!) and adds FF3 to the list of browsers we support on both Windows/Mac.  

It will take another couple weeks before all users have this new version, but for those who are able to log in now, feel free to verify the fix and mark this bug as close.  

Thanks,
Chris
Comment 74 Dave Townsend [:mossop] 2008-02-12 12:37:34 PST
*** Bug 417057 has been marked as a duplicate of this bug. ***
Comment 75 Corwin K. Watts 2008-02-12 13:32:30 PST
@Chris Lee,
Thank you for telling us, and I can confirm its not out yet. I still get the NS Error and the freeze up and lock out. I'll keep checking though as what I've seen of the beta looks good.
Comment 76 Kaushal 2008-02-12 19:42:16 PST
I have the new build of Yahoo mail and it works fine with beta 2, however, after updating to beta 3 today, I noticed that some of the chat contact names (not all) are blank (only the yellow circle is visible). I need to take the mouse cursor over the blank area next to the yellow online icon to bring up tooltip to see the name of the contact.
Comment 77 Philip Alexander Hassialis 2008-02-13 04:54:24 PST
I just downloaded and installef beta3 for windows (14.45 pm on GMT+2) and unfortunately I have to agree with the rest of the commentators, I get the NS_ERROR too along with the Login Error as was previously stated e.g. on comment #43 so I took action and after I got the pop up message that stated that "Mail took longer to load" I switched to Mail Classic. 
Is this behaviour something that must be alleviated from Yahoo!'s end or from Mozilla's? 
Thank you in advance.

P.S. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

Comment 78 u88484 2008-02-13 05:04:30 PST
Read comment 32 and comment 73
Comment 79 Carsten Book [:Tomcat] - PTO-back Sept 4th 2008-02-13 14:15:25 PST
*** Bug 417349 has been marked as a duplicate of this bug. ***
Comment 80 Dave Townsend [:mossop] 2008-02-14 07:36:52 PST
*** Bug 417492 has been marked as a duplicate of this bug. ***
Comment 81 Craig Kempson 2008-02-14 14:43:20 PST
(In reply to comment #76)
> I have the new build of Yahoo mail and it works fine with beta 2, however,
> after updating to beta 3 today, I noticed that some of the chat contact names
> (not all) are blank (only the yellow circle is visible). I need to take the
> mouse cursor over the blank area next to the yellow online icon to bring up
> tooltip to see the name of the contact.
> 

Can confirm this affects me too, only since installing Fx b3; however, with Fx b2 Yahoo! Mail didn't work at all, so this is a massive improvement (presumably from the Y! side).

Comment 82 Chris Lawson (gone) 2008-02-14 17:31:40 PST
Comment 76 and comment 81 should be filed as a separate bug (one or the other of you; don't both file it, please), as it really has nothing whatsoever to do with this one.

cl
Comment 83 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-02-15 01:02:23 PST
*** Bug 417666 has been marked as a duplicate of this bug. ***
Comment 84 Dave Townsend [:mossop] 2008-02-15 12:30:17 PST
*** Bug 417792 has been marked as a duplicate of this bug. ***
Comment 85 [:Cww] 2008-02-17 11:28:55 PST
*** Bug 418112 has been marked as a duplicate of this bug. ***
Comment 86 Dan Mills [:thunder] 2008-02-18 10:39:12 PST
*** Bug 418094 has been marked as a duplicate of this bug. ***
Comment 87 Roman R. 2008-02-26 12:38:16 PST
I can also confirm that the changes have reached the server I happen to be using. However, now that Firefox 3 can open Yahoo Mail "beta" without problems, a more serious problem has shown up: FF crashes extremely frequently on Yahoo Mail. So frquently that it's not usable. See bug 419695. I hope Chris Lee will take a note of this.
Comment 88 Manuel Deschamps 2008-02-26 12:51:23 PST
Roman, do you have Firebug installed? that causes a lot of crashes on the new yahoo mail.
Comment 89 Manuel Deschamps 2008-02-26 12:58:57 PST
Also Roman, from your bug 419695 it looks like you are not even using one of the released betas. You are using Minefield (dont know how old). why dont you try firefox 3 beta 3 too?
Comment 90 Roman R. 2008-02-26 13:14:46 PST
Manuel, I do have Firebug installed, but:
- it is disabled;
- and it's installed only in my "old" profile, and crashes happen in my new, clean profile that I created for some version of beta 4 pre.

Minefield I am using is of the latest version (I use nightly builds). However, I will try beta 3. That's a good point.
Comment 91 Roman R. 2008-02-26 13:16:00 PST
I meant to say that crashes happen in my new profile *too*.
Comment 92 Roman R. 2008-02-26 13:44:59 PST
Well, I just tried beta 3 and saw *this* bug is still there for me. So, it seems to be happening is that later versions of Firefox 3 beta have managed to hide this particular bug and led to crashes. I hope when changes made by Yahoo devs propagate to my account, behavior described in this bug and the crashes will disappear. Perhaps, my bug 419695 will be useful to FF developers anyway.
Comment 93 Chris Lee 2008-02-26 14:23:43 PST
Roman - Please try uninstalling Firebug all together and then see if Mail is still crashing for you on Beta 3.  

This release has not be pushed out to all users yet.  We are in the process of wrapping that up this week.  Assuming no major issues, the majority of users should have the latest build by early next week.  
Comment 94 u88484 2008-02-26 14:29:30 PST
Roman R. Please file a new bug.  This bug is closed and your bug has nothing at all to do with this one.  Reply back with the new bug number and leave this one as is.  Thanks
Comment 95 Roman R. 2008-02-26 14:42:33 PST
Kurt, I have filed a new bug report and posted it here, in comment #87. 

Also, as I've learned after I filed that bug report, the problem I described here does have something to do with this bug because Firefox has changed how they treat what the old code of Yahoo Mail did that caused you to file this bug. (See bug 418755.)
Comment 96 Tony Chung [:tchung] 2008-02-26 15:54:59 PST
Marking this bug verified on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022604 Minefield/3.0b4pre.   Thanks yahoo team for fixing this!
Comment 97 u88484 2008-02-26 18:21:49 PST
(In reply to comment #95)
> Kurt, I have filed a new bug report and posted it here, in comment #87. 
> Also, as I've learned after I filed that bug report, the problem I described
> here does have something to do with this bug because Firefox has changed how
> they treat what the old code of Yahoo Mail did that caused you to file this
> bug. (See bug 418755.)

Ok, well either way this bug was opened for a specific reason and has been fixed.  And now it even looks like WRONG_DOCUMENT_ERR won't even be thrown anymore anyways since it seems that it is to hard to get people to write according to standards so some devs just wanted to stop trying to push it.  Anyways, this bug is even now verified fixed for the original issue that started this bug so leave it be.

Comment 98 Roman R. 2008-02-26 20:52:08 PST
Chris, I did what you asked. However, let's talk in bug 419695 to avoid agitating people here.
Comment 99 Nael Masood 2008-02-26 22:01:41 PST
Something odd I've noticed in regards to this bug: I've been trying out Firefox 3 and Yahoo Mail, hoping that I could use the new interface again in Fx3. All the Yahoo Mail servers use the new version of the software by now; however, I've found that I still run into Javascript errors that forces me to use "classic" Yahoo Mail when using Fx3 beta 3. However, when I switch my browser to the Minefield b4pre nightlies, I can log in to the "new" Yahoo Mail just fine. It seems while the problems on Yahoo's end are fixed, those using a release version of beta 3 will still run into the problem. However if the nightlies are any indication, I guess the bug can be considered fully fixed when beta 4 is out (presumably by next week).
Comment 100 Roman R. 2008-02-26 22:53:44 PST
Nael, if you read comments starting from #87, you will understand what's going on. As Chris said, the new code "has not be pushed out to all users yet." The reason you can use Yahoo Mail with b4pre is that Firefox no longer objects to the way Yahoo Mail uses it.
Comment 101 Steve England [:stevee] 2008-02-27 00:32:50 PST
*** Bug 419805 has been marked as a duplicate of this bug. ***
Comment 102 Roman R. 2008-02-27 19:41:19 PST
Chris, if at all possible, please delay rolling out changes on your side until Mozilla devs get a handle on why FF crashes on Yahoo Mail (as reported in bug 419695). Right now I can easily reproduce the bug, and they are debugging FF on my machine remotely. It would be a bad thing, if your changes hide the cause of the crashes. Thanks.
Comment 103 larytet 2008-07-07 22:21:12 PDT
Confirmed for the mail.yahoo.com on the fully patched Ubuntu 8.04 - the Hardy Heron
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

Confirmed for the site https://www.bloglines.com 

$ firefox

(firefox:13122): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(firefox:13122): atk-bridge-WARNING **: IOR not set.

(firefox:13122): atk-bridge-WARNING **: Could not locate registry
Segmentation fault
$ 
Comment 104 larytet 2008-07-07 22:27:50 PDT
Created attachment 328444 [details]
run firefox -safe-mode

Continue "Confirmed for bloglines.com"
I attached what firefox dumps when 
i run firefox -safe-mode  from the command line
Comment 105 Chris Lawson (gone) 2008-07-08 05:30:46 PDT
(In reply to comment #103)

> Confirmed for the site https://www.bloglines.com 

That should be filed as its own bug if it is, indeed, a bug. It's not at all clear whether "confirmed" in comment 103 means "this bug exists" or "this bug is fixed". Either way, if you see new instances of this bug, you should file them as new bugs, because *this* bug has been fixed for several months.
Comment 106 larytet 2008-07-08 07:01:09 PDT
I am sorry, i did not pay attention that the issue is marked fixed.

Yesterday i discovered that firefox crashes when visiting Yahoo Mail. search brought me eventually to this bug record.
i do the same routine daily - yahoo mail, gmail, bloglines. 
Bloglines crashed the firefox too. there was no problem two days ago and the problem appeared only about 12 hours ago. i do not know if the problem is  a different and new one or this is the same already fixed problem. 
i am going to open a new issue for the bloglines.

(In reply to comment #105)
> (In reply to comment #103)
> 
> > Confirmed for the site https://www.bloglines.com 

> That should be filed as its own bug if it is, indeed, a bug. It's not at all
> clear whether "confirmed" in comment 103 means "this bug exists" or "this bug
> is fixed". Either way, if you see new instances of this bug, you should file
> them as new bugs, because *this* bug has been fixed for several months.
> 

Comment 107 Dão Gottwald [:dao] 2008-07-08 07:04:16 PDT
(In reply to comment #106)
> i am going to open a new issue for the bloglines.

Please do so. This bug was about a Javascript error, not a crash.

Note You need to log in before you can comment on or make changes to this bug.