[10.9][10.10] Two finger swipe gesture fails, breaks subsequent scrolling (Mavericks, Yosemite).

RESOLVED FIXED in mozilla43

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: Nick Lowe, Assigned: mstange)

Tracking

(Blocks: 1 bug)

25 Branch
mozilla43
x86
Mac OS X
Points:
---
Bug Flags:
firefox-backlog -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: rdar://15313540)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131015052812

Steps to reproduce:

On a system running OS X Mavericks (10.9) follow a hyperlink to a page that can be scrolled, perform the two fingered swipe gesture to go backwards.


Actual results:

The gesture fails to function and subsequent scrolling using two fingers becomes impossible.


Expected results:

The gesture should function as expected and it should not break subsequent scrolling.
(Reporter)

Updated

4 years ago
Blocks: 883824
(Reporter)

Comment 1

4 years ago
This seems annoyingly intermittent. The issue reoccurred after closing and reopening Firefox in safe mode. After logging out and logging back in, however, Firefox now functions correctly. This may well be a false alarm or a fault in the underlying OS therefore.
No longer blocks: 883824

Updated

4 years ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core

Comment 2

4 years ago
This happens to me as well on Mavericks.  Are there any logs I can provide that will help track this down?

Comment 3

4 years ago
Side note: Disabling the two-finger "swipe between pages" gesture in system preferences seems to be an adequate workaround for the time being.
What we need are effective, precise and detailed steps-to-reproduce.

By "effective" I mean ones that work at least 50% of the time.
> Are there any logs I can provide that will help track this down?

Just after the problem happens, use the Console utility to look at system log output, and see if there's anything that seems related.  Be sure to look at the log entries' timestamps, to make sure they're close in time to the bug's occurrence.

Comment 6

4 years ago
This also happens with me.

Firefox 24.0
OSX 10.9 (Mavericks).

Note: in my experience this bug is not intermittent, i.e. it always occur as consequence of the actions described by the OP.

System Log Output (not sure it is related):

Oct 23 18:03:47 iMac-OSX.local com.apple.usbmuxd[2016]: _SendAttachNotification Device b8:ff:61:59:ce:d5@fe80::baff:61ff:fe59:ced5._apple-mobdev._tcp.local. has already appeared on interface 4. Suppressing duplicate attach notification.
Oct 23 18:04:17 iMac-OSX.local usbmuxd[2016]: AMDeviceConnect (thread 0x101881000): Could not connect to lockdown port (62078) on device 50 - 0e1d02b1532e5e9cdc6f666b808730fdca3c665f: 0xe8000084.
Oct 23 18:04:17 iMac-OSX.local usbmuxd[2016]: _AMDevicePreflightWorker (thread 0x101881000): Pair worker could not connect to lockdownd on device 50: 0xe8000084.
Oct 23 18:04:17 iMac-OSX.local com.apple.usbmuxd[2016]: HandleDeviceAttachHelperCallback preflighting failed for WiFi device 0x32-fe80::baff:61ff:fe59:ced5:0: 0xe8000084. Ignoring device.

Hope it helps.
> System Log Output (not sure it is related):

Looks like problems connecting to a USB device over WiFi -- almost certainly unrelated.

Comment 8

4 years ago
I can confirm this on the latest Firefox Beta (version 25).
So this issue happens consistently on Safari as well (by consistent I mean 100% of the time), so I think it's safe to say this is Apple's issue. I will file a bug shortly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This happens on all version of Firefox that support swipe-to-navigate.

Filed ticket #15313540 with Apple...
Whiteboard: rdar://15313540
(Reporter)

Comment 11

4 years ago
For info, this issue is also being tracked for Chrome via: https://code.google.com/p/chromium/issues/detail?id=310649
Duplicate of this bug: 931374

Comment 13

4 years ago
I am experiencing the same problem using a Macbook Pro.

Reproduction:

1. On a Macbook Pro running OS X Mavericks (10.9), place two fingers on the built-in trackpad and attempt to swipe right or left.

2. The expected action will not occur, and will break subsequent vertical scrolling (up/down) until Firefox is restarted.
We don't need any more "me too" reports.

Also note that this is an Apple bug that also effects Safari and Chrome, in addition to Firefox.  We hope and assume it will be fixed in a forthcoming update to OS X 10.9 Mavericks.
Blocks: 883824

Comment 15

4 years ago
Is there a thread on apple forums where we can follow this bug?
> Is there a thread on apple forums where we can follow this bug?

Not that I'm aware of.

If you find one please report the link here!

Comment 17

4 years ago
I'm not sure if this is a genuine fix, but I was having this issue and my 2 finger swipe/scroll began working again suddenly without the need for a restart (of Firefox or the OS).

Firefox>Preferences>Advanced>General

Check 'Always use the cursor keys to navigate within pages'.

Hit okay.

Then go back and uncheck it. 

Like I said, this doesn't sound like a genuine fix - at all, but it worked and continues to work for me.
There now seems to be a discussion in the Apple forum[1]. Although one reply was marked as the solution (resetting PRAM), subsequent replies mention that this doesn't solve the problem for them, or that resetting PRAM only temporarily fixes the issue.

One user mentions that he filed a radar bug[2] and that it got closed as duplicate of radar bug #14969656.

[1] https://discussions.apple.com/message/23467302#23467302
[2] https://discussions.apple.com/message/23557541#23557541

Comment 19

4 years ago
It works fine for me.... in Firefox Nightly, Aurora, Firefox Beta and Stable

Comment 20

4 years ago
Some extra info can be find in bug 943290

Updated

4 years ago
Duplicate of this bug: 943290
I can reproduce this issue on today's Nightly (12/1/13) and am comfortable producing regression ranges; would this help? It seems to have appeared suddenly because of something Firefox-related, as I noticed this after an update from a week-old Nightly, not after a system update.
(In reply to Alex Jordan [:strugee] from comment #22)
> I can reproduce this issue on today's Nightly (12/1/13) and am comfortable
> producing regression ranges; would this help? It seems to have appeared
> suddenly because of something Firefox-related, as I noticed this after an
> update from a week-old Nightly, not after a system update.
Or I'm running into a different bug.
Alex, do try to find a regression range for this bug.

This is definitely an Apple bug (since it also effects other browsers, though in different ways).  But we may also have done something to trigger it, or to make it worse.

Or (as you said) you may have found a different bug.

Either way a regression range may help to pin down the bug you saw.

Comment 25

4 years ago
RE:Regression Range

According to this post:

https://support.mozilla.org/en-US/questions/974137#answer-507698

Somewhere starting at FFX 21. The user reports that FFX 20 has no issues. How reliable the posters report is I dunno, but it's a small enough range to be easily checked.

Hope this helps...

Comment 26

3 years ago
I can reproduce this on FF27/OSX10.9.1 no plugins, fresh Mavericks, fresh User, external trackpad.

The problem doesn't manifest when setting
browser.gesture.swipe.down
browser.gesture.swipe.left
browser.gesture.swipe.right
browser.gesture.swipe.up
to empty (not "" but nothing) in about:config after restarting FF.

Hope this helps locating the problem.

Comment 27

3 years ago
I upgraded to the Aurora channel and perhaps it has to do with the new interface and associated changes, but this problem is not apparent on fresh FF29.0a2 / OS-X 10.9.1, same user from FF27, internal trackpad.

Hopefully this too helps with finding the bug.

Comment 28

3 years ago
Yeah also Nightly is bug-free for a few months I think.
Duplicate of this bug: 973218

Comment 30

3 years ago
Sorry for reporting a dupe, I don't know if its the same issue - I don't (intentionally) use two fingers swipe between pages.  I restarted my computer and the problem went away, and I don't seem to be able to make it repeat. I'll keep watching for it and try to spot what I do to cause it next time. 

Is there a good place to look for Firefox errors (I mostly help debug Thunderbird, and FF doesn't seem to have an Error Console). Is the system console the prefered place to look ?
(In reply to Mitra Ardron from comment #30)
> Is there a good place to look for Firefox errors (I mostly help debug
> Thunderbird, and FF doesn't seem to have an Error Console). Is the system
> console the prefered place to look ?

You can set devtools.errorconsole.enabled to true in about:config to add the error console to your "Tools -> Web Developer" menu.

Comment 32

3 years ago
Using refurbished MacBook Air 13", new out of the box yesterday, fully up to date with latest Mavericks. I have this exact issue. Two-finger scrolling works until a left or right gesture is done, then it's broken until FF restarts.

Comment 33

3 years ago
...this is quickly becoming infuriating.

Comment 34

3 years ago
(In reply to ajf from comment #33)
> ...this is quickly becoming infuriating.

From #c26, above, have you tried about:config?
browser.gesture.swipe.left
browser.gesture.swipe.right
to empty (not "" but nothing) and restarting FF.
Please see comment 24 before posting "me too" comments:

> This is definitely an Apple bug (since it also effects other browsers,
> though in different ways).  But we may also have done something to trigger
> it, or to make it worse.
> 
> [...] a regression range may help to pin down the bug you saw.

The Apple bug is referenced on the whiteboard (rdar://15313540). If you're able to reproduce this issue reliably, please try to find a regression range for Firefox using mozregression [1] and post your results here. Thanks!

[1] http://mozilla.github.io/mozregression/

Comment 36

3 years ago
(In reply to urs from comment #34)
> (In reply to ajf from comment #33)
> > ...this is quickly becoming infuriating.
> 
> From #c26, above, have you tried about:config?
> browser.gesture.swipe.left
> browser.gesture.swipe.right
> to empty (not "" but nothing) and restarting FF.

Yes, that seems to solve the issue! Thanks!

Comment 37

3 years ago
I used the mozregression tool and having trouble pinpointing the problem. All of the builds below are working for me (there are some gaps). However on release 27.0.1 I can reproduce the problem. Can someone point me to the doc to find the nightlies corresponding to before and after a given release?

2013-07-26-03-02-03-mozilla-central/firefox-25.0a1.en-US.mac.dmg
2013-09-15-03-02-08-mozilla-central/firefox-26.0a1.en-US.mac.dmg
2013-09-16-03-02-01-mozilla-central/firefox-26.0a1.en-US.mac.dmg
2013-09-17-03-02-14-mozilla-central/firefox-26.0a1.en-US.mac.dmg
2013-09-18-03-02-02-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-09-24-03-02-02-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-06-03-02-01-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-06-03-02-01-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-18-03-02-06-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-24-03-02-04-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-27-03-02-05-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-28-03-02-05-mozilla-central/firefox-27.0a1.en-US.mac.dmg
2013-10-29-03-02-01-mozilla-central/firefox-28.0a1.en-US.mac.dmg
2013-11-06-03-02-00-mozilla-central/firefox-28.0a1.en-US.mac.dmg
2013-12-28-03-02-04-mozilla-central/firefox-29.0a1.en-US.mac.dmg
2014-01-23-03-02-04-mozilla-central/firefox-29.0a1.en-US.mac.dmg
2014-02-05-03-02-03-mozilla-central/firefox-30.0a1.en-US.mac.dmg
2014-02-11-03-02-01-mozilla-central/firefox-30.0a1.en-US.mac.dmg
2014-02-14-03-02-02-mozilla-central/firefox-30.0a1.en-US.mac.dmg
2014-02-16-03-02-03-mozilla-central/firefox-30.0a1.en-US.mac.dmg
(In reply to urs from comment #37)
> Can someone point me to the doc to find the nightlies corresponding to
> before and after a given release?

Due to the way our nightly/aurora/beta/release channels work, there isn't really such a thing as a nightly "before and after a given release". There is (virtually) no code in a release build that isn't also in a nightly build. If you're unable to reproduce the issue with mozregression, I would verify the following two things:
1. Are your steps to reproduce reliable, i.e. if you follow the same steps, does the issue reproduce every time? Or is it unreliable/intermittent and using a mozregression build for a longer period of time would end up reproducing the issue? If this is the case, please use each mozregression build for more time until the issue either reproduces or not.
2. Are you able to reproduce in release 27.0.1 (without mozregression) with a new (clean) profile?

Comment 39

3 years ago
I have no actual data to confirm this but it's simply a description of what I've experienced:
– The issue was happening for me but only when I used my MBP's touchpad. I use Apple's bluetooth trackpad at work and (apparently) it didn't suffer from this issue.
— I updated to OS X 10.9.2 yesterday and now the bluetooth trackpad fails as well, leaving the browser in this unscrollable state. This is a blocker for optimal work.

Now I'm using the workaround of comment 26, but it's just that, a workaround, and the the back/forward navigation is lost by means of a two-finger swipe, which I use all the time.

I'm on Aurora by the way.

Comment 40

3 years ago
I can reproduce this on my MBA '12 integrated trackpad on OS X 10.9.1 only after I swipe back then try to scroll immediately. If I wait a second before scrolling (after swipe), I have no issues. My (default) prefs are: 

browser.gesture.swipe.down;cmd_scrollBottom
browser.gesture.swipe.up;cmd_scrollTop
browser.gesture.swipe.left;Browser:BackOrBackDuplicate
browser.gesture.swipe.right;Browser:ForwardOrForwardDuplicate

I wonder if this has something to do with the overlay scrollbars?

Can anyone who can reproduce this issue revert the above prefs back to default, then try again with overlay scrollbar disabled AND enabled (you can switch that option in the General part of the OS System Preferences)? By default, connecting a mouse automatically switches to always showing scrollbars. What is your default setting here?
Flags: needinfo?
Flags: needinfo?
Whoops, restoring Florian's needinfo.
Flags: needinfo?
(In reply to Florian Bender from comment #40)
> Can anyone who can reproduce this issue revert the above prefs back to
> default, then try again with overlay scrollbar disabled AND enabled (you can
> switch that option in the General part of the OS System Preferences)? 

I can trigger the bug using (above) default config and both with "Show scroll bars" set to "Automatically based on mouse or trackpad" (the default, afaik), "When scrolling" and "Always".
Flags: needinfo?
This problem did NOT occur for me until I upgraded to 10.9.2 today. There may be a correlation.

Comment 44

3 years ago
(In reply to Florian Bender from comment #40)
> OS X 10.9.1 

The update to 10.9.2 did not change anything for me. Still can't reproduce with STR from comment 0.
I can reproduce this with a fresh profile using the following steps:

1) Have a clean profile
2) Start Firefox
3) Hit Cmd+N to open a new window
4) Type "reddit.com" and hit Return
5) Choose a post and click to see it.

Now the critical step is:

6) Use two-finger swipe left to go back to the reddit start page.

Now you will notice that Firefox didn't go back and scrolling is broken. I can reproduce this 100% of all tries on my machine, I hope this works for others too.

Not sure how important the "clean profile" step is but I wanted to ensure that there are no other factors/prefs involved.
I tested the above with Nightly. I don't know if that works for Release as well.
Once again, this bug seems to be an Apple bug with OS X and happens if you use a two finger swipe gesture in any app.

Tim, does this same issue happen on Safari as well? If yes, you are also hitting the system bug, and we will have to hope for a fix from Apple (or find a workaround, which will be challenging). If not, then this will need closer investigation on the widget side.
Flags: needinfo?(ttaubert)
Yes, Safari breaks using the same STR, interesting. It breaks even worse because the current reddit tab has become completely unusable.
Flags: needinfo?(ttaubert)
Ok, sorry for the noise. After locking and unlocking my screen this doesn't seem reproducible anymore here. Seems to require unknown steps to get into that situation first.
This *just* started happening to me today on aurora, 29.0a2 (2014-03-17), it happens within 30min of restarting firefox (to fix the problem).  I initially thought it was caused by focus into a text field.  Another time it happened immediately after using cmd+up arrow to jump to the top of a page.  It does not affect any other applications (have not tried to repro in any other applications).  It affects all scrolling in firefox (e.g. scrolling the tab bar)

The only thing different I can think of over the past couple days:

- yesterday I added two more desktop screens and started using vmware full screen in one (though this is happening without vmware running).
- have expanded my use of tab groups from 4-5 to 9
- I was testing the "WindowShopping" addon (available in AMO) though it has been disabled across multiple restarts

will now restart the laptop and see if this continues after a full restart.

I'm on a 2013 11" air running osx 10.9.2 (updated to that a couple weeks ago I think).

Comment 51

3 years ago
This recently started happening to me. I tried a few fixes online and nothing worked. I then realised I had recently disabled the "Notification Center" swipe on trackpad options (System Preferences -> Trackpad ->More Gestures -> Tick/Untick Notification Center). I re-enabled this and the two finger swipe to go back works as intended.
For me, I have not experienced this problem since the day I added my report.  I also have not used vmware full screen on a separate desktop space since then.
Duplicate of this bug: 967990

Comment 54

3 years ago
Happens to me on FF v30 beta. Restarting FF helps. But keeps coming back.

Comment 55

3 years ago
I had this issue during a long running session (about 1 month) but it went away after some time (don't know if sleep mode "reset" the gesture control, or this just happened after some time). Haven't had it since.
I can reproduce this in Fx 29.0 OSX and the beta channel with a brand new profile.

To reproduce, I just go to :

https://www.mozilla.org/en-US/firefox/29.0/firstrun/

I close the popup dialog on the top right so that the main page is vertically scrollable with trackpad.

Test vertical scrolling with 2 finger swipe - works fine.

Do multiple 2 finger side swipes.

Try 2 finger vertical swipe again - and it no longer works.

This seems to break 100% of the time for me.
I just tried the tip in https://bugzilla.mozilla.org/show_bug.cgi?id=927702#c51 which didn't work for me.

I ended up disabling all side swipe gestures in OSX's trackpad preference pane - restarted firefox and things at least don't break anymore.

Updated

3 years ago
Flags: firefox-backlog?
This isn't something for the desktop team to tackle. It's an OS X bug and even if not it's at least a platform bug.
Flags: firefox-backlog? → firefox-backlog-
though we probably dont need it, another data point...had one person tell me at the conference I just attended that this bug is why he doesn't use firefox.

Comment 60

3 years ago
Just to be clear - there are THOUSANDS of users having this problem.  Just check your own website about problem reports!!!  I'm a product developer too and understand how these issues can go.  

It's so easy to just "pass the buck" and blame someone else all the while your product is being abandoned.  It does not mater if the problem is Apple's or someone else's.  This bug must be fixed because it critically affects the user experience on a mac.  It's easy to just "hope and wait".

I'm not convinced that this bug is "all" Apple's.  I run firefox and safari simultaneously.  

Here's how I was able to reproduce this bug immediately (for Firefox only).

1. Start Firefox
2. Navigate to your favorite website that will require two-finger scrolling
3. Scroll up and down, but as you scroll, ever so slightly twist your fingers to the right and down (while dragging the fingers down, it's almost a twisting gesture)

I think the gesture motion could almost be confused with a page swipe.

Hope this helps.

Comment 61

3 years ago
This bug is entirely Apple's responsibility.

The failure affects the platform across all a user's windowed processes when it occurs.

It can be observed in Safari, Chrome and Firefox without requiring one of them to be the trigger.

FWIW, I have not yet noticed the issue in 10.9.3. While that certainly does not mean that it has been resolved, have you updated and are still encountering the issue?

Comment 62

3 years ago
For me, this bug does not affect any other windowed process.  When I see the problem, it is completely isolated to Firefox.  To be clear, I have not seen an issue like this with Safari.  

Here's my system overview:

  System Version:	OS X 10.9.2 (13C1021)
  Kernel Version:	Darwin 13.1.0
  Firefox:              29.0.1
  Safari:               Version 7.0.3 (9537.75.14)


As for your comment about "This bug is entirely Apple's responsibility.", I think this is a terrible attitude. I am not convinced you have identified the problem to root cause.  Root cause would be a line of code.

Maybe the issue is all Apple, but if you listen to the comments, there are clearly some people who report that the problem is isolated just to Firefox.  

How do you know that there are not multiple issues here?  Maybe Apple will fix whatever the issue is with the trackpad, but maybe the problem will remain in Firefox because Firefox is doing something special?  Why wait that long?  

Maybe you can isolate the problem to a particular line of code in Firefox?  That line of code may be a system call, but at least you know where the problem occurs and I'm sure Apple would appreciate knowing about it too.  It also would aid regression testing.

Comment 63

3 years ago
When it occurs, if you perform the same gesture in another windowed process that supports that gesture it will fail to function correctly afterwards if you try and scroll.

The fact it persists after you close and reopen Firefox demonstrates that it has corrupted more global state.

The problem is observably not isolated to Firefox.

Comment 64

3 years ago
(In reply to Nick Lowe from comment #63)
> When it occurs, if you perform the same gesture in another windowed process
> that supports that gesture it will fail to function correctly afterwards if
> you try and scroll.
> 
> The fact it persists after you close and reopen Firefox demonstrates that it
> has corrupted more global state.
> 
> The problem is observably not isolated to Firefox.

Maybe on your machine. For me, restarting Firefox will fix the problem.

I refuse to believe this is an Apple issue when it affects nothing else.

Comment 65

3 years ago
You will be able to scroll in Firefox after closing and reopening it, it is only after performing the gesture that subsequent scrolling with fail.

Comment 66

3 years ago
*will fail.

Have you all updated to 10.9.3 too?

Comment 67

3 years ago
(In reply to Nick Lowe from comment #65)
> You will be able to scroll in Firefox after closing and reopening it, it is
> only after performing the gesture that subsequent scrolling with fail.

Right. Then, when you re-open Firefox, it all works again.

Comment 68

3 years ago
(In reply to ajf from comment #67)
> (In reply to Nick Lowe from comment #65)
> > You will be able to scroll in Firefox after closing and reopening it, it is
> > only after performing the gesture that subsequent scrolling with fail.
> 
> Right. Then, when you re-open Firefox, it all works again.

Not at all, you have misunderstood the issue completely.

Normally, gestures to go back and forward will function as expected within Firefox. However, at a seemingly random point in time during the course of using the system a gesture will fail to function as expected and subsequent scrolling will ail.

If you then close Firefox and reopen it, the instant that you perform a gesture to go back or forward, subsequent scrolling will fail.

The corruption in state is in OS X and not Firefox.

Updated

3 years ago
Duplicate of this bug: 1016919

Comment 70

3 years ago
(In reply to Florian Bender from Bug 1016035 comment #1)
> Is there a way back/forward swiping can be reimplemented with APZ
> (preferably with as little MT processing as possible) that avoids Bug 927702
> from happening?

(In reply to Markus Stange [:mstange] from Bug 1016035 comment #2)
> Yes, implementing it with APZ would avoid it, since we don't have access to
> the buggy API on the APZ thread.

Mind that APZ is not happening for another couple of releases.
See Also: → bug 1016035

Comment 71

3 years ago
I'm running Mac OS 10.9.3 on a MacBook Air and have this issue quite a while now. So, I used the mozregression tool (for the first time) and I think I might have found something interesting… (But more probably I'm just raising a false alarm now xD)

I came to this:
Last good revision: be17ceae8d60 (2011-08-12)
First bad revision: 9698a1031317 (2011-08-13)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be17ceae8d60&tochange=9698a1031317

I looked through the push log and took out suspicious commits and I guess one of these two might have something to do with the issue. (But then again it's also possible, as some here mentioned, that it might be a bug of OS X and not of Firefox)
- http://hg.mozilla.org/mozilla-central/rev/5c8b3f1db588
- http://hg.mozilla.org/mozilla-central/rev/420c7a55b4a0

Eventually someone wants to look through this…

Comment 72

3 years ago
Everything was working fine until 2 or 3 days ago. Problem same as everyone else, I try to swipe back and scrolling altogether stops working. I have to restart my computer completely for it to not occur for a while. Here's my console report:

6/29/14 1:45:43.000 AM kernel[0]: firefox (map: 0xffffff803b4794b0) triggered DYLD shared region unnest for map: 0xffffff803b4794b0, region 0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this increases system memory footprint until the target exits.
First, let me repeat this *again* and say that the issue here is an Apple bug, which was verified by the fact that they duped my radar to another one. So please, refrain from anymore "me too" comments.

(In reply to evotopid from comment #71)
> - http://hg.mozilla.org/mozilla-central/rev/5c8b3f1db588
> - http://hg.mozilla.org/mozilla-central/rev/420c7a55b4a0

All this tells us is that the issue occurred when we landed two finger swiping in Firefox, which is obvious, since that's when we started using the relevant APIs.
I heartily agree with Josiah -- please no more "me too" comments.

But this might at bottom be a hardware problem (possibly a networking
problem), so there might be something interesting in the console logs
for people who see this bug.

> firefox (map: 0xffffff803b4794b0) triggered DYLD shared region unnest for map:
>  0xffffff803b4794b0, region 0x7fff8f000000->0x7fff8f200000.
> While not abnormal for debuggers, this increases system memory footprint
>  until the target exits.

This is *not* interesting (not relevant):  It happens every time you
quit Firefox, and is (basically) benign.

But the log statements from comment #6 *might* be interesting, despite
what I said about them in comment #7.

Look for statements whose timestamp coincides with when you see the
problem.

In fact it's probably best to

1) Restart your computer

2) Work on it until you start seeing this bug again, then immediately
   run the Console app and look for statements dated around the time
   the problem [re]started.

Comment 75

3 years ago
I just found out that in my case it is the "Swipe between pages -> Scroll left or right with two fingers" setting, that does not swipe between pages.  If I change the gesture to one of the other two settings, e.g. "Swipe with three fingers", everything works fine. 

See: http://i.imgur.com/bEoypoE.png

So the question is, is Firefox supposed to support "Swipe between pages" with the default two-finger-scroll-gesture? Or just the three-finger-swipe? If the default gesture is suppose to work, is it still Apple's issue or not? 

As I stated in Bug 1016919, all gestures work just fine in Safari, and two finger scrolling (up and down) work just fine in Firefox. 

Also, the "Swipe with three fingers" conflicts with the "Three finger drag" setting, that can cause the "Swipe between pages" to change the gesture to change it's default (Scroll left or right with two fingers). Which could appear as "swipe between pages just broke in firefox".

Comment 76

3 years ago
History two-finger gesture fails if history is empty, can we get this thing finally fixed? It's making me switch to chrome.

Comment 77

3 years ago
Seems to me the best (and it works for me) workaround is to change from a two-finger swipe in System Prefs to the three-finger swipe.

Comment 78

3 years ago
I am not having this problem. I can two finger back-swipe just fine with no problems. I know this isn't a solution, but I wanted to report that some are not experiencing this. It's perplexing... No one that I (personally) know has the problem with Safari, but early on when Mavericks was first released Safari was affected (see Apple discussion boards). I ONLY use Firefox. I can't live without NoScript. I haven't launched Safari in years (and don't ever want to if possible), and I won't use Chrome either - it's a personal choice/philosophy. 

I am currently running 10.9.4, FFX 32.0 with the extensions - NoScript, Adblock EDGE, Refcontrol, "Download YouTube Videos as MP4", and BetterPrivacy. All are the current versions. You would think if this was an Apple issue it would affect more than just browsers, but someone above swears that this is an Apple bug - that may indeed be the case. Apple doesn't seem to be in any hurry to fix it though. If this was JUST affecting FFX they probably wouldn't even bother fixing it (I remember Tim Cook ridiculing FFX outright a couple of Key Notes ago - not cool). Anyway, I wouldn't hold my breath waiting for Apple to fix the issue. It's quite possible that they may never address it.

*** I haven't beta'd Yosemite, but can anyone out there who has tell me if FFX still exhibits this same behavior under the 10.10beta? Thanks.

If it is still locking up under 10.10b, then don't look for a fix anytime soon from Apple... Unfortunate, but true.

Comment 79

3 years ago
(In reply to 8-bit from comment #78)

Replying to self... Can someone repro this and then get a sample of FFX via Activity Monitor (~/Utilities/), then post it to the pastebin (don't forget to copy the URL so you can paste it into your post otherwise we wont be able to see/access it). Thanks!

Comment 80

3 years ago
I just started having this problem after a few weeks on 10.9.4 with no issue. Here is a sample:

http://pastebin.com/wY9wtVJW

It *may* have something to do with custom scrollbars on certain pages...I've noticed that it happens quickly if I have gmail open and have scrolled around using 2 finger trackpad gesture.

Comment 81

3 years ago
(In reply to bjcasillas13 from comment #72)

See: https://bugzilla.mozilla.org/show_bug.cgi?id=804010

The Mac's Console report that you report, also occurs upon starting Firefox 31 and starting SeaMonkey 2.29; the Console also reports the "triggered DYLD shared region unnest for map" at the moment of running the SeaMonkey 2.29 installer.  I do not get the Console report for Firefox 29.0.1 and SeaMonkey 2.26.1 --- and I returned to using those older versions.

> Everything was working fine until 2 or 3 days ago. Problem same as everyone
> else, I try to swipe back and scrolling altogether stops working. I have to
> restart my computer completely for it to not occur for a while. Here's my
> console report:
> 
> 6/29/14 1:45:43.000 AM kernel[0]: firefox (map: 0xffffff803b4794b0)
> triggered DYLD shared region unnest for map: 0xffffff803b4794b0, region
> 0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this
> increases system memory footprint until the target exits.

Comment 82

3 years ago
(In reply to bjcasillas13 from comment #72)

Re my comment 81, above ... this part I wrote incorrectly:

"the Console also reports the "triggered DYLD shared region unnest for map" at the moment of running the SeaMonkey 2.29 installer"

Corrected: The bug showing at the moment of running the SeaMonkey 2.29 installer, is:

9/18/14 12:53:53 PM	KernelEventAgent[69]	tid 00000000 received event(s) VQ_LOWDISK, VQ_VERYLOWDISK (516)

---

> Everything was working fine until 2 or 3 days ago. Problem same as everyone
> else, I try to swipe back and scrolling altogether stops working. I have to
> restart my computer completely for it to not occur for a while. Here's my
> console report:
> 
> 6/29/14 1:45:43.000 AM kernel[0]: firefox (map: 0xffffff803b4794b0)
> triggered DYLD shared region unnest for map: 0xffffff803b4794b0, region
> 0x7fff8f000000->0x7fff8f200000. While not abnormal for debuggers, this
> increases system memory footprint until the target exits.

Comment 83

3 years ago
Neither of those console reports has anything to do with this issue. However in the sample that Ben provided (thanks for that) I did find a few interesting things, although they may be unrelated as well:

Line 974:  | + 43 ___trackSwipeWithScrollEvent_block_invoke  (in AppKit) + 3174  [0x7fff860b7817]
Line 1259: | + 3 ___trackSwipeWithScrollEvent_block_invoke  (in AppKit) + 1059  [0x7fff860b6fd4]

These look interesting, but may be unrelated....

Comment 84

3 years ago
I am wondering if it DOES have everything to do with OS X scroll bars and not necessarily anything to do Firefox itself, though of course that in and of itself is a bug in FF.

For me, the only time scrolling quits working is when the gesture for back or forward in history is used.

Even if there is no available page in the history to go forward to, using that gesture breaks FF scrolling.

I have been through the ringer here trying to find a cause and this seems to be the only one. Clicking a link isn't always a cause of the broken scrolling feature. I do not have a plug-in mouse handy to use to test to see if using it would work even after the trackpad 2-finger scrolling quit working.

My Mac is 13" MBP 9,2 with 8GB RAM and SSD. Mavericks 10.9.3 (aviding .4 and .5 due to horrible bugs I experienced regarding RAM and SSD performance, so I did a fresh format a few days ago and stuck with the default I had saved on USB which was 10.9.3.)

The only things I am seeing in Console is what has already been mentioned regarding the DYLD and xpcproxy assertion failed.

If it helps, the apps I am currently running alongside of Firefox are:
Console
TextEdit (2 windows open)
Finder (2 windows open)
System Preferences
Mail
Notepad (from MAS, developer: Kupon.BG Ltd)
Mac App Store
The Sims 3 Game Launcher (don't judge)
Activity Monitor

Current Physical Memory: 8GB
Memory Used: 5.98 GB
Virtual Memory: 8.07GB
Swap Used: 0 bytes
App Memory: 3.05 GB
File Cache 1.92 GB
Wired Memory: 993.3 MB
Compressed 43.2 MB.
Memory pressure green, very low.
CPU - System: 1.25%
CPU - User: 1.05% (of course these are always changing and I am typing them out)
CPU - Idle: 97.08%
CPU load extremely low
Threads 763
Processes 183

Comment 85

3 years ago
I don't know if this has already been mentioned, but switching the trackpad gesture to 3-fingers for "Swipe between pages" seems to have totally fixed the firefox scrolling and back/forward in history problem. Only now, the gesture is backwards, instead of swiping left to right to go back in history it goes forward, and the reverse is true for forward. But at least I can use a gesture for it instead of manually clicking the back/forward buttons.

Comment 86

3 years ago
This is clearly a FF bug on Mac OS X. It triggers for me *ONLY* :
 - *if* FF just auto-updated
 - *when* using gesture for back/forward

Each time FF auto-uptade, I remove it completely and I use another browser to download it again, because Mozilla had the brilliant idea to hide download link for user coming with FF.

Re-installing it from scratch is necessary, but is not sufficient. I don't know what is the second condition to have gesture working back (reboot ?).

Comment 87

3 years ago
I just updated to 10.10 Yosemite, and found i could reproduce this bug.
Disable "swipe between pages" in system perference could fix it, but when I use Mavericks, I never affected by this bug.

And I found the "scrolling freeze" looks like locking by window:
1.Open window 1, open any url you like, and swipe life/right. Then you found your scrolling broken;
2.Open window 2, open any url. Scrolling doesn't work either;
3.Close window 1, now the scrolling works in window 2 immediately.

I found safari had this bug exactly like in firefox: same reproduce method; same "locking by window"; fix by disable "swipe between pages" same. Since I never affected by it in Mavericks, I'm supposing it's a new bug in Yosemite system but not in firefox.

Comment 88

3 years ago
I still have this problem with FF 33.0.2 on Mavericks. It's annoying as ***k and has been there for a year, and everybody's saying it's an OS X issue. Well if it's an OS X issue how come it works perfectly in Chrome (both 32-bit and the new 64-bit versions), both sideswiping for back/forward, and naturally scrolling up/down. Tired of the excuses, this should be fixed already.
Duplicate of this bug: 1091618
(In reply to Thomas Horsten from comment #88)
> I still have this problem with FF 33.0.2 on Mavericks. It's annoying as ***k
> and has been there for a year, and everybody's saying it's an OS X issue.
> Well if it's an OS X issue how come it works perfectly in Chrome (both
> 32-bit and the new 64-bit versions), both sideswiping for back/forward, and
> naturally scrolling up/down. Tired of the excuses, this should be fixed
> already.

It is a problem in Chrome too: https://code.google.com/p/chromium/issues/detail?id=310649

I've been able to repro in *many* applications on OSX 10.10.1.

Comment 91

3 years ago
(In reply to Corey Richardson (:cmr) from comment #90)

> It is a problem in Chrome too:
> https://code.google.com/p/chromium/issues/detail?id=310649
> 
> I've been able to repro in *many* applications on OSX 10.10.1.

I am now using Yosemite 10.10.1 and do NOT have any issue with Firefox anymore. I did a straight upgrade from 10.9.3 and am now using Firefox full-time! I missed it so badly.

I have not installed Chrome, as I have a small 256GB SSD instead of a regular HDD so space is very limited. In fact today I got several notifications that I had run out of disk space. Nice. So I was scrambling to delete files. 

Anyway, I have not had any of the problems listed in this report and in the comments with Yosemite 10.10.0 and 10.10.1. Again, my Mac is a MBP 9,2 (mid 2012 13" MBP with Core i7 2.9ghz (dual), 8GB ram, 256 SSD)

Comment 92

3 years ago
(In reply to Toni Pokki from comment #75)
> I just found out that in my case it is the "Swipe between pages -> Scroll
> left or right with two fingers" setting, that does not swipe between pages. 
> If I change the gesture to one of the other two settings, e.g. "Swipe with
> three fingers", everything works fine. 

> As I stated in Bug 1016919, all gestures work just fine in Safari, and two
> finger scrolling (up and down) work just fine in Firefox. 

I've no idea what happened, but the 'swipe between pages' by using two fingers has started to work. I've not actively used the gesture as it hasn't worked before, so no idea what fixed this issue (and when). Anyway, here's latest updates and changes that might be related:

- osx update to 10.10.1
- Xcode 6.1.1
- command line tools 6.1
- ff upgrade to 33.1
- ff upgrade to 34.0

When I noticed that it worked, I checked the ff version and it was 33.1. At the same time ff noticed that there was update available, so I bravely updated to 34.0. And the swiping still works... \o/

Comment 93

3 years ago
I can report that this is (still) an issue for me with the following configuration:

- FF 34.0.5
- OS X 10.10.1

The only thing in Console is this (not sure it's related):
2014-12-19 15:48:42,535 hidd[72]: IOHIDEventQueue: Timeout waiting for IOKit to be quiet #1 (e00002d6)
2014-12-19 15:49:12,536 hidd[72]: IOHIDEventQueue: Timeout waiting for IOKit to be quiet #1 (e00002d6)
2014-12-19 15:49:42,539 hidd[72]: IOHIDEventQueue: Timeout waiting for IOKit to be quiet #1 (e00002d6)
...

Comment 94

3 years ago
This time again, the bug was triggered by a FF auto-update and stopped when I deleted/reinstalled FF then reboot.
On my MacBook Pro (Yosemite), Google Chrome doesn't suffer of this bug.

Updated

3 years ago
Duplicate of this bug: 1108945

Updated

3 years ago
Summary: [10.9] Two finger swipe gesture fails, breaks subsequent scrolling (Mavericks). → [10.9][10.10] Two finger swipe gesture fails, breaks subsequent scrolling (Mavericks, Yosemite).

Updated

3 years ago
Duplicate of this bug: 1110943

Comment 97

3 years ago
Trying to navigate back and forward no long works using hand gestures of any kind.

I was using BetterTouchTool's mapping of 3 fingers left/right to back/forward (with native trackpad settings disabled) but today that has stopped working.

Comment 98

2 years ago
This bug just returned for me as well, I had this in the past and it was resolved, it has been too long to remember if I did something to resolve it or if it was resolved with an update.

Comment 99

2 years ago
OK Just remembered the fix from also time, if you open up the trackpad settings, disable every gesture, then quit Firefox, then enable the gestures you want, then open Firefox, and the bug should go away.

Comment 100

2 years ago
I was on an old version of FF (25.x or perhaps 28.x... not sure). An update to 31.x went through. Noticed the two-finger scrolling for work for a little, and then stop completely. A restart would fix it for a minute or two. Updated to 35.0.1 and the issue persists.
On a MacBook Pro 17", 2012 model. OSX 10.9.5
Strangely, I can three-finger scroll. Never done that before. And a little scrolling icon (not sure what else to call it) appears on the screen. Three-finger swiping up the trackpad moves up toward top of page. Swiping down moves down towards bottom of page (so it's reversed from what it is normally).
Going to try Rusty Kerr's suggestion in comment 99.
Page back and forth does not work. Nor does tab previous/next work (shift two-finger left/right, according to the about:config settings for that gesture).

Comment 101

2 years ago
Further to my comment above (#100), the workaround mentioned by Rusty Kerr (#99) did not work. It seems, and I can't be 100% sure, that the scrolling dies when scrolling to where a flash object is on a page. That may just be a coincidence though.
I am using BetterTouchTool as a work around.

Comment 102

2 years ago
Still a problem in 36.0 (release) on 10.9.5 (Mac Book Pro 15" Retina late 2013, Nvidia Graphics)

after CMD+Q and then relaunch of Firefox 36.0 scrolling works for a minute or two, then problem returns. Only reboot of the system solves the issue.

Comment 103

2 years ago
I'm still having this problem on 36.0.1 on 10.9.5 (Mac Book Pro 13"). 

I've been having this problem for quite a while now going back many versions of FF.  The two finger gesture scrolling disables randomly and quitting FF and relaunching brings it back.  It is isolated to just FF and I have no problems swiping to different desktops or gesture scrolling on other applications.

Tonight the scrolling disabled again except this time instead of quitting, I decided to clear my cache and the gesture scrolling came back as soon as I closed the preference window, no restarting required.  

If (when?) it returns, I'll report if clearing cache corrects it again.
Duplicate of this bug: 1158592

Comment 105

2 years ago
(In reply to DW from comment #103)
> I'm still having this problem on 36.0.1 on 10.9.5 (Mac Book Pro 13"). 
> 
> I've been having this problem for quite a while now going back many versions
> of FF.  The two finger gesture scrolling disables randomly and quitting FF
> and relaunching brings it back.  It is isolated to just FF and I have no
> problems swiping to different desktops or gesture scrolling on other
> applications.
> 
> Tonight the scrolling disabled again except this time instead of quitting, I
> decided to clear my cache and the gesture scrolling came back as soon as I
> closed the preference window, no restarting required.  
> 
> If (when?) it returns, I'll report if clearing cache corrects it again.

As a follow up to my earlier report, I found that clearing my cache only worked the one time I reported it and never aftewards.

However I did find that closing the lid and re-opening it (ie: putting my Macbook Pro to sleep and waking it) did resolve the issue without further needing to close the application, logout, or reboot so this suggests to me that this issue is either graphics card and/or memory related.

Comment 106

2 years ago
Just a note that this is happening on 38.0.5 / Yosemite 10.10.3.  A fix (at least temporarily, this only happens ever few weeks) is to disconnect / reconnect the magic trackpad via the Bluetooth menu in the menu bar (just turning the magic trackpad off and on doesn't do anything).

Comment 107

2 years ago
Same problem occurring here. Incredibly annoying and frustratingly intermittent.
(Assignee)

Comment 108

2 years ago
Bug 1016035 changed our swiping implementation to no longer use the Cocoa API. I'm expecting that to fix this bug.
Assignee: nobody → mstange
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43

Comment 109

2 years ago
(In reply to Markus Stange [:mstange] from comment #108)
> Bug 1016035 changed our swiping implementation to no longer use the Cocoa
> API. I'm expecting that to fix this bug.

Hope it does fix it, but no other app on OSX is affected. Even when scrolling stops working in Firefox, every other app still works.

Comment 110

2 years ago
I'm still having this problem on Firefox 41.0.2 on MacOS 10.10.5.

Comment 111

2 years ago
I'm still having this problem on Firefox 41.0.2 on MacOS 10.10.5.

Comment 112

2 years ago
As stupid as this might sound, I've found I can fix this 100% of the time by just mashing the Force Touch trackpad with all my fingers a few times. Could point to a potentially permanent fix?

Comment 113

2 years ago
(In reply to dem from comment #111)
> I'm still having this problem on Firefox 41.0.2 on MacOS 10.10.5.

Have you tried my previous solution in comment 99?  If you open up the trackpad settings, disable every gesture, then quit Firefox, then enable the gestures you want, then open Firefox, and the bug should go away.

The bug returned when I had to reinstall firefox, but the settings work fine from update to update, I have only had to redo this the one time.
(Assignee)

Comment 114

2 years ago
The fix landed in Nightly 43. It will ride the trains and be released in Firefox 43.

Comment 115

2 years ago
Thanks. I tried the fix in comment 99, but it didn't work for me.

Comment 116

2 years ago
(In reply to dem from comment #115)
> Thanks. I tried the fix in comment 99, but it didn't work for me.

Must be a different bug with the same problem, I have used this several times on machines built between 2010 and 2013, the new machines are shipping with a different trackpad, so that could be it.

Comment 117

a year ago
So is this working perfectly for everybody now? Just wanted to check in.... 

Bueller?
Bueller?

Comment 118

a year ago
(In reply to 8-bit from comment #117)
> So is this working perfectly for everybody now? Just wanted to check in.... 
> 
> Bueller?
> Bueller?

Seems the bug didn't occurred since a few versions ago.

Updated

a year ago
Duplicate of this bug: 1164544

Comment 120

11 months ago
(In reply to Joachim Rousseau from comment #118)
> (In reply to 8-bit from comment #117)
> > So is this working perfectly for everybody now? Just wanted to check in.... 
> > 
> > Bueller?
> > Bueller?
> 
> Seems the bug didn't occurred since a few versions ago.

I'm seeing this issue under Firefox 47.0 on Mac OS X 10.10.5. Blanking out the browser.gesture.swipe.{left,right} prefs did not solve it, but disabling two-finger page navigation in the OS-level settings seems to have done the trick.

Markus -- do you want me to re-open this bug, or file a new one?
Flags: needinfo?(mstange)
(Assignee)

Comment 121

11 months ago
Adam, does moving the mouse fix this for you? If so, you might be seeing bug 1245083. If not, please test whether it's fixed in Nightly, and if not, file a new bug. Thanks!
Flags: needinfo?(mstange)

Comment 122

11 months ago
(In reply to aaron.hastings11 from comment #112)
> As stupid as this might sound, I've found I can fix this 100% of the time by
> just mashing the Force Touch trackpad with all my fingers a few times. Could
> point to a potentially permanent fix?

 this actually works. ive felt like people have seen me do this and thought i was throwing a mini temper tantrum at my computer, but this genuinely works for me, only temporarily though and then i have to do it every fifteen minutes. im glad im not the only one.

Comment 123

11 months ago
(In reply to ilis uc from comment #122)
> (In reply to aaron.hastings11 from comment #112)
> > As stupid as this might sound, I've found I can fix this 100% of the time by
> > just mashing the Force Touch trackpad with all my fingers a few times. Could
> > point to a potentially permanent fix?
> 
>  this actually works. ive felt like people have seen me do this and thought
> i was throwing a mini temper tantrum at my computer, but this genuinely
> works for me, only temporarily though and then i have to do it every fifteen
> minutes. im glad im not the only one.

i saw on reddit someone wrote "basically any force-touch action can be done with a three finger tap on non force touch trackpads" i didnt fact check that but it might explain why this works
You need to log in before you can comment on or make changes to this bug.