Bug 1341102 (stylo-bustage)

stylo: Bustage metabug

RESOLVED WORKSFORME

Status

()

defect
P5
normal
RESOLVED WORKSFORME
2 years ago
6 months ago

People

(Reporter: bholley, Unassigned)

Tracking

(Depends on 2 bugs, Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
We're ending up with a pretty regular cadence of fixing up bustage and adjusting test expectations to keep autoland green. I thought it would be handy to have a metabug to track these fixups. Alias "stylo-bustage".
Reporter

Updated

2 years ago
Depends on: 1340838, 1340439, 1338872
Reporter

Updated

2 years ago
Depends on: 1340978
Reporter

Updated

2 years ago
Depends on: 1341025
Reporter

Updated

2 years ago
Depends on: 1341013
Reporter

Updated

2 years ago
Depends on: 1341112
Depends on: 1341348
Reporter

Updated

2 years ago
Depends on: 1341740
Reporter

Updated

2 years ago
Depends on: 1342193
Reporter

Updated

2 years ago
Depends on: 1342862
Depends on: 1343028
Depends on: 1343030
Depends on: 1343031
Depends on: 1343050
Depends on: 1343166

Comment 1

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/17b6cdda4c10
Revendor rust dependencies; r=bustage
Depends on: 1343622
Depends on: 1343701
Depends on: 1344133
Depends on: 1344303
Depends on: 1344304
Depends on: 1344333

Comment 3

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9beaa662eb45
Make stylo reftests green; r=orange
Depends on: 1346349
Depends on: 1346353
Depends on: 1346461

Comment 5

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/011ca940ccae
Update stylo test expectations; r=bustage

Comment 6

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4435b3244b01
Update stylo test expectations. r=me

Comment 7

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4895fb7b57d
Mark several intermittent failures random.
> Mark several intermittent failures random.

It would probably be better to skip-if(stylo) instead of using random. Or at least random-if(stylo), so we remember to grep for them later and fix them, because this sort of random fail on tests that always pass for gecko seems like a stylo bug, no?

In general, it would be best if we standardized on a small set of "test disabled for stylo only" annotations...
Flags: needinfo?(xidorn+moz)
Reporter

Updated

2 years ago
Priority: -- → P5
(In reply to Boris Zbarsky [:bz] (still a bit busy) (if a patch has no decent message, automatic r-) from comment #10)
> It would probably be better to skip-if(stylo) instead of using random. Or at
> least random-if(stylo), so we remember to grep for them later and fix them,
> because this sort of random fail on tests that always pass for gecko seems
> like a stylo bug, no?

This only changes reftest-stylo.list. I suppose that is a list only run with stylo mode. Do we still need to add if(stylo) there?
Flags: needinfo?(xidorn+moz) → needinfo?(bzbarsky)
Reporter

Comment 12

2 years ago
We don't need if(stylo) in reftest-stylo.list.
Using skip-if(stylo) consistently makes it easy to grep for it or search via searchfox/dxr in all reftest and crashtest manifests.  And while we run reftest-style.list in stylo mode only, we run crashtests.list in both modes, so have to use skip-if(stylo) there.

Also, we have some existing "skip" in reftest-stylo.list that came from the corresponding reftest.list.  For purposes of figuring out "what are the things that are uniqely broken with stylo", those would be distractions...

In any case, marking stuff as "random" definitely doesn't clearly communicate "this is a stylo bug that needs to be fixed so we can turn it on".  :(
Flags: needinfo?(bzbarsky)
Reporter

Comment 15

2 years ago
(In reply to Boris Zbarsky [:bz] (still a bit busy) (if a patch has no decent message, automatic r-) from comment #13)
> Using skip-if(stylo) consistently makes it easy to grep for it or search via
> searchfox/dxr in all reftest and crashtest manifests.  And while we run
> reftest-style.list in stylo mode only, we run crashtests.list in both modes,
> so have to use skip-if(stylo) there.
> 
> Also, we have some existing "skip" in reftest-stylo.list that came from the
> corresponding reftest.list.  For purposes of figuring out "what are the
> things that are uniqely broken with stylo", those would be distractions...

Ok, that's a fair argument. I retract comment 12.

Comment 19

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ab9bdbdc7780
fix autoland bustage; r=bustage a=bustage

Comment 20

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/cef93bf5a0a1
fix autoland bustage; r=bustage a=bustage

Comment 27

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0075024192ed
Fix failures from -moz-system-metric changes (bug 1341086); r=manishearth

Comment 29

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45d7dc648ed1
Adjust test expectations after merging #15983. r=me

Comment 31

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a7f0db97af0
Update stylo mochitest expectation for caret-color.

Comment 32

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/253780566f3b
Revendor rust dependencies. r=me (CLOSED TREE)

Comment 34

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/42f7c37bd492
Update expectations after merge of #16006. r=me

Comment 37

2 years ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/d81996338334
Adjust expectations for servo/servo#15604 and servo/servo#16028: Fix reftest expectation format. r=reftest-fix on a CLOSED TREE

Comment 39

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/75a3db6d2f77
Adjust expectations for new passes caused by servo/servo#15918. r=me

Comment 40

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ee95a66bea56
Skip some timing-dependent tests due to bug 1338982. r=emilio

Comment 42

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/01e61eff9b62
Adjust reftest expectations now that dynamic changes account for :not. r=emilio

Comment 43

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9d48fb9f6620
Update stylo test expectations for #16104. r=me
Depends on: 1350363
Depends on: 1350479
Depends on: 1350485

Comment 45

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e1905b6be7a4
Update stylo reftest expectations; r=orange
Depends on: 1350610
Depends on: 1350714
Depends on: 1350716
Depends on: 1350827
Depends on: 1351520
Depends on: 1351620
Depends on: 1351636
Depends on: 1351750
Depends on: 1351949
Depends on: 1351950
Depends on: 1352040
Depends on: 1352136
Depends on: 1352253
Depends on: 1352256

Comment 55

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b82d0e0dc533
stylo: Add some fuzziness to box-decoration-break-with-inset-box-shadow-1.html.
Depends on: 1345283
Depends on: 1352535
(In reply to Pulsebot from comment #57)
> Pushed by manishearth@gmail.com:
> https://hg.mozilla.org/integration/autoland/rev/eb4ab1b12bfe
> Fix stylo bustage; r=orange

Backed this out in https://hg.mozilla.org/integration/autoland/rev/6adff9a52cea6e422641a30d20aeca99cfa0718c because it turned the tests permafail.
Depends on: 1352613
Depends on: 1352614
Depends on: 1352663
Depends on: 1352936
Depends on: 1352942
Depends on: 1352945
Depends on: 1353109
Depends on: 1353117

Comment 63

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5694d3ce08bf
Update stylo reftest expectations; r=orange
Depends on: 1353892
Depends on: 1354256
Depends on: 1354270
Depends on: 1354316
Depends on: 1354541
Depends on: 1355224

Comment 73

2 years ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54943b790dfd
Update mochitest expectations. r=me

Comment 75

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ed5ddbb68bb
Update stylo reftest expectations ; r=manishearth

Comment 78

2 years ago
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/741c590fe3ed
Update expectation data r=me a=me CLOSED TREE
Depends on: 1356013

Comment 80

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3ef306a6bf0
Update test expectation on a CLOSED TREE.
Depends on: 1356144
Depends on: 1356198
Depends on: 1356349
Depends on: 1356428
Depends on: 1356430
Depends on: 1356633
Depends on: 1356717
Depends on: 1357086
Depends on: 1357088
Depends on: 1357221
Depends on: 1357223
Depends on: 1357324
Depends on: 1357385
Depends on: 1357521
Depends on: 1357529
Depends on: 1357830
Depends on: 1357916
Depends on: 1357922
Depends on: 1357925
Depends on: 1357939
Depends on: 1358256
Depends on: 1358266

Comment 91

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/b80e4589fc11
Update Stylo expectations. r=me
https://hg.mozilla.org/mozilla-central/rev/5e3dc7e1288a
Update Stylo expectations. r=me a=merge
Depends on: 1358483
Depends on: 1067360

Comment 95

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c027928dd158
Remove empty failure annotations. r=me

Comment 97

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/23f98bf94cca
Remove empty failure annotations. a=me
Depends on: 1358673
Depends on: 1358760

Comment 99

2 years ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8acb43479aaf
Update mochitest expectations for transition shorthand fix. r=me
Depends on: 1358858
Depends on: 1359153
Depends on: 1359161
Depends on: 1359162
Depends on: 1359175
Depends on: 1359253
Depends on: 1359354
Depends on: 1359380
Depends on: 1359561
Depends on: 1359785
Depends on: 1360051
Depends on: 1360159

Comment 109

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6728bd7bcb15
Update expectations for gradient interpolation hints (servo/servo#16628). r=emilio

Comment 111

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6e0ecc3bf3f8
Update expectations so mstyle-1.xhtml only fails on debug a=bustage

Comment 112

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/659cddddd434
Mark shadow-dom-1.html and mstyle-1.xhtml as random on stylo since they're still randomly failing on opt builds a=bustage

Comment 113

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0515b8deb0ff
stylo test expectation adjustments. r=me

Comment 114

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45facddc6737
stylo test expectation adjustments. r=me
Depends on: 1360453

Comment 115

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/84762dbeb538
stylo test expectation adjustments. r=me a=merge

Comment 117

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5286b5f67892
stylo test expectation adjustments. r=me

Comment 118

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/d19b88fdf81d
stylo test expectation adjustments. r=me a=merge

Comment 119

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/702d9d8be8aa
stylo test expectation adjustments. r=me a=merge (CLOSED TREE)
Depends on: 1360528
Depends on: 1360530
Depends on: 1360656
Depends on: 1360685
Depends on: 1360720
Depends on: 1360722

Comment 122

2 years ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b9b9546e3fff
Update mochitest expectations for -moz-transform. r=me

Comment 124

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/de63010ad9d6
Revendor rust-dependencies manually on a CLOSED TREE. r=emilio
Depends on: 1361019

Comment 128

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/83a9069a527d
Remove fails-if(stylo) for color-stop-clamp-interpolation.html a=bustage
Depends on: 1361142
Depends on: 1361160

Comment 130

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71ba44a4c38a
stylo: Adjust test expectations for Servo #16683. r=me
Depends on: 1361523
Depends on: 1361527
Depends on: 1361565
Depends on: 1362116
Depends on: 1362153

Comment 142

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/90c2b464f60c
Update test expectations ; r=manishearth
Depends on: 1362777

Comment 146

2 years ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/74ff52c38236
Fix the reftest expectation for text-shadow from bug 1361304. r=expectation-update

Comment 148

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/964f96b08cc6
Revendor rust dependencies on a CLOSED TREE. r=red
Depends on: 1363230
Depends on: 1363231
Depends on: 1363514
Depends on: 1363705

Comment 150

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/42168646d299
Update reftest expectations; r=manishearth

Comment 151

2 years ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/37bea3f592dc
Hopefully fix busted reftest annotations by removing whitespaces. r=me on a CLOSED TREE
Depends on: 1363898
Depends on: 1363926

Comment 153

2 years ago
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/78a8cb97115e
Update reftest expectations a=bustage

Comment 154

2 years ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e956dc8d6b1d
Update reftest expectations for border radii. r=me
Depends on: 1364254

Comment 157

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/81a718fee557
Update test expectations for Servo PR #16821; r=manishearth
Depends on: 1364657
Depends on: 1364682
Depends on: 1364683
Depends on: 1364731

Comment 163

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84ff12c658ea
Update reftest expectation for #16855.
Depends on: 1365006
Depends on: 1365039
Depends on: 1365040
Depends on: 1365083
Depends on: 1365726
Depends on: 1365743
Depends on: 1365923
Depends on: 1366108
Depends on: 1366109
Depends on: 1366270
Depends on: 1366271
Depends on: 1366409
Depends on: 1366897
Depends on: 1366899
Depends on: 1366900

Comment 181

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2ede14818ea0
Update stylo test expectations after the landing of PR #16947.
Depends on: 1367065
Depends on: 1367067
Depends on: 1367202

Comment 183

2 years ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/63c7903c6690
Update reftest expectations for text-overflow. r=me

Comment 187

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ab4f7d18364e
Disable test_animations_omta.html.
Depends on: 1367826
Depends on: 1368032
Depends on: 1368061
Depends on: 1368259

Comment 195

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fb5302d02246
Fix stylo heap analysis bustage ; r=bustage
Depends on: 1368642
Depends on: 1368770
Depends on: 1368804
Depends on: 1369090

Comment 199

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/591656964cf4
Revendor rust dependencies on a CLOSED TREE.

Comment 200

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed1a152dba74
Revendor rust dependencies again after several manual update on a CLOSED TREE.
As a record, what I had to do for the latest pushes:
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p rayon
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p gkrust
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p rayon
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p gkrust-gtest
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p url
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p idna
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p unicode-bidi
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p url
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p idna
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p unicode-bidi
cargo update --manifest-path testing/geckodriver/Cargo.toml -p url
cargo update --manifest-path testing/geckodriver/Cargo.toml -p idna
cargo update --manifest-path testing/geckodriver/Cargo.toml -p geckodriver
./mach vendor rust

It is not clear why I need to do these many commands manually, but it seems otherwise it would either end up making vendor rust fail (without clear message why it is happening), or vendor incorrect Rust crates.

I'll file some bugs for this.

Comment 202

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f11d37b8446b
Update vendored clap to get more consistent bitflags on a CLOSED TREE.
Some further commands:
cargo update --manifest-path toolkit/library/rust/Cargo.toml -p clap
cargo update --manifest-path toolkit/library/gtest/rust/Cargo.toml -p clap
cargo update --manifest-path testing/geckodriver/Cargo.toml -p clap

then revendor.

This is because both stylo uses both bitflags 0.7 and 0.8 (via different dependency path), while geckodriver only uses bitflags 0.7 via an old version of clap, so when vendoring crates for geckodriver, bitflags 0.7 from that overrides the bitflags 0.8 crates in third_party.
Filed bug 1369227, bug 1369242, and bug 1369247 so far. I think I may have more to file...
Ok, I don't have more. The last one seems to be an issue for unicode-bidi crate, not our build system.

Comment 206

2 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/556929c74ca0
Vendor only pre-1.0 version of serde on a CLOSED TREE.
I don't know what happened, but it seems we vendored two versions of serde before, and unicode-bidi fails to build for some unknown reason when it depends on the new version of serde. After some back-and-forth change in the Servo side code (no actual change eventually), it manages to revendor only the old version of serde (which is used by many other crates), and unicode-bidi works again.
Depends on: 1369350
Depends on: 1369452
Depends on: 1369487
Depends on: 1369828
Depends on: 1369922
Depends on: 1369924
Depends on: 1370012
Depends on: 1370397
Depends on: 1370410
Depends on: 1370600
Depends on: 1371427
Depends on: 1371859
Depends on: 1371866
Depends on: 1371917
Depends on: 1372023

Comment 211

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad90f0a5b56c
Update test expectations for servo #17213. r=me
Depends on: 1372762
Depends on: 1372770
Depends on: 1373017
Depends on: 1373400
Depends on: 1373580
(In reply to Pulsebot from comment #200)
> Pushed by xquan@mozilla.com:
> https://hg.mozilla.org/integration/autoland/rev/ed1a152dba74
> Revendor rust dependencies again after several manual update on a CLOSED
> TREE.

This added some Cargo.toml.orig files that break building out of the source tarballs such as the one for 55.0b1 (http://ftp.mozilla.org/pub/firefox/releases/55.0b1/source/firefox-55.0b1.source.tar.xz) with the following error:

   error: failed to calculate checksum of: /<snip>/third_party/rust/url/Cargo.toml.orig

(that's with cargo 0.17.0, if that makes a difference)
Hah, funny one, in fact, my build fails because one of the preliminary steps happening when building a debian package is... removing any .orig file from the source directory. So the Cargo.toml.orig file in the tree gets removed, and cargo isn't happy. And that happens because those .orig files are referenced in the .cargo-checksum.json files.
I think that is a problem of those crates...
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #217)
> I think that is a problem of those crates...

There is no Cargo.toml.orig in https://github.com/servo/rust-url and never was according to git log.
(In reply to Mike Hommey [:glandium] from comment #218)
> There is no Cargo.toml.orig in https://github.com/servo/rust-url and never
> was according to git log.

That isn't in their git repo, but you can find it from the package on crate (which is, unfortunately, not downloadable directly). If you have something which depends on url 1.4.1, you can find that file in ~/.cargo/registry/src/github.com-1ecc6299db9ec823/url-1.4.1/.
Reporter

Comment 220

2 years ago
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #219)
> (In reply to Mike Hommey [:glandium] from comment #218)
> > There is no Cargo.toml.orig in https://github.com/servo/rust-url and never
> > was according to git log.
> 
> That isn't in their git repo, but you can find it from the package on crate
> (which is, unfortunately, not downloadable directly). If you have something
> which depends on url 1.4.1, you can find that file in
> ~/.cargo/registry/src/github.com-1ecc6299db9ec823/url-1.4.1/.

Yeah, so the basic issue is that the maintainer ran |cargo publish| with the .orig files in the directory.

The solution for this particular issue is to ask the maintainer to remove the files and republish. The general solution is to get cargo modified to detect such files (.orig, ~, .bak, etc) and reject them from publishing.

Comment 221

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4bef0e5df19d
disable two crashtests on stylo for leaks. r=me

Comment 222

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7241b9a3bc7
Disable the leaking test, not the one after it that was taking the blame. r=me

Comment 223

2 years ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/266c83593037
Continue zeroing in on the actual leaking crashtest. r=me
Depends on: 1373944
Depends on: 1374081
Depends on: 1374439
Depends on: 1374445
Depends on: 1374455
Depends on: 1374780
Depends on: 1374840
Depends on: 1374844
Depends on: 1374853
Depends on: 1374864
Depends on: 1374868
Depends on: 1374883
Depends on: 1375282
Depends on: 1375294
Depends on: 1375295
Depends on: 1375301
Depends on: 1375310
Depends on: 1375326
Depends on: 1375608
Depends on: 1375638
Depends on: 1375642
Depends on: 1375644
Depends on: 1375645
Depends on: 1376710
Depends on: 1376731
Depends on: 1377063
Depends on: 1377363
Depends on: 1377963
Depends on: 1378049
Depends on: 1378054
Depends on: 1378521
Depends on: 1378522
Depends on: 1378530
Depends on: 1378577
Depends on: 1378580
Depends on: 1378957
Depends on: 1378959
Depends on: 1379010
Depends on: 1379011
Depends on: 1379077
Depends on: 1379267
Depends on: 1379315
Depends on: 1379320
Depends on: 1379321
Depends on: 1379547
Depends on: 1379645
Depends on: 1379678
Depends on: 1379708
Depends on: 1379795
Depends on: 1379914
Depends on: 1380360
Depends on: 1380511
Depends on: 1380528
Depends on: 1380728
Depends on: 1380831
Depends on: 1381161
Depends on: 1381171
Depends on: 1381281
Depends on: 1381303
Depends on: 1381310
Depends on: 1381397
No longer depends on: 1346353
No longer depends on: 1381397
No longer depends on: 1363231
No longer depends on: 1341348
No longer depends on: 1371427
No longer depends on: 1378577
No longer depends on: 1366900
No longer depends on: 1352256
No longer depends on: 1374780
No longer depends on: 1360051
No longer depends on: 1352663
No longer depends on: 1363230
No longer depends on: 1379077