Closed Bug 1827042 Opened 1 year ago Closed 6 months ago

Incorrect scrolling position in the message list when opening a folder. This particularly affects unified or virtual folders.

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 112

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115+ fixed, thunderbird120? fixed)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 + fixed
thunderbird120 ? fixed

People

(Reporter: tawn, Assigned: welpy-cw)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [Supernova3p][STR comment 2])

Attachments

(2 files)

Steps to reproduce:

Sort messages with newest at bottom of message list.
Select bottom (newest) message.
Close Thunderbird.
Re-open Thunderbird.

Actual results:

Thunderbird always opens with message list scrolled to top.

Expected results:

Thunderbird opens with message list scrolled to bottom since that's how it was last time it was closed (as it does on Thunderbird 102).

Whiteboard: Supernova
Summary: Scroll Position in Message List not saved/restored → Scroll Position in Message List not saved/restored - should scroll to bottom of list if that's where the last selected message was before restart
Blocks: sn-msglist
Keywords: regression
Whiteboard: Supernova → [Supernova]
Whiteboard: [Supernova] → [Supernova3p]

I can't reproduce this. Does it still happen?

Flags: needinfo?(stayopenmenu)

It still happens in Unified Folders. (IIRC it was also happening in All Folders previously.)
In Unified, if I even click on to the Drafts folder and then back to Inbox, the scroll position returns to the top (while the previously selected message remains visible in the preview pane, it may be scrolled out of view at the bottom of the message pane).

Updated steps to reproduce:

Folder Modes > Tic Unified Folders ON
In Folder Pane, select Unified Inbox
In Message Pane, sort messages with newest at bottom of message list.
Select bottom (newest) message.
Close Thunderbird. (OR click Unified's Drafts folder)
Re-open Thunderbird. (OR click back to Unified's Inbox folder)

Flags: needinfo?(stayopenmenu)

Just retested on 115.0b5 and issue no longer occurs when clicking the Drafts folder, but still happens when reopening Thunderbird (no message selected and scroll position is at top instead of bottom).

Thanks for the updates. It still happens in beta?

Flags: needinfo?(stayopenmenu)
See Also: → 1847720

p.s. is comment 2 the exact steps to reproduce in version 102?

(In reply to Wayne Mery (:wsmwk) from comment #5)

p.s. is comment 2 the exact steps to reproduce in version 102?

I'm guessing you didn't really mean 102, since you mentioned in comment #4 that 102 is unaffected...

Bug still occurs in 117.0b2 as well as 115.1.0. Only change in steps to reproduce is that mentioned in comment #3, but I've listed the updated steps in detail below. (Tested on Win10.)

Updated steps to reproduce:

Folder Modes > Tic Unified Folders ON
In Folder Pane, select (Unified) 'Inbox' (not an individual included account)
In Message Pane, sort messages with newest at bottom of message list. (View > Sort By > Ascending)
Click to select bottom (newest) message.
Close Thunderbird.
Re-open Thunderbird.

If you guys still cannot reproduce, let me know and I'll try to create a (clean) test profile to see if there's some other factor involved.

Flags: needinfo?(stayopenmenu)

Could this be related to Bug 1847842 ? (From comment #3 'no message selected and scroll position is at top instead of bottom')

Duplicate of this bug: 1847720

(In reply to custom.firefox.lady [:tawn] from comment #7)

Could this be related to Bug 1847842 ? (From comment #3 'no message selected and scroll position is at top instead of bottom')

Flags: needinfo?(geoff)
Whiteboard: [Supernova3p] → [Supernova3p][STR comment 2]

Unlikely.

What's happening is the decision to scroll occurs before any rows have appeared, so nothing happens. This happens for virtual folders (including the unified folders) but not real folders, because virtual folders typically don't have rows immediately. I'm aware of the problem but don't have a satisfactory solution at this point.

Flags: needinfo?(geoff)
See Also: → 1850190

I noticed this after upgrading from 102 to 115. Have a saved search folder that includes all messages from imap inbox & sent folders, threaded. In 102, opening it would scroll to the end. In 115 it doesn't. Not only does this happen when starting TB, but if you switch away from the saved search folder with no messages selected and switch back, it also opens unscrolled. This a very annoying regression.

I'm aware of the problem but don't have a satisfactory solution at this point.

How did this work in 102? Why is it so problematic to schedule a scroll for after the rows have been computed?

Assignee: nobody → h.w.forms
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9356734 - Attachment description: Bug 1827042 - Improve initial scroll position when selecting synthetic folder. r=#thunderbird-front-end-reviewers → Bug 1827042 - Improve initial scroll position when selecting virtual folder. r=#thunderbird-front-end-reviewers
Attachment #9356734 - Attachment description: Bug 1827042 - Improve initial scroll position when selecting virtual folder. r=#thunderbird-front-end-reviewers → Bug 1827042 - Set scroll position after messages have been loaded in a folder. r=darktrojan,leftmostcat
Duplicate of this bug: 1857867
Duplicate of this bug: 1857839
Duplicate of this bug: 1857265
Duplicate of this bug: 1857219
Duplicate of this bug: 1856749
Duplicate of this bug: 1856248
Severity: -- → S3
Priority: -- → P2

Just want to note that in 115.3.1 this has nothing to do with a restart. This is happening every time I switch between folders, making it a serious irritant. My folders are sorted most recent at the bottom.

On synthetic folders where the previously highlighted message is no longer in the folder upon returning, highlight is typically at the top of the folder. I would expect the highlight to be on the message nearest to the one that is now absent.

Precisely as Mozilla reports. The OP made this clear.

Duplicate of this bug: 1858654
Duplicate of this bug: 1855635
Summary: Scroll Position in Message List not saved/restored - should scroll to bottom of list if that's where the last selected message was before restart → Incorrect scrolling position in the message list when opening a folder. This particularly affects unified or virtual folders.
Duplicate of this bug: 1857921
Duplicate of this bug: 1856912
Duplicate of this bug: 1854252
See Also: → 1848556
See Also: → 1858094

I first noticed the problem when downloading messages

The newest messages are still correctly for me at the end of all messages - however the automatic jump to first message unread is not happening

It jumps to random position in all downloaded messages in the Inbox, but does not highlight anything

Duplicate of this bug: 1859043
Duplicate of this bug: 1859218

Not listed here, but there are many support posts about this.

Priority: P2 → P1
Duplicate of this bug: 1859468
Duplicate of this bug: 1859610

This bug is still in the latest version, 115.3.3 It was not in version 102.15.1

Duplicate of this bug: 1860374
Duplicate of this bug: 1860393
Duplicate of this bug: 1860875
Duplicate of this bug: 1861009

In 1.5.3.3 I see this in normal folders, not unified or virtual folders which I don't use.

Target Milestone: --- → 121 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1e3fdf01460a
Set scroll position after messages have been loaded in a folder. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Attachment #9356734 - Flags: approval-comm-beta?
Attachment #9356734 - Flags: approval-comm-beta?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9360717 - Attachment description: Bug 1827042 - Follow-up fix for quick search in multi-folder view. r=darktrojan → Bug 1827042 - Follow-up fix for scroll position in quick search. r=darktrojan
Duplicate of this bug: 1861803
Duplicate of this bug: 1861715

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/54a929f3ca16
Follow-up fix for scroll position in quick search. r=darktrojan

Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Resolution: --- → FIXED
Attachment #9356734 - Flags: approval-comm-beta?

Comment on attachment 9360717 [details]
Bug 1827042 - Follow-up fix for scroll position in quick search. r=darktrojan

.

Attachment #9360717 - Flags: approval-comm-beta?
Duplicate of this bug: 1854774

Comment on attachment 9356734 [details]
Bug 1827042 - Set scroll position after messages have been loaded in a folder. r=darktrojan,leftmostcat

[Triage Comment]
Approved for beta

Attachment #9356734 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9360717 [details]
Bug 1827042 - Follow-up fix for scroll position in quick search. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9360717 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1862005
Duplicate of this bug: 1861986
Duplicate of this bug: 1862488
Duplicate of this bug: 1862254
Duplicate of this bug: 1852483
Duplicate of this bug: 1862913
Duplicate of this bug: 1863160
Attachment #9356734 - Flags: approval-comm-esr115?
Attachment #9360717 - Flags: approval-comm-esr115?

Comment on attachment 9356734 [details]
Bug 1827042 - Set scroll position after messages have been loaded in a folder. r=darktrojan,leftmostcat

[Triage Comment]
Approved for esr115

Attachment #9356734 - Flags: approval-comm-esr115? → approval-comm-esr115+

Comment on attachment 9360717 [details]
Bug 1827042 - Follow-up fix for scroll position in quick search. r=darktrojan

[Triage Comment]
Approved for esr115

Attachment #9360717 - Flags: approval-comm-esr115? → approval-comm-esr115+
Duplicate of this bug: 1864359

There apparently are still issues after this patch on 115.4.3 that were not found in weeks of beta testing.

If you are CC on this bug and

  • had no problems prior to 115.4.3 but now have a problem, please file a bug report with the details.
  • had a problem prior to 115.4.3 and the probably got worse, please file a bug report with the details.

Setting mailnews.scroll_to_new_message to a non-default value of false may be involved (the default value is true).

The history of scroll bugs filed filed since supernova code landed may be useful - https://mzl.la/3SJtQuv are bugs with activity since 2023-08-01.

See Also: → 1865478
Duplicate of this bug: 1852567
Duplicate of this bug: 1845934

(In reply to Wayne Mery (:wsmwk) from comment #59)

There apparently are still issues after this patch on 115.4.3 that were not found in weeks of beta testing.

If you are CC on this bug and

  • had no problems prior to 115.4.3 but now have a problem, please file a bug report with the details.
  • had a problem prior to 115.4.3 and the probably got worse, please file a bug report with the details.

Setting mailnews.scroll_to_new_message to a non-default value of false may be involved (the default value is true).

The history of scroll bugs filed filed since supernova code landed may be useful - https://mzl.la/3SJtQuv are bugs with activity since 2023-08-01.

I just tested this on 155.6.0 and it still does not appear to work right, even with mailnews.scroll_to_new_message set to a non-default value.

Maybe this bug needs to be reopened.

Maybe this bug needs to be reopened.

Please file a new bug

No longer duplicate of this bug: 1860875
Regressions: 1849650
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: