Deleted mail not actually removed from Inbox file

VERIFIED INVALID

Status

MailNews Core
Database
VERIFIED INVALID
16 years ago
8 years ago

People

(Reporter: Cliff, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

It appears that if I delete a message from any local mail folder, the body of
the message is not actually removed from the flat-file in my profile.  Over
time, this results in large amounts of wasted space.

Reproducible: Always

Steps to Reproduce:
1. delete mail
2. view contents of flat-file (i.e. "Inbox") for message text


Actual Results:  
Muchas wasted space (450Megs for my mail folders!!?!?)

Expected Results:  
Deleted messages should also be cleaned from mail database as appropriate
Have you tried the "compact folders" option ?
(Assignee)

Comment 2

16 years ago
you need to compact the folder. you can also set up mozilla to automatically
compact folders when XX KB of disk space are being wasted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
hmm, the fast bug resolving way -> verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Yep, that is the fastest bug fix I've ever seen :)  Thanks
see bug 181248#c1 why you need to compact
(Reporter)

Comment 6

16 years ago
And I agree that it should be turned on by default since I doubt many users
really know it exists...

Comment 7

15 years ago
*** Bug 198392 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 173819 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 220192 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 220400 has been marked as a duplicate of this bug. ***
Because this is now the dupe target ...

The reason for this :

Imagine that you have a 300MB Inbox file. You delete now ine message in the
middle of the file (size=1k). Mozilla would have to rewrite the whole 300MB file
after you deleted this mail and you have to wait 2 minutes before you can work
again with Mozilla.
That would be dumb or ?

Mozilla does this (currently) :
It seeks in the file to the message and changes one byte in the message Header
(X-Mozilla-Status). You don't need to rewrite the whole file if you change one
byte in the file and Mozilla knows now that you marked this mail is deleted.
(and you can't see it in the UI)

Mozilla rewrites the whole 300mb if you do a compact folder and there are
"deleted" mails inside this file.

Comment 12

15 years ago
As a follow up and request for additional feature..
The confussion comes in do to dear old Bill G and MS double dos disk compression.
Us achients that have been around since DOS 3.1 and 5.25 drives go no where near
anything that remote resembles disk compression as "compact" ambiguously implies.

True had I rtfm as I finally did immediately before the DE responded, I would no
the behavior, but I have been using netscape mail since the beginning.

I would there for suggest that the compact feature be changed to 
compact/purge
or add another button called purge of houskeeping anything that implies that the
 removal of dead messages is being performed.

I still say as a user if I "trash", I assume that time will be spent on the
operation especially if I delete 500M of mail.

Thanks
John
*** Bug 221554 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 207536 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
*** Bug 270386 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 16

14 years ago
*** Bug 273865 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
*** Bug 276247 has been marked as a duplicate of this bug. ***
*** Bug 276521 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
(In reply to comment #11)

Suggestion: Why not have thunderbird "zero out" the payload of an e-mail within
the inbox-file upon deletion? This should only take slightly longer (linear
function of the e-mail size; independent of overall inbox-filesize) then the
current behavior and avoid the current security/privacy issues. The "compress
folder" function would then only be used to defragment/compress the inbox-file.  

Comment 20

13 years ago
*** Bug 278464 has been marked as a duplicate of this bug. ***
*** Bug 287037 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
*** Bug 310543 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
*** Bug 314595 has been marked as a duplicate of this bug. ***

Comment 24

12 years ago
*** Bug 324297 has been marked as a duplicate of this bug. ***

Comment 25

12 years ago
*** Bug 326064 has been marked as a duplicate of this bug. ***

Comment 26

12 years ago
There should be default options that automatically compact folders when the deleted/non-deleted ratio reaches some extent.
I had the case on my mum's PC where the deleted mails took 500MB of space - while the inbox only contained a dozen of e-mails without attachments. Her disk was almost full.
She freaked out when I explained her how to actually delete her mails.

Also, an option to compact folders in the background when Thunderbird exits sounds like a good idea too.

So please, think about your average-joe users.
There is such an option in Seamonkey, don't know about Thunderbird but that is not this bug.

Comment 28

12 years ago
To wait until an automatic compacting option and/or a command-line tool for compacting, i suggested a few ways to compact mailboxes with a script.

The goal is to delete all messages with a "X-Mozilla-Status" field equal to "0008" or "0009", this is a good way to gain diskspace but this is *not* equivalent as a "real" compacting.

After the deletion, all .msf files must be deleted, they'll be automatically reduild during the fist access to the mailbox.

http://forums.mozillazine.org/viewtopic.php?t=425074

I've tested on mailboxes of real end-users and even with a binary program working in place (mutt on Cygwin), it's deadly slow.

Obviously it's too late for me because end-users have already very large mailboxes and the script works with an average of 100MB per minute, furthermore, the "speed" is unfortunately decreasing exponentially with the size of the mailbox.

Comment 29

12 years ago
*** Bug 297298 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 374592
Duplicate of this bug: 430584
Duplicate of this bug: 440341
Duplicate of this bug: 448090
Product: Core → MailNews Core
Duplicate of this bug: 451101

Comment 35

8 years ago
I've reached 8GB of space wasted by your "Feature" unless stuck with incoming emails with zero inside even headers was deleted ... (subject was present) and Ispend 4hrs to solve this problem and my search come me to here at the end, here I've realized that is not an error and solution is on the surface. And yes as mention above "Compress folder" - is really not appropriate title for this function and at least it should be more explained in program, for any user that your emails well be actually deleted only after this operation!!!!!!

I assume new title as "Purge old emails" is more self explanatory in this case. Maybe you should give number of emails that is deleted and you can purge.

Bear in mind I'm Russian so English is not my first language.
You need to log in before you can comment on or make changes to this bug.