Closed Bug 194632 Opened 18 years ago Closed 15 years ago

notification preference to use a self-defined wav-file does not function well

Categories

(SeaMonkey :: MailNews: Message Display, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ruurd, Assigned: mscott)

References

Details

(Keywords: fixed1.8, Whiteboard: see comment 51)

Attachments

(4 files, 4 obsolete files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

In the notifications tab of the Mail & Newsgroups in the Preferences window, one
can select to use the system default Mail sound, or a custom wav file.
I browsed for a wav file, but the system default beep of my MacOSX stays. I
tried preview in the preference window and it sounded the system beep too. I
tried a default system sound file (blabla.aiff), which resulted in the default
system beep too.
I looked in the prefs.js file to see if it did show up, and it seemed to be
correct in there. Because the element is called mail.biff.play_sound.url I tried
using file://<path/file> but that did result in no sound at all. No error or
dialog too.

Reproducible: Always

Steps to Reproduce:
1. open preferences
2. go to mail/notifications
3. enter a valid path to a wav file

Actual Results:  
I heared a system beep

Expected Results:  
play the wav file on new mail (biff)
->mailnews
Assignee: ben → mscott
Component: Preferences → Mail Notification
Product: Browser → MailNews
QA Contact: sairuh → stephend

*** This bug has been marked as a duplicate of 177280 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Keywords: useless-UI
Resolution: --- → DUPLICATE
Summary: The mailnotification preference to use a self-defined wav-file does not function well → notification preference to use a self-defined wav-file does not function well
Reopening per bug 177280 comment 23 (which this was recently duped to). 
Although this is the same symptoms, it's OS-specific code, and something
different has to be done to fix it on OS X, so it can't be the same bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
and confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true
bug 177280 was fixed, and as expected, it's still broken on OS X.  Anyone know
what's up?

I have the same symptoms as the original reporter.  When I use a normal file
path, I get the system beep.  If I use a file:/// url, nothing happens at all.

I use Mozilla Mail for my work email and too many things use the system beep on
my system, so I can never tell when I have new mail without constantly tracking
down the mailnews window and looking, so this is really annoying for me.

Adding nbaca because this was supposedly verified fixed on 10.1.5 according to
the other bug....  ???
Severity: normal → major
forgot to say I'm using OS X 10.2.6, Mozilla build 2003060908
Same problem for me in Moz 1.4 RC1 using Win98SE.
I fixed it be deleting:

user_pref("mail.accountmanager.localfoldersserver", "server2");
user_pref("mail.biff.play_sound.type", 1);
user_pref("mail.biff.play_sound.url", "C:\\WINDOWS\\MEDIA\\xxx.WAV");

from prefs.js

and ensuring that in the registry the data (wave file) pointed to my choice.
key involved is:
HK_current_user\appevents\schemes\apps\default\mailbeep. Fix all values
(.current, .default, etc.). There are two interations to find and fix.

Same non-acceptance of user preference for sound notification of captured popup:

user_pref("privacy.popups.remove_blacklist", false);
user_pref("privacy.popups.sound_enabled", true);
user_pref("privacy.popups.sound_url", "C:\\WINDOWS\\MEDIA\\YIPE.WAV");

does not work.
There is no regestry option that I can find.
Same problem for me in Moz 1.4 RC1 using Win98SE.
I fixed it be deleting:
user_pref("mail.biff.play_sound.type", 1);
user_pref("mail.biff.play_sound.url", "C:\\WINDOWS\\MEDIA\\xxx.WAV");

from prefs.js

and ensuring that in the registry the data (wave file) pointed to my choice.
key involved is:
HK_current_user\appevents\schemes\apps\default\mailbeep. Fix all values
(.current, .default, etc.). There are two interations to find and fix.

Same non-acceptance of user preference for sound notification of captured popup:

user_pref("privacy.popups.remove_blacklist", false);
user_pref("privacy.popups.sound_enabled", true);
user_pref("privacy.popups.sound_url", "C:\\WINDOWS\\MEDIA\\YIPE.WAV");

does not work.
There is no regestry option that I can find.
Branch build 2003-06-10: WinMe, Mac 10.1.5 - Fails to play sound. I also tried a
build used when verifying bug# 177280 and it also does not work. At this point
I'm not sure how it was working and now it is not.

Branch build 2003-06-10: Win2k, WinXP (Esther's system) - Successfully plays
sound using the native path (not needing file:/// format)

Branch build 2003-06-10: Mac 10.2.6 (Esther's system) - Also successfully plays
sounds (using the file:/// format)
QA Contact: stephend → nbaca
Marking nsbeta1 since the preferences include UI that doesn't always work.

Assigning to Seth for now. Please reassign if appropriate.
Assignee: mscott → sspitzer
Keywords: nsbeta1
Here is a possible workaround: In the browser load the wav file to get the file
url. Copy the file url and then go to the Notification preference and paste the url.

Bug# 177280 (Comment# 75) stated that sound was working on WinMe and Mac 10.1.5
using the 2003-06-06 build. Then using today's build (2003-06-10) I noticed that
it wasn't working. Using the copy/paste workaround plays the correct sound. I
may have followed this procedure on 6/6.

Interesting... I compared the string I typed and the string that was pasted and
they look the same. 
Keywords: nsbeta1
Re: comment 11 - I found the key...

The .wav file has to exist in your browser cache.  It won't go and load it by
itself.  If you dump your cache it stops working again.  If you listen to it in
the browser window so it goes back in your cache, then it works again.  All
without touching the preference.
re:  comment 11
placing the wave files in the browser cache does not work for me.
otherwise:
from what I can deduce, using the mailbeep key in the registry is part of the
moz coding 20030610 (and before) (Mailbeep.current). Likely it is the same for
the popup sound, but there is no key/value created for it (in sounds),
therefore, Moz uses the default sound. No way of referring to
file:///c://windows// etc or any other variation, including capturing it in the
browser and pasting it into prefs or userprefs works. In fact, I have to REMOVE
the mailbeep instruction in prefs for me to be able to use my own specified
sound, which is located in the mailbeep key of the registry.
hmm, yeah, the preview button in the preference UI works if and only if the
sound is already loaded in the cache.  The actual new mail notification still
doesn't work, with or without it in the cache.  (on OS X)
accepting
Status: NEW → ASSIGNED
Also on linux mail notification does not work, but only a beep is heard (from pc
speaker).

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617
On OSX Mozilla 1.5b it works for me now!!! Cool
With 2003082703 does not work, always the system sound plays.
After reading  Giovanni Gatti's post I tried to get the mailsound again. No
luck. However I was sure I heard that sound yesterday, so I started looking
around what I had done, and found out the following:

- go to a site which uses the soundsystem to play a sound, like
http://www.osdata.com/kind/mac.htm
- after it has loaded the quicktime plugin and played the sound, go to
preferences | notifications
- fill in the path to the wav file, prefixed by file://, otherwise the system
beep will play
- press the preview button and it works ...

It looks to me as if the mailbeep thing doesn't load the quicktime plugin which
it uses to play the sound.
I tried myself but it worked only once.
Now there is no way.
In Linux the problem seems to be the loading of the libesd.so library.
After making a link from libesd.so.0.x.x to libesd.so the user-defined
notifications started to work.
Should we use libesd.so.0 instead of libesd.so ?
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk/nsSound.cpp#89

BTW I think the Hardware and OS should be changed to All.
I just copy-pasted this fix from GTK2 to GTK.
Attachment #132306 - Flags: superreview?(sspitzer)
Attachment #132306 - Flags: review?(sspitzer)
Attachment #132306 - Flags: superreview?(sspitzer)
Attachment #132306 - Flags: superreview?(blizzard)
Attachment #132306 - Flags: review?(sspitzer)
Attachment #132306 - Flags: review?(blizzard)
Comment on attachment 132306 [details] [diff] [review]
patch to fix notifications in Linux

Fix some indenting in there, please.  Not enough to hold review, though.

r+sr=blizzard
Attachment #132306 - Flags: superreview?(blizzard)
Attachment #132306 - Flags: superreview+
Attachment #132306 - Flags: review?(blizzard)
Attachment #132306 - Flags: review+
Same fix but different diff options. So r/sr=blizzard.
Could someone check this in?
Attachment #132306 - Attachment is obsolete: true
To sum up for newly released Mozilla 1.5:

Mail notification doesn't work in OS X. - If one selects a custom .wav file, the
system-default sound is played instead.
If one uses the browser to open the .wav file, the QT-Plugin will initialize and
afterwards, if one copies the complete url (file:///...wav) into the
preferences, the sound will actually play, when clicking on the 'preview'
button. But still, if new mail arrives, the system-default sound is played.
I believe the notification sound works on Windows, and I can tell for sure that
the notification and the pop-up-block sound work on Linux, so there's no need to
discuss these two any longer.

OT: I heard somewhere that mail-notification will be disabled for junkmail
folders, that would be nice indeed.

Cheers, David
Dear freinds, what happens to this bug? It's still unfixed and it is very
relevant for the user!
I can donate US$ 10,- once it is fixed!!!

Thanks
My experience is that this bug has been fixed in Windows XP Pro, but not in
Windows 98/98SE. (Moz 1.5/1.6)
Still unchanged (not working) on Apple OSX, see previous post.
One other thing (maybe I'll open another ticket for this one): I just tried
Thunderbird 0.4 on OSX and the mail notification isn't working as well. - Not
that I'd have expected it to work, since it's so closely related to the Moz.
Mail/News client. - Thunderbird 20031205 on OSX 10.3.2.
it's really absurd that this bug can't be fixed! It's the first thing one would
change when personalizing the suite: a different sound notification!!!
Hi,

Windows ME, Mozilla 1.6 - after selecting the .wav file for email notification I
still get the system sound only.

This problem still hasn't gone away and remains multi-platform since its listed
here as OS/X, I've got Win-ME...

Is there no fix activity on this ? Does that mean its fixed for the (linux)
developers now ?

(In reply to comment #21)
> In Linux the problem seems to be the loading of the libesd.so library.
> After making a link from libesd.so.0.x.x to libesd.so the user-defined
> notifications started to work.
> Should we use libesd.so.0 instead of libesd.so ?
> http://lxr.mozilla.org/seamonkey/source/widget/src/gtk/nsSound.cpp#89
> 
> BTW I think the Hardware and OS should be changed to All.

fwiw, creating this link fixes notification sound on my system:
Linux tengu 2.6.1 #5 Mon Feb 23 15:18:45 EST 2004 i686 GNU/Linux
running debian sarge/sid with..
Mozilla 1.6, build 2004011310

i havent tried Smaug's patch yet, but id bet it works. if you run linux
and cant get the sound to work try the link, or recompile with the patch.
is the problem for linux users just that this patch never got checked in? Looks
like it has an r/sr. I can check it in if someone can confirm. Looks to me like
it never got checked in.
Brian says this is the way to fix this issue on linux. Just try to load .0
Assignee: sspitzer → mscott
Attachment #132356 - Attachment is obsolete: true
Attachment #143081 - Flags: superreview?(bryner)
Comment on attachment 143081 [details] [diff] [review]
new patch for gtk and gtk2

Yeah, this is the right way to do this, as I learned from the GNOME helper app
code.
Attachment #143081 - Flags: superreview?(bryner) → superreview+
The linux patch has been checked in. 

I believe the only remaining linux problem is that the pref needs to be a
file:// url and the suite still puts in a file path. I fixed that in Thunderbird
yesterday. We need to do something similar for the suite and then I think the
linux issues for this bug would be fixed.

Not sure about the OSX issue.
I'm presuming that patch only addresses the issue of actually getting the sound 
to play, but does not address the "useless-UI" portion of this bug which appears 
in the Keywords above.

See bug 169414: "handle *native paths* for sound files as biff sounds for all 
platforms."  (emphasis mine)  Perhaps that "useless-UI" keyword should be moved 
to the older bug.
Mike, I don't understand why this UI is listed useless. Can you elaborate? Also,
I don't understand why we have to have native file path support instead of just
using a generic file url. Are there some platforms that the file url technique
won't work on?
I can't speak to the Mac or Linux issues, but under Windows, the UI allows you 
to browse to a file, then puts the path to the file in the text box.  Anyone 
using this would think everything is fine; but in fact, the sound won't play 
unless the user manually prefixes the path with "file:///".  

Therefore, the UI is useless: it not only doesn't act as it should, it pretends 
that it's doing the right thing when it isn't.  Result: frustrated users.
Mike, see http://bugzilla.mozilla.org/show_bug.cgi?id=194632#c37

I fixed it so we now insert a file url instead of a native file path. 
Scott, I don't use Tbird; if it's not fixed in the suite, it's not fixed.
BTW, a cross-reference to the bug where you submitted the patch to 'fix it 
yesterday' would be helpful.
I believe I said in comment #37 that a patch needs to be made for seamonkey too.
Nor was any bug in seamonkey closed to make it look like that was not the case.
Sorry if that was not clear. The thunderbird bug for this issue was Bug #233428.

Here's the seamonkey version of the thunderbird fix I made.
Attachment #143334 - Flags: superreview?(bienvenu)
Attachment #143334 - Flags: review?(Stefan.Borggraefe)
Attachment #143334 - Flags: superreview?(bienvenu) → superreview+
Comment on attachment 143334 [details] [diff] [review]
patch to force file urls into the sound url text box

Now that the mailnewsSoundFileUrl-textbox is read-only, you can remove its
oninput-handler. After this you can inline the one-liner function
onCustomWavInput() to its last caller.

r=me with this change

I tested the patch with a Gtk1-build from yesterday and it works as expected.
Attachment #143334 - Flags: review?(Stefan.Borggraefe) → review+
Attachment #143334 - Attachment is obsolete: true
Comment on attachment 143574 [details] [diff] [review]
updated patch with Stefan's comments

carrying over the r/sr's for this bug.
Attachment #143574 - Flags: superreview+
Attachment #143574 - Flags: review+
Attachment #143574 - Flags: approval1.7b?
Comment on attachment 143574 [details] [diff] [review]
updated patch with Stefan's comments

a=chofmann for 1.7b
Attachment #143574 - Flags: approval1.7b? → approval1.7b+
fixed. I think the file url change + the change to linux for loading sound
libraries should make things much better. 
Status: ASSIGNED → RESOLVED
Closed: 18 years ago17 years ago
Resolution: --- → FIXED
Now the file:/// is added under mac os x but the sound is not played neither
with the preview button nor during actual oparation: nothing beeps.
2004031205 (10.2.8)
(In reply to comment #50)
> Now the file:/// is added under mac os x but the sound is not played neither
> with the preview button nor during actual oparation: nothing beeps.
> 2004031205 (10.2.8)

After reading the MacOS X specific comments in this bug this isn't suprising.
The patches in this bug fixed other things surrounding the notification sound,
but not the issue originally reported. See comment 0, comment 5 and comment 12.

The funny thing is we fixed some Linux-specific bugs here while the bug report
was about a MacOS X-specific problem. ;-)

I don't have a Mac to test this myself, but since nothing was done to fix the
original issue yet, it sounds reasonable that it is not fixed at all (other
things were fixed in this bug though). Reopening.
Status: RESOLVED → REOPENED
Keywords: useless-UI
Resolution: FIXED → ---
Whiteboard: see comment 51
Yes, under Mac OS X sometimes the sound is played correctly. I still have to
understand under what conditions is the sound played correctly. Perhaps it is
played once the browser had played some music via some plugin like quicktime.

Anyway if you restart from scratch the sound is never played.
Pop-up and wave notifications in Moz 1.7B Gecko/20040316 Netscape 7 for Win98SE
still not working.
I am sorry, I should have said: user selected preferences for pop-up and mail
notifications still not working with Moz 1.7B Gecko/20040316 Netscape 7 under
Windows 98SE. Moz selects the system default sound for these notifications.
*** Bug 218739 has been marked as a duplicate of this bug. ***
Custom wav file does not work when assigned to .wav file, preview button also
does not play .wav file, file plays fine in iTunes. System default sound works fine.

MacOS 10.3.3, latest patches as of 04/12/2004
PowerBook G4 17" 1GHz
1GB RAM
Mozilla 1.7 beta {Build ID: 2004031613}
This bug still exists or has been confirmed with using the latest Thunderbird
build 20040419.

  Machine Model:	PowerBook G4 15"
  CPU Type:	PowerPC G4  (3.2)
  Number Of CPUs:	1
  CPU Speed:	1 GHz
  L2 Cache (per CPU):	256 KB
  L3 Cache (per CPU):	1 MB
  Memory:	1 GB

OSX: 10.3.3

Default system sound option will work, however a selected (known good) .wav file
does not play when the "preview" button is push or when new mail arrives.
Attached patch Plays wav file properly (obsolete) — Splinter Review
The Quicktime toolbox wasn't getting initialized, so NewMovie was failing. This
patch calls EnterMovies() and ExitMovies() in the constructor and destructor of
nsMovieSoundRequest.
Comment on attachment 147584 [details] [diff] [review]
Plays wav file properly

Asking a Mac-Guru for review. ;-)
Attachment #147584 - Flags: review?(pinkerton)
actually I was going to suggest Simon too but we'll see what Pink says if this
is something he's comfortable looking at :)


Thanks again for working on this Jon.
No problem. It occurs to me that since we're using Quicktime, we're not limited
to WAV files. That's pretty cool. I tested this patched build with an AIFF file,
and it worked. I would guess that we can play any Quicktime supported audio
type, but I haven't tried anything other than AIFF and WAV.
how expensive is enterMovie()? is it something we should call in our toolkit
startup code once, not every time we start a sound?
According to http://developer.apple.com/qa/qtmtb/qtmtb36.html, it's pretty minimal:

"If the current A5 world has a QuickTime environment from a previous EnterMovies
call, then nothing is done except to increment a counter that keeps track of the
number of times EnterMovies was called."

(Note: That's a Technical Note from 1995, so I suppose it might not be relevant
anymore, but I haven't found anything to say otherwise.)

But yeah, I was thinking it might make more sense to just call it once at
startup and set a boolean or something.
"If the current A5 world has a QuickTime environment from a previous EnterMovies
call, then nothing is done except to increment a counter that keeps track of the
number of times EnterMovies was called." 

but we reset this counter back to zero in the dtor, so the next time we play a
sound it has to create the "a5 world" again (i doubt that's what it does these
days, but it probably does some non-trivial amount of work). the same technote
says further down that calling it repeatedly could cause delays:

"Be aware that this can waste a lot of CPU time if the main application (or
something else in the A5 world) doesn't call EnterMovies first, since each of
the EnterMovies calls in your externals requires QuickTime to reinitialize."

Maybe we're not talking about much time at all these days, but that's why I
asked the question ;)
I think you want your sound to fire as close to immediately as possible, so yes,
we should try to minimize overhead. Sounds like we have two options:

1. Call EnterMovies when the rest of the toolbox is initialized, and don't call
ExitMovies until the app shuts down.
2. Call EnterMovies in the nsMovieSoundRequest constructor and do not call
ExitMovies ever (except maybe when the entire app is shutting down.)

I've noticied in my Thunderbird build that there is a noticable delay between
the bouncing dock icon notification and the sound getting fired. That could very
well be the QT initialization. 

I think option 2 would give us that delay, so I think option 1 is probably the
best choice.
*** Bug 242541 has been marked as a duplicate of this bug. ***
Where do we initialize the toolkit? I'd like to verify that moving the
EnterMovies call to there will still work.
Well I have discovered this.

I have put a wav file as nitification sound to be played in the preferences.

This DOES NOT WORK unless I open a navigator window and load the homepage of
http://www.ilfoglio.it

If I open other webpages, instead of this, the wav is not played, nothing is
played on new mail arrive.

I am now using 2004031613 1.7b with Mac Os 10.2.6.

I have discarded recent builds because I cannot navigate paypal.com and issue
payments because the buttons on the page freeze.

I'd like to move forward on this. How do we finish this up?
With 1.7 rc2, I confirm my previous comment. If I open the www.ilfoglio.it, the
wav is played correctly. If the page is not there in a window, then the system
sound is played!!!
Still broken on Thrunderbird version 0.6+ (20040609)
OSX:  10.3.4
Check again with the webpage http://www.ilfoglio.it opened in a navigator window!
*** Bug 250145 has been marked as a duplicate of this bug. ***
*** Bug 257352 has been marked as a duplicate of this bug. ***
I can confirm this is still broken on Mozilla 1.7.2 and 1.8a3.  Opening
http://www.ilfoglio.it makes no difference.
My patch from way back in May works. The only issue seems to be making sure we
only call EnterMovies() one time (see Comment #64). If someone could point me to
where the Toolbox initialization takes place, I could just place that call there
and this would be fixed.
anther webpage that could be open is www.dagospia.com.

if you have this in the background, your wav playa on new mail
still broken in Thunderbird version 0.7+ (20040830)

OS X 10.2.8

very old bug, over a year old.
the last pending question was where is the toolbox init code. a good place for
it would be in the nsToolkit ctor/dtor. For firefox/seamonkey, they always have
a window open (hidden window) so this will only get called once. Camino doesn't
have one of these, but we use a different widget impl. Does cocoa widget need a
similar patch to this one?

should be easy to fix, just move the 2 lines from the patch to the toolkit
ctor/dtor.
Comment on attachment 147584 [details] [diff] [review]
Plays wav file properly

r- on the patch that calls enter/exit over and over.
Attachment #147584 - Flags: review?(pinkerton) → review-
*** Bug 233143 has been marked as a duplicate of this bug. ***
*** Bug 264400 has been marked as a duplicate of this bug. ***
works for me!
Attachment #147584 - Attachment is obsolete: true
Product: Browser → Seamonkey
Attachment #166062 - Flags: review?(pinkerton)
*** Bug 271970 has been marked as a duplicate of this bug. ***
Comment on attachment 166062 [details] [diff] [review]
EnterMovies/ExitMovies in Toolkit constructor/destructor

r=pink
Attachment #166062 - Flags: review?(pinkerton) → review+
Comment on attachment 166062 [details] [diff] [review]
EnterMovies/ExitMovies in Toolkit constructor/destructor

Just helping out with the flags... I don't have a Mac to test this patch
myself, but this fix is pretty important for TB 1.0 I guess.
Attachment #166062 - Flags: approval-aviary?
(In reply to comment #86)
> (From update of attachment 166062 [details] [diff] [review])
> Just helping out with the flags... I don't have a Mac to test this patch
> myself, but this fix is pretty important for TB 1.0 I guess.
> 

If it makes its way into a nightly build, I'll be able to test it on my Mac at
home. Don't have the time to make my own build at the moment.
See comment #61. If this patch goes through, can we re-word the preference so it
is not wav-file specific?
Attachment #166062 - Flags: approval-aviary? → approval-aviary-
still not working in Thunderbird official 1.0 and build version 1.0 (20041215)
OS X 10.3.6
*** Bug 271445 has been marked as a duplicate of this bug. ***
Same problem on OSX 10.2 
Mozilla 1.8a6
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20050111

I have tried wav and others formats. There is an other report saying that
mozilla is able to play all sound format playable by quicktime. Is it exact ?
see bug:172541
the preview button does nothing
Flags: blocking-aviary1.1?
*** Bug 284076 has been marked as a duplicate of this bug. ***
*** Bug 289286 has been marked as a duplicate of this bug. ***
*** Bug 293018 has been marked as a duplicate of this bug. ***
I'd like to nominate this bug for blocking-aviary1.1 though this is Suite bug...
So will a fix for this see the light of day in 1.1?
*** Bug 304594 has been marked as a duplicate of this bug. ***
After reading through the whiteboard and all comments i'm uncertain what the
current status is of this bug now. 

If i'm not mistaken we have a review+ on a patch that is supposed to fix the
original problem (not playing on OS X), attachment 166062 [details] [diff] [review]?

So asking for sr is the next step?rehti
 > If i'm not mistaken we have a review+ on a patch that is supposed to fix the
> original problem (not playing on OS X), attachment 166062 [details] [diff] [review] [edit]?

I thought the "patch" was to hide the customize sound option (advanced button).
(In reply to comment #100)
> I thought the "patch" was to hide the customize sound option (advanced button).

I think attachment 185328 [details] [diff] [review] hides the pref, while attachment 166062 [details] [diff] [review] supposedly fix
the actual bug.
dih 
I have opened up a new bug (see bug 305784) which I am sure is related.  But 
in my case I never get ANY sound not even a system beep.  What is worse it 
looks like installing Thunderbird also breaks sound in other applications like 
Apple Mail.  Now I don't even get a new sound in Apple mail!

I am sure Thunderbird is the cuprit. My Apple is brand new.  The only other 
applications I have installed is Mozilla, Firefox, NeoOffice and Thunderbird. 
The problem started when I installed Thuinderbird for one user on my Apple.  
The other users which have NOT been set up to use Thunderbird are not 
experiencing any problems.  Apple Mail gives the new mail sound.

This bug in Thunderbird may be a trap that other developers have fallen into.  
Apple has a good post on the problem and the solution -- See  
http://docs.info.apple.com/article.html?artnum=300832

Rob
(In reply to comment #101)

> I think attachment 185328 [details] [diff] [review] [edit] hides the pref, while attachment 166062 [details] [diff] [review]
[edit] supposedly fix
> the actual bug.
> dih 

Yes, attachment 166062 [details] [diff] [review] fixes the bug. Can we get a superreview?
Thatt's great! So when will is see the light of day (released)?
Comment on attachment 166062 [details] [diff] [review]
EnterMovies/ExitMovies in Toolkit constructor/destructor

sr=me but please say in the comment that EnterMovies is required for nsSound to
work.
Attachment #166062 - Flags: superreview+
Attachment #166062 - Flags: approval1.8b4?
Attachment #166062 - Flags: approval1.8b4? → approval1.8b4+
So for the unitiated (dense like me) people what do these approvals mean in the sheme of things and what 
does the 1.8b4 mean in regards to when the fix might appear in a build? Thanks!
I believe that means Jon is allowed to check in his patch, and it'll show up in
the next nightly build after it's checked in.
Jon: do you have check-in privs, or do you need someone to check this in for you?
Nope. No privs.
I've checked in the EnterMovies patch on the branch and the trunk for Jon. 
Status: REOPENED → RESOLVED
Closed: 17 years ago15 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
I just picked up the nightly build off the branch that included this before I
saw the email saying it had been checked in, and was pleasantly surprised to
hear my chosen sound instead of the system beep when new mail came in. :)

Verified fixed on the mozilla1.8 branch.
ok, upon further testing it now plays both the system beep and the notification
sound instead of just one or the other.  I suppose that's a new bug though.
I've noticed the dual sounds too. Interesting that it only happens when Thunderbird is in the background 
(unfocused). If Thunderbird is in the front, I only get the new .wav sound.
with seamonkey 2005090409 and Mac OS X 10.3.9 the only improvement is that the
system sound now works, but the self-defined wav does not work unless there is
some navigation window open with some content using quicktime or something like
that.

this bug is not fixed!
>> with seamonkey 2005090409

That's the Sept 4 build. The fix was checked in on Sept 6. 

Perhaps the system beep is actually coming from the "animate dock icon" setting? Normally a background 
app will beep when it requires attention and the icon will start bouncing, so that would explain why the 
system beep is only heard when Thunderbird is in the background. 
with today's build it works!
(In reply to comment #110)
> I've checked in the EnterMovies patch on the branch and the trunk for Jon. 

The information sound of new mail came to ring by this checkin. 
But popup block sound is not work.

The parameter value preserved in pref.js is different as follows. 

mail.biff.play_sound.url: "file:///" format.
                          The non-ascii sound file name is a file name where it
is escaped. 

privacy.popups.sound_url: Unix path format(ex. "/User/foo/Sound/bar.aiff")
                          The non-ascii sound file name is a file name where it
is not escaped.(It is preserved with UTF-8 in a Japanese file name. )
                          The sound doesn't ring even if the value is changed
into "File:///" format with the manual. 

Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050918
SeaMonkey/1.1a
*** Bug 263040 has been marked as a duplicate of this bug. ***
This seems to have regressed with the universal binary builds. 
version 1.5.0.4 (20060508) on an Intel mac no longer plays the notification sound.
This is still marked as fixed even though there appear to be issues still open related to it.

Anyway, the text in the window for configuring a custom sound says ".wav" but AIFF files work on the Mac.  There's something that still needs doing here. :)
Component: MailNews: Notification → MailNews: Message Display
QA Contact: nbaca → search
Eric, I mentioned that way back in comment #61. It's a feature, not a bug! :) Should be pretty trivial to change the text for OS X.
You need to log in before you can comment on or make changes to this bug.