Contacts sidebar in Thunderbird lacks "Add to BCC:" button.

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
Message Compose Window
--
enhancement
VERIFIED FIXED
14 years ago
6 years ago

People

(Reporter: Joerg Starkmuth, Assigned: Christopher Wright)

Tracking

Trunk
Thunderbird 3
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 6 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When I open the Contacts sidebar in the Compose window of Thunderbird (version
0.3), there's no possibility to select several addresses and add them to the
message as bcc recipients, there are only buttons for "Add to To:" and "Add to
Cc:". I often send mails to many people, many of them don't want to have their
address visible to others, so I normally bcc to all. This was convenient in the
address selection window of the Mozilla suite, but is not possible in Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
I'm really surprised there's ablsolutely no action going on about this bug. Am I
the only one who is missing this function?
Severity: minor → normal
OS: Windows XP → All
Hardware: PC → All
This bug is very annoying. Sending a mail to a lot of people you have to click
to or cc and change it manually afterwards.

I'm sure the fix is really simple, so asking for blocking aviaryRC1.0.
Flags: blocking-aviary1.0RC1?

Comment 3

13 years ago
not a blocker
Flags: blocking-aviary1.0RC1? → blocking-aviary1.0RC1-
Target Milestone: --- → After Thunderbird 1.

Comment 4

13 years ago
I also would like this fixed soon.  It's a real pain the way it is.

Change the buttons to "To:" "Cc:" and Bcc:", The "Add to" is
unnecesary and wastes space.
In Mozilla, in the "Select Addresses" dialog (opposed to contact sidebar in
ThunderBird) it was possible to press Alt+B to add a selected address to BCC.

It would be nice to put this function back, please.

Comment 6

13 years ago
I realize there is a large gap in the dates on these replies, but other than
that, is there some other place where this discussion has been continued?
I actually do not see that there is a problem.  I have installed version 0.7.3,
and I am able to select a contact list name (left mouse button, in
left-side-bar), do a right mouse click and the following menu pops up:

1) Delete
2) Properties
----------------
3) Add to To field
4) Add to Cc field
5) Add to Bcc field

When I selected the "Add to Bcc field" item, the last selected To: field in the
message headerblock was changed to the Bcc: select-list choice and the
appropriate email address was copied to the adjacent input box.  This appears to
be full functionality.  
If there was an additional button at the bottom, it would be forcing the sidebar
to be wider than it physically has to be [now].  IMHO, if anything, I would
actually remove those two buttons and utilize the space for a "signature" or "no
signature" select-list to satisfy bug 218903.

rfb

(Reporter)

Comment 7

13 years ago
I am the orginal reporter of this bug.  Thanks to rfb for mentioning the
right-click menu.  I didn't know about that - which only shows that this feature
is somewhat hidden and should be documented better if the BCC button is not
added any time soon. 

However, I still would prefer the button.  The address panel doesn't have to be
wider for this - just print "Add to:" once and add three smaller buttons labeled
only with "To", "CC" and "BCC".
Severity: normal → enhancement
I KNEW the existence of the context menu, but that's useless.  Well, if you send
a  mail to just several BCC, that isn't a problem.  But if you send to tens or
twenties of persons in BCC, and a lot of mails per day, that IS a problem.

Personally, I would rather prefer the ugly "Select Addresses" dialog in Mozilla
than the sidebar in ThunderBird.

Or there's a workaround (suggestion): every double-click in a contact should
follow the choice on the address pane, but not just as To:
(Reporter)

Comment 9

13 years ago
> I KNEW the existence of the context menu, but that's useless.  Well, if you send
> a  mail to just several BCC, that isn't a problem.  But if you send to tens or
> twenties of persons in BCC, and a lot of mails per day, that IS a problem.

I thought so before, but then I found that if you select several addresses (with
CTRL + left mouse click) and then use the context menu command, *all* selected
addresses will be copied to BCC in one step, not just the one you clicked on
with the right mouse button. Exactly what we want - just very hidden and
non-intuitive.
But don't forget to hold the ctrl button or all selected entries are lost. IMO
the last method (To, CC, BCC) should be used for the entry within the next line.
So it's enought to double click a contact. If you want another method just
update the methode like above. With this feature the context menu would be
enought for me.
(In reply to comment #9)

> I thought so before, but then I found that if you select several addresses (with
> CTRL + left mouse click) and then use the context menu command, *all* selected
> addresses will be copied to BCC in one step, not just the one you clicked on
> with the right mouse button. Exactly what we want - just very hidden and
> non-intuitive.

That's nice!  Ctrl+click was possible in Mozilla, but I haven't thought of it. 
Thanks for reminding us :)

Comment 12

13 years ago
I do miss this button. It should be standard

Comment 13

13 years ago
xref bug 252665
(In reply to comment #8)
> I KNEW the existence of the context menu, but that's useless.  Well, if you send
> a  mail to just several BCC, that isn't a problem.  But if you send to tens or
> twenties of persons in BCC, and a lot of mails per day, that IS a problem.
> 
> Personally, I would rather prefer the ugly "Select Addresses" dialog in Mozilla
> than the sidebar in ThunderBird.

another workaround - open address book, select addresses to your heart's
content, drag and drop into an empty addresss field in the mail window (make
sure you set the field first to BCC, CC or TO).

I too hanker for the old (now called "core") address selection capability.
(But I think it unlikely it will come to TB.)

Comment 15

13 years ago
*** Bug 270093 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
*** Bug 272724 has been marked as a duplicate of this bug. ***

Comment 17

13 years ago
*** Bug 276833 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
*** Bug 241136 has been marked as a duplicate of this bug. ***
(In reply to comment #14)
> another workaround - open address book, select addresses to your heart's
> content, drag and drop into an empty addresss field in the mail window (make
> sure you set the field first to BCC, CC or TO).
> 
> I too hanker for the old (now called "core") address selection capability.
> (But I think it unlikely it will come to TB.)

   This solution doesn't solve the problem.  To the opposite, it shows another
problem.  Once the first dragged address appeared as BCC/CC, the next field
switched back to TO.

   On the other hand, drag and drop a few addresses is acceptable, but drag and
drop tens of addresses isn't.

Comment 20

13 years ago
(In reply to comment #14)
> another workaround - open address book, select addresses to your heart's
> content, drag and drop into an empty addresss field in the mail window (make
> sure you set the field first to BCC, CC or TO).

but this works only for one address due to  bug#271917


Comment 21

13 years ago
*** Bug 286515 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
Created attachment 182847 [details]
Add Bcc Button Extension

http://www.supportware.net/mozilla/#ext12

Comment 23

13 years ago
(In reply to comment #22)

Great ! I've test it, it works, hope it will soon be sign and available in
https://addons.update.mozilla.org/extensions/?application=thunderbird !

Though, there is something strange, the width of the button depends on the
contact frame's size (there must be a useless width:100% somewhere).

Comment 24

12 years ago
*** Bug 312612 has been marked as a duplicate of this bug. ***

Comment 25

12 years ago
It's clear from other comments that the functionality exist in various forms (context menu, drag-n-drop). I particalurly like the suggestion in comment 9.

In my opinion this is a serious UI issue. I also didn't know about the context-menu option. I think that the mere fact that I saw only two buttons at the bottom of the sidebar intuitively led me to believe that the functionality doesn't exist, and that there will also be only two buttons at the context-menu. That is, not only that the functionality is hidden from me, the UI deceives me to believe that it is non-existent. Otherwise, I would have tried the context-menu a long time ago.

Such a confusing UI issue should be, in my opinion, a blocker (in reply to comment 3).
(In reply to comment #19)
> (In reply to comment #14)
> > another workaround - open address book, select addresses to your heart's
> > content, drag and drop into an empty addresss field in the mail window (make
> > sure you set the field first to BCC, CC or TO).
> > 
> > I too hanker for the old (now called "core") address selection capability.
> > (But I think it unlikely it will come to TB.)
> 
>    This solution doesn't solve the problem. 

It is an effective workaround if you choose all your addresses before dragging.


>To the opposite, it shows another
> problem.  Once the first dragged address appeared as BCC/CC, the next field
> switched back to TO.

probably Bug 271917
Version: unspecified → Trunk

Comment 27

12 years ago
*** Bug 324505 has been marked as a duplicate of this bug. ***
*** Bug 334045 has been marked as a duplicate of this bug. ***

Comment 29

11 years ago
Anyone working on this?
(Assignee)

Comment 30

11 years ago
I've created a patch for this.  You can find it here: http://softpixel.com/~cwright/programming/projects/thunderbird-2.02b.bcc.patch
It's a pity so many lines were burned here for workarounds; the fix is only like 5 lines of code...  BTW, how would/should I go about trying to get this patch into the main distro?
(Assignee)

Comment 31

11 years ago
Created attachment 260482 [details] [diff] [review]
This is a patch to add this button.  Pretty simple.
Attachment #260482 - Flags: review+
Comment on attachment 260482 [details] [diff] [review]
This is a patch to add this button.  Pretty simple.

You can not give r+ to your own patch. Ask the right person. Further you should create a diff (like -pu8) against the cvs repro first.
Attachment #260482 - Flags: review+

Comment 33

11 years ago
Tested on my build.  It works.  It's simple.  It should have been done 3 years ago.  Who cares if it is not built as a patch against cvs.  Someone should come along and just apply it.  But hey, if the developed assigned hasn't done anything about it in 3 years I guess Thunderbird will continue sucking for 3 more years.
(Assignee)

Comment 34

11 years ago
Created attachment 260545 [details] [diff] [review]
A Patch against current CVS, with more context.

This patch is against the current CVS, not the 2.0b2 branch.
Attachment #260482 - Attachment is obsolete: true
(Assignee)

Comment 35

11 years ago
Created attachment 260567 [details] [diff] [review]
A cvs diff patch, hopefully made correctly.

Ok, I think this is the correct method for creating a patch?
(Secret: Chris Wright is unskilled at making cvs patches :)
Attachment #260545 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Attachment #260567 - Flags: review?(bienvenu)

Comment 36

11 years ago
Comment on attachment 260567 [details] [diff] [review]
A cvs diff patch, hopefully made correctly.

looks reasonable to me - one question - does the contacts siderbar initially come up wide enough to see all three buttons?
Attachment #260567 - Flags: superreview?(mscott)
Attachment #260567 - Flags: review?(bienvenu)
Attachment #260567 - Flags: review+
(Assignee)

Comment 37

11 years ago
I made the button in a new hbox.  This sacrifices some contact list height, but also allows for another additional button if someone wants another.  Maybe Comment #7 is the way to go?
(In reply to comment #36)
> looks reasonable to me - one question - does the contacts siderbar initially
> come up wide enough to see all three buttons?

No, definitely not. For all major platforms it's too narrow. The 'To' and 'CC' buttons already fills up the complete width. If the new hbox doesn't wrap we get an ugly scrollbar. On the other hand we shouldn't enlarge the contact sidebar anymore. It has still the correct width. IMO the 'BCC' button has to wrap into the next line.
(In reply to comment #37)
> I made the button in a new hbox.  This sacrifices some contact list height, but
> also allows for another additional button if someone wants another.  Maybe
> Comment #7 is the way to go?

Christopher, I assign this bug to you so anyone can see that you are working on patches.

Assignee: mscott → cwright
Status: NEW → ASSIGNED
(Assignee)

Comment 40

11 years ago
Woah, woah, calm down :)  I'll try to explain.  In the contacts side bar, we have the address book selector, the directory pane, and then the add-to and add-cc button hbox.  With the additional hbox for the add-bcc button, it simply takes space from the directory listing.  It does _Not_ change the width of the side bar.  It does _Not_ change the height of the side bar.  It does _Not_ change the window dimensions in any way.  Its modifications to the user interface are just about the same as the ones for the extension that was mentioned in Comment #22.  Nothing radical.

I developed it and tested it on OS X, surely one of the "Major Platforms" you reference.  Normal window size is perfectly usable.  Maximizing the window does not wrap.  Maximizing the window and then dragging the side-bar resizer all the way to the right still doesn't wrap.  That's what the spring tags are for I believe (they're in both hboxes, just in case).

Would it be more helpful to just fling up some before/after screenshots?

Comment 41

11 years ago
Any chance to get this into TB 2?
(In reply to comment #40)
> add-cc button hbox.  With the additional hbox for the add-bcc button, it simply
> takes space from the directory listing.  It does _Not_ change the width of the
> side bar.  It does _Not_ change the height of the side bar.  It does _Not_

Especially on Mac OS X the default width of the sidebar is still too narrow. The  right side of the CC-Button is still cut-off. Can you provide a screenshot after this changes were applied? Are the To and CC buttons smaller with that patch? 

> Would it be more helpful to just fling up some before/after screenshots?

Indeed. It would be. 

(In reply to comment #41)
> Any chance to get this into TB 2?

No, it is too late for TB2.0 bcause we also have ll0n changes here. 

(Assignee)

Comment 43

11 years ago
Created attachment 261012 [details]
Screenshot of the new button and its orientation on the window.

Here's a picture of the window at default sizes.
Thank you Christopher. Meanwhile I got my Mac OS X to build my own builds. After integrating your patch all looks fine. But there is one thing what I would prefer. IMO putting the CC and BCC button on one line would make a bit more sense due to both sending copies to given recipients. David what's your opinion?

Comment 45

11 years ago
How do I apply the patch on comment #30?  When I click on the link, I see the code.

m
QA Contact: message-compose
Scott, this patch looks good. It still waits for your sr to get checked in. It would be nice if you could have a look at it. Thanks.
Flags: blocking-thunderbird3?

Comment 47

10 years ago
Comment on attachment 260567 [details] [diff] [review]
A cvs diff patch, hopefully made correctly.

What do you think of this patch Phil? I just realized these buttons don't have access keys. I wonder if we should try to add them (that could be a separate bug). And we'd have to make sure the behavior works right when the contacts sidebar is closed.
Attachment #260567 - Flags: superreview?(mscott) → superreview?(philringnalda)
Comment on attachment 260567 [details] [diff] [review]
A cvs diff patch, hopefully made correctly.

Sorry, Christopher, but what would a first Mozilla bug experience be without experiencing bitrot? They didn't have accesskeys, because their accesskeys were waiting for checkin in bug 364229, and now that they're in, Add to BCC: needs one too.

Also, while I don't think comment 7 is the way to go, I suspect that comment 44 is right that having To alone on the first row, and CC and BCC together on the second, would look and work better. Give that a try, please?
Attachment #260567 - Flags: superreview?(philringnalda) → superreview-
Phil, with the patch on bug 364229 the accesskeys are set as following

 <!ENTITY toButton.label                     "Add to To:">
+<!ENTITY toButton.accesskey                 "A">
 <!ENTITY ccButton.label                     "Add to Cc:">
+<!ENTITY ccButton.accesskey                 "d">

Can we change that so we can have 'T', 'C' and 'B' as accesskeys? I don't know the sidebar code and if the keys are already used. But for me it makes more sence to use the addressing value.
(Assignee)

Comment 50

10 years ago
Created attachment 267967 [details]
Buttons Rearranged

Here are the buttons rearranged.  To me it makes sense, but I'm indifferent either way.  (new patch coming soon :)
(Assignee)

Comment 51

10 years ago
Created attachment 267968 [details]
Updated patch: Rearranged buttons, access keys.

Ok, I like the 'T', 'C', and 'B' idea (it's intuitive,) so I added that to this patch.  it changes the keys assigned from bug 364229, which is a bad idea: Ctrl-C is a bad shortcut for windows users (it's Copy).  I don't know what the Right Thing to do is, so just pick some keys and I'll make it so (or y'all can, it is open source after all. :)  Thoughts?
Attachment #260567 - Attachment is obsolete: true
Attachment #267968 - Flags: review?

Comment 52

10 years ago
Created attachment 267969 [details]
Add bcc button, compatible with TB 2

The end of this bug is not far.
But if you want this feature now, it can be useful.
No change in code, I've just added 2.0.0.* compatibility)
(Assignee)

Comment 53

10 years ago
Thank you Théophile.  Unfortunately, I do not think that fixing core usability issues with extensions is a viable option for Thunderbird, or any application for that matter.  Though it is a good immediate fix (since this is taking far longer than expected :)
(Assignee)

Comment 54

10 years ago
Created attachment 267974 [details]
non-malformed (sorry about that
(Assignee)

Comment 55

10 years ago
Created attachment 267975 [details] [diff] [review]
non-malformed (sorry about that)

[note to self, check output...]
Attachment #267968 - Attachment is obsolete: true
Attachment #267975 - Flags: review?
Attachment #267968 - Flags: review?
Attachment #267974 - Attachment is obsolete: true

Updated

10 years ago
Attachment #267975 - Flags: superreview?(bienvenu)
Attachment #267975 - Flags: review?(philringnalda)
Attachment #267975 - Flags: review?
Comment on attachment 267975 [details] [diff] [review]
non-malformed (sorry about that)

If only adding accesskeys was as easy as picking the best letter. Unfortunately, the _T_ools menu and the Atta_c_hments pane got to t and a before you did, so you can't use either of those.
Attachment #267975 - Flags: superreview?(bienvenu)
Attachment #267975 - Flags: review?(philringnalda)
Attachment #267975 - Flags: review-
(Assignee)

Comment 57

10 years ago
Right.  What's a good key to use for BCC?  I know nothing of accesskey picking, that's why I'm asking for suggestions :)  I don't use accesskeys personally, so I'm completely indifferent.  Someone just Pick 'em already :)
We don't have any chance to set an accesskey for "Add to BCC" without changing other ones. Each of these letters are already assigned somewhere:

a: Add to To
d: Add to Cc
t: Tools menu
o: Search For (contact sidebar)
b: Address Book (contact sidebar)
c: Attachments

The only possibility I can see, is to change the accesskey for "Address Book" into "k" and using "b" for "Add to Bcc". We still can't use any other letter. It's really hard at this point. Seems that this is the only way. Otherwise all accesskeys of the compose window have to be renewed.
(Assignee)

Comment 59

10 years ago
maybe 'l' for bLind-carbon-copy ?
No, we only can use a letter which is part of the button text and 'L' doesn't appear there. Phil, what is your opinion?
(Assignee)

Comment 61

10 years ago
looks like ':' is the only option we have left ;)  man this is out of control :)

Comment 62

10 years ago
At this point in project development you have to forget about the consistency of assigning an access key to every single feature, and just bite the bullet and not have one.

Also, an access key is outside the scope of this patch and bug - "Contacts sidebar in Thunderbird lacks 'Add to BCC:' button".
Mike, with your checkin of accesskeys for To and Cc we have a problem with the newly Bcc button. See my comment 58 for a proposal how to get things working. What shall we do?

Comment 64

10 years ago
(In reply to comment #58)
> The only possibility I can see, is to change the accesskey for "Address Book"
> into "k" and using "b" for "Add to Bcc". 

This seems like a completely logical way to go.

Another (more complex and probably less useful) option would be a dropdown to select between To, CC and BCC, plus an Add button.

Comment 65

10 years ago
I agree with Mike, changing the access key for Address Book seems reasonable.
(Assignee)

Comment 66

10 years ago
Created attachment 269072 [details] [diff] [review]
Rebinds accesskeys, plus previous layout stuff.

I think this cleans up all the issues.  Addressbook now uses 'k' so bcc can use 'b'.
Attachment #267975 - Attachment is obsolete: true
Attachment #269072 - Flags: review?
Attachment #269072 - Flags: review? → review?(philringnalda)
Comment on attachment 269072 [details] [diff] [review]
Rebinds accesskeys, plus previous layout stuff.

Looks good, thanks!
Attachment #269072 - Flags: review?(philringnalda) → review+
mail/components/addrbook/content/abContactsPanel.xul 1.13
mail/locales/en-US/chrome/messenger/addressbook/abContactsPanel.dtd 1.5
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: Future → Thunderbird 3
Flags: blocking-thunderbird3?
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070622 Thunderbird/3.0a1pre ID:0000000000 [cairo].

Thanks for your effort, Christopher.
Status: RESOLVED → VERIFIED
Just for information: The checked in patch was a bit modified before it went to trunk. The lower 'b' accesskey for BCC was corrected to a 'B'. We have to take care because accesskeys are case sensitive. Thanks Phil.
Duplicate of this bug: 361353

Updated

10 years ago
Duplicate of this bug: 414111

Comment 73

10 years ago
Is there any possible way to get this added in on branch? Is there any "bake time" or wait time or other reason it can't get in? 
I think it won't be approved for 1.8 branch because it's not a security related fix and string changes were made.
Duplicate of this bug: 420602
Duplicate of this bug: 458413

Updated

8 years ago
Duplicate of this bug: 503743
Duplicate of this bug: 533143
You need to log in before you can comment on or make changes to this bug.