Last Comment Bug 256763 - Java applet causes cursor to get stuck, resulting in backwards or jumbled typing in location bar or other textbox
: Java applet causes cursor to get stuck, resulting in backwards or jumbled typ...
Status: RESOLVED WORKSFORME
See comment 53
: qawanted, testcase
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- normal with 14 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jim Mathies [:jimm]
Mentors:
http://www.jeep.com/en/wranglers/360/...
: 238701 260828 260998 269973 271084 274230 277120 281412 288733 300854 302905 306013 317427 323403 326057 350983 365836 375944 377310 405304 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 14:06 PDT by Harri Pesonen
Modified: 2010-10-14 17:22 PDT (History)
45 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Harri Pesonen 2004-08-24 14:06:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040823 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040823 Firefox/0.9.1+

When I am in the Java login screen, all keyboard handling in Firefox is buggy.
The cursor moves erratically when I type to Google search box, or to some form
in any other tab or window. It is really annoying... the cursor moves to before
the written letter, not after it. Please test this, it should be fixed as soon
as possible. Everything works in IE, but in Mozilla and Firefox it is impossible
to write any text. I write this in Notepad and then paste to Firefox screen...

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.runescape.com/
2. Click Play Game / High Detail / Select some server.
3. It loads an Java applet. I have tried Sun's 1.5 beta and 1.4.2.
4. When you get to the New user / Existing User screen, there is a background
music playing in IE, not in Firefox.
5. Now enter some text into Google search box, for example. Randomly the cursor
moves to the beginning of last written letter.
Actual Results:  
he ursor moves erratially as you see hre. I is imossileo write any tex .tt bpteeccT

Expected Results:  
Keyboard should work normally.
Comment 1 Harri Pesonen 2004-08-27 02:59:42 PDT
Might be related to bug 247140 (Java applets permanently hog keyboard focus) but
in this case the cursor just doesn't move correctly in any tab/window when this
java applet is running. It is possible to enter text to URL and Search box, but
the text is entered incorrectly, randomly the cursor does not move after the
last entered letter.
Comment 2 u88484 2004-09-26 00:14:01 PDT
This is a duplicate of Bug# 247140
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:00:51 PST
*** Bug 260998 has been marked as a duplicate of this bug. ***
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:00:57 PST
*** Bug 271084 has been marked as a duplicate of this bug. ***
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:01:09 PST
*** Bug 260828 has been marked as a duplicate of this bug. ***
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:01:10 PST
*** Bug 238701 has been marked as a duplicate of this bug. ***
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:01:35 PST
*** Bug 274230 has been marked as a duplicate of this bug. ***
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-11 16:24:04 PST
Confirming as it certainly does not seem to be a dupe of bug 247140. That is a
Mac  core bug, this is Firefox specific and happens on WinXP.
Comment 9 Thomas Spear 2005-01-03 09:54:07 PST
I can say that this does happen but only sometimes..  Most of the time I load up
Firefox (1.0) and the keyboard handling is fine, but every now and then it
messes up in this game.  But if I restart the computer and try it again I cant
get it to do it, so there really arent any steps to reproducing the bug..

Actually I originally came to this bug because another one I was looking into
was marked as a dupe of this one, even though it really isnt..

There are 2 bugs with runescape in firefox (and i am assuming all mozilla
based-browsers)..

This is one of them, and the other is that the sound for the game never works in
Firefox, but it does in IE..  Note that I am using Sun's 1.5 JRE, not the MS
one, so I would think that if it were a bug in the JRE, the sound wouldnt work
in either IE or FF

So anyways I will go ahead and create a new bug for the sound issue if that's
ok, since they are unrelated bugs, just need someone to email me telling me to
do so..
Comment 10 Kevin Brosnan 2005-02-04 10:49:14 PST
*** Bug 277120 has been marked as a duplicate of this bug. ***
Comment 11 Kevin Brosnan 2005-02-07 19:25:38 PST
*** Bug 281412 has been marked as a duplicate of this bug. ***
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-04-03 00:10:23 PST
*** Bug 288733 has been marked as a duplicate of this bug. ***
Comment 13 Kevin Brosnan 2005-04-03 00:21:16 PST
formated summary for tech evang
also see bug 248640 bug 264286 and bug 285069
Comment 14 232378 2005-04-03 21:46:46 PDT
Umm I don't htink its a duplicate, and I can get it to do it everytime. and its
only types it wrong thats only problem.
Comment 15 Andrew Gower 2005-04-04 01:26:38 PDT
Ok, there are multiple DIFFERENT bugs being reported here, and very confusing.
Only 1 of them is a bug in firefox. Let me clarify

1) Text cursor moves erratical. We do not think this is RuneScape specific
problem. As far as we can tell this is simple a race condition in firefox's
textbox code such that if the computer is at 100% CPU load the text cursors no
longer moves properly. You can reproduce this bug by loading up ANY java applet
that uses 100% cpu and then trying to type into the address bar or any of
firefoxes windows. The reason only some people see this is people with very fast
computer can play runescape without hitting 100% cpu. Write yourselves a simple
test applet that uses several threads to thoroughly eat all the cpu and then
you'll see it happening.

2) The sound doesn't work in RuneScape under firefox. This is NOT a firefox bug.
This is our fault, it's because we are using an IE specific feature to do the
sound because at the time we wrote it Java had no decent midi player. This is on
our list of things to fix, since Java 1.5 finally has an ok midi player. I
repeat this is NOT a firefox bug.

3) The person complaining about getting 2 context menus, when he right clicks in
runescape. Go to Tools->Options->WebFeatures. Click the 'advanced' button next
to 'enable javascript' and tick 'disable or replace context menus'. It will then
work ok. For some reason this javascript option also seems to change the
behaviour of java applets even though, which is technically a bug, or certainly
confusing. But easy to work around.
Comment 16 joell haugan 2005-07-14 17:31:49 PDT
I agree completely with Andrew's comments and can reproduce the bug (#1) on my
machine too (and have been seeing it for some time but could never figure out
where to log it! :) ).  My son goes through all kinds of hoops to type in
messages when his Runescape is running in any open tab or window.  All other
windows will mix up the typing.

The sound not playing is not a mozilla issue.
Comment 17 William Bumgarner [:zsinj] 2005-07-14 19:31:31 PDT
*** Bug 300854 has been marked as a duplicate of this bug. ***
Comment 18 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-08-01 03:28:29 PDT
*** Bug 302905 has been marked as a duplicate of this bug. ***
Comment 19 Diego Duclos 2005-08-08 04:40:49 PDT
Starting runescape in low detail should help on most Pentium-IV systems
Comment 20 Thomas 2005-08-09 12:19:21 PDT
(In reply to comment #19)
> Starting runescape in low detail should help on most Pentium-IV systems

what about those running sempron 2500+ with 512MB PC3200 on a 64MB Radeon
game runs fine, never lags
and cpu use is about 85-90% (firefox is about 75-80% of cpu usage)
and thats high detail

and i still see erratic movement :P
Comment 21 Diego Duclos 2005-08-10 02:15:40 PDT
well here i got a pentium-IV 2.6Ghz 512MB of memory i got erratic cursor
movement in high detail (game uses 100% CPU) but not in low detail (about 85-90%
CPU)
Comment 22 Kevin Brosnan 2005-08-25 21:22:24 PDT
*** Bug 306013 has been marked as a duplicate of this bug. ***
Comment 23 joell haugan 2005-11-21 21:49:24 PST
This bug persists and now I'm finding (on two different AMD64 machines) that once my son plays runescape and then closes Firefox it will not completely shut down (although it does not appear in the running applications but does show under running processes).  One must CTRL-ALT-DEL and kill the firefox.exe process. 
Comment 24 zug_treno 2005-11-23 02:51:50 PST
*** Bug 317427 has been marked as a duplicate of this bug. ***
Comment 25 Rick 2005-12-17 23:46:22 PST
This happens to me too. I'm running the latest version of Firefox and the same thing happens on both my laptop and PC. Both run widows XP Pro, the laptop has 512MB RAM, 1.73GhZ Pentium M processor, the PC has 192MB RAM, 633MhZ processor (I know, it's a dinosaur :P ). I've tried running Firefox in safe mode and the same thing happens, the cursor randomly jumps around while I'm typing anything in FF (search bar, location bar, forms, etc). This only happens in high detail mode, which makes it seem like a memory problem. I've seen the memory useage go up past 200MB, although the CPU useage never goes above 50%. Note that before I tried all of this, I restarted my computer and I have no other programs open.. only one tab in firefox, and it seems very odd that a browser should use that much memory after such a short period of time.
Comment 26 Whit 2005-12-23 20:44:27 PST
I experience this bug as well. Cursor jumps around in any text field on the page including address bar and search box.  It happens 100% of the time for me.
Comment 27 :Gijs Kruitbosch 2005-12-26 08:01:54 PST
(In reply to comment #8)
> Confirming as it certainly does not seem to be a dupe of bug 247140. That is a
> Mac  core bug, this is Firefox specific and happens on WinXP.

I'd hold off on calling this a Firefox specific bug. Did anyone actually try to reproduce on Suite? (I can't reproduce in Firefox, probably because my pc's specs are simply to high to care, so attempting to reproduce on Suite doesn't make sense for me). From what comment #15 says, I'd think this should be moved to Core, and is not tech evangelism at all. Sure, the sound thing is tech evangelism, for that there is bug 264286. The textbox code is shared, so I'd say that's Core.
Comment 28 Travis Gayton 2005-12-27 01:40:02 PST
This is actually a bug in the gecko core, any version up to current of gecko core malfunctions while a java applet is taking input (Anything, including java chat clients) the only way to fix it is to patch the gecko core or find a workaround with java, Im not a java developer so im not sure if its possible to check the applet focus, but if so, the best way around this would be checking the focus of the applet and if it de-focused temporarily stop taking input.

If anyone has any suggestions on a workaround, please feel free to post, Hearing from Chris / Andrew on changing java applet input status would be great.

SpookyTee [spookytee@san.rr.com]
Comment 29 zug_treno 2006-01-14 12:58:28 PST
*** Bug 323403 has been marked as a duplicate of this bug. ***
Comment 30 zug_treno 2006-02-06 09:36:26 PST
*** Bug 326057 has been marked as a duplicate of this bug. ***
Comment 31 m.bergijk 2006-02-06 23:25:15 PST
(In reply to comment #9)

> This is one of them, and the other is that the sound for the game never works
> in
> Firefox, but it does in IE..  Note that I am using Sun's 1.5 JRE, not the MS
> one, so I would think that if it were a bug in the JRE, the sound wouldnt work
> in either IE or FF

I think the Runescape music does not work inside FF/M because they use the Microsoft Java Api. And inside FF/M you don't have access to this Api. I think Runecraft uses this Api because it offers better access to the sound hardware. Look up on this problem in the Runescape forums. Search "Tech Support" on "sound" or more specific "SERIOUS MUSIC PROBLEM"
Comment 32 Onkar Shinde 2006-02-24 00:32:05 PST
Bug 1, Java applet interfering with text input in URL bar is reproducible in SeaMonkey 1.0, Windows 2K SP4, Java 1.5.0_06.
Faced the problem on www.runescape.com. Applet (in background tab) interfered with    text input in url bar and comment field of this bug.

Bug 2, about sound not working is also reproducible.

So this isn't a Firefox only bug.
Comment 33 :Gijs Kruitbosch 2006-02-24 01:33:29 PST
Attempting to select a better component...
Comment 34 :Gijs Kruitbosch 2006-02-24 01:34:53 PST
Not sure if this makes sense - didn't want to put it in Layout: Form Controls because this is not so much about layout as about actually using it. Maybe this distinction is wrong though - if someone more knowledgeable in this area comes along, please poke this bug again. It'd be nice to get some traction on this.
Comment 35 Cameron 2006-05-16 05:37:56 PDT
Runescape has just released a new game engine, supposedly reducing memory usage. I'm currently unable to reproduce this bug. 

Windows XP SP2 Home
Firefox 1.5.0.3 
Java(TM) 2 Platform Standard Edition 5.0 Update 6
3.2 Ghz, 1 GB RAM.

If some people could attempt to reproduce this now (in light of this new update) on a much slower pc then that'd be some useful info. We may have to drop runescape relevance (the "tech evangalism" section of the bug") and find a new testcase.
Comment 36 Thomas Spear 2006-05-16 07:26:42 PDT
IIRC it was a race condition that caused this, so it may be a bug in java itself, and not in Firefox.  Seems to only occur in Firefox probably because FF has higher CPU and memory usage than IE does on slower machines.  I don't have my laptop that I could reproduce this problem on anymore, but I know someone who has a _really_ old laptop we could test it on.  I'll post more results as I get them
Comment 37 joell haugan 2006-05-16 08:43:07 PDT
Seems to be working fine now on my machine that previously had the problem.  Will test again on slower machine.
Comment 38 joell haugan 2006-05-16 22:20:29 PDT
I tested on a slower/older machine and it's working fine.  It's fixed from my perspective.
Comment 39 Cameron 2006-05-16 22:30:13 PDT
Removing runescape relevance from the bug. I'll see if I can chase down a testcase.
Comment 40 Thomas Spear 2006-05-16 23:49:30 PDT
runescape could still be a testcase, as on my sempron 2600, just sitting at the loading screen uses 70-80% of my cpu, and eats 130mb of RAM..  I'll look into maxing out the cpu by loading 2 applets at the same time and get back to you.  i cant do it atm due to having to backup my hd, and needing the spare cycles :-)
Comment 41 Thomas Spear 2006-05-19 16:24:56 PDT
I agree.  I ran 4 copies of runescape, 2 in Ie, and 2 in Firefox, left all 4 at the login screen, verified CPU was at a constant 100% and attempted login on one of the 2 firefox copies.  It came out perfect multiple times, even though the graphis were studdering all over the place like i was on a 14.4 connection lol.
Comment 42 Cameron 2006-05-19 16:27:20 PDT
(In reply to comment #41)
> I agree.  I ran 4 copies of runescape, 2 in Ie, and 2 in Firefox, left all 4 at
> the login screen, verified CPU was at a constant 100% and attempted login on
> one of the 2 firefox copies.  It came out perfect multiple times, even though
> the graphis were studdering all over the place like i was on a 14.4 connection
> lol.
> 
Did you try typing in the location bar? That was where this bug was usually present.
Comment 43 Thomas Spear 2006-05-19 16:36:12 PDT
Techincally, if runescape was our only testcase and it has been fixed with an upgraded engine, it would have to be an engine bug in runescape.  Granted it may have only happened in firefox, but that is probably due to some weird incompatibility between the old engine and the sun jvm, vs the ms jvm that gets used when running under ie.

It could also be a bug in FF 1.0.x that was fixed in 1.5.x, or a bug in xp that was fixed in SP2..  Regardless, this happened for me on an older pentium laptop, and for others on semprons..

My guess is that it was a combination of factors, that which we will never figure out, but that since it is no longer reproducible, we should just resolve the bug and move on with our lives :-)
Comment 44 Thomas Spear 2006-05-19 16:37:11 PDT
Yes I had to type into the location bar to get to runescape.com..  I dont use the bookmarks
Comment 45 Ryan Flint [:rflint] (ping via IRC for reviews) 2006-05-19 17:19:08 PDT
Testcase here: http://www.screwedbydesign.com/mozilla/testcases/256763/
The applet runs two threads, each doing a small calculation in a while(true) loop.

Note: There is a 2 second delay built-in before the calculation is run.
Comment 46 Thomas Spear 2006-09-07 19:25:56 PDT
Testcase #2: Download windows vista RC1 from http://download.windowsvista.com/preview/rc1/en/download.htm

It uses a Java download client that does NOT even use 10% of my CPU and as I am typing not only in the location bar, but in any form under FF, every now and then the cursor stays in place while the character in inserted before it so several of my words come out looking like this: there once was a woman who lived in a shoe, she had so many children, she didn't know what to do..  jack be nimblejack be quick, jac jump over the candle stick..k 

notice that the k from jack is after the .. from me having fiished my sentence, and there again it is for the word finished...n
Comment 47 Henrik Skupin (:whimboo) 2006-09-09 08:17:24 PDT
It's also happen on following URL:
http://www.jeep.com/en/wranglers/360/wrangler/exterior/index.html?tname=wrangler360

The cursor is jumping forwards and backwards. Additionally I can't use the clipboard anymore because nothing is copied in it.
Comment 48 Cameron 2006-09-09 09:05:23 PDT
I've changed my mind, I don't think this is related to 100% CPU at all - whoops! I also think this might be a dupe of bug 269973, not a dependency, but will await confirmation on bug 269973 comment 35 (backwards, or just jumbled?)

I am now able to reproduce this at both http://www.jeep.com/en/wranglers/360/wrangler/exterior/index.html?tname=wrangler360 and http://www.stolaf.edu/people/hansonr/jmol/test/ping/Test_pingpong.html on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2 ID:2006082101 with Java 5.0 update 6.

I'm also wondering if anyone is able to reproduce this on any OS other than Windows? 
Comment 49 Henrik Skupin (:whimboo) 2006-09-09 09:14:52 PDT
(In reply to comment #48)
> I've changed my mind, I don't think this is related to 100% CPU at all -
> whoops! I also think this might be a dupe of bug 269973, not a dependency, but
> will await confirmation on bug 269973 comment 35 (backwards, or just jumbled?)

Don't think so. It's not backwards only. The text is totally scambled on my box.

> I'm also wondering if anyone is able to reproduce this on any OS other than
> Windows? 

I ask on bug 351940 if it's reproducible for Camino. 

Comment 50 Cameron 2006-09-11 08:11:13 PDT
Resummarising for dupe.
Comment 51 Cameron 2006-09-11 08:15:30 PDT
*** Bug 269973 has been marked as a duplicate of this bug. ***
Comment 52 Cameron 2006-09-11 08:19:56 PDT
Bug 269973 comment 30 has a useful testcase and some additional information
Comment 53 Alfred Peng 2006-09-11 23:53:29 PDT
There is already a bug on sun bug database for it: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6408194

And the target release for it is jre1.5u10.
Comment 54 Henrik Skupin (:whimboo) 2006-09-12 00:24:47 PDT
(In reply to comment #53)
> There is already a bug on sun bug database for it:
> http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6408194

Due to the reason that it is a Java bug we could resolve this bug as invalid? Or do we have to wait until it will be fixed to verify?
Comment 55 Thomas Spear 2006-09-13 14:17:04 PDT
(In reply to comment #54)
> Due to the reason that it is a Java bug we could resolve this bug as invalid?
> Or do we have to wait until it will be fixed to verify?

I would say that we should wait for the fix from sun to resolve it, as it is not reproducible (as far as we know) under any browser that does not use the gecko engine, such as IE, or Konqueror.
Comment 56 Majken Connor [:Kensie] 2006-10-24 00:53:32 PDT
I've had this happen in the url bar and in gmail's javascript gtalk.  Is there another bug for that, or does that fit in the scope of here, and maybe it's not all java afterall?
Comment 57 Thomas Spear 2006-10-30 21:59:19 PST
When it happens in the address bar, is there anything java running in the background, or possibly in the browser window itself?

From every report I have seen this only happens when java is doing something and only within firefox, so if you are using the java google talk client, THRU firefox, then it is still related to this "incompatibility" between firefox and java.

P.S. You did post to the correct bug.
Comment 58 Majken Connor [:Kensie] 2006-10-30 23:25:31 PST
javascript != java

as far as I know gmail only uses js.
Comment 59 Thomas Spear 2006-10-31 09:59:34 PST
Fair enough.  Gmail's js-based google talk shouldnt be the cause.  Just because it happens in that window doesn't necessarily mean that it is cause by it.

From what I see, this problem, whatever it is, affects every text input field that is rendered by firefox, whether it is part of a web page, part of a java applet, or part of FF itself, so double check and make sure that javaw.exe is not in your process list in task manager whenever this condition occurs for you.  If it is, then your issue definitely falls under this bug, if it is not, then it may still fall under this bug, but one of the developers should make that call.
Comment 60 Majken Connor [:Kensie] 2006-10-31 10:47:42 PST
I'm fairly certain I only had gmail open, but I can test again.  It was happening on my parents' computer which is fast, but their connection is slow.  It happened to me on this machine once when something huge was loading (I think a bugzilla list that was taking up a lot of resources).  To me the issue seems to be about typing faster than something can process the keystrokes.  Which is what seems to be happening to the others I've seen with the issue.  Maybe it's not java itself, but java is tying up a resource, which can be tied up/delayed in other ways?
Comment 61 Thomas Spear 2006-10-31 11:08:22 PST
For the most part I think that is actually what is happening with everyone else.  As the original thread title was something along the lines of being a race condition with 100% cpu and something java running in the background.

I don't think that a connection speed would cause it though.  Its possible that even though the computer is fast, there may have been something at a lower priority tieing up the cpu and so the computer seemed to respond to clicks and keystrokes, but it was just enough cpu load to cause the condition.  On yours, it may possibly be something to do with a bugzilla load, but how that ties in with java, I am not sure.  Like I said though, even if java isn't necessarily the thing being the resource hog in your case, it could still be causing the issue, since firefox loads up the java plugin, so yea if you don't mind, make sure that javaw.exe is not in the process list, and if it is, try doing an end process and see if that clears the problem.  Also, make sure that you have the latest java (1.5.0_09) on any machines that you test this with..
Comment 62 Bob Hanson 2006-10-31 11:11:57 PST
I cannot believe that after so many months (years?) this bug and its many forms has not be satisfactorily addressed. What does it take to convince these developers that this should be a priority -- all applet polling in Firefox is impossible. Whether it is focus or what, someone surely can track this down. It is completely reproducilble by any number of methods. Sorry to vent. 
Comment 63 Majken Connor [:Kensie] 2006-10-31 11:22:33 PST
it wasn't cpu.  In the case of gmail's gtalk I image the characters need to be sent to google so they can be displayed.  Also the gtalk window is the only one it was happening on.

bob - from what I have seen this happens on slow machines and/or slow connections.  The devs tend to have fast machines and fast connections by nature of their job.  It's annoying as hell though, and if we can establish that this isn't a java problem, then the firefox devs might actually look at this and try to fix it.  Otherwise, if it IS a problem with java's mozilla plugin, then we can't do anything but wait for sun to fix it.
Comment 64 Thomas Spear 2006-10-31 11:50:48 PST
Bob, its ok, but it isn't in the hands of the mozilla devs anymore, it has been passed on to the sun devs, as it has been identified as a java issue.

As far as it only happening on slow machines, that isn't completely true.  For the most part, yes it happens MORE on slow machines, however I have repoduced it once on this machine (and not since), which is a 2.6 GHz Sempron with 1GB RAM, and others have produced it on 3+GHz machines, it's not totally the slower machines that do it.

Also, it's not necessarily related to the java plugin, all the plugin does is render what java processes, and pass user interaction from firefox to java, and vice versa, so it may be a problem in the JRE itself, which would explain why it is taking so long for sun to get a fix out.
Comment 65 Ria Klaassen (not reading all bugmail) 2007-01-03 14:04:27 PST
*** Bug 365836 has been marked as a duplicate of this bug. ***
Comment 66 Woody 2007-01-25 10:06:53 PST
Looks like it´s fixed in: Java Runtime Environment (JRE) 6 

Download:
http://java.sun.com/javase/downloads/index.jsp
Comment 67 :Gijs Kruitbosch 2007-03-30 05:23:54 PDT
*** Bug 375944 has been marked as a duplicate of this bug. ***
Comment 68 Bernd Eckenfels 2007-06-08 12:42:54 PDT
*** Bug 377310 has been marked as a duplicate of this bug. ***
Comment 69 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-09-04 08:14:56 PDT
I just attached a testcase in bug 275783, that also makes this bug 100% reproducible:
https://bugzilla.mozilla.org/attachment.cgi?id=279607
For the record, I'm using Java1.6.0_02-b06.
Comment 70 Eddward DeVilla 2007-11-05 11:36:36 PST
I don't know if I should add to this problem or a new one.  I am having this problem with FF 2.0.0.9 on XP and java is not running under processes in the task manger.

Specifically, the above was originally:

I don't know if I should add to this poblem or a nw ne.  Iam having this problem with FF2.0.0.9 on XP and java is not runningunder processes in the task manger.    oer

I'm on 2Ghz system with 2GB ram.  The system is not heavily loaded.
Comment 71 Adam Guthrie 2007-12-21 09:01:31 PST
*** Bug 350983 has been marked as a duplicate of this bug. ***
Comment 72 Alis 2008-07-14 16:12:12 PDT
ignn aent tt  Iau .syekwrorra ylno ,revo aera txen eht ot og ot euom ruoyes tonnc uoy ,noitidda n.sdleif hcraes la dna rab sserdda eht ni srrucco osla rorreh  .rorre eh evahon did dna rerolpxe tenreti dkcehc i s,cp ym o gineppah ton si ti taht demrifnocof evah I  .eesylraelc nacuoy sa ,nirrucco llts si rorre sihT
p...tra gnikatsniap eht won

What i justsaid was that ican confirm that this is still occurring and thatit is apecific to firefox, i tried in i.e. and it wrote in the correct direction. i cannot use the mouse to move the cursor, just the arrow keys. the error occursin the address bar as well. i just downloaded the latest release this morning and did not have problems like this prior.

3.0
vista
3gb ram 
Comment 73 Hixie (not reading bugmail) 2008-08-23 03:45:22 PDT
Jonathan Page contacted me and asked me to add the following comment on his behalf (he didn't want his e-mail address made public):

I have just encountered this issue in a brand new installation of
Firefox 3.0.1 running on Windows XP Professional. Everything I type in
Firefox's textboxes -- whether in the URL bar, the Google search box, or
the text field on google.co.uk's home page -- has just starting
appearing backwards. It is as though I have selected a right-to-left
input method. The I-cursor stays at the left-hand side of the input
field as I type. I only have English-UK selected as my Windows input
methods and have never selected any other language or keyboard.

Since installation Java has been disabled in Firefox, and there is no
Java process running in Task Manager. So at least this manifestation of
the backwards typing issue has nothing to do with Java. In fact, Firefox
is the ONLY application I have installed on the computer so far. It is
an extremely clean installation and so I am confident that Firefox is
unfortunately to blame.

Closing all windows and restarting Firefox seems to have fixed the
issue, at least for now.
Comment 74 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-08-23 03:58:53 PDT
That seems like a different bug to me, he should probably file a new bug for that.
Comment 75 Marco Zehe (:MarcoZ) 2008-12-22 23:54:54 PST
I see that Sun had to close their bug because they can't resolve this on their end. See the bug link in comment #53, and specifically this part:

>Searching around mozilla.org, I found the following comment from Rick Potts >suggesting that Java Plugin must push a new EventQueue whenever a sub message
>pump is entered:
>https://bugzilla.mozilla.org/show_bug.cgi?id=54725#c69
>
>Unfortunately, both nsIEventQueue and nsIEventQueueService had been obsolete >in Mozilla. I had contacted Mozilla to ask for help on implementing the >equivalence
>to nsIEventQueue when we need to run sub-message pump. This loop pump in >Plugin main thread is currently happened during applet's resource loading. We
>are blocking JS->Java calls during that time to prevent deadlocks caused by >round-trip J->JS->J or JS->J->JS when the applet is not yet ready.
>
>Still waiting for response from Mozilla.org.

Did anyone ever get back to Sun about this issue? My wife who is playing java-based online games regularly runs into this issue frequently even with Firefox 3.0.5.
Comment 76 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-12-23 03:24:06 PST
I think this should now work just fine with the latest Java release.
Comment 77 Marco Zehe (:MarcoZ) 2008-12-23 03:26:42 PST
Martijn, do you mean Java6 Update11 as the latest release? This was what my wife was offered this morning. She installed it, but so far has not had the chance to see if the problem was solved.
Comment 78 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-12-23 04:01:10 PST
Marco, sorry, I'm not completely sure in which release this was fixed. Sun has a rather confusing version numbering.
I'm now using Java build 1.6.0_05-b13 and I don't see the bug in there.
I used to have this problem, see comment 69, I attached a testcase in bug 275783 that also reproduced this bug.
According to bug 275783 comment 137, it should work fine in  Java(TM) Platform SE 6 U10
Comment 79 Mats Palmgren (:mats) 2009-01-03 15:15:29 PST
*** Bug 405304 has been marked as a duplicate of this bug. ***
Comment 80 chas_g_ 2009-06-04 14:16:54 PDT
I have just experienced this issue today, and can confirm that it is exclusive to Firefox at this moment on my PC. FF ver 3.0.10. Java ver SE 6 U3. Problem is initiated follwing load of Java used in facebook.com picture uploader applet. This is 100% repeatable and exclusive to Firefox.
Comment 81 Henrik Skupin (:whimboo) 2009-06-04 17:02:17 PDT
JRE6 update 3 is really old. Please install the latest JRE6 update 13 to check it again. On which website you have seen this problem?
Comment 82 Thomas Spear 2010-09-03 19:59:24 PDT
Voting for closure. Have not seen this problem in ages, no reports of it in over a year.
Comment 83 Wayne Mery (:wsmwk, NI for questions) 2010-10-14 17:22:26 PDT
WFM per comment 82

Note You need to log in before you can comment on or make changes to this bug.