Last Comment Bug 546131 - (eubrowserchoice-l10n) [tracking] Localize browserchoice.mozilla.com
(eubrowserchoice-l10n)
: [tracking] Localize browserchoice.mozilla.com
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Tracking (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: chris hofmann
Mentors:
Depends on: 546135 546136 546137 546138 546139 546140 546141 546142 546143 546144 546145 546146 546147 546148 546149 546150 546151 546152 546153 546154 546156 546157 546158 547830 548278 548280 548281 548282 548283 548284 548285 548286 548287
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-14 12:48 PST by Staś Małolepszy :stas
Modified: 2011-07-04 04:47 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Staś Małolepszy :stas 2010-02-14 12:48:07 PST
This is a tracking bug for the localization of the browserchoice.mozilla.com website, a.k.a. the 'Learn More' page of the European Browser Ballot campaign.

The website uses gettext. Localization files are located in http://svn.mozilla.org/projects/browserchoice/trunk/locale/ under ${locale_code}/LC_MESSAGES/ directories. You should already have RW access to this directory.

You can use SVN to check out and commit your translations, or translate on-line using Verbatim: http://localize.mozilla.org/verbatim/projects/browserchoice/

We'd love to get the translations from you by Wednesday, February 24th. The whole page has only around 520 words to translate--we really tried to keep it short :)

(For French and Dutch locales: Microsoft will be running a pilot next week in French and Dutch, please see your bugs for more information about this.)

The staging server is located at http://browserchoice.stage.mozilla.com. 

You can find more details at https://wiki.mozilla.org/L10n:Browserchoice

Please don't hesitate to ask questions. Ideally, please post general questions in this bug, and locale-specific questions in your locale's bug. 

Thanks in advance!
Comment 1 George Fiotakis 2010-02-14 15:52:07 PST
I've noticed in the wiki that there's going be a change for the personas link to the personas section on amo, will that affect all locales? i mean, could we just keep it for locales that have already completed the personas website localization?
And another thing, aren't those localised images XP style? shouldn't we have vista/windows 7 style images?
Comment 2 Pascal Chevrel:pascalc 2010-02-14 16:08:03 PST
For locales that have done gerpersonas localization (3 locales, among which yours), we will use getpersonas link, for locales that haven't done it we will point to AMO-personas section (since we have AMO localized for many European locales).
Comment 3 George Fiotakis 2010-02-14 16:38:56 PST
Thanks Pascal,
What about the images? should we stick to XP or replace them?
Comment 4 Pascal Chevrel:pascalc 2010-02-14 16:40:56 PST
we stick to XP because the majority of users that will be seeing this page in the months to come will be XP users, we may later on replace that by Vista/7 screenshots depending on the evolution of Windows market share.
Comment 5 Francesco Lodolo [:flod] 2010-02-14 23:02:47 PST
Do we need to upload a compiled messages.mo or is it created server side?
Comment 6 Pascal Chevrel:pascalc 2010-02-14 23:13:45 PST
@francesco 
The .mo file is created server-side, no need to upload it.
Comment 7 Francesco Lodolo [:flod] 2010-02-15 00:31:29 PST
Here I am (again) ;-)

* can we have two (or more) English quotes, just in case we're unable to find interesting/suitable local quotes for the two bubbles?
* is the language detection already working on stage?
* how long is the cache and how often is the .mo file generated?
Comment 8 Pascal Chevrel:pascalc 2010-02-15 00:35:02 PST
@francesco

* I think Barbara has asked our local press agency in Italy for good quotes
* locale detection is not working yet on stage
* I couldn't tell for the last one, stas will probably know since he filed the IT bugs to have the cron jobs set up
Comment 9 Rubén Martín [:Nukeador] 2010-02-15 00:44:02 PST
Pascal, keep in mind that there are some locales that have already translated getpersonas and are pending for localization to go live [1], for example Spanish ;)

[1] http://groups.google.com/group/mozilla.dev.l10n.web/browse_thread/thread/67c2625620cb5c5c#
Comment 10 Staś Małolepszy :stas 2010-02-15 04:30:16 PST
@flod: I would expect there is no cache since this is a staging server. But I'll ask Alex today to confirm this. The stage svns up every 10 minutes or so, and then compiles the .mo files every 15 minutes. You should be able to see your work at http://browserchoice.stage.mozilla.com/?locale=it_IT.utf8.

@Nukeador: We'll remember that :) I think we'll use the getpersonas.com link for Polish, Czech, Greek and Spanish.
Comment 11 Staś Małolepszy :stas 2010-02-15 04:43:35 PST
@flod: re quotes. Our PR agency has suggested some quotes at https://wiki.mozilla.org/3.6_Local_Reviews#Italian________it

I'll post an update about the quotes tomorrow. Patrick will have the English ones tomorrow morning and we'll figure out what to do with the locale ones.
Comment 12 Leszek Zyczkowski 2010-02-16 13:37:54 PST
For quotation should be use national quote characters e.g. for Polish „ and ”.
Comment 13 Leszek Zyczkowski 2010-02-16 13:45:36 PST
In the 2 sections text is not properly justify. See:
http://browserchoice.stage.mozilla.com/?locale=pl_PL.utf8#reason-security
http://browserchoice.stage.mozilla.com/?locale=pl_PL.utf8#reason-privacy
Text is justify only in the 6 lines, 7-th line isn't justify.
Comment 14 Seth Bindernagel 2010-02-16 15:21:18 PST
(In reply to comment #13)
> In the 2 sections text is not properly justify. See:
> http://browserchoice.stage.mozilla.com/?locale=pl_PL.utf8#reason-security
> http://browserchoice.stage.mozilla.com/?locale=pl_PL.utf8#reason-privacy
> Text is justify only in the 6 lines, 7-th line isn't justify.

Alex Buchanan is the webdev lead on this project.  If there is an issue, I am thinking we might need to email Alex or file a bug to properly call out the error because he might not see this note here.  

Perhaps the latter option is best.  Leszek, do you want to file that bug? 

https://bugzilla.mozilla.org/enter_bug.cgi?product=Websites

Component is browserchoice.mozilla.com

Be sure to indicate in the summary section that you see it as a problem on the *Polish* page.
Comment 15 Alex Buchanan [:abuchanan] 2010-02-16 15:24:43 PST
(In reply to comment #14)

I'm here :)  just hadn't made it to this TODO item yet.

Filed bug 546534
Comment 16 Patrick Finch 2010-02-17 02:19:59 PST
(In reply to comment #8)
> @francesco
> 
> * I think Barbara has asked our local press agency in Italy for good quotes
> * locale detection is not working yet on stage
> * I couldn't tell for the last one, stas will probably know since he filed the
> IT bugs to have the cron jobs set up

Local quotations that PR agencies and others found are here:
https://wiki.mozilla.org/3.6_Local_Reviews
Comment 17 Staś Małolepszy :stas 2010-02-17 06:08:47 PST
Hey all,

With the recent changes to the code, the new URLs that allow to preview the translation are of the form:

http://browserchoice.stage.mozilla.com/?locale=es-ES (for Spanish)

where "es-ES" is the Mozilla-style locale code. So you don't need to specify a gettext-style code anymore (es_ES.utf8).
Comment 18 Staś Małolepszy :stas 2010-02-17 10:02:29 PST
Hey all, me again.

I've updated the English (reference) file and merged all locales. Please svn up or "update from VCS" in Verbatim (although I did that for all locales in Verbatim already, so you should be good).

Some strings were marked as fuzzy, please review them. In majority of cases, they should be good as they are. 

More importantly, I replaced the bubble_one, bubble_two placeholders with the English quotes from the press. You can translate them if you wish, but if you can find local quotes from local media, please do use them instead. This is in fact a preferred solution.

You can find some good quotes identified by our PR agencies at https://wiki.mozilla.org/3.6_Local_Reviews.
Comment 19 George Fiotakis 2010-02-18 18:39:51 PST
1) Looking at the stage server page, i think that the "security","Customisation" (btw, shouldn't that be "Customization"?),"Global Acclaim" and "Privacy" columns on the top section look a little bit ugly for most locales.  There's more text in the last two columns and that makes the distribution not even in the page.
2) The mozilla europe awards page which is linked from the page looks outdated with 4 and 5 years old awards.
Comment 20 Francesco Lodolo [:flod] 2010-02-19 00:13:27 PST
Am I the only one who finds not a great idea using the same string for button labels ("Learn More") and the page title ("Learn More : Mozilla Firefox")?
Comment 21 Patrick Finch 2010-02-19 00:51:23 PST
(In reply to comment #19)
> 1) Looking at the stage server page, i think that the
> "security","Customisation" (btw, shouldn't that be "Customization"?),"Global
> Acclaim" and "Privacy" columns on the top section look a little bit ugly for
> most locales.  There's more text in the last two columns and that makes the
> distribution not even in the page.
> 2) The mozilla europe awards page which is linked from the page looks outdated
> with 4 and 5 years old awards.

"Customisation" is British English.

If the Mozilla Europe page is not updated, I would suggest to replace with the non-localised Mozilla.com page
http://www.mozilla.com/en-US/press/awards.html
Comment 22 Staś Małolepszy :stas 2010-02-19 04:31:16 PST
(In reply to comment #20)
> Am I the only one who finds not a great idea using the same string for button
> labels ("Learn More") and the page title ("Learn More : Mozilla Firefox")?

Ah, good catch flod. Would be good to change this. We're going live tonight, so I'll work on updating this on trunk but not production.
Comment 23 Rimas Kudelis 2010-02-19 04:54:20 PST
I think alt text is not needed for purely presentational images (those that convey no meaning) such as icons, and probably even screenshots. Having alt text like "Security icon" doesn't add much accessibility, just makes the translation harder. Ideally, those icons should be added by CSS as backgrounds.

Similarly, alt text like "Security screenshot" doesn't make much sense either. I think it would be better to tell in more detail what the screenshot holds. E.g. "Instant Web Site ID Screenshot" in Mozilla Europe's website is a better alt text IMO.
Comment 24 Rimas Kudelis 2010-02-19 04:58:14 PST
Also, it's of course the designer's call, but I don't quite get why we have such poorly looking images compared to those on Mozilla Europe's website. Why is this website so grey as if it was all dusty and muddy?..
Comment 25 Patrick Finch 2010-02-19 06:03:12 PST
(In reply to comment #24)
> Also, it's of course the designer's call, but I don't quite get why we have
> such poorly looking images compared to those on Mozilla Europe's website. Why
> is this website so grey as if it was all dusty and muddy?..

I am not a designer either, but I do have some of the background.  This page will not necessarily be rendered as a full web page, but rather as something that is supposed to resemble a Windows update screen.  We didn't want it to be *that* bland, but that is part of the reason for offering this plainer, more focused version of the Firefox product page.

HTH
Comment 26 Rimas Kudelis 2010-02-19 06:11:55 PST
Oh, I see. That still doesn't explain greyness though.

Another note: what's the point of current http://browserchoice.stage.mozilla.com/css/screen.css ? IE/Mac is long since dead, and it's not the target audience anyway, so why work around its bugs?
Comment 27 Staś Małolepszy :stas 2010-02-19 11:57:57 PST
Hey all,

As flod noticed in comment 20, the <title/> element uses the same string as the "Learn more" button below the four blurbs. This can be a bit limiting in some languages, so we will change this in the PHP code: we will do _('Learn more') for the button and sprintf(_("Learn More : %s"), 'Mozilla Firefox') for the <title/>.

For now, I've only updated the English (reference) file with this one new string and merged all locales. Please svn up or "update from VCS" in Verbatim.

I have not yet made the actual change in the PHP code, as we're going live tonight and I don't want to break the translations 5 minutes before the launch. The PHP code still uses the old string:

<title><?= _("Learn More") ?> : Mozilla Firefox</title>

Please update your localizations by adding the translation of the new "Learn More : %s" string. We will make the switch (first on stage, then on production) when the majority of localization have been updated. We're targeting next week for the switch.

Again, please svn up or "update from VCS" in Verbatim.

Thanks.
Comment 28 Staś Małolepszy :stas 2010-02-19 13:14:33 PST
Dear all,

Just a note to let you know that both http://www.browserchoice.eu/ (Microsoft's site) and http://browserchoice.mozilla.com/ are now live :) 

This is a 'silent' launch for testing purposes, so we still have time to take new locales and fix bugs. Please, feel free to test as much as you can! Land your fixes in Verbatim and SVN and let me know about them (preferably in your locale's 'browserchoice' bug) so that we can publish them on the production server.

We're currently 3-4 days ahead of the schedule, as the pilot ballot update will go live on Tuesday, Feb 23rd (in the UK, France and Belgium). For other countries/locales, our target date is Wednesday, February 24th, and MS is planning to publish the ballot update around March 1st.

Today, we already have an amazing number of 14 locales ready and counting! Thanks so much for being so responsive and quick and congrats on the work done so far.

-stas
Comment 29 Alex Buchanan [:abuchanan] 2010-02-19 17:07:47 PST
Hello all,

We've made a change, to fix the locale name printed on the download button, e.g. "English (British) 9.4MB"

A reference for the code change:
http://viewvc.svn.mozilla.org/vc/projects/browserchoice/trunk/locale/templates/LC_MESSAGES/messages.pot?r1=62780&r2=62779&pathrev=62780#h27

Please svn up and un-fuzz the string by removing the language name (instead, it will be printed using our localeDetails library)
Comment 30 Rimas Kudelis 2010-02-20 00:51:14 PST
Staś, do your have any thoughts regarding comment #23 ?
Comment 31 George Fiotakis 2010-02-20 01:26:56 PST
(In reply to comment #28)

> 
> Just a note to let you know that both http://www.browserchoice.eu/ (Microsoft's
> site) and http://browserchoice.mozilla.com/ are now live :) 
> 
Hmmm.. I thought el (Greek) was marked for production last night, apparently it doesn't seem to be available yet.
Comment 32 Staś Małolepszy :stas 2010-02-20 05:35:25 PST
The site is very aggressively cached, as we're preparing to get a lot of
traffic in a short period of time. That's why you'll be still seeing the old revision for some time, even after the push of a newer one.

To bypass the cache, specify any query parameter in the URL, for
example: http://browserchoice.mozilla.com/el/?no_cache.
Comment 33 Rimas Kudelis 2010-02-20 07:50:49 PST
Won't this website have a language chooser?
Comment 34 Patrick Finch 2010-02-20 08:27:34 PST
(In reply to comment #33)
> Won't this website have a language chooser?

The site is not a fully featured website as it's downstream from what will effectively appear to be a Windows update.  The language is coded by the URL presented to the user which is defined by their preference in IE.  We will add redirects for languages which are used in the region but not catered for by MSFT (e.g. Catalan, Russian, Turkish etc.) next week.  But the user will be directed to the language of their existing preferences in IE.
Comment 35 Pascal Chevrel:pascalc 2011-07-04 04:47:43 PDT
all dependencies fixed, this site is currently only in maintenance mode, marking fixed.

Note You need to log in before you can comment on or make changes to this bug.