Closed Bug 637542 Opened 9 years ago Closed 9 years ago

Please block McAfee SiteAdvisor for Firefox4.0

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: Matti, Assigned: fligtar)

References

Details

(Keywords: relnote, Whiteboard: [noncode][hardblocker])

We had many reports during for the FF4 beta builds (b7+) ,that the McAfee SiteAdvisor breaks Firefox4.
The worst problem is a not working UI after startup.

The problem is that I don't have any version information for this broken addon that claims to be compatible with Firefox4 but i requested that information in some bug reports. 

example bugs are : bug 633844, bug 634214, bug 627479, bug 626868, bug 625998, bug 626314
I had reached out to the Site Advisor team asking them to ensure compatibility a couple months ago and have yet to receive a reply. I'll ping them again and see if they're planning any additional updates, or if they can get their team looking at the bugs.
Summary: Please block McAfee SiteAdvisor for Firefox2.0 → Please block McAfee SiteAdvisor for Firefox4.0
Without a version range, what are we intending to blocklist? All McAffee Site Advisor? Seems ... harsh.
Kev: please renominate once you have a blocklist range!
blocking2.0: ? → ---
Adding relnote to add it to the list of known issues, in case this hasn't been already noted.
Keywords: relnote
From the reporter in bug 626868:
McAfee SiteAdvisor 3.3 false {B7082FAA-CB62-4872-9106-E42DD88EDE45}
Spoke with McAfee today, and they have a new release they've started to push out. 3.3.1 should be compatible, but I will wait until I have confirmation via email. They hope to have the majority of their userbase updated within 3-4 weeks. Once I have that, I'll specify version range for Fx4 for the BL.
Assignee: nobody → kev
3-4 weeks is too slow.
The browser is just unuseable if I read the reports in bugzilla. I'm not sure if this happens to all McAfee SiteAdvisor Users but it breaks many Firefox 4 installations. The Sumo people also got a number of reports about this issue (bug 626868).
This extension should be blocked before the release of the final version IMHO.
Blocks: 626868
Found quite a few more bugs caused by Site Advisor, adding for visibility/to help you work out version ranges.
Blocks: 638657
Blocks: 503947
Blocks: 521745
Blocks: 621071
Blocks: 621820
Blocks: 562016
Blocks: 636962
There seems to be quite an increase in issues in the last 5 days:
http://input.mozilla.com/en-US/beta/search?q=McAfee+&product=firefox&version=--&date_start=&date_end=&sentiment=sad

(Only searched for "mcafee", there are approx 50-100 more comments if you look for variations on the spelling in input)
Blocks: 626013
Blocks: 639297
This very frequently locks up the browser completely with the first RC1 candidate, requiring Firefox to be nuked with the task manager. IMO, this should absolutely block the final release.
To confirm, it was "mcAfee siteadvisor 3.3" that locked up the browser.
Blocks: 639247
There are 22 bugs caused by this addon marked as dependants of this one; with more being filed daily (plus those cases being dealt with directly by SUMO). 

I've requested version info where missing, results as follows:

- In all 12 recent bugs where the reporter has responded with version info; all of them are for McAfee Site Advisor version 3.3
- The GUID  has been confirmed as {B7082FAA-CB62-4872-9106-E42DD88EDE45} (in 5 separate bugs)
- In addition, the following older versions experience crashes (bug 521745), so should probably be included in the block range too:
3.0.0.479
3.0.1.109
3.0.1.111

Re-nominating for visibility, per comment 3, now that versions/GUID are known.

Along the lines of comment 7, it is my opinion that the problem is too widespread (22+ bugs filed, more daily) and also too severe (crashes, hangs, unable to even use basic sites like google/yahoo) to wait 3-4 weeks for McAfee to roll out the update to all users.
blocking2.0: --- → ?
Blocks: 639402
Fliggy, can we work up a block based on the above? Looks like we want to block 3.3 and lower, but not 3.3.1 as per previous comments.
Adding to blocker list to make sure we add the block before shipping final if they haven't updated.
blocking2.0: ? → final+
Whiteboard: [noncode][hardblocker]
Kev, can you get more info on how many users will be inconvenienced if we blocklist today vs a week from now? I'm trying to understand when we should pull the lever on this. (I'm of the opinion we block everything pre 3.3.1 that we've got a crashing stack or a bug report on ASAP.)
Kev's out this week. This add-on is the 48th most used add-on in Firefox 4 with over 50,000 beta users. We don't have per-version information.
Is this blocking final release of FireFox 4? and IF Site Advisor Team doesnt care, why should we? Lets block this ineffably maladjusted slattern and a dastardly, stench-emitting spawn of a mad scientist and a disastrous test tube experiment and an irredeemably decadent narcissist and a perverted, coma-inducing mental midget with the natural grace of a swamp rat.
Block This Hard Ass Blocker
They need to **** their way out of it, are they freakish specimen of botched genetics?
Siteadvisor is completely inferior to Firefox/Google's own StopBadware attack site/forgery blocker and WebofTrust so I wouldn't have many qualms in blocking it. Aside from being ineffective, sites are also encouraged to 'pay for certification' which is most certainly not the case with Web of Trust or Stopbadware. A good opportunity to promote this FF feature I think.

http://www.mywot.com/en/scorecard/siteadvisor.com
http://siteadvisorclassaction.com/
Hah, backtracking a bit on WOT
http://www.mywot.com/en/trustseal/payment?target=siteadvisor.com&package=1

Firefox/Google's Stopbadware seems pretty transparent in comparison
http://stopbadware.org/home/webmasters
In bug 621833; the reporter was having consistent hangs with v3.3; that were fixed by updating to 3.3.1.125_p1 ; in case that helps with the upper bound of the block range...
Duplicate of this bug: 640066
Assignee: kev → clegnitto
> Keywords: relnote

nothing about this issue. why ?
http://www.mozilla.com/en-US/firefox/4.0rc1/releasenotes/
Your relnote won't appear until RC2 if they have another releasenotes page, pal-moz. They don't re-update release notes like that.
Blocks: 640511
Block info for McAfee Site Advisor:

GUID: {B7082FAA-CB62-4872-9106-E42DD88EDE45}
Type: Hard

Min Firefox version: 3.7a1
Max Firefox version: <<none>>

Min Extension version: <<none>>
Max Extension version: 3.3.0.* (I'm going to be safe and assume all 3.3.1's are fixed even though comment 22 has a specific version known to be good)

Note I am not going to block it on 3.5 and 3.6 (as bug 521745 would suggest) due to not having any modern reports and this bug focusing on FF4 specifically
Assignee: clegnitto → fligtar
Status: NEW → ASSIGNED
On staging:
    <emItem id="{B7082FAA-CB62-4872-9106-E42DD88EDE45}">
      <versionRange minVersion="0.1" maxVersion="3.3.0.*">
        <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
           <versionRange minVersion="3.7a1" maxVersion="*"/>
        </targetApplication>
      </versionRange>
    </emItem>
Whiteboard: [noncode][hardblocker] → [noncode][hardblocker][needs testing][needs website update]
Has anyone tested this block? https://wiki.mozilla.org/Blocklisting/Testing
Depends on: 641603
I just tested it using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0 and I did get the block dialog, so it looks good.
Great, thanks Marcia. As soon as the website update is live we'll block.
Whiteboard: [noncode][hardblocker][needs testing][needs website update] → [noncode][hardblocker][needs website update]
Blocked in production.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [noncode][hardblocker][needs website update] → [noncode][hardblocker]
In the blocklist it says versions below 3.3.1 however I have the latest version installed i.e. 3.3.1 and Firefox 4 is blocking it with no way to enable it again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
They didn't say they would only block that one version.
I don't think you are understanding... the blocklist says versions BELOW 3.3.1 are the ones that are supposed to be blocked.
I think the problem is that whilst the app/the uninstall entry in control panel reports the version as 3.3.1.129, the version reported to Firefox via the addons manager is only 3.3.

ie even for the latest version (3.3.1.129) from http://www.siteadvisor.com/ , about support shows:
McAfee SiteAdvisor 3.3 true {B7082FAA-CB62-4872-9106-E42DD88EDE45}

The block was for * < 3.3.1 ; but since the version reported to Fx is 3.3; this is included in the range.
zeonis@yahoo.com: Please enter about:support and copy the whole line from the Siteadvisor (comment #5 contains an example)
Blocks: 641766
FWIW, in my Windows 7 Control Panel, it reports the Site Advisor version as 3.3.176 - I downloaded it directly from the site today.
Should I try installing the newest version which was apparently released today?

Here is from about:support
McAfee SiteAdvisor 3.3 false {B7082FAA-CB62-4872-9106-E42DD88EDE45}
In that case marking fixed, the block is working as expected.
Someone should contact McAfee that they use an incorrect version number in the install.rdf.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
I'd suggest making the status uneditable by no one except admins from here on. A lot of people 'depend' on commercial anti-malware to help them.
I am not sure if you are trying to say that I changed the status cause I didn't.
I had reopened this for investigation. zeonis, did you install the latest version and was it blocked? If they downgraded their version number that would not be good at all and we may need to alter the block.
Yes I installed the latest version today and it is still blocked.
(In reply to comment #42)
> I had reopened this for investigation. zeonis, did you install the latest
> version and was it blocked? If they downgraded their version number that would
> not be good at all and we may need to alter the block.

I have installed the latest version also. Am just wondering why this was totally blocked and not allow users to make the choice to enable/disable the Site Advisor Add-on. It just seems so unfair to those users such as my self who have never had an issue and works well for me and especially for my kids by blocking them from bad sites.
Thanks.
I sent an e-mail to Site Advisor support around midnight last night explaining the problem and now today they released a new version that correctly displays as 3.3.1 in Firefox so it is no longer blocked.
Thanks zeonis!
(In reply to comment #0)
> We had many reports during for the FF4 beta builds (b7+) ,that the McAfee
> SiteAdvisor breaks Firefox4.
> The worst problem is a not working UI after startup.
> 
> The problem is that I don't have any version information for this broken addon
> that claims to be compatible with Firefox4 but i requested that information in
> some bug reports. 
> 
> example bugs are : bug 633844, bug 634214, bug 627479, bug 626868, bug 625998,
> bug 626314


There are two different SiteAdvisor product families - consumer and enterprise.  You're referencing version numbers for the CONSUMER product, and as a result you're also blocking SiteAdvisor Enterprise product used by corporations, latest version of which is 3.0.0.633.
That snould not be a problem if they are 2 different product famalies because they should have different UUIDs.
(In reply to comment #48)
> That snould not be a problem if they are 2 different product famalies because
> they should have different UUIDs.

But it IS a problem - FF4 RC2 is blocking currently ALL versions of SAE below 3.3.1 - and there IS no v3.3x for SAE Enterprise Plus, so it's an erroneous block that needs to be adjusted.  Unless corrected, we'll have to block FF4 from being deployed.
only the extension with the extension ID "{B7082FAA-CB62-4872-9106-E42DD88EDE45}" is blocked. McAfee doesn't use a different UUID for the different Enterprise product ?

Justin Scott: Could we change the minVersion="0.1" to something like minVersion="3.2" ?
But that would allow the consumer 3.0.x versions which are also known to cause problems, see comment 12.

Surely the onus is on McAfee to actually use UUIDs correctly, ie: if it's a different product, then use a different UUID. 

Also, is it even confirmed that the enterprise version 3.0.x isn't causing the same problems as the consumer one was with Fx4?
There have been reports of McAfee SiteAdvisor 3.3.1 still causing problems:
eg Bug 645317 and bug 645362

:-(
Blocks: 645317, 645362
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: 645361
Blocks: 644868
Two more for 3.3.1: Bug 645361 and bug 641766.
Blocks: 641262
I'm not sure if it would be better to create a new bug.
The really huge problem with a not working browser after startup is fixed after this block
This bug needs to be re-triaged. FF4 has been shipped.
blocking2.0: final+ → Macaw+
Actually, I think this should be closed as we did blocklist the affected versions, and it seems like what we still have around is related to malware that stops the McAffee software from working properly if I understood it correctly, see discussions in bug 641766.

And, gal, did you mean to set this directly to Macaw+? And why does a blocklist update block release? We can ship updates to it any time and things won't get worse for people if we don't, will they?

I'm with Matti here and think this one should be closed and potentially another one created for the "new" problems with 3.3.1 to figure out what's going on there.

Another reason for ongoing could be that McAfee actually didn't fix their problems with the update to 3.3.1, do we have a contact with them that can dive into that?
Please re-file the left-overs. I will clear the blocking flag and close the bug.
Status: REOPENED → RESOLVED
blocking2.0: Macaw+ → ---
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
I had to have McAfee turned off and blocked by my computer installer as it would not let me on the internet.
McAfee has different versioning for the Enterprise version of their SiteAdvisor product.  The latest version of SiteAdvisor Enterprise Plus v3.0 is SAE Plus 3.0.0.638.4.  Has anyone tested with this package?  I'm wondering since Firefox only looks at the version mumber, it is probably thinking that this is a really old version of the free offering.
We have installed McAfee SiteAdvisor Enterprise Plus 3.0.0.638 (Patch3).
But the Plugin is disabled in Firefox 4.0.
According McAfee KB71532 this issue will be resolved in SiteAdvisor Enterprise Plus 3.0 Patch 4, which is expected to be released at the end of July, 2011
I have not been noticing any problems with this addon when I was using FF 4.0 or FF 5.0
i have not have any problems with with the McAfee add on im upset that i cant use it honestly i wish it would be unblocked!!!
I'm on Windows XP Pro SP3, not Windows 7.  I didn't have issues with it.  Is there a work around for me?  My company requires this add in
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.