Last Comment Bug 67574 - Can't open (some) menus after switching themes
: Can't open (some) menus after switching themes
Status: VERIFIED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
: -- major with 3 votes (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: sairuh (rarely reading bugmail)
:
Mentors:
: 67660 68077 68363 68492 68610 68669 68746 68901 68906 68999 69026 69040 69050 69068 69090 69321 69535 69640 69777 69796 69958 70190 70479 70659 70726 71017 71265 71357 72909 (view as bug list)
Depends on:
Blocks: 68973
  Show dependency treegraph
 
Reported: 2001-02-03 14:30 PST by Mark Bialkowski
Modified: 2014-04-26 03:21 PDT (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix. (1.02 KB, patch)
2001-02-07 13:38 PST, David Hyatt
no flags Details | Diff | Splinter Review

Description Mark Bialkowski 2001-02-03 14:30:51 PST
Using 2001020309 build, switching to a new skin will prevent the View, Search,
and QA dropdown menus from actually dropping down until you restart Mozilla. 
You can click on them; the menu just won't appear.
Comment 1 Oliver Klee 2001-02-03 14:54:15 PST
Confirming for 2001/02/02/20 build on Win2k. Platform and OS should be ALL.
Comment 2 Blake Ross 2001-02-03 15:35:43 PST
-> hyatt
Comment 3 Anatoly Kochergin 2001-02-05 04:44:29 PST
*** Bug 67660 has been marked as a duplicate of this bug. ***
Comment 4 Anatoly Kochergin 2001-02-05 04:45:11 PST
*** Bug 67660 has been marked as a duplicate of this bug. ***
Comment 5 Richard Hurt 2001-02-06 04:53:45 PST
I can confirm this on WinNT 4.0 (sp5) running Build 2001020520.  One thing
though: it only seems to affect the first browser window opened.  If you open
another window all the menus drop down properly.

BTW: It affects these menus: View Search Go Bookmarks Tasks
Comment 6 Asa Dotzler [:asa] 2001-02-07 12:45:42 PST
this is ugly and highly visible.  would be great to see this fixed for 0.8
Comment 7 David Hyatt 2001-02-07 13:21:10 PST
I know how to fix this.
Comment 8 David Hyatt 2001-02-07 13:35:16 PST
sr=brendan@mozilla.org (brendan using hyatt's iMac).

/be
Comment 9 David Hyatt 2001-02-07 13:38:27 PST
Created attachment 24684 [details] [diff] [review]
Fix.
Comment 10 Asa Dotzler [:asa] 2001-02-07 18:01:06 PST
a=asa-driver  Does this still need review or is it ready to go?
Comment 11 Brendan Eich [:brendan] 2001-02-07 18:08:43 PST
hyatt, get ben to r= so he can buddy xbl better.

/be
Comment 12 Dean Tessman 2001-02-07 18:50:14 PST
Any chance this fixes bug 51996?
Comment 13 Asa Dotzler [:asa] 2001-02-07 19:24:53 PST
*** Bug 68077 has been marked as a duplicate of this bug. ***
Comment 14 David Hyatt 2001-02-08 15:25:26 PST
fixed.
Comment 15 David Hyatt 2001-02-08 15:26:53 PST
Fixed the XBL issues.  I notice that some menus in Navigator still don't open,
but it's unrelated to my checkins or to insertion points.
Comment 16 Blake Ross 2001-02-09 12:50:55 PST
Random menus still don't open after switching themes, just as they didn't 
before this fix.  I'm not convinced this is fixed, so reopening even if to 
reassign and handle the other problem hyatt referred to...
Comment 17 Blake Ross 2001-02-09 12:59:40 PST
And also, this isn't Navigator-only.  I'm assuming you used the View menu to 
switch, but if you switch from the theme pane in a prefs dialog launched from 
Mail or Composer, you'll see similar problems (although confined to the Edit 
menu, it seems).
Comment 18 Blake Ross 2001-02-09 13:03:33 PST
Sorry....

Nevermind about it being confined to Edit.  I just saw it for almost every menu 
in Editor.
Comment 19 Dean Tessman 2001-02-09 13:13:36 PST
I'm still seeing this, too.  I just opened Mozilla fresh, switched themes to
Blue in navigator, and then Edit and View menus didn't open.  I opened a new
navigator window and switched themes back to Modern and in that new window only
the Debug and QA menus open.  Back in the first navigator window, none of the
menus open anymore.

Build 2001020904
Comment 20 Stephen Walker 2001-02-09 16:44:48 PST
*** Bug 68363 has been marked as a duplicate of this bug. ***
Comment 21 Stephen Walker 2001-02-11 08:26:17 PST
*** Bug 68492 has been marked as a duplicate of this bug. ***
Comment 22 Brian Haskin (Janzert) 2001-02-11 19:01:21 PST
I'm seeing this also with build 2001021008. For me at least the menus that won't
open are any that had been opened before switching themes. Only the ones that
hadn't been opened yet still work.
Comment 23 Dean Tessman 2001-02-11 20:12:54 PST
I'm seeing it on more than just the menus that I use before switching themes.  
But I haven't found a pattern yet.
Comment 24 Alex Stewart 2001-02-11 21:58:47 PST
I agree with Dean.  After a View->Apply Theme command has been issued from the
window, the window components that deal with navigation (Back, Forward, Reload
and Stop), the throbber and the URLbar don't update when the current document is
changed.  But it's still possible to use them unless they were disabled before.
Comment 25 Stephen Walker 2001-02-12 13:57:46 PST
*** Bug 68610 has been marked as a duplicate of this bug. ***
Comment 26 R.K.Aa. 2001-02-13 08:05:09 PST
*** Bug 68669 has been marked as a duplicate of this bug. ***
Comment 27 Peter ``jag'' Annema 2001-02-13 13:12:53 PST
I believe what Dean and Alex are referring to is a different issue covered by
bug 68662. That issue is browser specific and I'm working on a fix.

That said, I have no idea what's causing this bug.
Comment 28 Stephen Walker 2001-02-13 17:29:55 PST
*** Bug 68746 has been marked as a duplicate of this bug. ***
Comment 29 ratman 2001-02-14 15:49:49 PST
another confirm using win32 installer build 2001021408 m0.8 <gasp!>

just adding my $0.02 by saying that opening a new browser window fixes the
relevant menu problems.
Comment 30 R.K.Aa. 2001-02-15 04:20:40 PST
*** Bug 68901 has been marked as a duplicate of this bug. ***
Comment 31 Oliver Klee 2001-02-15 06:00:09 PST
*** Bug 68906 has been marked as a duplicate of this bug. ***
Comment 32 Oliver Klee 2001-02-15 06:04:00 PST
Adding mostfreq keyword (9 dupes).
Comment 33 R.K.Aa. 2001-02-16 04:54:50 PST
*** Bug 69026 has been marked as a duplicate of this bug. ***
Comment 34 Oliver Klee 2001-02-16 06:07:11 PST
*** Bug 69040 has been marked as a duplicate of this bug. ***
Comment 35 Oliver Klee 2001-02-16 08:34:38 PST
*** Bug 69050 has been marked as a duplicate of this bug. ***
Comment 36 Oliver Klee 2001-02-16 10:10:10 PST
*** Bug 69068 has been marked as a duplicate of this bug. ***
Comment 37 Fabian Guisset 2001-02-16 12:12:19 PST
*** Bug 69090 has been marked as a duplicate of this bug. ***
Comment 38 Andreas M. "Clarence" Schneider 2001-02-16 13:52:00 PST
*** Bug 68999 has been marked as a duplicate of this bug. ***
Comment 39 Stephen Walker 2001-02-18 21:06:03 PST
*** Bug 69321 has been marked as a duplicate of this bug. ***
Comment 40 sairuh (rarely reading bugmail) 2001-02-19 16:04:42 PST
moz0.8 is out. nominating for 0.9.
Comment 41 Stephen Walker 2001-02-20 13:04:32 PST
*** Bug 69535 has been marked as a duplicate of this bug. ***
Comment 42 Fabian Guisset 2001-02-21 05:00:02 PST
*** Bug 69640 has been marked as a duplicate of this bug. ***
Comment 43 Fabian Guisset 2001-02-22 04:15:48 PST
*** Bug 69777 has been marked as a duplicate of this bug. ***
Comment 44 Fabian Guisset 2001-02-22 07:06:32 PST
I have messed a little bit with this, and here is the smallest testcase I could
find:
1) In navigator.xul, in the main toolbar, I added
 <button class="button-toolbar-1 top" id="stop-button" crop="right"
oncommand="hideMenubar();" value="Hide Menus"/>
2) In navigator.js, I added :
function hideMenubar()
{
  var menubar = document.getElementById('main-menubar');
  (menubar.getAttribute("hidden") == "true") ?
  menubar.removeAttribute("hidden") :
  menubar.setAttribute("hidden", "true");
}

This reproduces the bug everytime. I'm not sure however why, and also, why only
some menus are affected!
Comment 45 Fabian Guisset 2001-02-22 10:07:59 PST
*** Bug 69796 has been marked as a duplicate of this bug. ***
Comment 46 Joe Hewitt (gone) 2001-02-22 15:42:17 PST
Marking dogfood.  It's fun having to dup this bug 2x every day.
Comment 47 gary_Cope 2001-02-23 05:53:30 PST
*** Bug 69958 has been marked as a duplicate of this bug. ***
Comment 48 Oliver Klee 2001-02-26 07:02:30 PST
*** Bug 70190 has been marked as a duplicate of this bug. ***
Comment 49 Håkan Waara 2001-02-26 08:04:45 PST
Is anyone working on this!?  This is a big shame - someone with the knowledge
and braveness must fix this for mozilla 0.9!

I even think the Severity should be Critical.
Comment 50 Håkan Waara 2001-02-26 08:06:23 PST
Also, should this go to Skinability? I guess that's what's causing this bug. The
menus are the side-effect - they are not the problem.
Comment 51 Boris Zbarsky [:bz] (still a bit busy) 2001-02-28 11:15:19 PST
*** Bug 70479 has been marked as a duplicate of this bug. ***
Comment 52 Deven Corzine 2001-02-28 12:51:56 PST
As I mentioned in bug 70479, I was unable to reproduce this problem in either
mozilla-0.7 or the 2001012310 nightly build, but it happened (with variations)
in every build I tried from 2/8/01 onward.  This bug was originally opened on
the 2001020309 build; has anyone tested any builds between 1/23/01 and 2/3/01
for this bug to narrow down when it first appeared?

Has anyone audited the code changes in this timeframe to look for this bug?
Comment 53 Peter Trudelle 2001-03-01 15:47:35 PST
per hyatt, ->xpapps, please put try blocks around this, patch xul and js as needed.
Comment 54 Blake Ross 2001-03-01 16:59:02 PST
hyatt, put try blocks around what?  I'm not really convinced this is an xpapps 
problem yet.  Can you elaborate (with the knowledge that arbitrary menus are 
busted each time, null contentViewer or not)?
Comment 55 Louis 2001-03-01 18:28:32 PST
*** Bug 70659 has been marked as a duplicate of this bug. ***
Comment 56 Peter ``jag'' Annema 2001-03-01 18:41:31 PST
The odd thing is that it only affects (or only seems to affect) menus which were
opened before the switch, so I doubt it has anything to do with oncreate
handlers.

Also, Fabian's small testcase suggests you don't even need to skin switch.

So, I just tested his testcase, and this is what happened:

I opened a menu, closed it, and clicked the button (this hides the main
menubar).
I clicked the button to show the menubar again, tried to open the same menu, and
couldn't. I could open another menu, but after clicking the button twice again,
I also couldn't open that menu any longer.

I tried a few combinations to see if this was something specific to only some
menus, but it seems like the determining factor is whether the menu has been
opened already or not.
Comment 57 Peter ``jag'' Annema 2001-03-01 19:15:41 PST
Btw, I put this line in navigator.xul instead of Fabian's, right below the stop
button:

<button id="hide-button" crop="right" oncommand="hideMenubar();" value="Hide
Menus"/>
Comment 58 Stephen Walker 2001-03-02 15:10:53 PST
*** Bug 70726 has been marked as a duplicate of this bug. ***
Comment 59 Gilles Durys 2001-03-06 07:37:54 PST
*** Bug 71017 has been marked as a duplicate of this bug. ***
Comment 60 Deven Corzine 2001-03-06 07:43:57 PST
Peter, after some experimentation, I concur that opening a menu before a theme
switch will cause that menu to malfunction after the switch.  However, it's NOT
necessary to actually open the menu!  Even highlighting the menu title with a
simple mouseover is sufficient; you don't need to drop down the menu.

What happens the first time the mouse moves over a menu that makes a difference?
Comment 61 Deven Corzine 2001-03-06 07:47:37 PST
This probably shouldn't be a surprise at this point, but opening a menu with an
Alt-key shortcut is just as effective as a mouseover in causing that menu to
malfunction after a theme switch.
Comment 62 Deven Corzine 2001-03-06 10:12:35 PST
Could a Javascript/XUL bug of some sort be causing this and bug 67442?
Comment 63 Blake Ross 2001-03-06 13:27:25 PST
wfm in a build from today.
Comment 64 sairuh (rarely reading bugmail) 2001-03-06 14:19:33 PST
interesting. also wfm on linux [2001.03.06.08]. marking verified. pls do reopen
if it crops up again.
Comment 65 David Hyatt 2001-03-06 14:27:17 PST
I fixed this yesterday.  It was my bug after all.  :)
Comment 66 Deven Corzine 2001-03-06 14:34:06 PST
If you know what the bug was, could you explain the bug and fix, and mark this
FIXED instead of WORKSFORME?
Comment 67 Deven Corzine 2001-03-06 14:42:35 PST
I don't know what you changed, but I concur that it is fixed in the current
build (2001030608), and it was still broken in yesterday's build (2001030505).

Too bad this didn't fix bug 67442 as well. :-)
Comment 68 sairuh (rarely reading bugmail) 2001-03-06 14:45:54 PST
hyatt: heh, thx. :)
Comment 69 sairuh (rarely reading bugmail) 2001-03-06 14:46:19 PST
...and marking fixed per hyatt's comments.
Comment 70 sairuh (rarely reading bugmail) 2001-03-06 14:46:41 PST
and vrfy!
Comment 71 Dean Tessman 2001-03-06 15:10:13 PST
Any chance (again) that this fixed bug 51996 as well?

Hyatt: Care to share where the fix took place?
Comment 72 Dean Tessman 2001-03-06 15:53:33 PST
Re: Bug 51996... nope.  But now that this is fixed, who cares?  (Well, I still
do, but not nearly as much...)
Comment 73 Michael Hendy 2001-03-06 17:58:59 PST
Woohoo! :)
Comment 74 Warner Young 2001-03-06 18:15:13 PST
Not sure if there's a separate bug on this already, but even with the new build,
after switching themes, the URLbar dropdown doesn't work anymore.  The File,
Edit, and View menus DO work, though.
Comment 75 Dean Tessman 2001-03-07 08:51:11 PST
Warner, I'd file that as a separate bug.  All other menus, etc., seem to work
fine after the switch, including the drop-downs on the back and forward buttons
and auto-complete.
Comment 76 Fabian Guisset 2001-03-07 23:11:18 PST
*** Bug 71265 has been marked as a duplicate of this bug. ***
Comment 77 Gilles Durys 2001-03-08 16:02:14 PST
*** Bug 71357 has been marked as a duplicate of this bug. ***
Comment 78 Gilles Durys 2001-03-23 14:28:39 PST
*** Bug 72909 has been marked as a duplicate of this bug. ***
Comment 79 doctor__j 2001-05-09 01:09:08 PDT
The bug shows up again for Win32 build 2001050820.

Cannot open View menu after switching theme.
Comment 80 Asa Dotzler [:asa] 2001-05-09 10:34:01 PDT
I'm not seeing any problems with 050904 mozilla win32 build on win2K
Comment 81 Dean Tessman 2001-05-09 11:03:17 PDT
doctor__j: Can you not open the menu at all, or does it just appear depressed? 
If it's the latter then that's probably bug 51996.
Comment 82 doctor__j 2001-05-09 11:48:33 PDT
Well, the view menu item appeared depressed AND no View menu is drawn down.
I can draw down File menu, Edit menu, and so on, except View menu.
Comment 83 Dean Tessman 2001-05-09 12:30:24 PDT
This is working for me in 2001050904.
Comment 84 doctor__j 2001-05-15 11:19:42 PDT
The View menu cannot be pulled down after switching themes.
In addition, when other menu is pulled down (say Edit menu) and you sweep the
mouse to go pass the View menu and then landed in other menus (say Bookmarks
menu), the other menus are not pulled down any more as it was supposed to be.

I can still see this bug on Win32 build 2001051504.
Comment 85 Fabian Guisset 2001-05-15 11:48:24 PDT
worksforme build 2001051308 win2k.
The only wierd thing I'm seeing is that after switching skins and going back
over the view menu, it appears "active" instead of "hover", but I can still open
it without problem.
Comment 86 neil@parkwaycc.co.uk 2001-06-13 09:13:36 PDT
Doesn't work for me in build 2001060704

Error: this.docShell.contentViewer has no properties
Source File:
chrome://global/content/bindings/general.xml#browser.markupDocumentViewer (getter)
Line: 0

Note You need to log in before you can comment on or make changes to this bug.