Closed Bug 18575 Opened 20 years ago Closed 8 years ago

[meta] cannot navigate Preference dialog using keyboard only

Categories

(SeaMonkey :: Preferences, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: xiaotong, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, meta, Whiteboard: [rtm-] UE1 [Halloween2011Bug])

When the Perference dialog first appears, where the focus is is unknown. Tab
key does not work at this point to get to category or prefs at the right side
of the panel. After clicking on the panel, Tab key will work somehow to go
through controls (not including OK and Cancel buttons). One have to use mouse
to navigate this dialog. This is opened to address the keybaord access issue
according to W3C accessibility guidelines.
Assignee: shuang → lake
re assign to lake to address it in the spec. also cc matt and german since it is
part of pref work.
A general spec for treatment of keyboard navigation is being considered.
Included would be a portion indicating that when a dialog is first opened the
first item/control will be given focus by default. From there the tab button
will cycle through the remaining items. Any exceptions will be addressed
specifically in the related spec.
Status: NEW → ASSIGNED
QA Contact: claudius → sairuh
spam: in my testing realm, so reassigning qa contact to me, en masse.
Blocks: uaag
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
Nominating for Beta 3 - Pollish
Keywords: nsbeta3
Need to have keyboard acess on all parts of all apps.
Keywords: UE1
Keywords: access
marking nsbeta3- while this bug is assigned to lake
Whiteboard: nsbeta3-
This bug can't stay assigned to lake.

Hyatt can you help triage this bug to a bonified engineer? thx
Assignee: lake → hangas
Status: ASSIGNED → NEW
Keywords: rtm
OS: Windows NT → All
QA Contact: sairuh → mpt
Hardware: PC → All
Whiteboard: nsbeta3-
QA Contact: mpt → sairuh
This bug depends on focus issues being fixed (54105). 
Status: NEW → ASSIGNED
Depends on: 54105
Component: User Interface: Design Feedback → Keyboard Navigation
hangas - focus issues are now fixed. Where does this bug go?

I think all that needs doing is adding accesskey attributes to some XUL - this 
is a fairly major accessibility issue.

Gerv
This is a huge issue for the product.  We tried and were denied.  Fixes like this 
will no longer get marked rtm++ so it will have to wait until after rtm to be 
checked in on the trunk.  I will take this and find a "volunteer" when we have 
checkin ability.
Whiteboard: [rtm-]
*** Bug 27647 has been marked as a duplicate of this bug. ***
Depends on: 64051
Depends on: 64052
*** Bug 64051 has been marked as a duplicate of this bug. ***
nominating for beta1 [n6-side]... howz bout 0.9 for mozilla?
Keywords: nsbeta3, rtmnsbeta1
Target Milestone: --- → mozilla0.9
Making this a metabug.  Bug 64150 now tracks the issue originally brought up in 
this bug, which is that you can't tab from the category tree to an individual 
panel of prefs.  I've removed the nsbeta1 nomination from this bug since it's 
now a metabug; please re-add it to important bugs that this bug depends on.
Depends on: 64150
Keywords: nsbeta1meta
Summary: cannot navigate Preference dialog using keyboard only → [meta] cannot navigate Preference dialog using keyboard only
Adding blockers: 56150,64075,64076,64157,64161.
Depends on: 56150, 64075, 64076, 64157, 64161
Adding blockers: 959,54329,55323,56141,64167,64170,64176,64181
Depends on: 56137
Depends on: 40759
Adding blockers: 57192,62425

By the way, several of these bugs are present in the new Form Manager dialog as 
well.
Depends on: 57192, 62425
Depends on: 66605
Sending to Alec as owner of keyboard navigation.  I hope you are the correct 
owner for this puppy.
Assignee: hangas → alecf
Status: ASSIGNED → NEW
moving a few 0.9 bugs out to 1.0 to lighten my 0.9 load.
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9 → mozilla1.0
we need to add mnemonics for all controls in every panel, right now some 
controls seem to have the underlined character but it can't really be accessed, 
the underlined character is also not used everywhere. An update to the spec is 
needed here, I will update. In the meantime if there are proposal for the 
appropriate shortcuts and menmonics, bring them on...
No longer depends on: 40759
german: filed bug 68243 for adding mnemonics.
Depends on: 68243
Depends on: 68359
See also bug 68340, which is like this bug but covers the MailNews "Account 
Settings" dialog.
* SPAM *
Tacking on another keyboard navigation issue
Depends on: 70958
Depends on: 78261
Keyboard nav -> aaronl
Assignee: alecf → aaronl
Status: ASSIGNED → NEW
Keywords: UE1
Whiteboard: [rtm-] → [rtm-] UE1
Depends on: 6533
CC'ing bryner since there are a lot of focus bugs in here.

It would be nice to test any new focus code extensively in prefs. 
Depends on: 104993
Depends on: 105321
Depends on: 105153
->trudelle
Assignee: aaronl → trudelle
->sgehani
Assignee: trudelle → sgehani
->099, to get off mozilla1.0 milestone
Target Milestone: mozilla1.0 → mozilla0.9.9
Target Milestone: mozilla0.9.9 → mozilla1.0.1
Depends on: 129808
*** Bug 214812 has been marked as a duplicate of this bug. ***
retargeting
Target Milestone: mozilla1.0.1 → Future
Is this bug still Valid? I don't have any trouble navigating around the
preference dialog with my keyboard.
(In reply to comment #32)
> Is this bug still Valid? I don't have any trouble navigating around the
> preference dialog with my keyboard.
Did you look at any of the dependancy bugs? For example, were you able to choose
a color palette without the mouse?
Yes, absolutly selecting from a color palette with keyboard alone works just
fine, although Ive never tried in Mac OS/X where that bug is valid for i guess.
Assignee: samir_bugzilla → prefs
Component: Keyboard: Navigation → Preferences
Product: Core → Mozilla Application Suite
QA Contact: bugzilla
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
Priority: P3 → --
Target Milestone: Future → ---
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20111017003001

This bug was filed for the old Suite.

The pref panels have been completely rewritten as part of the "Toolkit Transition" for SeaMonkey 2.

AFAICT, all remaining dependencies have now been RESOLVED one way or another (and not as EXPIRED which just means "don't know"). => FIXED.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [rtm-] UE1 → [rtm-] UE1 [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.