Right-clicking a bookmark no longer allows a "Sort By Name" to sort the item within its parent / doing so on a folder sorts its contents

RESOLVED DUPLICATE of bug 429392

Status

()

Firefox
Bookmarks & History
P4
normal
RESOLVED DUPLICATE of bug 429392
11 years ago
6 years ago

People

(Reporter: RenegadeX, Unassigned)

Tracking

({regression, uiwanted, user-doc-needed})

Trunk
regression, uiwanted, user-doc-needed
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101905 Minefield/3.0a9pre

Right-clicking on a bookmarked item (but not a bookmarked folder) in:
- the Bookmarks menu
- the Bookmarks Toolbar
- Places Organizer

.. results in a greyed-out "Sort By Name".

Reproducible: Always

Steps to Reproduce:
1. Create a new profile
2. Right-click on the 'Getting Started' bookmark on the Bookmarks Toolbar.
3. Repeat in Bookmarks menu, and in Places Organizer ("Organize Bookmarks")


Expected Results:  
'Sort by Name' should be available so that bookmarks in the parent folder are sorted.

Composite image showing the behaviour I witnessed in all 3 locations: http://img132.imageshack.us/img132/5244/sortbynamenotavailablenpw2.jpg
Isn't this logical and intended behaviour ?

You can't sort a single bookmark, which you selected, so I'd expect the [Organize Bookmarks] context menu to be grayed out.

You can sort the content of a folder, and that has the the context menu available.

Comment 2

11 years ago
confirmed, this is a regression from 2.0.0.x.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)
> Isn't this logical and intended behaviour ?
> You can't sort a single bookmark, which you selected, so I'd expect the
> [Organize Bookmarks] context menu to be grayed out.
> You can sort the content of a folder, and that has the the context menu
> available.

We've always (2.0.0.7 and before, anyhow) been able to right-click on an individual bookmark in any of the 3 locations to sort ("By Name") the folder THAT IT IS IN. Until now, right-clicking on a folder always sorted the parent folder that contains it, rather than its contents. Internet Explorer has always done it this way (and continues to do so) with its Favorites, so it's fairly safe to say that its how most computer users today expect it to work. (In Opera, you can't even do a right-click Sort, and I'm not sure about Safari or the old Netscape).

Is this progress?
No, for the simple reason that due to the sudden change, if I add a bookmark to the main bookmarks folder, there is now no way for me to sort it unless I make a special visit to the Places Organizer. Most people, I suspect, comfortable with the old way of performing the task by clicking on a bookmark - will take some time and trial-and-error to figure out that the only way to complete the task is to right-click on the "Bookmarks" item at the top of the left-side panel. So it CAN be done, it's just it now takes 5 clicks to do (inc. closing the Organizer).

"Progress", in my opinion, would be:
- right-click on a FOLDER and have the context menu say "Sort folder contents" (or simply "Sort contents"), in addition to the current "Sort by Name" directly above it.

Note: "Sort by Name" is still valid, as a user might want to sort that folder within its parent by Name.
(Reporter)

Comment 4

11 years ago
Just noticed this wasn't marked "Trunk" so am doing that now.

Also discovered that despite what I wrote in Comment #3 it's possible to sort the root bookmarks folder in the Bookmarks Menu by right-clicking 1 of the first 4 items ('Bookmark This Page', 'Subscribe to this Page', 'Bookmark All Tabs', 'Show All Bookmarks'). This however is not at all intuitive and not easily discoverable.

This really needs addressing before 3.0 release as you can't just do a 180-degree turnaround on a well-known behaviour and not make it obvious what the new behaviour is. Well you can, just not without confusing and upsetting a lot of people!
Version: unspecified → Trunk
(Reporter)

Comment 5

11 years ago
FYI: Because of this change, as the "Bookmarks Toolbar Folder" item was removed from the Bookmarks Menu (some time in mid-November), should a user wish to sort items on the Bookmarks Toolbar, there is now no way to do so without going into 'Show All Bookmarks' ('Library' nee 'Places Organizer').

It's illogical that I can sort folder subtrees on my Bookmarks Toolbar, but not the top-level folder that contains them.
(Reporter)

Comment 6

11 years ago
I'm beating what's probably a dead horse, but I came across some Firefox 3 "goals" and 1 of them was "visual OS-integration". If this is deemed so important, then should adhering to OS-behaviours not be even more important? After all, most of us can readily adapt to visual changes, but learning new behaviours (and conflicting ones for the same task at that) is more challenging.

I'm not sure how it works on other OSes, but on Windows (up to and including XP, at least) it has always been that if you click on:

Start Menu -> All Programs
.... and then right-click on any item (inc any subfolder) and choose "Sort By Name", that item is sorted within its own parent folder.

In other words, my OS operates on a "sort vertically" principle (as did Firefox 1&2) while Firefox-3 currently operates on a "sort across" principle. That's no good.
what's the UX team decision here?

mantain the old firefox 2 / ie7 / windows behaviour: sort folder containing bookmark or bookmark folder
mantain the new ff3 behaviour: sort container pointed by bookmark folder, disable for bookmark
Keywords: uiwanted

Comment 8

10 years ago
(In reply to comment #6)
> I came across some Firefox 3 "goals" and 1 of them was "visual OS->integration". If this is deemed so important, then should adhering to OS->behaviours not be even more important?

I suspect there's a different way of thinking shared by some in the Mozilla development community. See bug 396513 for what I mean. It demonstrates, in my opinion, an outrageous disregard for common and expected behavior in Windows and many applications written for it.
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
i'm asking blocking because i think that UX team should take a decision on this before the final release.

problems:
- the behaviour has changed from Firefox 2
- on Windows and IE (don't know what is common on OS X or Linux) the common behaviour for this is "sort the parent folder"
- there is no way to sort bookmarks menu other than using the Library (i think that many users now are sorting it with simple opening, right click, sort by name)

fix or wontfix?
Flags: blocking-firefox3?

Comment 10

10 years ago
I totally agree Firefox 2/IE behavior is the most logical and quickest way of sorting bookmarks.
IIRC this was a deliberate design decision, but blocking as a low-end blocker so UX can circle back here.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P4

Comment 12

10 years ago
This is related to bug 409676
If it's decided that right-clicking a bookmark should not offer the option to sort the folder it's in, then the disabled context menu item for bookmarks should be removed.

I took its presence to mean “there's some situation in which you could do a Sort By Name here, but not right now” and tried changing the view to Unsorted to re-enable the menu item.

Comment 14

10 years ago
(In reply to comment #13)
> If it's decided that right-clicking a bookmark should not offer the option to
> sort the folder it's in, then the disabled context menu item for bookmarks
> should be removed.

I prefer the behavior in FF 2.x.  If feel un-natural clicking on the folder to sort the objects within that folder.  It seems to me that the behavior should be the following:

1) Right-clicking on a folder sorts the folders themselves (within the bookmarks menu) by name and NOT the contents of that folder

2) Right clicking on the contents ONLY sorts the contents of that specific folder

This is the behavior in FF 2.x and IE 7.

~B

Duplicate of this bug: 419233
Duplicate of this bug: 420407
Duplicate of this bug: 421225
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Duplicate of this bug: 423150

Comment 20

10 years ago
In FF3 Beta 4 & 5, the "sort by name" option is still not present. It is greyed out as some other people have stated.

Is there a fix for this? Even going to the "bookmarks folder" does not fix the issue. you can sort within the folder, but it does not change the order in the drop down bookmark menu.

this really isn't a huge problem, as you can type in the address bar and find your bookmarks easy, but never the less it still is a problem.

-Alex
Duplicate of this bug: 427756
Duplicate of this bug: 430340
Duplicate of this bug: 432009
Duplicate of this bug: 433712
Duplicate of this bug: 433842

Comment 26

10 years ago
Which genius decided it would be a good idea to make it so you must open up organise bookmarks in order to sort them?
Duplicate of this bug: 434421

Comment 28

10 years ago
Right clicking on (under Bookmarks menu) "Bookmarks toolbar" will sort them at the top layer. NOT obvious that this is the sort /hot spot/.
At least provide an option for "classic menu sort" in options if you are going to change.
I have to agree the "classic way" is NOT really the most correct for reasons others have pointed out. The problem is some of us have 15 years of doing it that way, Like clicking "Start" to shutdown. Like clicking "Review and Install" to disable a particular update.

Updated

10 years ago
Flags: blocking-firefox3.1?
Duplicate of this bug: 437732
Duplicate of this bug: 437732

Updated

10 years ago
Duplicate of this bug: 438506

Comment 32

10 years ago
(In reply to comment #28)
> I have to agree the "classic way" is NOT really the most correct for reasons
> others have pointed out. The problem is some of us have 15 years of doing it
> that way, Like clicking "Start" to shutdown. Like clicking "Review and Install"
> to disable a particular update.
> 

What is right in human behavior?
NOTHING!

Why do you want to make it complicated if you can do it with a mere 2 click?
That's DUMB!

Comment 33

10 years ago
(In reply to comment #26)
> Which genius decided it would be a good idea to make it so you must open up
> organise bookmarks in order to sort them?
> 

I second that.
Which one of you?

Comment 34

10 years ago
04;4;Avril

Comment 35

10 years ago
(In reply to comment #33)
> (In reply to comment #26)
> > Which genius decided it would be a good idea to make it so you must open up
> > organise bookmarks in order to sort them?
> > 
> 
> I second that.
> Which one of you?
>

Wasn't me :]

I agree, want this basic function back for final release 3

Duplicate of this bug: 438536

Comment 37

10 years ago

(In reply to comment #35)
> (In reply to comment #33)
> > (In reply to comment #26)
> > > Which genius decided it would be a good idea to make it so you must open up
> > > organise bookmarks in order to sort them?
> > > 
> > 
> > I second that.
> > Which one of you?
> >
> 
> Wasn't me :]
> 
> I agree, want this basic function back for final release 3
> 

Lack of the "right-click | Sort by Name" option had me seriously annoyed since I downloaded beta 4. Being very frustrated led me to this forum to discover that others seem to have the same sentiments. I'd like to have the classic way of sorting back as well. I never would have discovered it otherwise. To me the Bookmarks Toolbar is more of an annoyance than anything else and in FF 2 I downloaded an add-on to let me remove it. Probably would have never discovered this as the place to sort the top-level bookmark folder. While not a programmer I am an engineer and I can only imagine the frustration of the general population when they download the initial release and can't sort their bookmarks. New unannounced *features* are a major downfall in all sorts of products and I'm hoping the FF dev team realizes this and puts it on their priority list to fix. In the meantime, now that I know where to go the Bookmark Toolbar sort is good enough. I'll see if I can get one of my programmer friends to donate some time.....

Comment 38

10 years ago
(In reply to comment #37)
> 
> (In reply to comment #35)
> > (In reply to comment #33)
> > > (In reply to comment #26)
> > > > Which genius decided it would be a good idea to make it so you must open up
> > > > organise bookmarks in order to sort them?
> > > > 
> > > 
> > > I second that.
> > > Which one of you?
> > >
> > 
> > Wasn't me :]
> > 
> > I agree, want this basic function back for final release 3
> > 
> 
> Lack of the "right-click | Sort by Name" option had me seriously annoyed since
> I downloaded beta 4. Being very frustrated led me to this forum to discover
> that others seem to have the same sentiments. I'd like to have the classic way
> of sorting back as well. I never would have discovered it otherwise. To me the
> Bookmarks Toolbar is more of an annoyance than anything else and in FF 2 I
> downloaded an add-on to let me remove it. Probably would have never discovered
> this as the place to sort the top-level bookmark folder. While not a programmer
> I am an engineer and I can only imagine the frustration of the general
> population when they download the initial release and can't sort their
> bookmarks. New unannounced *features* are a major downfall in all sorts of
> products and I'm hoping the FF dev team realizes this and puts it on their
> priority list to fix. In the meantime, now that I know where to go the Bookmark
> Toolbar sort is good enough. I'll see if I can get one of my programmer friends
> to donate some time.....
> 

The main problem is that this bug won't be fixed in 3.0.0, although it MIGHT be fixed in 3.1. There's no patch and it's way late to drop into mozilla-central. Also when I upgraded from 2.0 to 3.0 BETA I realised that my bookmarks kept in the default Bookmarks Folder were transfered to the Bookmark Tab, quite annoying really. A few of my friends also had this problem and downgraded to Firefox 2.0 as a result of this.

In my opinion Firefox 3.0 simply isn't ready for release.

Comment 39

10 years ago
This bug doesn't justify your conclusion but I do think this should have been fixed already. And I don't think it is really hard  to fix it. No offense to the developers out there, but you guys can be pretty stubborn... Thinking that you know it better than the end users. This is not a wild comment but I came to that conclusion after testing open source projects for several years.

Bottom line: I don't think it wasn't fixed because of the complexity of the problem or due too limited time but due thinking their way is the right way... unfortunately. So get rid of the stubbornness and listen to your users.
Stop spamming here.

I think the point is clear to everyone, a decision was taken some time ago and the design is coherent with that decision, based on comments from users the drivers could change their view, but spamming duplicated comments is not useful at all, use the forums for that.

About the problem of right clicking bookmarks toolbar menuitem to sort bookmark menu is an unwanted feature due to the way the toolbar view is handled in the menu, nothing more, you can also right click any other element in the menu that is not a bookmark to sort, the toolbar is such a kind of element.
Severity not major:  that would be the case if sort was completely broken 
 Severity -> normal
Severity: major → normal

Updated

10 years ago
Duplicate of this bug: 439032

Updated

10 years ago
Duplicate of this bug: 413140
(Reporter)

Comment 44

10 years ago
Hi. Due to the bookmarks changes since I filed this Bug and due to the number of Bug duplicates filed and still being filed, I am renaming this Bug to "Right-clicking a bookmark no longer allows a 'Sort By Name' to sort the item within its parent / doing so on a folder sorts its contents". Apologies for its wordiness but it is what it is and as such I feel it will be easier for users to find.

Similarly, some of the points made so far in this Bug thread are now obsolete, while others remain valid.

What it boils down to is this: the new bookmarks sorting method is unintuitive, it's completely opposite to both the way Firefox operated previously and the native-OS behaviour of Microsoft Windows and possibly other operating systems, and to complicate things further, sorting items within the top-level of the Bookmarks Menu is not plainly discoverable. Therefore 3 solutions have been proposed:
- 1) revert back to the classic method
- 2) provide users with an option to use the new method or revert back to the 'classic' method.
- 3) if we're going to be stuck with the new method, then the ability to sort bookmarks & bookmark folders should be made more user-friendly. This means both more discoverable and more clear in precisely what the action does, and where.

Incidentally, though I've just changed the name of this Bug, under certain circumstances, "Sort By Name" is *still* present but greyed-out in the Library's right-hand pane.
ex: left-click a folder in the left-pane, then right-click in the right-pane.
Summary: "Sort By Name" on a bookmark (but not bookmark folder) is greyed-out → Right-clicking a bookmark no longer allows a "Sort By Name" to sort the item within its parent / doing so on a folder sorts its contents

Updated

10 years ago
Duplicate of this bug: 440621
This bug applies to Mac OSX.4.11 as well you can sort by control-Clicking folders on the bookmarks bar but does not apply at all to contents of subfolders within those folders. To organize sub folder you must drag and drop in correct position.

In the Bookmarks > organize feature You appear to be sorting but as soon as you go to amother folder everything reverts back to original state. even loose websites not sorted into folders revert
(In reply to comment #1)
> Isn't this logical and intended behaviour ?
> 
> You can't sort a single bookmark, which you selected, so I'd expect the
> [Organize Bookmarks] context menu to be grayed out.
> 
> You can sort the content of a folder, and that has the the context menu
> available.
> 


Actually no. In my case have many URL that are not organized into folders and it doesn't even sort them (Mac OSX.4.11

Updated

10 years ago
Duplicate of this bug: 442014

Updated

10 years ago
Flags: blocking-firefox3.1?
(In reply to comment #26)
> Which genius decided it would be a good idea to make it so you must open up
> organize bookmarks in order to sort them?
> 

Actually both methods either sort by bookmarks or by opening the Bookmarks organizer should exactly the same.

In fact opening the Bookmarks organizer clicking on the Bookmarks (the very top level) and then choosing sort by name should apply to everything. Look Bookmarks, Folders, and contents of folders all in one swoop.

If you want to choose items to organize, the use the new method and have it so that when you go into drop down menu of contents of a sub folder you can sort by name That way. so that you only alphabetize the contents of certain folders.  
"Sort by name" now was completely removed from context menu of bookmark items.

I think a context menu item like this is useful, but it is misleading. If someone clicks on a folder and select "Sort by Name", he could expect the sorted folder is the containing folder. So IMO it's better to wontfix this bug.
Sort  by name in reference to this problem has to do with these items which should *all* work: 

First clicking on Bookmarks Bar and not on a Folder on the bar should sort all the  Folders and items listed on the Bookmarks Bar. If website URL are are inserted loose (not in sub folders They should be sorted as well through a context menu .

two clicking on a folder should bring up a context menu allowing for sorting by name. This would sort the contents of that individual folder.

Next when you go to main menu click on Bookmarks the organize Book Marks you should be able to do the same as above 2 items.

I have Bookmarks That I don't have sorted for example I save a URL in an email its says save as bookmark I click on it and the book mark is added but does not bring up a window that allows me to tell where it supposed to be placed.  (in SEaMonkey) but if I import thes book marks to FF they are still *loose*. So unless I can sort by name the Loose bookmarks within the Bookmarks Organizer window. it does me no good.

So context menu and BookMarks Organizer should be do exactly the same thing.

You may suggest to wontfix but your going to frustrate a lot of  users. Me included. 
(Reporter)

Comment 52

10 years ago
(In reply to comment #50)
> I think a context menu item like this is useful, but it is misleading. If
> someone clicks on a folder and select "Sort by Name", he could expect the
> sorted folder is the containing folder. So IMO it's better to wontfix this bug.

He *could*, but if he's one of the many millions of Windows users out there who has ever sorted items in their Start Menu's 'All Programs' folder tree, then I have no idea why he would, or should. You may not be a Windows user, the developers who pushed for this new change might not be Windows users, but fact is Windows users are the majority and therefore this new sorting behaviour is completely alien and unintuitive to the majority of users.

Also, the new behaviour is not consistent. In the Bookmarks Menu:
- right-click and perform a 'Sort by Name' on the a bookmark folder. Its contents get sorted.
- now do the same on the 'Bookmarks Toolbar' item in the Menu. We should expect the contents to be sorted. But NO, it seems to be treated not as a folder but as a bookmark item, and the parent (Bookmarks Menu) is sorted instead. So, we conclude that the Bookmarks Toolbar is 'special'.
- now open the Library and do the same, and it sorts the Bookmarks Toolbar's folder contents! Confused? I certainly am!
- And what's more, in the Library, the Bookmarks Toolbar *isn't* even a child of the the Bookmarks Menu(it's a child of "All Bookmarks") - so why  did doing the BT sort in the Menu sort the Bookmarks Menu?

Its inconsistencies like these which prove that not enough thought or consideration was put into this new sorting behaviour change. Of the options I suggested in Comment #44, though I prefer Option#1, I do not believe it will happen, and neither is Option#2, so that leaves Option#3. I suggested one solution in Comment #3, and see now that another has been proposed under Bug 444437. I can't add a "+" to "wanted for Firefox 3.1" in the Bug Description, but I feel cleanup like this should be a priority.
(In reply to comment #52)
> Also, the new behaviour is not consistent. In the Bookmarks Menu:
> - right-click and perform a 'Sort by Name' on the a bookmark folder. Its
> contents get sorted.
> - now do the same on the 'Bookmarks Toolbar' item in the Menu. We should 
> expect the contents to be sorted. But NO, it seems to be treated not as a 
> folder but as a bookmark item, and the parent (Bookmarks Menu) is sorted 
> instead.

See Bug 429392.

> I suggested one solution in Comment #3, and see now that another has been 
> proposed under Bug 444437

I think you mean Bug 444429.


I don't agree with your motivations, but I agree "Sort by name" applied to parent folder is a better solution, for only one reason: it's quite impossible to sort by name bookmarks for the main Bookmark Menu folder in this way. You must do it in sidebar or in Library.

I don't agree with Comment #3, since a double option for selected and parent folder is redundant.

Comment 54

10 years ago
Here's a userChrome.js script that makes Sort by Name work properly again (like in Firefox 2).

// fix Sort by Name to work properly
if(location.href == "chrome://browser/content/browser.xul" ||
   location.href == "chrome://browser/content/places/places.xul") {
  eval("PlacesController.prototype.isCommandEnabled = " + PlacesController.prototype.isCommandEnabled.toString()
    .replace(/(case "placesCmd_sortBy\:name":)(?:.|\n)*?(default)/, "$1return !!this._view.selectedNode;$2")
  );
  eval("PlacesController.prototype.sortFolderByName = " + PlacesController.prototype.sortFolderByName.toString()
    .replace(/(_view\.selectedNode)/, "$1.parent")
  );
  document.getElementById("placesContext_sortBy:name").setAttribute("selection", "any");
  alert(document.getElementById("placesContext_sortBy:name").getAttribute("selection"))
}

Comment 55

10 years ago
Created attachment 330527 [details]
Attached version, with alert line removed

opps, forgot to remove the testing alert line

also userChrome.js extension: 
http://forums.mozillazine.org/viewtopic.php?t=594331
Duplicate of this bug: 437419
Duplicate of this bug: 437308
Duplicate of this bug: 438301
I notice there is a running theme of "changed in FF2 and IE7

Why why do we give a rats backside about IE. I thought the reason for having FF or Seamonkey for That Matter is to be different Internet Explorer. If we want to look and act Like Internet Explore Get Microsoft's permission to Take Internet Explorer to the  Free Community. and Just Make IE available to All platforms.

IF I wanted to use IE I'd buy a PC instead of a Mac and use IE.

The Fact is you should be able to sort by any criteria whether using Right Click , click and hold on a Folder icon in Bookmarks bar or in the Bookmarks menu > Manage Bookmarks.

Design our own product, not something that has to mimic everything that IE does. 

Comment 60

10 years ago
Adding user-doc-needed since this is a commonly seen "complaint".  I'm not actually sure if anyone prefers the new way (we obviously get lots of people in various channels who want the old way).  I'm also not sure that UI changes are pushed in point-releases but that's a discussion for someone more in the know.

Anyhow, adding the keyword so we can stay appraised of updating our documentation if this change is pushed.

A compromise may be writing an extension that brings back the old way (if one does not yet exist).  It seems that if the javascript in comment 54 works, we could make a stopgap extension.

Updated

10 years ago
Keywords: user-doc-needed

Comment 61

10 years ago
What I find interesting is that, from a UI perspective, a Windows user expects the Sort By Name function to work inside a list, since that is how sorting Windows directories works.
Duplicate of this bug: 441926
No longer depends on: 444429
Duplicate of this bug: 444429
Duplicate of this bug: 488434
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429392

Updated

6 years ago
Duplicate of this bug: 757008
You need to log in before you can comment on or make changes to this bug.