Closed Bug 1060901 Opened 6 years ago Closed 6 years ago

[tb31.1 only] expand mail list broken for lists whose description is quoted

Categories

(MailNews Core :: Composition, defect)

defect
Not set

Tracking

(thunderbird32 unaffected, thunderbird33 unaffected, thunderbird34 unaffected, thunderbird35 unaffected, thunderbird_esr3132+ fixed)

VERIFIED FIXED
Thunderbird 31.0
Tracking Status
thunderbird32 --- unaffected
thunderbird33 --- unaffected
thunderbird34 --- unaffected
thunderbird35 --- unaffected
thunderbird_esr31 32+ fixed

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

(Keywords: regression, Whiteboard: [regression:tb31.1])

Attachments

(1 file)

Attached patch proposed fixSplinter Review
So when bug 1008718 landed on ESR the associated test turned orange and was disabled.

Although list expansion normally do work, I now see the case it apparently caught was that lists where the list description is set to a multi word description -> the description is quoted -> the list expansion fails. 

This is not a problem for 32+, as something between 31 and 32 changed the quoting. On 32+ the description is never quoted afaikt. I would guess bug 790855, but that patch doesn't apply cleanly so i didn't verify it.
Attachment #8481911 - Flags: review?(Pidgeot18)
Keywords: regression
OS: Linux → All
Hardware: x86_64 → All
Version: Trunk → 31
Duplicate of this bug: 1061959
Duplicate of this bug: 1062213
Today TB updated to 31.1 and all mailing lists stopped working.
I usually have them descriptive, with two or more words.

Example of list no longer working, which worked yesterday on 31.0
Prehrana komercijala PPP <"Prehrana komercijala PPP">

(This is copy/paste from compose window)

Is this same issue or I need to file new bug?
Whiteboard: [gs][regression:tb31.1]
See recent comments in Bug 451118. This is a very painful bug. How can we increase its urgency?
Workaround that works is to replace the blanks " " between the words in multiword descriptors with an underscore "_".
In Comment 5 replace "descriptors with "list name".
Duplicate of this bug: 1062649
Duplicate of this bug: 1062606
Duplicate of this bug: 1062741
Duplicate of this bug: 1062788
Duplicate of this bug: 1062811
Confirmed workarounds:

* While composing an email open the address book and select the list you are trying to send to, highlight all the names in the list and drag them to the To: box. This uses your existing data without modifying it. 
* Replacing the blanks " " between the words in such lists' descriptions with an underscore "_". This requires modifying your mailing list(s) description(s).
Several support requests for this are coming in via Thunderbird SUMO. I've bookmarked a few here:
https://l1bre.ca/l/?searchtags=1060901
Comment on attachment 8481911 [details] [diff] [review]
proposed fix

Review of attachment 8481911 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/compose/src/nsMsgCompose.cpp
@@ +4640,3 @@
>      return mailList.mDescription.IsEmpty() ?
>        mailList.mName.Equals(recipient.mEmail, nsCaseInsensitiveStringComparator()) :
> +      (mailList.mDescription.Equals(recipient.mEmail, nsCaseInsensitiveStringComparator()) || 

Nit: trailing whitespace
Attachment #8481911 - Flags: review?(Pidgeot18) → review+
Contrary to the third comment in bug #1062606, this problem is NOT limited to putting a mailing list in the BCC: line.  See the attachment in bug #1062606, which clearly shows the error with a mailing list in the To: line.
Why must I remove the blanks in mailing list names when blanks are okay in the names of individual addresses?
(In reply to David E. Ross from comment #16)
> Why must I remove the blanks in mailing list names when blanks are okay in
> the names of individual addresses?

You don't HAVE TO do that--only if you want the current version to work.  This bug is the path to create a fix that will be in a future version--there is no way they can suddenly make the current version already installed on you computer to suddenly start working.  The 'workaround to substitute the underscore for spaces was trying to HELP you if you wanted to make it work without having to uninstall current and reinstall an earlier version.
the problem is the List name is handled differently
I had one user with this error on upgrade to 31.0
All users now have it at 31.1

List Name:     must not contain spaces NOW
List Nickname: no effect
Description:   no effect

so users must now edit all Address List Names to not contain spaces
if you remove the spaces, then the address list works as desired
Attachment #8481911 - Flags: approval-comm-esr31?
Duplicate of this bug: 1062938
Please also note that, in Thunderbird 31.1.0, the PopMailListRecipients extension no longer decomposes a mail list into its individual addresses.  This extension would be a good work-around for this problem if only the extension were not also broken by the changes between Thunderbird 31.0 and 31.1.0.  

In repairing Thunderbird for this bug, please ensure that PopMailListRecipients again works.  Perhaps, that extension should be incorporated directly into Thunderbird as indicated in bug @119977.
Blocks: 790855
Whiteboard: [gs][regression:tb31.1] → [regression:tb31.1]
I am experiencing the same issues with the mailing lists in TB 31.1.  The lists will function when spaces in the name are replaced by underscores as Fabian said above.  I also support David's comments requesting that the resolution also reinstate decomposition of the mailing list into individual addresses once again.
Duplicate of this bug: 1063159
Duplicate of this bug: 1063275
Duplicate of this bug: 1063306
Duplicate of this bug: 1063477
Will a post be made here when a stable channel release is made (not development or beta) that fixes this bug?

I am running an older version to avoid it, but want to upgrade when a version comes out that fixes it.
Duplicate of this bug: 1063849
Duplicate of this bug: 1063955
Duplicate of this bug: 1063744
So far I've answered / seen 17 support requests related to this:
https://l1bre.ca/l/?searchtags=1060901
Comment on attachment 8481911 [details] [diff] [review]
proposed fix

[Triage Comment]
Please get this landed in trunk and across aurora/beta asap.
Attachment #8481911 - Flags: approval-comm-beta+
Attachment #8481911 - Flags: approval-comm-aurora+
It should not go into aurora/beta, as it's a problem ONLY on 31.1.
Duplicate of this bug: 1063383
Duplicate of this bug: 1064059
Duplicate of this bug: 1064094
Duplicate of this bug: 1064112
Duplicate of this bug: 1064112
Duplicate of this bug: 1064123
Duplicate of this bug: 1064135
Comment on attachment 8481911 [details] [diff] [review]
proposed fix

Sorry, got that wrong about where this needed to land.
Attachment #8481911 - Flags: approval-comm-esr31?
Attachment #8481911 - Flags: approval-comm-esr31+
Attachment #8481911 - Flags: approval-comm-beta+
Attachment #8481911 - Flags: approval-comm-aurora+
Fix landed:

https://hg.mozilla.org/releases/comm-esr31/rev/aca1ac1d498e

We hope to be releasing this either today or tomorrow.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
> We hope to be releasing this either today or tomorrow.

Does this mean the stable Thunderbird download to the public will contain it, i.e. be a 31.1.1 version (for example)?
Duplicate of this bug: 1064292
Duplicate of this bug: 1064423
(In reply to Mark Banner (:standard8) from comment #41)
> Fix landed:
> 
> https://hg.mozilla.org/releases/comm-esr31/rev/aca1ac1d498e
> 
> We hope to be releasing this either today or tomorrow.

will an email notice be sent if we supply an email address? This bug is driving me buggy. :)
Flags: needinfo?(mkmelin+mozilla)
Duplicate of this bug: 1064577
Would it be possible to get a Thunderbird 31.2 with this fixed so that we do not have to wait for Thunderbird 32?
A tb31.1.1 release is on its way, probably within days. Candidate builds are already here: 
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/candidates/31.1.1-candidates/build1/
Flags: needinfo?(mkmelin+mozilla)
Is there a test going along with the bug fix? While searching for the cause of this error I ran across references to the bug in the past and previous fixes. It would be nice if going forward it did not get past the testing stage.
Yes, there is a test in place.
Thunderbird 31.1.1 containing the fix has now been released.
Downloaded.  Tested.  Looks good!

Thanks!
--Fred Stluka
31.1.1 works fine thanks works as expected from previous editions thanks
Thunderbird 31.1.1 appears to have fixed the problem.  Thanks to all who participated in getting this fixed.
To those who fixed this and to whoever made the decision to release it in Thunderbird 31.1.1:  Thank you, thank you, thank you.  

Even the PopMailListRecipients extension works.
The quick fix is much appreciated. I echo my thanks.
Thanks so much for fixing this annoying bug :-)
And I'll also echo everyone's thanks; I especially appreciate the speed with which all you software people developed, tested, and got the fix out the door. Thank you!
Late to offer my thanks as I've been helping my daughter move house, but I really appreciate the speedy fix of what is for me an essential feature. Thank you!
Seems verified from the responses.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1067004
Duplicate of this bug: 1067043
Target Milestone: --- → Thunderbird 31.0
This issue was fixed in version 31.1.1
I am not experiencing a problem.
However, I would like to report that I'm seeing a report in support forum  that version 38.2.0 is showing same issue.
https://support.mozilla.org/en-US/questions/1083411?utm_campaign=questions-reply&utm_medium=email&utm_source=notification

Also there was a report by Andrew S. McCullough in this bug 542947 stating same issue in version 38.2.0

Could this be looked at before we start to get loads of reports.
Should a new bug be created?
You need to log in before you can comment on or make changes to this bug.