Closed Bug 815278 Opened 10 years ago Closed 5 years ago

Localization needed for about:healthreport server side content

Categories

(Mozilla Localizations :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: laura, Unassigned)

References

Details

Filed https://wiki.mozilla.org/L10n:FHRJelly with details known so far.

The content is not yet finalized, but will consist of HTML that will be served over the web and be used by Firefox to render about:healthreport.

This is a web localization bug, but the tracker is filed under Firefox:General, so I wasn't clear how to file this as per https://wiki.mozilla.org/L10n:Localizing_Projects_and_Content.  Please correct as needed.
Will a new specialized website be built to host that content or will it be part of an existing site?
A new specialized site will be built.
A few more questions:

- Will this about:healthreport be an url available for desktop Firefox only or also for Firefox for Android?
- If this is going to get regular text updates, like weekly, will text updates be created the week before they are in the product or several weeks before?
- Will there be a testing server set up soon to have an idea of what it will look like?

Thanks
(In reply to Pascal Chevrel:pascalc from comment #3)
> A few more questions:
> 
> - Will this about:healthreport be an url available for desktop Firefox only
> or also for Firefox for Android?

I believe it is only for desktop.  ccing deinspanjer for comment.

> - If this is going to get regular text updates, like weekly, will text
> updates be created the week before they are in the product or several weeks
> before?

This one is for deinspanjer or tnorris.  My question: how far in advance would you like it to be done?

> - Will there be a testing server set up soon to have an idea of what it will
> look like?

I will file an infra bug soon and put the bug number in here.

Also, we think it might be easiest if we use the same l10n process as start.mozilla.org.  Is that a good way to go?
In reply to Pascal Chevrel:pascalc from comment #3)
> A few more questions:
> 
> - Will this about:healthreport be an url available for desktop Firefox only
> or also for Firefox for Android?

Initial release will be desktop only, but will eventually be released on Android.

> - If this is going to get regular text updates, like weekly, will text
> updates be created the week before they are in the product or several weeks
> before?

The reason for the smaller iterative updates is so we can fine-tune the actual visualizations. Changes to strings should only be happening per Fx release, and should be available several weeks before.

> - Will there be a testing server set up soon to have an idea of what it will
> look like?

Right now the majority of strings are in the product. The externally hosted iframe exists for a small set of data visualizations. For that we are still in process of finalizing the functional spec (amazing how complex a single graph can be). Once that is done we'll get the designs from UX.

Until then we won't know exactly how many strings are needed. In the first release of visualizations there will only be a single graph, so at most we'd have a dozen short strings.
We intend for this to work exactly the same as start.m.o, which means using .lang files.  

Strings are supposed to be finalized today, and we should have the repo and staging environment set up shortly.  jakem is point from Ops.
Depends on: 844170
Blocks: 851137
Blocks: 853120
No longer blocks: 851137
Depends on: 851137
Depends on: 853645
Depends on: 853651
Depends on: 853652
Depends on: 854621
Depends on: 854622
Depends on: 854628
Depends on: 854630
Depends on: 854631
Depends on: 854632
Depends on: 854633
Depends on: 854634
Depends on: 854635
Depends on: 854636
Depends on: 854637
Depends on: 854638
Depends on: 854639
Depends on: 854640
Depends on: 854641
Depends on: 854642
Depends on: 854643
Depends on: 854644
Depends on: 854645
Depends on: 854646
Depends on: 854647
Depends on: 854648
Depends on: 854649
Depends on: 854650
Depends on: 854651
Depends on: 854652
Depends on: 854653
Depends on: 854654
Depends on: 854655
Depends on: 854656
Depends on: 854657
Depends on: 854658
Depends on: 854660
Depends on: 854661
Depends on: 854662
Depends on: 854663
Depends on: 854664
Depends on: 854665
Depends on: 854666
Depends on: 854667
Depends on: 854668
Depends on: 854669
Depends on: 854670
Depends on: 854671
Depends on: 854672
Depends on: 854673
Depends on: 854674
Depends on: 854675
Depends on: 854676
Depends on: 854677
Depends on: 854678
Depends on: 854679
Depends on: 854680
Depends on: 854681
Depends on: 854682
Depends on: 854683
Depends on: 854684
Depends on: 854685
Depends on: 854686
Depends on: 854687
Depends on: 854688
Depends on: 854689
Depends on: 854690
Depends on: 854691
Depends on: 854692
Depends on: 854693
Depends on: 854694
Depends on: 854696
Depends on: 854697
Depends on: 854698
Depends on: 854699
Depends on: 854700
Depends on: 854701
Depends on: 854702
Depends on: 854703
Depends on: 854704
Depends on: 854705
Depends on: 854706
Depends on: 854707
Depends on: 854708
Depends on: 854709
Depends on: 854710
Depends on: 854711
Depends on: 854712
Depends on: 854713
Depends on: 854714
Depends on: 854715
Depends on: 854716
Depends on: 854717
Depends on: 854718
Depends on: 854719
Depends on: 854720
Depends on: 854721
Depends on: 854722
Depends on: 854723
No longer depends on: 853645
Duplicate of this bug: 853645
Depends on: 868925
Depends on: 868926
Flags: in-qa-testsuite+ → in-qa-testsuite?
@Yuriy
This is a production Bugzilla instance. If you want to test it out, please use
https://landfill.bugzilla.org/ instead.
tracking-fennec: ? → ---
blocking-fx: ? → ---
Flags: sec-bounty?
Flags: in-testsuite?
Flags: in-qa-testsuite?
Flags: in-moztrap?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.