Bug 889230 (custom-elements-initial-release)

[meta] Implement Custom Elements (from Web Components)

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
6 years ago
a month ago

People

(Reporter: mike, Unassigned)

Tracking

(Blocks 2 bugs, {dev-doc-needed, feature, meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: btpp-meta)

User Story

Quote from comment 11:

The feature we want to implement is defined across DOM https://dom.spec.whatwg.org/ and HTML https://html.spec.whatwg.org/multipage/ these days. The following wiki pages have pointers to the relevant sections:

* https://github.com/whatwg/dom/wiki
* https://github.com/whatwg/html/wiki
Comment hidden (obsolete)
(Reporter)

Updated

6 years ago
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)

Updated

5 years ago
Flags: needinfo?(wchen)
We have an implementation of custom elements in the tree but it is pref'ed by dom.webcomponents.enabled and disabled by default. It is not being shipped because we are not confident in the current specification, we offer it as an experimental API to collect feedback from developers.
Flags: needinfo?(wchen)
Comment hidden (obsolete)

Updated

4 years ago
Depends on: 1093680

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: feature

Comment 11

3 years ago
FYI, the description in comment 0 is no longer accurate. The feature we want to implement is defined across DOM https://dom.spec.whatwg.org/ and HTML https://html.spec.whatwg.org/multipage/ these days. The following wiki pages have pointers to the relevant sections:

* https://github.com/whatwg/dom/wiki
* https://github.com/whatwg/html/wiki
Depends on: 1231265
User Story: (updated)

Updated

3 years ago
Depends on: 1253086

Updated

3 years ago
Depends on: 1274159

Updated

3 years ago
Depends on: 1274505
Keywords: meta
Whiteboard: btpp-meta

Updated

3 years ago
Depends on: 1275832

Updated

3 years ago
Depends on: 1275833

Updated

3 years ago
Depends on: 1275835

Updated

3 years ago
Depends on: 1275838

Updated

3 years ago
Depends on: 1275839

Updated

3 years ago
Depends on: 1287348

Updated

3 years ago
Depends on: 1288306

Updated

3 years ago
Depends on: 1292125

Updated

3 years ago
Depends on: 1293921
Depends on: 1294100

Updated

3 years ago
Depends on: 1299363

Updated

3 years ago
Depends on: 1301024

Updated

3 years ago
Depends on: 1309140

Updated

3 years ago
Depends on: 1309147

Updated

3 years ago
Depends on: 1309176

Updated

3 years ago
Depends on: 1309184

Updated

3 years ago
Depends on: 1276363

Updated

3 years ago
Depends on: 1315885

Updated

3 years ago
Depends on: 1317658

Updated

2 years ago
Depends on: 1319342

Updated

2 years ago
Depends on: 1325279

Updated

2 years ago
Depends on: 1326028

Updated

2 years ago
Depends on: 1331334

Updated

2 years ago
Depends on: 1331341

Updated

2 years ago
Depends on: 1334043

Updated

2 years ago
Depends on: 1334044

Updated

2 years ago
Depends on: 1121994

Updated

2 years ago
Depends on: 1334051

Updated

2 years ago
Depends on: 1340027

Updated

2 years ago
Depends on: 1347446

Updated

2 years ago
Depends on: 1348220

Updated

2 years ago
Depends on: 1351979

Updated

2 years ago
Depends on: 1352290

Updated

2 years ago
Depends on: 1354013

Updated

2 years ago
Depends on: 1357002

Updated

2 years ago
Depends on: 1359346

Updated

2 years ago
Depends on: 1374912

Updated

2 years ago
Depends on: 1377143

Updated

2 years ago
Depends on: 1378079

Updated

2 years ago
Depends on: 1378265

Updated

2 years ago
Depends on: 1379573

Updated

2 years ago
Depends on: 1392974

Updated

2 years ago
No longer depends on: 1392974

Updated

2 years ago
Depends on: 1396761

Updated

2 years ago
Depends on: 1396765

Updated

2 years ago
No longer depends on: 1396620

Updated

2 years ago
Depends on: 1406297
Depends on: 1406825

Updated

2 years ago
Depends on: 1406325
Depends on: 1410536

Updated

2 years ago
Depends on: 1413785

Updated

2 years ago
Depends on: 1414317
Depends on: 1415761

Updated

a year ago
Depends on: 1419295
Depends on: 1419305
Depends on: 1419662
Depends on: 1419902
Depends on: 1420178
Depends on: 1419803
Depends on: 1419799
Depends on: 1421180
Depends on: 1421831
Depends on: 1421833
Depends on: 1341693
No longer depends on: 1419799
No longer depends on: 1421831
Depends on: 1425079
Depends on: 1425400
Depends on: 1428244
Depends on: 1428246
No longer depends on: 1419803
Depends on: 1428784
Depends on: 1430034
No longer depends on: 1421833
No longer depends on: 1276363
No longer depends on: 1377143
No longer depends on: 1317658
No longer depends on: 1421180
No longer depends on: 1378265
No longer depends on: 1420178
No longer depends on: 1428784
Depends on: 1441029

Updated

a year ago
Depends on: 1443722

Updated

a year ago
Depends on: 1440382

Updated

a year ago
Alias: custom-elements
Depends on: 1452608
Depends on: 1452615

Updated

11 months ago
Depends on: 1462806

Updated

10 months ago
Priority: -- → P3

Updated

10 months ago
No longer depends on: 1374912

Updated

10 months ago
Blocks: 1471948
Depends on: 1475332
Depends on: 1477008
Depends on: 1477023

Updated

9 months ago
No longer depends on: 1477008

Updated

8 months ago
Depends on: 1480618
Depends on: 1502814

Updated

5 months ago
No longer depends on: 1502814

Comment 12

5 months ago
(In reply to Olli Pettay [:smaug] (high review load) from bug 1205323 comment #33)
> I'm marking this fixed, since this was really a tracking bug for shipping.
> Bug 1438607 is new things and tracking for regressions and such.
> Perhaps bug titles should be changed a bit.
Alias: custom-elements → custom-elements-initial-release
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Summary: Implement Custom Elements (from Web Components) → [meta] Implement Custom Elements (from Web Components)
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.