Closed Bug 179176 Opened 18 years ago Closed 18 years ago

b.m.o upgrade regressions meta-bug

Categories

(mozilla.org Graveyard :: Server Operations, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: myk, Assigned: myk)

References

Details

(Keywords: regression)

This bug tracks regressions on bugzilla.mozilla.org caused by the recent upgrade.
Alias: bmo-regressions
Status: NEW → ASSIGNED
Keywords: regression
QA Contact: myk → endico
Depends on: 179174
Depends on: 179183
Depends on: 179184
Depends on: 179203
Nominations:

Bug 179194 Custom front page has incorrect URL
Bug 179195 Remove blurb from top of b.m.o.
Bug 179199 Remove/change text at top of advanced bug entry form
Bug 179201 There are two has-review flag types
Bug 179202 Flag types should not be prefixed "has"

Gerv
No longer depends on: 179203
Depends on: 179205
More nominations:

Bug 179206 enter_bug isn't picking up version from URL
Bug 179207 Blessing doesn't work right

Gerv
Adding all of Gerv's regressions and other issues.
Hi,
The advanced is no longer advanced it is the regular (basic) bug reporting page
and I am mad about it. I am a loyal user to the advanced bug reporting pages and
it is gone. This needs to be fixed.
Bryan: that page is now compulsory for all those without the "canconfirm"
Bugzilla privilege - the lowest level of privilege. This is to make sure that
new contributors file good bugs. If you feel you know how to file good bugs,
then apply for the "canconfirm" permission. One place you can read how to do
that is on http://www.gerv.net/hacking/before-you-mail-gerv.html , but there
should be an official document somewhere.

Gerv
hrm. Getting to the advanced bug report form requires you to log in though.
Which I usually do when submitting and getting the request to log in.
Depends on: 179225
searching by commenter (longdesc) seems to be ignored if you do "exact" or
"contains".  "matches regexp" seems to work.
No longer depends on: 179225
" Reassign bug to ownerand QA contact of selected component "

notice the missing space between "owner" and "and".
oops, noticed too late that the missing space was alraedy reported as bug 179225
maybe this bug should depend on it?
Depends on: 179225
Andrew Shultz' comment tracked as bug 179238.

Gerv
Depends on: 179238
Bug 179225 is present in 2.16 as well, it is not a regression.

Bug 179207 is a confusing UI now that we tell people what groups they can bless.
 That is newly confusing, but only as confusing as it would ever have been had
someone with editusers privs done editusers on themselves.  

This is not a regression per se, but the page at
http://bugzilla.mozilla.org/flag-help.html seems incorrect... Specifically, the
'?' flag value is not present in the dropdowns and there's no textfield in which
to enter the name of the person you want to review....
Filed bug 179242: Searching for comment contains string + email gives "Not
unique table/alias: 'longdescs_' at globals.pl line 242"

(workaround anyone ?)
Depends on: 179242
Adding 178984, which was supposed to go in before the upgrade but got overlooked.
Depends on: 178984
Adding bug 179236 about a UI issue in the request tracker.
Depends on: 179236
Is it true that I can no longer change my default query without searching?

I also can't get commenter matches exact searches to work.
Depends on: 179260
Axel, re comment #6, filing a bug requires you to log in anyway...

Comment searches seem broken (we're not adding any constraint to the joined
table...), rkaa told me about it lkast night, but I don't know if she filed a
bug. I'll look, and file one if not
comment search breakage is bug 179238.

bz: myk hasn't turned requesting on yet from mozilla; we're shaking out the bugs
in the bugzilla product first
It's not quite fair to call bug 179264 a regression since the feature never
existed before, but it should be in this group of 2.17.1 last-moment-fixes anyway.
Depends on: 179281
> Is it true that I can no longer change my default query without searching?

Yes. Is changing your default query something you do often? :-) Anyway, you can
always close the browser window if you don't want the results.

Gerv
Depends on: 179290
Depends on: 179298
No longer depends on: 179290
Depends on: 179309
filed bug 179321, cannot clear status whiteboard
Depends on: 179321
Is it correct for me not to be able to add quips?  If not, that is a regression.
Tahts not a regression; bmo has had that off for ages. It just never used to
give you an error, I think There may have been a cryptic one.
Depends on: 179264
Depends on: 179334
Depends on: 179351
Quoting, "Note: Bugzilla has been upgraded. Regressions are being tracked in
meta-bug 179176." Can someone tell me what a regression is and what a meta-bug
is? Or point me somewhere to learn?
A regression is something which used to work but now doesn't. A meta-bug is a
bug which isn't a bug report in itself, but it used for keeping track of a list
of other bugs (see the list of dependencies.)

Gerv
Depends on: 179290
quips are no longer shown on searches. i can no longer add quips either.
RE Comment #26, this is intentional (see bug 179327, comment 1).
No longer depends on: 179309
> quips are no longer shown on searches.

Tracked as bug 179462.

Gerv
Depends on: 179462
>> Is it true that I can no longer change my default query without searching?
>Yes. Is changing your default query something you do often? :-) Anyway, you can
>always close the browser window if you don't want the results.

No, but as my default query would return all visible bugzilla bugs, I'm worried
that changing it will slow down b.m.o
> No, but as my default query would return all visible bugzilla bugs, I'm worried
> that changing it will slow down b.m.o

Running it once isn't that big a deal. If you close the connection, it stops
running anyway, because we catch the signal and terminate.

Gerv
Why do you have a query which will return all bugs???
I presume he means that it does a longdescs-related search, and so will be hit
by bug 179238.

Gerv
No longer depends on: 179351
I just re-cvs upped b.m.o, so if your problem was reported fixed before now, it
should be fixed on b.m.o as well.  If not, reopen the bug report for your problem.
Depends on: 179491
No longer depends on: 179495
Why is it now impossible to find a simple search form? If the advanced bug
reporting form has been removed so that new users don't get confused, why make
it so difficult to find bugs? To do a simple search I'm currently resorting to
starting to report a bug and using the search box there. This is bad. .... Oh,
no, it's worse. I just went to the "report a bug" form and tried to search from
it and the search failed saying that I was trying to search from the sidebar. No
I wasn't.

I'd second that. The simple search is very useful if you just have a bug number,
or if you remember a few words from the subject of a bug, but can't quite
remember which bug it was. The query page is overkill for a simple job.
The simple search has been briefly disabled while we track down a strange issue
with recent Mozilla builds, which appear to be redirecting standard search
queries to the simple search mechanism, which is thrashing Bugzilla.

Gerv
The problem gerv mentioned where standard search queries seem to be redirected
to the simple search mechanism is not a recent problem. I've looked in logs
all the way back to march and they're full of queries that look like they
should have been run on google.

The current theory is that the recent slowness is due to the fact that we're
now forcing newbies to use the bug helper, which also uses simple search and
therefore there are a lot more simple searches going on than before.

see bug 179500 for more info
Depends on: 179500
Depends on: 179608
Added bug 179706. There are far too many non-unique usernames not to fix this.
Depends on: 179706
Depends on: 179734
Can you protect submitter's e-mail addresses from SPAM harvesters?  I have had
to change my e-mail to try and prevent SPAM only to start receiving it again a
few weeks later.  Perhaps you should mask the e-mail addresses using a scheme of
some sort.  Suggestion "Submitter: john (at) somewhere.com".
JavaScript bug:

Line 111,
"document.forms.f.id is null or not an object"

URL: http://bugzilla.mozilla.org

Platform:  Windows NT 4.0 SP6, IE 6 SP1

More on Javascript problem.

Cause:

The form 'f' has been commented out.  Thus, there is no form element to take 
focus.

Solution:
comment out line 111.
Where has the search box on http://bugzilla.mozilla.org gone????
The bugzilla helper, whilst still linked to on http://bugzilla.mozilla.org , is
not shown clearly at the top of the page - ie. new users may use the advanced
bug reporter without realising it and so write less effective bug reports.
comments 40-32: YEs, quicksearch is temporarily disabled - see bug 179500.

Max: New users can't use bugzilla helper - if you don't have canconfirm you're
automatically forced to use teh helper. We should probably drop the '(advanced)'
text, though. myk?
don't drop the link to the 'advanced' bug entry form. that will
mess up advanced users who use that link.
endico: I meant that we shold drop the _word_ advanced, since that link now will
go to the bugzilla helper with people w/o canconfirm, so its no longer true that
thats the 'advanced' way to file bugs.

As it is, its just confuising people who know that they don't want the advnaced
version of anything
That page is a template.

Put a conditional in the template, and don't even show the link if the user
doesn't have "canconfirm".  That'll solve the problem without removing the link
for the people that are capable of using it.

Or, to help drive the point home, you could put "Advanced bug entry form
(disabled)" there, unlinked, if they don't have canconfirm.
http://bugzilla.mozilla.org/show_bug.cgi?id=98546

This bug shows the wrong "Opened:" date:

>Opened: 2001-09-06 10:28

It was opened in 1999-10. I don't remember having seen this before, so it
*might* be because of the new Bugzilla. Since I'm not sure, I'm not filing a
separate bug yet.
> It was opened in 1999-10.

Er... I think not. Not unless the opened dates on bug 98545:
 Opened: 2001-09-06 10:24
and bug 98547:
 Opened: 2001-09-06 10:32
are similarly wrong.

:-)

Gerv
you're missing the fact that the top comments were copied from an earlier bug -
see the real comnent #1. I'm not sure why it was moved; somebody probably put a
confidential comment in there, or something. I have this vague recolection of
several bugs having that happen to them at some point.
Not sure if this appropriate here : 
Using Moz or IE6 and checking for BUGS FILED TODAY i see bug 179920 marked as
NEW, whereas i already marked it as a duplicate.

Can't be a cached page, because this was the first time ever that i looked at
bugzilla using IE.
as to comment 51 : duped that particular bug at 2002-11-13 07:50, didn't show up
as DUPED until after 2002-11-13 07:58. Is that the time it usually takes?
regarding comment 51 and 52, 10 minutes is reasonable, yes.  That's better than
it has been at times in the past (I've seen it an hour or two behind at times in
the past).  Bugzilla is using two databases -- a master, and a slave -- to cut
down on lock contentions.  All queries via buglist.cgi are run against the slave
database.  Changes to bugs are done to the master, then propogated to the slave
as extra CPU cycles allow.
Depends on: 179960
> Why do you have a query which will return all bugs???

It was the system default query but without even the restriction on status.

I've worked around the problem by specifying an email address without actually
specifying why I've specified an email address, so I've now changed my default
query order to bug id because last changed data queries still don't work.
Depends on: 180176
Depends on: 175116
No longer depends on: 175116
unable to mark bug as WFM (see bug 155138) I marked teh priority as P3, entered
a comment as to why I was marking it wfm, selected wfm and then submit. An error
page was displayed:
Bug processed
 

Bugzilla has suffered an internal error. Please save this page and send it to
endico@mozilla.org with details of what you were doing at the time this message
appeared.

URL: http://bugzilla.mozilla.org/process_bug.cgi
A legal Version was not set.

Variables:
  
the bug initially stated the version as other, when I did a shift reload it
changed to trunk, once that happened I was able to process the bug
beppe: that was a matter of bad timing.  Hixie just changed the version list for
Browser and happened to remove the "other" version from the list.  It got
removed after you loaded the page but before you submitted.
I have had it.  How do I stop the e-mails from coming.  I know the answer
already.  Help.  I received 30 e-mails from you today. Please stop.  Help. This
is harasment. Is there some way I can shut this off?  Help Help.

Dave....
you can change your email preferences at
http://bugzilla.mozilla.org/userprefs.cgi - by default you get mail when you
vote, report, are on the cclist, etc for a bug
Depends on: 180281
Depends on: 180296
Re <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=bmo-regressions#c39">Comment
39</A>: It would certainly be best to hide real e-mail addresses in some
fashion, as they're archived all across the web. 

I received my first piece of unpleasant Spam in my shiny new mail account today,
and thanks to the wonders of sneakemail.com am able to verify it came from the
address I use to post to bugzilla. Boo.
Re Comment #5, I don't want to be able to confirm, but I do want to be able to
use the advanced bug filing page. I request a new priviledge level to allow
that. I would think there's a few other experience bug-filers out there as well,
who have no interest in confirming bugs.
Depends on: 180518
No longer depends on: 180518
I do not have time to check this page everyday so I want comments e-mailed to me.
Component: Server Operations → NSPR
Product: mozilla.org → NSPR
Fixing Bryan's goof
Component: NSPR → Server Operations
Product: NSPR → mozilla.org
I don't know if this qualifies as a regression, so start your flamethrowers. 
Bug 134571 changed <map>, and it's not working at this point.  Yeah, it's just
just acting like <a href=query.cgi><img></a> when I hit my 2.16.1 Bugzilla with
my moz1.1 (20020826).

Ask me some questions.  At this point, I have NO IDEA what information I can
give to help describe or track this thing.  And hey, if this isn't a regression
per se, then I'll accept flames ... written in swahili.
No longer depends on: 179500
No longer depends on: 179199
No longer depends on: 180296
I am assuming this  is a regression bug...

In 1.2beta I created about 5 user profiles in the "Mozila Profile Manager", but
I can now only see 2 of them in the "Available Profile" section.  I am running a
Red Hat 8 Linux distribution.

I am on a slow connection, so it is not practical for me to try out nightly
builds, but I am happy to suplly more info if that will help.
that would be a regression in Mozilla, not in bugzilla.mozilla.org.  it doesn't
belong here.
When I added bug 180951 comment 2, bugzilla added two keywords "topembed,
regression" to the bug, which definitively were not entered by me.
I removed the keywords with comment 3. Please let me know if you think this
sounds like a bugzilla regression and I should file a bug.
kaie: There have been reports about this happening if you add a keyword from the
enter_bug. I think timeless filed a bug on that.
Depends on: 180978
Depends on: 180980
Nominate bug 181900 (misspelling a cc name then hitting Back loses comments and
cc field).
Can this bug be resolved now that all dependencies are resolved?
Yes, although note that not all regression fixes have made it to b.m.o yet (I
think).
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Alias: bmo-regressions
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.