Last Comment Bug 22529 - [FEATURE] Keyboard shortcuts
: [FEATURE] Keyboard shortcuts
Status: VERIFIED FIXED
: meta
Product: Core
Classification: Components
Component: Keyboard: Navigation (show other bugs)
: Trunk
: All All
: P1 normal with 8 votes (vote)
: Future
Assigned To: Chris McAfee
: sairuh (rarely reading bugmail)
Mentors:
http://bugzilla.mozilla.org/showattac...
: 10132 16280 17340 21959 21989 22008 22471 22975 23016 23766 24128 25197 26373 28651 30964 31625 31864 33288 33297 34004 35187 36865 37851 38681 39038 43166 46676 61321 (view as bug list)
Depends on: 18768 51418 51597
Blocks: 2674 10132 16280 17340 21959 21989 22008 22471 22975 23016 23766 24128 25197 fishcam 25973 26373 28651 30431 31625 31864 36922 59538
  Show dependency treegraph
 
Reported: 1999-12-23 05:29 PST by don
Modified: 2003-09-28 08:53 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
latest status of keyboard shortcuts (6.27 KB, text/html)
2000-02-25 15:37 PST, sairuh (rarely reading bugmail)
no flags Details
Accelerators Spec (18.94 KB, text/html)
2000-08-22 10:13 PDT, jglick
no flags Details
Keyboard nav spec. (87.35 KB, text/html)
2000-08-28 15:02 PDT, Lakespur Roca
no flags Details

Description don 1999-12-23 05:29:06 PST
Chris, this is a place holder to make sure we get all the menu, dialog, and
other special keyboard shortcuts working.  Please file all other exisiting and
new broken keyboard shortcut bugs as a duplicate of this bug.  Let's just track
the whole mess here.
Comment 1 don 1999-12-23 05:34:59 PST
*** Bug 16280 has been marked as a duplicate of this bug. ***
Comment 2 don 1999-12-23 05:36:59 PST
The keyboard shortcut for opening a file "Ctrl|Alt-O" does not work.  See bug
#16280.
Comment 3 don 1999-12-23 05:38:59 PST
*** Bug 21959 has been marked as a duplicate of this bug. ***
Comment 4 don 1999-12-23 05:39:59 PST
Keyboard shortcuts in the "Go" menu do not work.  See bug #21959.
Comment 5 don 1999-12-23 05:40:59 PST
*** Bug 10132 has been marked as a duplicate of this bug. ***
Comment 6 don 1999-12-23 05:42:59 PST
The spacebar does not page down when not focused in a text entry area.  See bug
#10132.
Comment 7 don 1999-12-23 05:49:59 PST
Hmmmm, on second thought the spacebar not paging down may be part of the
keyboard navigation placholder bug #2674.
Comment 8 don 1999-12-23 05:56:59 PST
*** Bug 17340 has been marked as a duplicate of this bug. ***
Comment 9 don 1999-12-23 05:58:59 PST
The keyboard shortcut for find in page "Ctrl|Alt+F" doesn't work either.  See
bug #17340.
Comment 10 don 1999-12-23 06:02:59 PST
*** Bug 21989 has been marked as a duplicate of this bug. ***
Comment 11 don 1999-12-23 06:03:59 PST
The keyboard shortcut to access prefs "Ctrl|Alt+E" doesn't work.  See bug
#21989.
Comment 12 Paul MacQuiddy 1999-12-23 09:24:59 PST
sairuh is the queen of keyboard shortcuts
Comment 13 Chris McAfee 1999-12-23 23:14:59 PST
*** Bug 22008 has been marked as a duplicate of this bug. ***
Comment 14 Colin Blake 2000-01-03 08:14:59 PST
*** Bug 22471 has been marked as a duplicate of this bug. ***
Comment 15 don 2000-01-04 10:22:59 PST
*** Bug 22975 has been marked as a duplicate of this bug. ***
Comment 16 sairuh (rarely reading bugmail) 2000-01-04 14:37:59 PST
spam: added dup'd bug numbers as dependants so they don't fall off my radar when
this umbrella bug is fixed. ;-)
Comment 17 sairuh (rarely reading bugmail) 2000-01-05 19:37:59 PST
*** Bug 23016 has been marked as a duplicate of this bug. ***
Comment 18 Chris McAfee 2000-01-25 11:43:21 PST
*** Bug 23766 has been marked as a duplicate of this bug. ***
Comment 19 don 2000-01-27 18:25:19 PST
*** Bug 25197 has been marked as a duplicate of this bug. ***
Comment 20 don 2000-01-31 17:43:49 PST
*** Bug 25973 has been marked as a duplicate of this bug. ***
Comment 21 Sitsofe Wheeler 2000-02-08 11:22:35 PST
*** Bug 24128 has been marked as a duplicate of this bug. ***
Comment 22 Christine Begle 2000-02-21 13:04:51 PST
*** Bug 28651 has been marked as a duplicate of this bug. ***
Comment 23 Christine Begle 2000-02-21 13:05:32 PST
ESC key should stop loading a page - see #28651
Comment 24 Chris McAfee 2000-02-24 18:08:53 PST
m15
Comment 25 sairuh (rarely reading bugmail) 2000-02-25 15:37:29 PST
Created attachment 5771 [details]
latest status of keyboard shortcuts
Comment 26 leger 2000-03-08 14:21:36 PST
*** Bug 26373 has been marked as a duplicate of this bug. ***
Comment 27 Doron Rosenberg (IBM) 2000-03-15 05:57:13 PST
*** Bug 31864 has been marked as a duplicate of this bug. ***
Comment 28 Gervase Markham [:gerv] 2000-03-23 06:32:09 PST
Adding these from Bug 31625:

ESC (stop page loading/stop animations)
CTRL-F - Find in Page
CTRL-M - Add to bookmark
CTRL-G - Find Again/Find Next Occurrance

Gerv
Comment 29 Gervase Markham [:gerv] 2000-03-23 06:32:12 PST
*** Bug 31625 has been marked as a duplicate of this bug. ***
Comment 30 Gervase Markham [:gerv] 2000-03-25 15:53:39 PST
Copied from Bug 33297:

ALT-{1,2,3}: Open a browser/mail/composer window
BACKSPACE: Scroll up by a page (like the PGUP)

Updated list of dependents.

Gerv
Comment 31 Gervase Markham [:gerv] 2000-03-25 15:54:14 PST
*** Bug 33297 has been marked as a duplicate of this bug. ***
Comment 32 Gervase Markham [:gerv] 2000-03-27 04:08:59 PST
Copied from bug 33288:

When entering text in form elements the following standard keys don't 
work:

ctrl+home: Go to start of first row
ctrl+end: Go to end of last row
ctrl+shift+home: Go to start of first row while selecting
ctrl+shift+end: Go to end of last row while selecting
ctrl+backspace: Delete from cursor position to beginning of word before cursor
ctrl+delete: Delete from cursor position to end of word after cursor

Gerv
Comment 33 Jonas Sicking (:sicking) No longer reading bugmail consistently 2000-03-29 11:53:52 PST
*** Bug 33288 has been marked as a duplicate of this bug. ***
Comment 34 Matthew Paul Thomas 2000-04-05 07:39:57 PDT
Aren't all those dependencies on the wrong side of the dependency tree ...?
Comment 35 don 2000-04-05 13:39:30 PDT
Move to M16 for now ...
Comment 36 Blake Ross 2000-04-08 19:39:49 PDT
*** Bug 35187 has been marked as a duplicate of this bug. ***
Comment 37 Kevin Hecht 2000-04-23 10:38:46 PDT
*** Bug 36865 has been marked as a duplicate of this bug. ***
Comment 38 Jonas Sicking (:sicking) No longer reading bugmail consistently 2000-04-24 23:15:56 PDT
Pressing ctrl+enter in the url-field in the browser should add 'http://www.' 
before the entered text and '.com/' and then load the entered url. So to load 
altavista you just:
1. enter 'altavista' in url field
2. press ctrl+enter
3. done!

I know mozilla will try http://www.altavista.com automaticly, but it will try 
to load http://altavista/ first which gives an annoying delay. Autocompleat 
will not fix this either since it might be a site you havn't visited before.
Last but not least reason; IE does this :)
Comment 39 Matthew Paul Thomas 2000-04-26 21:15:13 PDT
No, that assumes that the majority of Web sites are for US or multinational 
companies (.com). That may be true now, but it might look very silly in a couple 
of years as the rest of the world catches up in Internet use. (BTW, for AltaVista 
you don't need to type `altavista', you can just type `av'. That would probably 
more than compensate for the additional slowness from checking
<http://altavista/> first ...)
Comment 40 Stanton McCandlish 2000-05-01 19:59:58 PDT
> Pressing ctrl+enter in the url-field in the browser should add 'http://www.' 
> before the entered text and '.com/' and then load the entered url.

This is definitely platform specific, at least with ref. to IE ("IE does this 
:)").  Mac IE does no such thing. Not with Ctrl-Enter or Cmd-Enter (the former 
is treated as same as Enter, the latter does nothing at all!)  On the Mac side, 
in IE if you just enter "altavista" in the address bar and hit enter, it does 
just what this guy wants (expands it automagically to http://www.altavista.com) 
right on the spot.  So, I guess a better way to think of all this stuff, is to 
look at the behavior of browsers on each platform and do the most sensible, 
useful and expected thing for that platform.  Right now IE defaults to adding 
www to the front and .com to the end, and as long as you understand this, it's 
pretty sensible and often useful.  I agree that in a few years this may not be 
true, esp. if the TLD space is thrown open to .biz, .firm, .whatever.  Kind of a 
tossup.  Anyway, my point was just that making Ctrl-Enter do this, cross 
platform, doesn't make much sense, because Ctrl-Enter is basically completely 
meaningless to anyone not using Windows.  These kinds of things (along with 
stuff I submitted earlier elsewere, about Home and End keys, for example) is 
highly pla
Comment 41 Stanton McCandlish 2000-05-01 20:02:55 PDT
*** Bug 37851 has been marked as a duplicate of this bug. ***
Comment 42 Stanton McCandlish 2000-05-01 20:03:37 PDT
*** Bug 37851 has been marked as a duplicate of this bug. ***
Comment 43 Jonas Sicking (:sicking) No longer reading bugmail consistently 2000-05-02 01:06:02 PDT
we can't add "www." and ".com" if the entered url contains only one word since 
there are some LAN that has DNS names containing only one word. I can see the 
point that some keybindings are platform dependent, but that dosn't mean that 
they are unneeded.
I still think there would be useful to have some functionality for easy access 
to urls like www.YourCompanyNameHere.(com/org/de/se) but that should be filed 
that as bug 37867.
Comment 44 Matthew Paul Thomas 2000-05-02 07:00:40 PDT
From bug 34004 and elsewhere: both Home and Ctrl+Home to go to the start of the 
document/text field, and both End and Ctrl+End to go to the end of the document/
text field.
Comment 45 Matthew Paul Thomas 2000-05-02 07:02:35 PDT
*** Bug 34004 has been marked as a duplicate of this bug. ***
Comment 46 Jonas Sicking (:sicking) No longer reading bugmail consistently 2000-05-03 14:57:04 PDT
On the windows platform the standard behaviour is:
Home:      start of line
Ctrl+Home: start of document/field
End:       end of line
Ctrl+End:  end of document/field

(btw it causes a real mess that the dependency-tree is backwards on this bug:( )
Comment 47 Claudius Gayle 2000-05-03 14:59:43 PDT
*** Bug 30964 has been marked as a duplicate of this bug. ***
Comment 48 sairuh (rarely reading bugmail) 2000-05-04 18:04:24 PDT
from bug 37851: add Cmd+. (Command-period) to stop page loading.
Comment 49 rubydoo123 2000-05-09 19:16:06 PDT
*** Bug 38681 has been marked as a duplicate of this bug. ***
Comment 50 hacksaw 2000-05-12 02:41:19 PDT
Someone ought to expand the keyword list for this bug to include
"hot keys", "shortcuts", "alt" and maybe a few other things. This would cut down
on duplicate entries like the one I just posted.
Comment 51 Hugh Kennedy 2000-05-12 05:55:40 PDT
*** Bug 39038 has been marked as a duplicate of this bug. ***
Comment 52 Jeremy M. Dolan 2000-05-12 09:16:32 PDT
Regarding the "www." and ".com" stuff, please see bug 37867 and the comments 
there for the reasons this is not a good idea. Also see the workaround, the 
keywords for bookmarks.
Comment 53 sairuh (rarely reading bugmail) 2000-05-12 15:11:14 PDT
*** Bug 29348 has been marked as a duplicate of this bug. ***
Comment 54 sairuh (rarely reading bugmail) 2000-05-12 15:13:42 PDT
from bug 29348: shortcuts for the Go menu items don't work: Back
(alt/cmd/ctrl+[), Forward (alt/cmd/ctrl+]), and Home (alt/cmd/ctrl+H).
Comment 55 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2000-05-12 15:41:55 PDT
Nominating for nsbeta2 because bug 29348 was marked as a duplicate of this bug,
and this seems to be a tracking bug by marking as duplicates rather than using
dependencies (which seems more sensible to me). 
Comment 56 Peter Trudelle 2000-05-15 14:05:07 PDT
[nsbeta2-] for the kitchen sink, please nominate any specific broken shortcuts 
as individual bugs for separate consideration.
Comment 57 Gervase Markham [:gerv] 2000-05-22 09:46:10 PDT
*SPAM* - adding mostfreq keyword to bugs with loads of DUPEs. Please aid this 
effort by adding this keyword to any bugs with more than 15 DUPEs.

Gerv
Comment 58 Marko Macek 2000-05-23 06:11:38 PDT
from bug 39038: alt+left arrow and alt+right arrow should work as back/forward.
Comment 59 don 2000-05-25 16:14:36 PDT
Move to M20 target milestone.
Comment 60 Gervase Markham [:gerv] 2000-05-27 15:23:02 PDT
Adding in bug 18768.

Gerv
Comment 61 Andrew McMillan 2000-05-28 12:46:34 PDT
Alt+R for 'Reload Page' is missing.  This is _really_ useful when developing
pages as I am refreshing all the time.
Comment 62 Matthew Paul Thomas 2000-05-28 15:41:16 PDT
... That would be Ctrl+R, rather than Alt+R, for reload. See bug 22515.
Comment 63 Sean Richardson 2000-06-20 09:48:30 PDT
*** Bug 43166 has been marked as a duplicate of this bug. ***
Comment 64 sairuh (rarely reading bugmail) 2000-06-20 10:59:12 PDT
forgive the spam: moving to the new Keyboard Nav component, where this belongs.
:-)
Comment 65 Chris McAfee 2000-06-21 08:32:38 PDT
Adding spec URL, sorry it's internal-only, yell at the UI people.
Comment 66 Matthew Paul Thomas 2000-06-21 20:38:43 PDT
See also the Aphrodite keyboard spec, which is (ahem) publicly available, albeit 
slightly incomplete:
<http://critique.net.nz/project/mozilla/general/interface/keys/>.
(Don't try to read it using 4.x, use Mozilla.)
Comment 67 exp 2000-06-26 12:29:33 PDT
What about holding SHIFT while clinking on a link to open it in
a new window? IE does this. And I think it is really usefull.
Comment 68 beryan 2000-06-26 15:44:09 PDT
"Open In New Window" left-click modifier... what a great idea!
I can't speak for anyone else, but include it, document it, and I'll use it :)
Comment 69 Andrew McMillan 2000-06-26 15:51:17 PDT
I've always been keen on Netscape's 'centre-click' to open in a new window.  Now
that you often can centre-click in Windows perhaps this could even be made 
cross-platform?
Comment 70 Sean Richardson 2000-06-26 16:05:43 PDT
Regarding the last three comments: the existing bug 12056, "[FEATURE] Click link 
with key modifier and open URL in new chromed window", is where that discussion
belongs. You may want to add votes, as it is in danger of being moved to the
"Future" milestone.
Comment 71 Stanton McCandlish 2000-06-29 17:24:08 PDT
Some platform-related remarks:

Someone asked for Shift-Click on a link to open it in another window. This must be a 
Windows thing. On Macs (every browser I've tested that has such a feature at all), it's 
Cmd-Click.

Likewise, someone wanted Ctrl- or Alt-R to reload.  On Macs it Cmd-R, and I certainly 
second the nomination for this being fixed.  Almost all browsers have a [Modifier Key]-R 
command for reloading, even Lynx does!  :-)  Very, very useful.  I don't see it even 
mentioned on the attachment that comes with this meta-bug, the chart listing all the key 
commands and their status.

Another minor but pesky problem is that pgup/pgdn don't seem to be working unless the 
focus is in the content area of the page.  If focus is in the URL entry navigation bar, 
pgup/pgdn don't work.  (And it's not like there would be any function of those keys in the 
URL entry area, since it's only a tiny portion of a page.)

Finally, I'd agree with the other commentator that suggested adding keywords like alt, 
control, ctrl, command, cmd, hotkey, hotkeys, shortcut, shortcuts, etc.  I didn't even know 
this uberbug existed for quite some time, and kept submitting new dupes...
Comment 72 Stanton McCandlish 2000-06-30 10:47:30 PDT
Noticed another keybinding issue - On a Mac, at least, hitting up-arrow when focus is 
a) in a one-line text-entry box, or 
b) on the top line of a multi-line text-entry box
should move cursor to beginning of line, and hitting down-arrow when
a) in a one-line text-entry box, or
b) on the bottom line of a multi-line text-entry box
should move cursor to end of line.

This is standard (Mac UI Guidelines-required, in fact) behavior for ALL applications under 
MacOS.

This problem applies to both the URL entry bar, and to form text-entry areas.


Also, I find that PgUp & PgDn do not work as expected (paging up and down) if the focus 
is in a text entry box in a form.  My take on this is that PgUp and PgDn should *always* 
scroll the current page, no matter where cursor focus is (even in form box, or in URL 
entry bar, or in a scrollable frame).  

Cmd-PgUp and Cmd-PgDn in MacOS (or Ctrl-PgUP and Ctrl-PgDn in Windows/*n*x) 
should scroll only current frame or text entry box (and jumpt to start/end of line under 
the conditions mentioned above for Up-Arrow and Dn-Arrow).  I argued elsewhere for 
PgUp/PgDn to move a frame up and down, not the window, if you are in a frame, but this 
actually strikes me as boneheaded on second thought. Much better for PgUp/PgDn to 
always do the same thing, and for a consistent & expected modifier key to move you 
within segments of a page, whatever those segments are.
Comment 73 Andrew McMillan 2000-07-07 03:58:39 PDT
A shortcut key command to view the source (Ctrl/Alt/Cmd + U in Netscape) to view
the source is a useful function for those of us actually developing dynamic
content pages.  I also love being able to do this in the Netscape e-mail client
to get to see the whole message 'in the raw'.

With this, and a shortcut to effect a 'reload', I will be able to use Mozilla
full time, and I will too :-)

I'm afraid I don't much mind _which_ key either of these are assigned to - I
press these so often I'd learn to like anything in about 1/2 an hour!
Comment 74 mozilla 2000-07-22 01:11:20 PDT
wouldn't it be beter to kill bug 18768 and ad it's content to this one?
i for one realy like the 
ctr-alt-t : for network activity
ctr-alt-s : for showing/hiding the status bar
keys they can provide you with a great deal of feadback when a window looks to 
be doing nothing
Comment 75 verah (gone) 2000-07-25 17:32:50 PDT
Nav triage team: [nsbeta3+]
Comment 76 Asa Dotzler [:asa] 2000-07-27 15:39:32 PDT
*** Bug 46676 has been marked as a duplicate of this bug. ***
Comment 77 gunther 2000-08-04 04:57:41 PDT
F5 should also reload page.
Comment 78 Daniel Veditz [:dveditz] 2000-08-09 13:05:32 PDT
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Comment 79 David Walser 2000-08-10 08:09:58 PDT
*PLEASE* don't forget the Ctrl-Alt-T open connections dialog as well as the rest
of this.  I believe this is already marked as bug <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=37693">37693</A>
Comment 80 Bill Law 2000-08-17 19:19:10 PDT
Chris, I think this can be P2'd if you like.
Comment 81 timeless 2000-08-20 18:59:47 PDT
Adding ue1 because i felt like it? akin to dveditz@netscape.com's 
nsbeta2/nsbeta3 keyword mass spams.
Comment 82 timeless 2000-08-20 19:21:48 PDT
mcafee@netscape.com it seems mpt's snipe at the non public nature of the url 
went unnoticed.  Please convince someone to publish this spec. Thank you.  
Comment 83 timeless 2000-08-20 19:48:34 PDT
mpt how about this spec from bug 22529? [Read the bug too, as usual the spec 
scares people].
Comment 84 sairuh (rarely reading bugmail) 2000-08-21 17:56:57 PDT
lake * jennifer, could we just attach (to this bug) the specs you wrote? namely:

keyboard accelerators:
http://gooey.mcom.com/client/5.0/specs/mail/Misc/Accelerators.html

keyboard navigation:
http://gooey.mcom.com/client/5.0/specs/keyboard/kybdnav2.htm

i don't understand why such info should be kept solely internally.
Comment 85 jglick 2000-08-22 10:13:26 PDT
Created attachment 13274 [details]
Accelerators Spec
Comment 86 jglick 2000-08-22 10:15:51 PDT
Accelerator spec is now attached. Lake can attach the navigation spec.

Lake and I do not have CVS check in rights. We are in the process of trying to 
get that. If someone would like to volunteer to post this spec on mozilla for 
us, that would be great.
Comment 87 Blake Ross 2000-08-22 10:17:33 PDT
I'll post it; let me know where you want it.
Comment 88 jglick 2000-08-22 11:33:00 PDT
Blake, if you could post it here: http://www.mozilla.org/projects/ui/netscape/
that would be great. Thanks.
Comment 89 Aaron Lehmann 2000-08-22 13:37:24 PDT
Alt-Right and Alt-Left seemed to be working in CVS a few weeks ago. Now it
doesn't seem to anymore :(.
Comment 90 Blake Ross 2000-08-22 17:05:42 PDT
Keyboard accelerator key spec now posted at: 
http://mozilla.org/projects/ui/netscape/accel_keys/index.html

Should I post the attached keyboard nav spec also?
Comment 91 Lakespur Roca 2000-08-22 17:32:20 PDT
I am even as I write this working on a revision. I will send it tomarow.
Comment 92 Lakespur Roca 2000-08-28 15:02:53 PDT
Created attachment 13637 [details]
Keyboard nav spec.
Comment 93 johng 2000-09-11 17:38:03 PDT
pdt:
nsbeta3- since we now how a series of individual bugs (thanks Lake for creating
those bugs) specing out precisely what we will implement for each component.
Comment 94 Francis Irving 2000-09-28 08:16:44 PDT
In Composer, if you Page Up and Page Down with the keyboard then the cursor
doesn't move, just the view.  So if you then move the cursor keys the page
"jumps"back to where the cursor is.  This is contrary to most editors, and it
makes it impossible to scroll up and down quickly without using the mouse.
Comment 95 Francis Irving 2000-09-28 08:19:30 PDT
Under Windows, Alt+Space does not work from the Navigator or Composer windows
(but curiously it does from the "view source" window - presumably because it has
no menu bar).

Alt+Space pops up the window manager's menu in all Windows windows.
Comment 96 Sean Richardson 2000-09-28 09:26:09 PDT
ALT+Space and ALT,Space not activating the MS-Windows control menu is the
subject of bug 19328, "[Windows] ALT+SPACEBAR is not activating control menu",
currently Future.
Comment 97 Jonas Sicking (:sicking) No longer reading bugmail consistently 2000-09-28 15:07:50 PDT
ctrl+shift+home and ctrl+shift+end for Windows still dosn't work. Keybindings 
seem to be correct but the functionallity is not...
Comment 98 don 2000-10-01 16:20:17 PDT
I'm moving this to the "Future" milesone because this is really just a tracking bug.
Comment 99 sairuh (rarely reading bugmail) 2000-10-02 12:54:44 PDT
...and since this *is* a tracking bug, any requests or bugs to implement
*specific* keyboard shortcuts should be filed as *separate* bugs. otherwise,
they're likely to not get looked at.

[in fact, i'm tempted to just resolve this one, just to reduce the clutter --esp
since individual bugs are more likely to get attention than an old tracking/meta
bug...]
Comment 100 sairuh (rarely reading bugmail) 2000-10-06 22:11:38 PDT
i've checked in Lake's keyboard navigation spec to the mozilla.org website:

http://mozilla.org/projects/ui/netscape/keyboard_nav/index.html

also cc'ing akkana and jag, who've been doing lotsa keyboard nav stuff 
(primarily linux-side), so that they can check out the specs/etc. (feel free to 
remove yourself, if this is too spammy for you. :)
Comment 101 Tom van Wietmarschen 2000-10-13 11:01:32 PDT
CTRL-right-arrow skips one word right in text fields, CTRL-left-arrow does nothing
(build ID 2000101221)
Comment 102 Kai MacTane 2000-11-07 14:41:21 PST
You are all going to hate me -- sorry I'm so late getting in on this. I'd like 
to request some behavior for the Bookmarks menu, to mimic Navigator 3.x. Why, 
you ask? Simple: it worked well.

In Navigator 3.x, Alt-B took you to the Bookmarks menu. From there, a single 
keystroke could open a sub-menu, or trigger a bookmark. And <EM>the user could 
select hir own hot-keys for bookmarks</em>. So, on my main Bookmarks menu, I 
have the item "Search &Tools" (with the hot-key bound to T to avoid conflict 
with other stuff), and the Search Tools menu contains (among other things) 
"Yahoo" and "Yahoo &Maps". So I can instantly get to Yahoo by pressing Alt-B, T, 
Y, and I can get to maps.yahoo.com by doing Alt-B, T, M. Even though the bookark 
entry titles both start with "Yahoo", I don't have to scroll around with the 
arrow keys.

This behavior really makes navigating a large and deeply-nested bookmark file a 
lot easier, and is so important to me that I still use 3.x as my primary 
browser, simply because no other version of Netscape (or IE) has this behavior. 
NN 4.x won't let me choose my own hot-keys, and that causes catastrophes for 
naming the bookmarks.

I realize this may be a somewhat complex behavior to include, especially at this 
point, and I'll totally understand if it has to be marked "FUTURE". But I'd love 
to see it at least get on the to-do list.
Comment 103 timeless 2000-11-07 19:25:43 PST
Kai MacTane: This is a tracker bug, please file a new bug [RFE] for what you 
described, and then mark this bug as blocking your new bug.
Comment 104 christian boesgaard 2000-11-28 03:48:52 PST
*** Bug 61321 has been marked as a duplicate of this bug. ***
Comment 105 Blake Ross 2000-12-16 18:08:31 PST
I don't think there's any point in having this open to track 3 bugs, and it 
looks like people are just using it as a place to pile up requests for keyboard 
shortcuts (when there should be individual bugs for each).  Closing this out, 
unless someone is still really using it...
Comment 106 Jesse Ruderman 2000-12-16 20:03:57 PST
The bugs that are marked as duplicates of this bug have all been fixed (or are 
covered by other, open bugs).  Someone should go through the attachments and 
see what's still missing...
Comment 107 sairuh (rarely reading bugmail) 2000-12-21 13:46:27 PST
hokay, i'm verifying this. also cc'ing aaron [even though this is rather
old/stale meta bug], who's working on a new keyboard navigation spec.
Comment 108 Bill Mason 2003-09-28 08:46:48 PDT
*** Bug 220530 has been marked as a duplicate of this bug. ***
Comment 109 Bill Mason 2003-09-28 08:53:25 PDT
*** Bug 220533 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.