Tracking Drag and Drop bugs in bookmark manager and sidebar

VERIFIED FIXED

Status

Core Graveyard
Tracking
VERIFIED FIXED
16 years ago
a year ago

People

(Reporter: BesTo, Assigned: Pierre Chanial)

Tracking

({meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 obsolete attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011210
BuildID:    2001-12-10-10

When relocating a bookmark in a folder on the end of the folder, it goes not on
the end but one position above.

Reproducible: Always

Comment 1

16 years ago
Wfm on 2001121003, Win98.

Comment 2

16 years ago
I'm seeing a slightly more general issue on Win98 2001121003.  I can get the
same results for all/most bookmarks, not just the bottom.

The bookmark always seems to move to the position immediately above the correct
one.  If I close and reopen the folder, the position changes to what was intended.

Regression of bug 68547?

Comment 3

16 years ago
Bug 114256 sounds like the same issue, but when dropped to folders.

Comment 4

16 years ago
*** Bug 116076 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 117134 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Confirming based on duplicates.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
I'm also seeing this under Win98 Build 2001122106 (0.9.7) at home, but not under
Win2000 0.9.7 at work. Both were completely clean installations.

The only difference that I can think of between the two is that I imported my
bookmark list created in 0.9.5 into the fresh installation at work, while I'm
using the 0.9.7 generated bookmark file at home.

Comment 8

16 years ago
Scratch my last comment. The problem also exists in my installation at work,
though it is not always reproducable.

Some bookmark moves will work correctly, but at other times will not. On an
attempt to move a bookmark down one position, it will either not move, or it
will move down three positions from its previous spot. On an attempt to move a
bookmark up one position, it will either not move or it will move up three
positions from its previous spot.

I haven't seen any variation from the above behavior so far. Also, as noted in
comment #2, if the bookmark folder is closed, then opened, the locations of the
bookmarks seem to be correct for what was attempted.

Comment 9

16 years ago
*** Bug 120245 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I also get what is described in comment #8 paragraph 2 (2002-01-14, winNT&win98).

This bug should be KW: nsCatFood, nsBeta1, and mozilla0.9.8 (if still possible).
there are a few other bugs for bookmarks, with summaries about insertion, sort,
copy, move, delete.. and maybe a few others.  D&D didn't affect this, it existed
before the bookmarks-outliner landing which was from 12-05 to 12-10 and maybe,
just maybe be fixed for the better by way of patches to outliner w.r.t. indexing
for bug 119504.  There is also the issue of the insertion placement bar doesn't
affect the actual insertion point, there are two bars on the same line, one for
the folder you are under, and one outside the folder, in the save level.
Keywords: nsbeta1, nsCatFood
I thinking about changing this to a tracking bug based on my previous comment
and dupes.
Created attachment 65597 [details]
this bookmark  will be put on the bottom of the 118937

changes to bug 109504 helps outliner bookmarks.  see this and more attachments.
Created attachment 65599 [details]
this bookmark 118676 will also be put on bottom of  118937

notice the difference where the while line is shown.. I'm dragging bookmark
118676 and using insertion bar in white area is different then attachment
65597 [details].. this will be also be put below 118937
Created attachment 65601 [details]
this blue insertion bar is shown 118676 is going to insert above 118937
Created attachment 65603 [details]
bookmark 118676 will be also be put on top of bookmark 118937

see the white insertion bar shows where this will be put above 118937..
Created attachment 65604 [details]
save this as bookmarks.html and use a profile from build 1-17 or newer

try my bookmarks.html file as it will show you the problem and bookmarks
insertion/sorting/move are closer to fixed but I would think that the optimal
solution is if there is a bar between two things that is where is should go, be
it two folders, two bookmarks, or one of each, it should insert it there..
all open bookmarks link in bugzilla:

http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=&emailtype1=substring&emailassigned_to1=1&email2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id=&changedin=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&product=Browser&component=Bookmarks&short_desc=&short_desc_type=anywordssubstr&long_desc=&long_desc_type=allwordssubstr&bug_file_loc=&bug_file_loc_type=allwordssubstr&status_whiteboard=&status_whiteboard_type=allwordssubstr&keywords=&keywords_type=anywords&field0-0-0=noop&type0-0-0=noop&value0-0-0=&cmdtype=doit&order=%27Importance%27
*** Bug 69801 has been marked as a duplicate of this bug. ***
*** Bug 113660 has been marked as a duplicate of this bug. ***
*** Bug 113979 has been marked as a duplicate of this bug. ***
*** Bug 119879 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: mozilla1.0
Summary: relocating a bookmark in a folder → relocating a bookmark in manage bookmarks doesn't insert/sort/move/Drag & Drop properly

Comment 23

16 years ago
Uh, please add *Sidebar* too.

Current:
relocating a bookmark in manage bookmarks doesn't insert/sort/move/Drag & Drop
properly

NEW:
Relocating a bookmark in Sidebar and Manage Bookmarks doesn't insert  / sort /
move / Drag & Drop properly

Comment 24

16 years ago
Is this bug now covering all bookmark DnD issues? The bug I filed (bug 119879)
is quite differant (deals with folders/seperators) from the original comment
here, and has a clear way to reproduce.

If this bug is for all bookmark DnD issues, severity should be bumped and we
need to get this targeted. Bookmark Manager is practically useless as far as
sorting is concerned currently.
True, Jeremy, 

I think the way to go is to make furthur bugs depend on this one or duped.. and
turn this to meta, tracking, the problem is essentially the same as this, I
changed the summary, that is because we have not had a new bug for this yet..
and other changes to stuff like outliner keep morphing the problem which is not
fixed yet.. and since I seen chris lyon started refering to this bug.. It would
be far easier to meta track, dupe and depend bugs on this as a major severity. 
That way we can clear bugzilla of all the old problems, because all the bugs
refer to the same problem of bookmarks have some problem with
sorting/moving/inserting/D&D.. the steps to reproduce are have been hard to
figure out, now with the chris waterson's change to outliner sorting in bug
119504, I have come up with a valid testcase to go by with the latest morphed
incarnation.  other changed included bookmarks-outliner changed (plenty of bugs
from that after 12-05), and stuff before that it was broke, but you cannot keep
those open, as they have the same problem but the steps to reproduce are not all
valid so this outliner landing helps to fix the problem.. just sometimes it
still has issues with moving up/down from where you visually placed it and where
it is actually being dropped when moving them a few bookmarks away and moving
the bookmarks long distances in the list.

I hope this will finally get this problem licked.

reassigning to ben and adding testcase, meta to keywords, changing severity to
major to get this noticed.
Assignee: pchen → ben
Severity: minor → major
Keywords: meta, testcase

Updated

16 years ago
Depends on: 119879

Updated

16 years ago
No longer depends on: 119879
*** Bug 121241 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 27

16 years ago
I don't think bug 121241 is a dup of this one, since it is about the first D in
DND. It just reports that
between bookmarks (not folders), there are two positions for the insertion line
instead of one, independently of the result of the drop.
pierre, that is what is bug is now covering.. I knew I'd be smacking myself
after change this and not starting a new bug.. sorry.

um, See comment #25, regarding the testcase and attachments.
Also you are correct, you have the same thing, pasting:

Linux build 2002 01 21 21

During a drag and drop in the bookmark outliner, the insertion line appears at
two positions between items:
- just below the first item
- just above the second item (item is shifted, as reported)
Only one position should be needed for the insertion line.


(Assignee)

Comment 30

16 years ago
imho, Dennis, if one morphes a bug into a tracking bug, I think he/she should
not dupe specific issues against it, but should rather add dependencies in order
not to clutter the tracking bug and because a perfect 'move/sort/insert/drag'
complete single patch is not likely to happen.
Btw, you should also move this bug to the tracking component.
Status: NEW → ASSIGNED
Keywords: regression
Target Milestone: --- → mozilla1.0
*** Bug 122599 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 121241

Comment 32

16 years ago
Summary of the behavior I see with 2002020118 on Mac OS X:

Four bookmarks in a folder, A, B, C and D in that order, reset back to this
after moving anything.

Drag B down to the little underline just below C, and B moves below C (as expected).
Drag B down to the line halfway between C and D, and B moves below D.
Drag C up to the little underline just below A, and C moves above A.
Drag C up to the line halfway between A and B, and C moves above B (as expected).
Drag C up to the line above A, and C moves above A (as expected).

The line halfway between bookmarks is the one that visually looks better,
although it should probably be thicker and more obvious.

Comment 33

16 years ago
Mac  9.2.2 with build id 2002020103: most of my bookmarks are in Hebrew: I can
not drag and drop bookmarks at all- I get one big squer that holds all the
bookmaks, so I can not re-arrange indevidual one. Very annoying...
Note to developers: blake, ben, chris.. 

I created a new profile with Netscape 6.2.1 (0.9.4.1) release and I dont see
this problem with 2 insertion lines.. but after the bookmarks-outliner landing
there are the two insertion bars between text or actual bookmarks.. not sure
what kinda change occured wrt this but It appears to work better than current
nightlies.

Comment 35

16 years ago
Fix for those two lines already exists, waiting for reviews.
Bug 121241
xslf@yahoo.com,

about comment #33, file a new bug about that issue, and if you see the same
problem  using hebrew, mark it as a blocker to this bug, are your bookmarks IE
bookmarks?  then this would be the case that you wont be able to move them around.
(Assignee)

Updated

16 years ago
Depends on: 124599
(Assignee)

Updated

16 years ago
Depends on: 124600
(Assignee)

Updated

16 years ago
Depends on: 124601
(Assignee)

Updated

16 years ago
Depends on: 124602
(Assignee)

Updated

16 years ago
Depends on: 124603
(Assignee)

Updated

16 years ago
Depends on: 124604
(Assignee)

Updated

16 years ago
Depends on: 124605
(Assignee)

Updated

16 years ago
Depends on: 121245
(Assignee)

Comment 37

16 years ago
I added some dependencies in an attempt to atomize the problems. Jan, I filed
the outliner-related ones against you. Feel free to reassign to the default
assignee.

Comment 38

16 years ago
Is it just me, or does DnD in manage bookmarks in 0.9.8 seam darn nice? On my
self-built opt build bookmarks really end up where I drag them and I don't have
to collaps/expand a folder to see the changes take effect.

Who is responsible for this wonderful change?:-)
(Assignee)

Updated

16 years ago
No longer depends on: 124605

Comment 39

16 years ago
nsbeta1- per Nav triage team.
This is wfm on win2K and Linux, using today's builds.  Claudius, can you repro?
Keywords: nsbeta1 → nsbeta1-
Peter,

Chris's bug 119504 actually really cleaned up indexing in the bookmarks problem,
and Jan just did some changes to 121241 that fix some of the visual problems,
but  you can still reproduce this bug if you test real carefully.  Pierre
dropped in a few dependencies after Jan patch to bug 121241.  The dependency
bugs show that the problem is not really fixed .. the recent patch for bug
121241 helped hide the problem visually for dragging down, and bookmark
shifting.  You still can reproduce this and get the same effect as before, Jan
just made it more visually hard to reproduce.  Jan noted its not a complete fix,
so this bug still is valid with the dependency problems.  I agree jan and chris
really did do a good job working on this problem so far.

I might take a few more screenshots showing how jan's patch affected the
screenshots that exist here.  I'm undecided as of right now about where to place
those, in what bug.
(Assignee)

Comment 41

16 years ago
Peter, Claudius: see test case in bug 124603.
and please reconsider the nsbeta minussing of this bug.
(Assignee)

Comment 42

16 years ago
patch for the main DND problem is in bug 124603, waiting for reviews.
Target Milestone: mozilla1.0 → mozilla1.1

Comment 43

16 years ago
*** Bug 130702 has been marked as a duplicate of this bug. ***
Just adding Sidebar to Summary from Peter's comment #23.  As this affects
Sidebar as well.  
Summary: relocating a bookmark in manage bookmarks doesn't insert/sort/move/Drag & Drop properly → relocating a bookmark in sidebar and manage bookmarks doesn't insert/sort/move/Drag & Drop properly

Updated

16 years ago
Depends on: 128461
(Assignee)

Updated

16 years ago
Depends on: 119879

Comment 45

16 years ago
removing self from cc list

Comment 46

16 years ago
I currently see D&D not working properly in the bookmarks sidebar.
Right click on a folder, selecting "New Folder" gives me a new folder
at the end of the contents of the parent folder. I'm unable to move
that folder using D&D as well as I'm unable to relocate other bookmarks
to be in that new folder (currently: I'm unable to reorder or relocate
any bookmarks in the sidebar menu). I have to choose the "Manage" button
to get that extra window open where I then can reorganize my bookmarks,
and this is then also reflected in the sidebar.

That's build 2002040306 on Linux.
(Assignee)

Comment 47

16 years ago
per last comment, adding bug 133351 instead of 128461 to the dependency list
Depends on: 133351
No longer depends on: 128461

Comment 48

16 years ago
*** Bug 137119 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
*** Bug 137117 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Depends on: 137119

Comment 50

16 years ago
Happens for me even on the 20020415 build on Windows 2000. Doesn't happen every
single time but I can reproduce very quickly.
(Assignee)

Updated

16 years ago
Depends on: 139398

Comment 51

16 years ago
Being annoyed by Bookmarks always appearing where I didn't expect them after
drag-and-drop (in Personal toolbar and in "Manage Bookmarks" - mostly they
appear one line above from where I placed them - this is one of my most hated
bugs nowadays) I looked around in bugzilla - and found a real jungle (including
this bug here) of open bugs describing the same:

bug 114256 (bookmark gets into wrong folder after dnd) although related, this
particular aspect is fixed now, but at least one of the dups is more general and
not adressed yet (bug 114878).

bug 114606 (bookmark goes to position above) describes exactly what I see and
hate, but in the meanwhile this bug has been somewhat changed into a tracking
bug and now also adresses other bugs related to bookmark d'n'd. (however,
component is not changed to "Tracking")
Many bugs that also describe the exact behaviour are duped to this one (I'll
list them later) because of its desription, but now nobody cares anymore about
the described problem because this one is now considered a tracking bug by some
people...

bug 119879 (bookmark appears one line above after dnd) is 100% what I see and hate.

bug 127437 (wrong position after dnd in personal toolbar) is about the same
problem just at another place (still mostly off-by-one after dragging bookmark).
Has *lots* of duplicates.

bug 137119 (bookmark positioned one line too high after dragging) is about
bookmark manager again, still the same problem. Was duped against bug 114606
already (same summary) but later reopened (bug 114606 is supposed to be tracking).

bug 139471 is finally about general dnd cleanup and is also supposed to fix this
particular issue I'm talking about. Very recently worked on, but now
unfortunately removed from RC2 list.


So it looks like (almost!) all of these six open bugs are duplicates of one
another, but correct duping and resolving was prevented by halfheartedly
changing bug 114606 into a tracking bug.
In addition the underlying bug I speak about (bookmark d'n'd results in wrong
position) was reported in many other bugs which are now duped to one of the six
bugs above: bug 115420, bug 116076, bug 117134, bug 120245, bug 122599, bug
130702, bug 137119, bug 130453, bug 130836, bug 132390, bug 134656, bug 137117,
bug 140071, bug 140342 and bug 140971 are the ones I found.


As you can see from the dup count or simply from imagining a browser where
bookmarks do not materialize where they are dropped, this is a quite serious
problem (and in my humble opinion should not go into 1.0). 

I think it would be a rewarding task for someone with the appropriate
permissions to clean up this jungle a bit. Maybe by clearly (and correctly)
labeling a general tracking bug and a separate one for the one particular d'n'd
problem I'm talking about (and duping the others against it).
This cleanup would get us rid of several ASSIGNED and NEW bugs and prepare the
way for fixing this one annoying d'n'd issue. 
Bug 139471 unfortunately was taken off the RC2 list (bug 138000) by Asa because
of its complexity. A simple "fix this one bug" wouldn't have been, I think.
(Assignee)

Comment 52

16 years ago
Changing title to reflect the tracking nature of this bug per Andreas request.
-> tracking
taking, to avoid assignee and qa spam
Assignee: ben → pierrechanial
Status: ASSIGNED → NEW
Component: Bookmarks → Tracking
QA Contact: claudius → pierrechanial
Summary: relocating a bookmark in sidebar and manage bookmarks doesn't insert/sort/move/Drag & Drop properly → Tracking Drag and Drop bugs in bookmark manager and sidebar.
(Assignee)

Updated

16 years ago
Attachment #65604 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #65603 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #65601 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #65599 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #65597 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
No longer depends on: 124604
Keywords: mozilla1.0, nsbeta1-, nsCatFood, regression, testcase
(Assignee)

Updated

16 years ago
Severity: major → normal
Target Milestone: mozilla1.1alpha → ---
(Assignee)

Comment 53

16 years ago
Updating temporarily the summary of this bug, since this bug it linked by a site
that do not deserve to be mentionned.
Bad luck, mangelo, I fixed this issue just in time before your unprofessional
"review"!!! mouahaha!

Btw: the "enlightning comment" (as you say) by Andreas (I wouldn't be surprized
if he and you were the same person, from what I can infer from your megalomany)
is completely off-topic and comes from a person that does not understand
anything from the mozilla code, as I pointed out in bug 139471 comment 19 and
that can not stand not being listen to, by spamming at least 4 bug reports with
the same comment, as pointed by timeless in bug 129471 comment 21.

Mangelo: you're just going against Mozilla. Rationalize your papers, judge the
pro and the cons of Mozilla, run benchmarks, tell us how many bugs there are in
IE. In one work: be professional.

-pch (free contributor)
Summary: Tracking Drag and Drop bugs in bookmark manager and sidebar. → MANGELO: YOU'RE JUST AN UNSATISFIED LOOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)
(Assignee)

Updated

16 years ago
Summary: MANGELO: YOU'RE JUST AN UNSATISFIED LOOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues) → MANGELO: YOU'RE JUST AN UNSATISFIED LOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)

Comment 54

16 years ago
Just a note to state that it still exists in the 1.0 release (Win2K). It's
somewhat better (in that it's less frequent), but happens often enough that it's
going to get really noticed now that 1.0 has been released, with the attendant
publicity.
(Assignee)

Comment 55

16 years ago
The fix for the main DND "annoyances" in sidebar and bookmark manager (bug
137119) has been approved for the m1.0.1 release.
Summary: MANGELO: YOU'RE JUST AN UNSATISFIED LOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues) → (MOZILLAQUEST) MANGELO: YOU'RE JUST AN UNSATISFIED LOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)

Comment 56

16 years ago
Changing back summary. Stop being so f*cking childish.
Summary: (MOZILLAQUEST) MANGELO: YOU'RE JUST AN UNSATISFIED LOSER! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues) → Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)

Comment 57

16 years ago
Andre: That is *not* being childish. It may well be the *only* opportunity we 
have to communicate with misguided readers of MozillaQuest.

Once they enter that *scumbag* of a site, they are inundated with lies. The link
to this page is one of *very* few link from MozillaQuest to mozilla.org.

It is one of very few points of defense we have. Therefore, please re-add the
subject line:

(MOZILLAQUEST) MANGELO: YOU'RE JUST AN UNSATISFIED LOSER! (Still: Tracking Drag
and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)

Better might be: MOZILLAQUEST ARTICLES ARE DELIBERATE MISREPRESENTATIONS OF
TRUTH ...
(Assignee)

Updated

16 years ago
Summary: Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues) → Mozillaquest is a misleading source of information! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues)

Comment 58

16 years ago
Pierre Chanial and Peter Lairo, I warn you, this is not the way bugzilla is
supposed to be used. If you abuse bugzilla, your account might get revoked.
Don't do this again.   Thanks.
Summary: Mozillaquest is a misleading source of information! (still Tracking Drag and Drop bugs in bookmark manager and sidebar, even if it tracks trivial issues) → Tracking Drag and Drop bugs in bookmark manager and sidebar
(Assignee)

Comment 59

16 years ago
Håkan Waara: please take off your armour of the Grreat Thrrreatening Defensorr
of the Law and don't be so solemn, it will scare me and I will have to jump in
my burrow.
Saying that, there is one thing I am sure is that bugzilla is not the place for
flaming.
As QA of this bug, I will resolve it as fixed, to close this futile discussion.
I have a fix for bug 124600 and the other issue does not need a tracking bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 60

16 years ago
and verifying it
Status: RESOLVED → VERIFIED

Comment 61

16 years ago
wfm 20020609 Windows 2000
Thanks, Pierre.. I thought this great battle would never end.. Its really
starting to shape up.  And Andre.. Yeah, I should of made this a "Tracking" bug.
 Hindsight is always 20/20 ain't it.  Anyway.. the majority of these issues have
been fixed and probably wouldn't of sooner.. given the nature of all the dnd
bugs scattered throughout bugzilla.  Next time.. Tracking all different types of
a given problem is easier to sift through to the real problem here and come up
with real solutions.  Which I have to note pierre has been a great help.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.