hotmail.com - The "allbox" (check all / mark all / select all checkbox) only selects first message

VERIFIED FIXED in Jun

Status

Tech Evangelism Graveyard
English US
P1
major
VERIFIED FIXED
16 years ago
2 years ago

People

(Reporter: Marcel Kunath, Assigned: bc)

Tracking

({qawanted})

unspecified
qawanted

Details

(Whiteboard: [Test account ID: mozilla_mozilla Password: bugzilla ][aok], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
BuildID:    2001112009

I came across this just now. This one is a special one and not easy to 
reproduce. If my explanations within this bug report don't suffice then contact 
me by email. I am pretty certain this is a bug.

First you need a hotmail account. =( Then you need to send tons of email to 
your hotmail account and overload it. Once your account has reached and 
surpassed the account size limit you will get the following message from 
Hotmail as you log into your account:

<quote>
ERROR: Your account is over 2560k in size. Access to your account has been 
temporarily disabled. Please delete messages so your account size will be 
reduced and you will regain access within 24 hours or sign up for Hotmail Extra 
Storage.
</quote>

(PS: I am unsure if this message appears immediately or overnight when they 
check your limit. I call this the "storage problem mode".))

After you get the message you want to be friendly and delete messages. Your 
INBOX has 800 messages and you want to delete the first 100 of them by simply 
checking the "allbox" on the screen. ("allbox" is referenced in the web page 
source code of Hotmail)

Then the Javascript is suppose to act and check all boxes on the page for you.

While you are in 'storage problem mode' with Hotmail the Javascript fails and 
only checks the first message and not all 100 of them. 

IE does this right and checks all 100 of them while you are in storage problem 
mode.



Reproducible: Always
Steps to Reproduce:
1. Get a hotmail account
2. Send some mail to hotmail.
3. Your inbox has 10 messages and you want to delete all of them. There is 
multiple ways of doing so. One way is to check the "allbox" and it will 
autocheck all messages on that page view. You then click delete and the ten 
messages are deleted. So far everything works in Mozilla and IE.
4. Now onto the bug. 
5. Overload your hotmail account. You must send tons of mail to it. I achieved 
this by subscribing to a mailing list and accumulated 800 mails in my INBOX.
6. After I surpassed the account size limitation I get the following message 
once logged into Hotmail:
<quote>
ERROR: Your account is over 2560k in size. Access to your account has been 
temporarily disabled. Please delete messages so your account size will be 
reduced and you will regain access within 24 hours or sign up for Hotmail Extra 
Storage.
</quote>
7. I want to comply with this and delete messages. I want to delete 100 
messages on the first INBOX page view by using the "allbox" method.
8. I go check the "allbox" and Mozilla's JavaScript implementation fails to 
autocheck all 100 messages but only checks the first single one.
9. IE in comparison does it right and autochecks all 100 on that page view.

Actual Results:  Mozilla fails to make use of the "allbox" check method in 
Hotmail while the Hotmail user is in "storage problem mode". "storage problem 
mode" is defined by me as having surpassed the account size limit. Only the 
first message is autochecked and 99 of them are not.

Expected Results:  The "allbox" in "storage problem mode" should autocheck all 
100 messages.

I know it takes effort to reproduce this bug but it is a bug which can be 
reproduced every time (once you are above the hotmail account size limit) and 
hence I find crucial.

I reproduced this on Mozilla win98, Mozilla SuSE 7.3 and Galeon SuSE 7.3 so if 
you can't reproduce this bug then I must have a really bad day... Otherwise 
thanks for working on a fix.

Go Open Source! Bugzilla rocks. I wish SuSE used it, not only internally.

Comment 1

16 years ago
Reassigning to DOM Level 0. I've set up a test account at hotmail.com: 

      [Test account ID: mozilla_mozilla  Password: bugzilla ]

Could someone bomb mozilla_mozilla@hotmail.com with emails, so that
the inbox count exceeds the account limit? Thanks - once that is done,
let us know and I will try to debug this with the JS Debugger.
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
Keywords: qawanted
QA Contact: pschwartau → amar
Whiteboard: [Test account ID: mozilla_mozilla Password: bugzilla ]

Comment 2

16 years ago
NOTE: the "allbox" is the checkbox to the left of the "From" anchor.
Go to the Inbox, hover over this checkbox, and you will see its title:
"Select or de-select all messages"

<input name="allbox" type="checkbox" onClick="CA();"
       title="Select or de-select all messages" tabindex="105">


The function CA() is from 
   http://sea1fd.sea1.hotmail.msn.com/cgi-bin/dasp/EN/hotmail___0.js


function CA(isOnload)
{
 var trk=0;
 for (var i=0;i<frm.elements.length;i++)
 {
  var e = frm.elements[i];
  if ((e.name != 'allbox') && (e.type=='checkbox'))
  {
   if (isOnload != 1)
   {
    trk++;
    e.checked = frm.allbox.checked;
   }
   else
   {
   }
  }
 }
}

Comment 3

16 years ago
Marcel has checked into this further and has found that actually,
the number of emails in the Inbox doesn't matter. You need only two
emails to see the bug. The "allbox" checkbox simply doesn't work:
clicking on it will select only the first email, and no others.


The reason is this error in the JavaScript Console:
  Error: document.all has no properties
  Source File: http://sea1fd.sea1.hotmail.msn.com/cgi-bin/dasp/EN/hotmail___0.js
  Line: 352


which is the indicated line below:


function CA(isOnload) {
  var trk = 0;
  for (var i = 0; i < frm.elements.length; i++) {
    var e = frm.elements[i];
    if ((e.name != "allbox") && (e.type == "checkbox")) {
      if (isOnload != 1) {
        trk++;
        e.checked = frm.allbox.checked;
        if (frm.allbox.checked) {
          hL(e);
          if ((folderID == "F000000005") && (ie) && (trk > 1)) {
            document.all.notbulkmail.disabled = true;
          }
        } else {
          dL(e);
          if ((folderID == "F000000005") && (ie)) {
            document.all.notbulkmail.disabled = false;
          }
        }
        if (document.all.nullbulkmail) {  <<<<<<<<<<<<<<<<<<<<<<<<<<<<< LINE 352
          document.all.nullbulkmail.disabled = document.all.notbulkmail.disabled;
        }
    } else {
        e.tabIndex = i;
        if (folderID != "") {             
          e.parentElement.parentElement.children[2].children[0].tabIndex = i;
        }
        if (e.checked) {
          hL(e);
        } else {
          dL(e);
        }
      }
    }
  }
}
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
NOTE: I goofed in Comment #2: that is the source for CA() provided to NN4.7.
What Mozilla/N6 sees is the source in Comment #3. 

|Document.all|is IE-only, and line 352 above is a flat-out coding error.
You can get away with:

                 if (document.all) {
                   etc.


This is OK because document.all === undefined in Mozilla, so this is 
equivalent to doing |if (undefined)|, which is not a syntax error. 
If  you do that you'll only get a warning in the JavaScript Console,
but execution will continue.


However, you can never do
 
                 if (document.all.nullbulkmail) { 
                   etc.


For now you are testing |if (undefined.nullbulkmail)|. Since |undefined|
does not have a property called |nullbulkmail|, this is a run-time error
which causes execution of the function to halt. That is why only the first
email gets checked.


What the site authors should have done is the same kind of check they 
used elsewhere in this function: 

                 if ((ie) && (document.all.nullbulkmail)) { 
                   etc.

Comment 5

16 years ago
Reassigning to Evangelism, raising severity to major because of the
importance of this site!!!

Again, the "allbox" is the checkbox to the left of the "From" anchor.
Go to the Inbox, hover over this checkbox, and you will see its title:
"Select or de-select all messages"
Assignee: jst → bclary
Component: DOM Level 0 → English: US
Product: Browser → Tech Evangelism
QA Contact: amar → zach
Version: other → unspecified
(Assignee)

Comment 6

16 years ago
Phil, P1 priority will get more attention than the severity. Severity is very
rarely used in evangelism.

Adding to microsoft tracking bug.
Blocks: 114158
Priority: -- → P1

Comment 7

16 years ago
So anything after 352 can be passed off?

What does this error below mean?

Error: e.parentElement has no properties
Source File: http://lw7fd.law7.hotmail.msn.com/cgi-bin/dasp/EN/hotmail___0.js
Line: 359
(Assignee)

Comment 8

16 years ago
parentElement is an MS/IE proprietary extension to the DOM
(Assignee)

Updated

16 years ago
Summary: The "allbox" Hotmail Mozilla Bug → hotmail.com - The "allbox" Hotmail Mozilla Bug

Comment 9

16 years ago
*** Bug 116691 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
CC'ing me...

I highly doubt MS is going to fix this for us... Anyone else think we should
just duplicate IE's behavior in this case?

If we refuse to, MS will just keep doing this on all of their sites until
Mozilla is unusable on them. I hate jumping when they say 'jump', but what else
will work at present?
(Assignee)

Comment 11

16 years ago
Oh ye of little faith...

Contacted today. News at 11.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: --- → Feb

Comment 12

16 years ago
*** Bug 119721 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Whiteboard: [Test account ID: mozilla_mozilla Password: bugzilla ] → [Test account ID: mozilla_mozilla Password: bugzilla ][aok]
(Assignee)

Updated

16 years ago
Keywords: evang500

Comment 13

16 years ago
*** Bug 115054 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
I noticed this in 0.93, and it is still present in what I am using now - 0.98? 
Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.8) Gecko/20020204  

For me, it doesn't depend on having an overfilled email box.  No matter how many
or few messages are in the box (Junk mail, Inbox, or other) only the first one
in the list is selected when they should all be selected.  

It works fine in the Netscape 4.75 I use at work, so it's a Mozilla thing. And
with the quantity of spam my HotMail account gets, it's an annoying bug.  
(Assignee)

Comment 15

16 years ago
Tsu Dho Nimh, this is not a mozilla bug. This is a proprietary js implementation
in hotmail.

Comment 16

16 years ago
So, Bob, do you consider Netscape 4.x broken because it accomodates
the proprietary js?  If so, does it hurt anything?

Comment 17

16 years ago
Hi,

Is it possible to have if(document.all.nullbulkmail) evaluate to false,
the same as if(document.all)?

Would this effect the standards based javascript implementation?

I do not need to be flamed over this question, I am just asking!

Thanks
Jason

Comment 18

16 years ago
Trying to read properties of a non-existent object must cause a
ReferenceError, according to the ECMA-262 Edition 3 Final spec:
 
               http://www.mozilla.org/js/language/


Here is the relevant section:

8.7 The Reference Type

The internal Reference type is not a language data type. It is defined
by this specification purely for expository purposes. An implementation
of ECMAScript must behave as if it produced and operated upon references
in the manner described here. 

                            etc.
                            etc.

A Reference is a reference to a property of an object. A Reference consists of
two components, the base object and the property name.

The following abstract operations are used in this specification to access
the components of references:

• GetBase(V). Returns the base object component of the reference V.
• GetPropertyName(V). Returns the property name component of the reference V.

The following abstract operations are used in this specification to operate on
references:

8.7.1 GetValue (V)
1. If Type(V) is not Reference, return V.
2. Call GetBase(V).
3. If Result(2) is null, throw a ReferenceError exception.
4. Call the [[Get]] method of Result(2), passing GetPropertyName(V)
   for the property name.
5. Return Result(4)


Now, in Step 2, the result of GetBase(document.all.nullbulkmail)
is going to be null, because document.all is undefined in Mozilla.
So we must throw a ReferenceError according to Step 3 -
(Assignee)

Comment 19

16 years ago
Walter, I don't want to get in a debate over this. The issue about what to
support has already been debated to death and it is late in the game for that
now. They support nav4 because they support the PROPRIETARY nav4 layer api. It
is not too much to ask of them to support the W3C DOM API. I have already been
in contact with them over this issue and will continue to do so. 

Comment 20

16 years ago
Bob - 
  OK - I'll start whining to the HotMail support people about it and the way it
makes the lovely feature unusable, because of their non-standard JavaScript. 
They have a "report a bug" link ... Mozilla is not even one of the listed
browsers, so I'll ask them to add it too. 

Tsu

Comment 21

16 years ago
And again, the mistake is outlined in Comment#2 above. 
Instead of doing:
 
              if (document.all.nullbulkmail) { 
                etc.


the site authors should have done the same kind of check they 
used elsewhere in their own code: 

              if ((ie) && (document.all.nullbulkmail)) { 
                etc.


The same principle applies for document.all.ANY_PROPERTY
wherever it may be in the code.

Comment 22

16 years ago
Oops, it was outlined in Comment #4, not Comment #2 -

Comment 23

16 years ago
*** Bug 128402 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 130686

Updated

16 years ago
No longer blocks: 130686

Comment 24

16 years ago
*** Bug 130686 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
There is a 'Report a bug' link in Hotmail - suggest we all use it, to add a bit
of weight to Bob's communications with them!
*** Bug 132761 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
*** Bug 133879 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
I'm joining late in the game.  So what seems is that this won't be fixed because
it's Microsoft's poor code?  Or am I reading this wrong?

Updated

16 years ago
Keywords: nsbeta1

Comment 29

16 years ago
*** Bug 134052 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 30

15 years ago
ok, contacted them again about document.all usage, server side sniffing which
confuses Mozilla with Navigator 4, the use of parentElement, children, etc. We
will see. Follow up again next month.
Target Milestone: Feb → Apr

Comment 31

15 years ago
*** Bug 137289 has been marked as a duplicate of this bug. ***

Comment 32

15 years ago
clarifying summary. this bug is very hard to find by summary.
Summary: hotmail.com - The "allbox" Hotmail Mozilla Bug → hotmail.com - The "allbox" (check all / mark all / select all checkbox) Hotmail Mozilla Bug

Comment 33

15 years ago
Seems to have been corrected in the nightly builds starting in April.  Now 
works on all web based email  
(Assignee)

Comment 34

15 years ago
nope not fixed.
Error: document.all has no properties
Source File: http://pv2fd.pav2.hotmail.msn.com/cgi-bin/dasp/EN/hotmail___1.js
Line: 356

Comment 35

15 years ago
The April builds haven't done anything for me.  Still doesn't work as of
2002041203 under XP.

Comment 36

15 years ago
Suggestion

Do you have NPOJI600.dll in the plugins directory?
(Assignee)

Comment 37

15 years ago
this has nothing to do with java and has everything to do with their use of
proprietary IE only API without an adequate fork for W3C DOM Compliant browsers.

Comment 38

15 years ago
I am not sure about whether this is a microsoft hack or whatever - BUT it works
with Netscape 4.79 and it works with Konqueror - as a matter of fact it has
always worked with both these browsers.

I just moved to mozilla a few weeks ago and am having this problem for the first
time.

Thanks

Comment 39

15 years ago
Hi,

I think this is the point.  Hotmail.com is identifying Netscape 4.x as netscape
and doing the right thing, while Mozilla is being misidentified as Microsoft IE.

Is this a valid statement people?
(Assignee)

Comment 40

15 years ago
no it is not: for example:

function CA(isOnload){
var trk=0;
for (var i=0;i<frm.elements.length;i++)
{
var e = frm.elements[i];
if ((e.name != 'allbox') && (e.type=='checkbox'))
{
if (isOnload != 1)
{
trk++;
e.checked = frm.allbox.checked;
if (frm.allbox.checked)
{
hL(e);
if ((folderID == "F000000005") && (ie) && (trk > 1))
document.all.notbulkmail.disabled = true;
}
else
{
dL(e);
if ((folderID == "F000000005") && (ie))
document.all.notbulkmail.disabled = false;
}
if (document.all.nullbulkmail)
document.all.nullbulkmail.disabled = document.all.notbulkmail.disabled;
}
else
{
e.tabIndex = i;
if (folderID != "")
e.parentElement.parentElement.children[2].children[0].tabIndex = i;
if (e.checked)
{
hL(e);
}
else
{
dL(e);
}
}
}
}
}

This has been communicated to hotmail. Please complain to them about their poor
coding practices. You are not going to get them to fix it by commenting this bug.

Comment 41

15 years ago
Yeah,

but netscape 4.x works.  So the javascript being used is different for Netscape
and IE.  

When Mozilla is used with Hotmail the IE javascript is being returned.

This is what I meant by misidentification...

Comment 42

15 years ago
I will admit that I do not fully understand the problem, but 
I submitted a bug report to hotmail.com as suggested.

Thanks
Jason
(Assignee)

Comment 43

15 years ago
Jason, I get the same errors with NS6 as in Mozilla.

Comment 44

15 years ago
*** Bug 140654 has been marked as a duplicate of this bug. ***

Comment 45

15 years ago
*** Bug 140658 has been marked as a duplicate of this bug. ***
*** Bug 141353 has been marked as a duplicate of this bug. ***

Comment 47

15 years ago
I have also noticed this while checking my MSN mail through hotmail.com and the
check all box only automatically checks just the first box and not all, but the
function does work in Netscape 4.75 and in IE5/IE6, so the problem is with
Mozilla and their Javascript programming.
(Assignee)

Comment 48

15 years ago
Richard, WRONG. It is with Hotmails use of proprietary IE only DOM methods. PERIOD.
*** Bug 143297 has been marked as a duplicate of this bug. ***
*** Bug 143319 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: hotmail.com - The "allbox" (check all / mark all / select all checkbox) Hotmail Mozilla Bug → hotmail.com - The "allbox" (check all / mark all / select all checkbox) only selects first message

Comment 51

15 years ago
I want to share they way I cope with this:

I use this "bookmarklet":
javascript:void(document.onmouseover=function(e) { if(typeof e.target.checked !=
"undefined") e.target.checked=!e.target.checked })

It will check/uncheck every checkbox just by hovering with the mouse pointer =)

Sorry for the spam, but I thought it could be useful as a simple workaround for
people surfing through bugzilla.

Comment 52

15 years ago
You should send that as a spam to all hotmail members ;-)

Comment 53

15 years ago
*** Bug 145437 has been marked as a duplicate of this bug. ***

Comment 54

15 years ago
nice stalemate we have here.  i've been tracking this for a while and i must say
its very frustrating after that weekend of not checking my mail to then have to
check off a 100 new mails one by one for deletion.
(Assignee)

Comment 55

15 years ago
I agree totally. 

I have never used my hotmail email account for anything but testing but still
receive hundreds of spam emails. The fact that hotmail gives your email to
spammers which results in hundreds of spam messages for every real one makes
this bug in hotmail much worse. 

I do have a recommendation for you however. I also have a netscape.net address
which I also only use for testing purposes. I have never received spam to that
address. 

You decide which to use.

Comment 56

15 years ago
Its not a matter of choosing an email id anymore - once you have a particular
email address and have been using it for 4-5 years, you can't just up and change
to a new email id.  You have to live with it.  I get more spam on hotmail than
on yahoo - so you are probably right about hotmail selling information, but now
its too late for me to change.

Also, what I can't understand is - why does the check box work on Netscape 4.X
and not on Mozilla - if its a browser identification problem, can I somehow set
my browser identification for hotmail.com to be some other browser. 

That check all box works for all browsers I have used except for Mozilla (that
includes Konqueror, Netscape 4.x, Opera and Mshit-xplorer).
(Assignee)

Comment 57

15 years ago
mozilla ends up in an IE only code fork. I haven't looked closely enough to see
what other code paths would support us... but if the others are supported then
we need to find which fork will support us and try to get them to send us there.
I will look when I have time.

Comment 58

15 years ago
Once again this is showing how Microsoft abuses it's resources.  They are
obviously attempting to stop people from using freeware products such as Mozilla
by decreasing the functionability on their websites with the browser.

Comment 59

15 years ago
I just came today to report this bug and had narrowed it down to a JavaScript
coding error on their site.  I was simply going to notify the community that
this was happening, and I was 99% certain that it was Microsoft just mucking
around with NS/Moz.  Then I found this extensively debated bug report.

So I'll just staple my 2 cents on here -- there's a bug, and I don't know how to
solve it, since Mozilla's js behavior appears to be correct, and MS's javascript
is certainly out-of-spec.

Comment 60

15 years ago
Since this bug does not show up for Konqueror, Netscape 4.x etc, is it possible
to just change the browser identification that is given to Hotmail.com -
Konqueror has this option, is it possible to incorporate it for Mozilla -
atleast for hotmail ?

Comment 61

15 years ago
No - if you change the user agent string in mozilla it *still* does not work. 
(Assignee)

Comment 62

15 years ago
Actually it will work but you have to be very tricky!

They won't let me in using just a ua string of Mozilla/4.0, but I can log in
with my NS7 ua. Once in, I switched my ua to Mozilla/4.0 and the delete all
button works fine! rotflmao... muwhawhahwha!!!

Comment 63

15 years ago
Nice laugh ya got! I will let them know. 

Comment 64

15 years ago
I can verify that comment 39 from Jason Pell is correct. I tried changing the
user-agent string to "Mozilla/4.72 [en] (Windows NT 5.0; I)" and that made the
All checkbox work on hotmail.com

In other words, comment 4 correctly describes what is wrong. This is not a bug
in Mozilla.

The only way to "fix" this is to bug Microsoft about it. Why not include a link
to this bug report so they can see what's wrong too? 

Can someone please tell me the page where I should report this to Microsoft? If
everyone sends the bug report to the same place, things are going to get faster
I think.

Comment 65

15 years ago
So, Hotmail serves up broken javascript for Mozilla/5.0 but correct javascript
for Mozilla/4.9?  (I tried the 4.9 and it and it works.)

Do I understand this correctly?  If not, 'splain it to me, please!

Comment 66

15 years ago
Walter, see comment 39.

hotmail.com thinks that Mozilla is "IE compatible", so it sends JavaScript
specific to IE (e.g. non-standard code).

In other words, there's little we can do about it, except complain to the
Microsoft support.
*** Bug 149454 has been marked as a duplicate of this bug. ***
*** Bug 152174 has been marked as a duplicate of this bug. ***

Comment 69

15 years ago
*** Bug 152189 has been marked as a duplicate of this bug. ***

Comment 70

15 years ago
For me, the person who reported this bug, it can be reproduced as many times as
i could manage to try. Also, it does not depend on the amount of storage taken.
If there are 2 emails or if there are 200 it will always reproduce itself.

Comment 71

15 years ago
By default, the "Bug Reporter" within Hotmail is only available if you are
signed in.  I managed to 'tweak' the Bug Reporter URL so that it will work, even
if you _are not_ signed in.  (It will also work if you _are_ signed in).  Not
all fields are mandatory, but fill any 'applicable' fields.

Generic Bug Reporter page:
http://hotmail.msn.com/cgi-bin/dasp/links_shell.asp?matter=reporter&nonavpage=0


Bob, have there been any updates?  (no pressure!)  And what, if anything, would
you like people to do, to get this bug fixed?

Comment 72

15 years ago
This should be fixed in the next few weeks. It's on MSN's development schedule. 

Comment 73

15 years ago
*** Bug 152616 has been marked as a duplicate of this bug. ***
*** Bug 153656 has been marked as a duplicate of this bug. ***

Comment 75

15 years ago
*** Bug 153794 has been marked as a duplicate of this bug. ***

Comment 76

15 years ago
It seems that using 20020625 the "all" checkbox now works like it's supposed to.
I guess they changed their JS code to account for Mozilla.

Comment 77

15 years ago
It's working for me on Linux.  I'd like to think the js code was changed because
 of non-standard coding and not just because it didn't work in Mozilla.

Comment 78

15 years ago
Also confirming "allbox" now WFM.  Trunk build 2002062508, Windows XP.

Note: Hotmail still refuses to let me modify my Profile Information - still get
canned message about it no longer supporting my browser version.  However,
that's a separate issue.

Comment 79

15 years ago
I'm not sure what you guys are talking about..I upgraded to build 2002062508 and
the problem continues. I have no doubt that it works in Linux though.

Comment 80

15 years ago
Still not working for me (Mozilla 1.0, Win2K):

Error: document.all has no properties
Source File:
http://lw11fd.law11.hotmail.msn.com/cgi-bin/dasp/EN/hotmail___904500017.js
Line: 129

I note that Hotmail runs on many servers - perhaps the problem is fixed on some
servers and not others?

Comment 81

15 years ago
Perhaps.  I just tried it again, and it no longer works.  I don't know if I was
lucky before and got a "good" server or not.  However, I suspect not since it
hasn't worked for me once in the past few months, then suddenly did yesterday. 
My opinion is that they're testing code changes and those who reported it
working just managed to go there during a brief window when they implemented
those changes - which have now been backed out for whatever reason. <sigh>

Comment 82

15 years ago
I apologize for being redundant (spam), but I also confirm the "allbox" worked
late yesterday (25 June 2002), and was no longer functional (again) by early
morning (26 June 2002).

Comment 83

15 years ago
*** Bug 154439 has been marked as a duplicate of this bug. ***

Comment 84

15 years ago
With the latest build (2002062608), this bug is still present and
verrrrrrrrrrrrry annoying.

Comment 85

15 years ago
I tried it again today and the select all doesn't work anymore.

Comment 86

15 years ago
as of 7:01pm Eastern time, 6.27.02, the all box is now working correctly again
for me using 2002053012.

Comment 87

15 years ago
Yes, me too...for the first time. It is 4:11pm PST and its working for me too.
(Assignee)

Comment 88

15 years ago
heh. it worked for me too! Everyone get your sweaters and mittens! 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 89

15 years ago
it works it works it works it works for me too !!!!! hurrrah!!!

Comment 90

15 years ago
*** Bug 154726 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Target Milestone: Apr → Jun

Comment 91

15 years ago
It works for me with the original 1.0 version (20020530) that I downloaded.

Excellent!

Comment 92

15 years ago
Suggest not closing this bug quite so quickly.  Hotmail worked for a brief
period of time a few days ago, then stopped again.  I would reopen it then wait
a while.  Also, I don't think it should be marked "FIXED" (because nothing in
Mozilla was "corrected" but WORKSFORME...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 93

15 years ago
Bugs in evangelism never get fixed in Mozilla. They are bugs about the websites
and hence they get fixed at their end. So an evangelism FIXED would mean that
efforts to make non-compliant sites compliant have succeeded. No evangelism bug
is fixed with a change to Mozilla so worksforme is wrong here. An evangelism
WORKFORME would mean that someone filed it but noone was able to reproduce the
bug (right after filing).

At least this is the way I understand it. But I'll let others (bclary?) decide.
Also this bug should be marked FIXED and it should be reopened only when it can
be reproduced. Its been over 12 hours that this is fixed.

Comment 94

15 years ago
I'd say let this bug sit till Monday before we close it.

Comment 95

15 years ago
Pratik: After further thought I think I agree with you after all.  It does seem
to make more sense that evangelism bugs (but only those) should be FIXED rather
than WORKSFORME.  (Old habits from other components had me automatically object
without really considering the aspect of this component category.)

I agree with Kevin that it should remain open until Monday.  If it still works
throughout the weekend, closing it after that would be appropriate.  Since there
has now been a history of the Hotmail allbox working for a time, and then not
working again, I'd rather err on the side of caution and make sure Microsoft has
their code in place somewhat more permanently than last time.
(Assignee)

Comment 96

15 years ago
I say follow the evangelism guidelines and let the evangelist manage their own
bugs. This bugs was resolved fixed, not verified fixed not closed fixed. If they
change their behavior again we can reopen or file a new bug.

-> fixed
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
*** Bug 161259 has been marked as a duplicate of this bug. ***

Comment 98

14 years ago
works ok with a recent trunk build, so I guess this can be verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.