Closed Bug 168517 Opened 22 years ago Closed 22 years ago

Entry Point error dialog thrown at first startup (nsAVLTree)

Categories

(SeaMonkey :: Installer, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: lohphat, Assigned: dveditz)

References

Details

Attachments

(1 file)

win32 2002091304 on xp-pro.

This has been happening for the last two days.  See Attachment.
Attached image GIF of dialog
Component: Browser-General → XPCOM
Do you use the installer ?
Do you install over an older build ?
Do you use third-party enhancements for mozilla like enigmail .... ?
Assignee: asa → dveditz
Component: XPCOM → Installer
QA Contact: asa → bugzilla
No.  I use the .zip nightlies after each packaged public release installer (1.0,
1.1, etc.).

I completely remove the entire old app build, unzip, and only recopy the plugin
and spellcheck files.
Can you please unzip it again in a clean new directory and DON'T copy the
spellchecker files ?
Bingo.  That's it.

Why the error only on the first startup?
Interesting.   You can generate the error if you visit:
http://spellchecker.mozdev.org/installation.html
and install the xpi file.  You'll get the dialog after restart.
-> invalid

They must update the spellchecker.
(they must use an unfrozen interface or something like that)

Please file a bug for the spellchecker Team
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
Actually, it's not just spellchecker, installation of PieMenus causes the same
behavior.  It looks like something changes in the xpi/xpcom spec that multiple
packages are choking on.

http://optimoz.mozdev.org/gestures/installation.html
Yes, every release all those things break because they're using non-frozen
interfaces. The embedding team needs to evangelize the use of their glue/utility
layers better
Should we not then create a meta bug and creat a pointer for known component
authors to reference?
v invalid
Status: RESOLVED → VERIFIED
Summary: Entry Point error dialog thrown at first startup → Entry Point error dialog thrown at first startup (nsAVLTree)
see [meta] bug 98417
Depends on: 98417
*** Bug 177537 has been marked as a duplicate of this bug. ***
*** Bug 177603 has been marked as a duplicate of this bug. ***
*** Bug 178753 has been marked as a duplicate of this bug. ***
*** Bug 181660 has been marked as a duplicate of this bug. ***
*** Bug 182220 has been marked as a duplicate of this bug. ***
*** Bug 182206 has been marked as a duplicate of this bug. ***
*** Bug 183191 has been marked as a duplicate of this bug. ***
*** Bug 183557 has been marked as a duplicate of this bug. ***
*** Bug 184175 has been marked as a duplicate of this bug. ***
Getting same error. I went to MozillaCafe.org and installed the latest spell
checker XPI. Same error on startup. And I was using the installer so it should
have installed the updated XPI anyway, correct? Or is the updated XPI not a part
of the installer. Is there a place where a working spell checker can be obtained
for Mozilla 1.2 or 1.3?

http://mozillacafe.org/MozSpell_1.2f_w32.xpi

should work with 1.2
uninstall mozilla, delete all files except the plugins folder and reinstall will
fix this.
*** Bug 184267 has been marked as a duplicate of this bug. ***
*** Bug 184495 has been marked as a duplicate of this bug. ***
*** Bug 184960 has been marked as a duplicate of this bug. ***
*** Bug 184954 has been marked as a duplicate of this bug. ***
*** Bug 185005 has been marked as a duplicate of this bug. ***
*** Bug 185257 has been marked as a duplicate of this bug. ***
*** Bug 186167 has been marked as a duplicate of this bug. ***
*** Bug 186699 has been marked as a duplicate of this bug. ***
*** Bug 189104 has been marked as a duplicate of this bug. ***
*** Bug 189614 has been marked as a duplicate of this bug. ***
*** Bug 190418 has been marked as a duplicate of this bug. ***
This isn't just a spellchecker problem. I can reproduce consistently on winXP by
installing Mozilla 1.0.2, exiting the browser and installing the latest nightly
build on top of 1.0.2. This is with no extensions or 3rd party add-ons/themes at
all. Mozilla simply won't start if you install the latest trunk on top of the
latest branch. This needs to be looked into. We can't do this to 1.0.x users
migrating to the latest trunk milestone. 
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'll try this tomorrow (installing over 1.0.2 and find the old file)
Asa: If you get this on Mozilla-only upgrades *before* the GRE whackage then
there's definitely a problem to be addressed in this bug. If after the GRE
whackage then this is covered by bug 190144
Dan is correct. Sorry for the spam. My problem is 190144. Installing a GRE build
on top of a non-GRE build is totally broken. I'm re-resolving this which is
specific to the spellchecker.
Status: NEW → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → WONTFIX
*** Bug 190753 has been marked as a duplicate of this bug. ***
verified
Status: RESOLVED → VERIFIED
*** Bug 195076 has been marked as a duplicate of this bug. ***
*** Bug 197011 has been marked as a duplicate of this bug. ***
*** Bug 198949 has been marked as a duplicate of this bug. ***
*** Bug 199916 has been marked as a duplicate of this bug. ***
*** Bug 207891 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
WONTFIX -> WORKSFORME to get this bug away from the Most Frequently Reported Bugs list.
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: