Closed Bug 376084 Opened 13 years ago Closed 11 years ago

Clicking or Pressing enter after entering URL in address bar doesn't work. (caused by old version of Delicious add-on)

Categories

(Firefox :: Extension Compatibility, defect, major)

defect
Not set
major

Tracking

()

VERIFIED INVALID

People

(Reporter: tommyharding, Unassigned)

References

Details

(Whiteboard: [Video of the problem in Bug 439233])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Now and again, FF goes into one of these spasms whereby entering a url into the address bar and pressing enter doesn't do anything. The same applies when i click the 'go' button.


Reproducible: Sometimes

Steps to Reproduce:
1.Enter URL
2.Press Enter or click 'go' button.
Actual Results:  
No response whatsoever. Its as if i haven't pressed enter or clicked the go button.

Expected Results:  
Loaded the URL.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070330 Minefield/3.0a4pre
Works for me. Please retest in -safe-mode, with a new profile or with a reinstallation in a new empty directory.
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
I'm having the same problem. Seems to happen fairly frequently. Exactly the same as described by Thomas.
Same problem on Vista using FF 3.0 RC1. Ctrl-Enter does not work either. Firebug is not installed and del.icio.us is version 2.0.48.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

-- Cory
Regardless of what I try, I cannot type in an address and click enter.  I can click on links.
I've been seeing this bug for quite a while, currently on OS X 10.5.3 FF3.0 rc3.

Possibly helpful:  when it happens, it affects only that window.  If I open a new window, the url bar works normally, but only in that new window...nothing seems to ever unstick the affected window's url bar.
This bug made it into the release.  I'm currently using the following:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0


Same issue, the address bar ceases to function as expected at random.  The new suggest features still work, but when enter or go is pressed nothing happens.  It does work when opening a new window or restarting.
This issue has been reported several times. See bug 437241, bug 440769, bug
441482, bug 441510 and bug 441502.

I personally run into this issue randomly (not so often) on Mac OS X from time
to time. Closing the current window solves the issue.
Confirming, component -> location bar, OS -> all
Status: UNCONFIRMED → NEW
Component: General → Location Bar and Autocomplete
Ever confirmed: true
OS: Windows XP → All
QA Contact: general → location.bar
Duplicate of this bug: 437241
Duplicate of this bug: 440769
Duplicate of this bug: 441502
I'm having the same issue. Clicking on bookmarks, links within system, Delicious addon links all work normal. 

This has happened twice in two days. If I open a new window, the new window works fine, but the original window does not work.

Entering data in the Search box does work as planned.

Windows XP SP2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Delicious 2.0.64
Dictionary Switcher 0.9
dragdropupload 1.6.7
Forecastfox 0.9.7.6
Google Gears 0.3.24.0
Google Notebook 1.0.0.20
Greasemonkey 0.8.20080609.0
IETab 1.5.20080618
NoScript 1.7.1
Operator 0.9.3
Remember The Milk 1.0.2
(In reply to comment #12)
> I'm having the same issue. 

Can you please try running Firefox in safe mode and see if the problems persists?
The problem is not regular. Sometimes it'll go days without doing it, sometimes within a few hours. 

If the bug pops up, any restart will resolve the issue. Running in Safe Mode will always fix the problem, but I wouldn't be able to determine if the problem would not occur in safe mode.

This morning, it began to happen after only a few minutes of use. I restarted the browser (normally) and attempted to go to all of the same websites I went to prior. I couldn't get Firefox to reproduce the problem.

I know it helps little to none if the problem can't be reproduced... I'm paying more attention to my activity to try to keep note of last actions before the problem arises. I'll post again here if I can discover anything new/determine steps to reproduce.
Latest time:
Opened Firefox at ~5pm local.
Left computer, left Firefox running at 5:30 with with three tabs:
http://www.menswearhouse.com/tuxedos/tuxedo_wedding.jsp
http://www.alsformalwear.com/portfolio-wedding-index.asp
http://www.google.com/calendar/hosted/utcatholic.org/render

Returned to Firefox at 8:05pm local.
Address bar did not respond.

Opened new window, address bar responds.

This occured on a different computer than my above entry:

Windows XP SP2
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Delicious 2.0.64
Google Gears 0.3.24.0
Greasemonkey 0.8.20080609.0
IEView Lite 1.3.3
Move Media Player 1.0.0.07103010
NoScript 1.7.1
Operator 0.9.3
Remember The Milk 1.0.2

That means this cannot be related to:
Dictionary Switcher 0.9
dragdropupload 1.6.7
Google Notebook 1.0.0.20
IETab 1.5.20080618
Duplicate of this bug: 443235
And middle clicking on the go button, does that work?
(In reply to comment #17)
> And middle clicking on the go button, does that work?
> 

For me, unknown. None of the trackpads/trackballs/mice I use have a middle button.
Duplicate of this bug: 439233
Bug 439233 contains a video of this problem.
Whiteboard: [Video of the problem in Bug 439233]
I can just confirm that I also have this problem. At the moment I can only remember getting this on w2k, not my vista or ubuntu machine. But I can be remembering wrong about vista. And ubuntu I am not runnnig as frequent as vista an w2k.
Duplicate of this bug: 443409
Is this only after opening a new tab?
Yes, only after opening a new tab and it's appears randomly. From time to time.
If I open a new one Firefox app instance, everything is fine.
I can confirm this for my experience as well. When the bug strikes, it is after a new tab is opened. The address bar, however, will fail for all tabs in that window.
In Bug 443346 the reporter noted that they the del.icio.us add-on installed. Have those who had the problem tried safe mode? It seems that some of them (comment #15) has the del.icio.us add-on.
I have the same problem since Firefox 2 and I'm currently using Delicious Bookmarks 2.0.64
(In reply to comment #27)
> I have the same problem since Firefox 2 and I'm currently using Delicious
> Bookmarks 2.0.64

I've forgotten to say that I'm using:
Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.0) Gecko/2008061600 SUSE/3.0-1.1 Firefox/3.0
Tulio: did you try safe mode?
http://support.mozilla.com/kb/Safe+Mode
I'm trying it now, but I think it's difficult to catch it because it fairly happens.
I hope to help you.
This will sometimes happen a few times an hour, and sometimes I go days ithout
it ever being a problem. I'll add the info for my machine.

MacBook Pro, OSX Version 10.4.11

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004
Firefox/3.0

Add-ons:
CSSViewer 1.0.3
Delicious Bookmarks 2.0.64
Firebug 1.2.0b4
Operator 0.9.3
Piclens 1.7.0.3458
Screen grab! 0.95
User Agent Switcher 0.6.11
Web Developer 1.1.6
I just want to add that I run the following plugins.

Addblock Plus 0.7.5.5
Delicious Bookmarks 2.0.64
Firebug 1.2.0b4
FireGestures 1.1.2
User Agent Switcher 0.6.11
Web Developer 1.1.6

and I run Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I will also start running in -safe-mode.
This problem is happening to me with FF3. This always happen after some period of time.

More problems with the same problem on Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/240242
Duplicate of this bug: 443924
Duplicate of this bug: 444336
Happens to me in Windows XP w/ all the latest updates with FF3 with Adblock Plus 0.7.5.5 and Delicious 2.0.64.
Can you please try uninstalling the Delivious add-on.
Duplicate of this bug: 438932
Duplicate of this bug: 436985
Duplicate of this bug: 433487
(In reply to comment #26)
> In Bug 443346 the reporter noted that they the del.icio.us add-on installed.
> Have those who had the problem tried safe mode?

I am pretty sure this is related to the Delicious extension. Some posts on the
extension's mailing list over the last few months:
http://tinyurl.com/67vej5
http://tinyurl.com/6g9qpx
http://tinyurl.com/562oxd
Duplicate of this bug: 444789
I reviewed the lists of plugins used by others who are (like me) running into this bug, and the only one I have in common with all three of them is Delicious.  I'm at version 2.0.72 now.

Come to think of it, I ran into this bug again earlier, and I think it was late in a Firefox session where an update to Delicious had been downloaded and installed for me earlier.  I think.  Don't quote me on that.
Duplicate of this bug: 441317
I've noticed this on my brother's computer, running Fedora, with both the default Fedora Firefox install and a custom install I did directly from Mozilla.com.  No plugins at all, and EVERY TIME the browser starts, the location bar doesn't respond to the enter key or the Go button.  At all.
Duplicate of this bug: 445351
The problem went away after I had disabled the smart location bar.

Duplicate of this bug: 445144
Something about this bug isn't right. There has been a _recent_  and massive uptick in the number of people seeing this symptom and I'm pretty well convinced that this new round of failures is not what this bug was originally reporting because the original report is quite old and saw no activity until just recently. 

The major new round of failures can almost all be traced to the Delicious extension and duping them all against this bug makes it look like there's some longstanding issue here when that's just not what we're seeing.
i am one of the duplicate bug's reporter - I can confirm that I am always using the delicious extension! I have not tried to disable it and see what happens because the bug anyway..appears from times to times!

I am too using the Delicious extension.

Asa, you are right on you observations, however how about the bug existed since then and the delicious extension causes it to occur more frequently.

It could mean that it is the same bug only that since most people are now using the delicious extension, which is linked to the bug in some way, makes it seem like the culprit.
Just to add that I am also using the Delicious extension...
My guess it that the reporter of this bug was running into bug 393244. It seems now like this is an issue with the delicious extension. 

It would be great if it could be verified that the delicious extension is causing this.
IMHO, I can not say definitely it is, since over the past weeks I have updated several times the delicious plugin!

One more hint for me! I can remember this bug from the early Alpha releases and late beta's of firefox, in some of the I did not have (if I remember correctly) the delicious plugin installed!
(In reply to comment #54)
> One more hint for me! I can remember this bug from the early Alpha releases and
> late beta's of firefox, in some of the I did not have (if I remember correctly)
> the delicious plugin installed!
> 

Yeah, that got fixed. See comment 53.
Paris, does it happen frequent and quickly enough that if you uninstalled delicious you could tell if that had an impact?

I see this once every few days with FF3 - I recently installed delicious, but I can't say for sure that my first occurrence didn't precede delicious.  

Symptoms:
* only happens in one window of several FF windows
* both enter key and click of entries in history drop down in URL bar fail
* autocomplete works, but hitting enter from any selected autocomplete item
fails
* open URL in new tabs from existing tabs in that window works.
* going offline and back online has no effect
* nothing in console
* enter in search bar/field works fine

Bug 228303 is quite old reporting something similar, but not known yet if
reporter was using delicious (I think it predates the extension).
Hi, i have to admit that lately I have not encountered the bug! There was an update to the delicious plugin which I did - I always do! 

So at the moment so far so good!
I should have stated I am running version 2.0.72 of delicious extension, which is the latest available.

Plus (unfortunately) several other extensions.
yeap me as well! 2.0.72
I also have this problem from time to time (sometimes going days without encountering it and sometimes having it happen within minutes of the last occurrence.)  Opening a new window fixes the problem (at least temporarily) but the address bar will not work properly (ie cannot hit enter or the open url button) in any tab within the effected window.
I too had 2.0.72 of the delicious extension.  I could try disabling it, but since the bug crops up at such seemingly random intervals (usually it's at least a few hours after starting FF, but this morning it happened immediately after starting FF, ie I couldn't open any URL's from the address bar after the FF startpage came up) that it would take me days of using it before I could say for sure that that had fixed the problem, and I'd rather not operate for several days without delicious.
My brother is NOT using the delicious extention, and is getting this problem...
running Delicious Extension 2.0.72 as well... suffering the same bug..

My colleague however, who is not running the Delicious Extension and has the same or rather a similar bug, in his case it seems to be triggered by forms when autocompletion is used.
I'm running Firefox 3.0.1, I'm not running delicious, and I see this bug about once a day. Clicking links does not work, clicking reload does not work. Sometimes even clicking the window-close thing stops working.
Yeah, yesterday I saw it too for the first time, on a Windows Vista system that I only use occasionally. I had just made a new profile and was testing a 11 July 2008 trunk build. In my case also the new window didn't work when I tried to drag the favicon from the old to the new window.
As far as Delicious goes, this was ostensibly fixed in the latest *experimental* version (i.e. not released on a.m.o yet). More info and link to the XPI here: http://tech.groups.yahoo.com/group/delicious-firefox-extension/message/3016.
(In reply to comment #64)
> I'm running Firefox 3.0.1, I'm not running delicious, and I see this bug about
> once a day. Clicking links does not work, clicking reload does not work.
> Sometimes even clicking the window-close thing stops working.
> 

I'm experiencing this bug at this exact moment; reload and clicking links works. I think the bug in #64 is different.

Installing the experimental delicious release now; will report back if I experience the problem again.
Yes, I agree that #64 sounds like a different bug, as I've always been able to click links, reload, open new tabs (by right clicking), and even opening pages from bookmarks.  Whenever the problem crops up for me it only effects the location bar.
I found a similar problem. If you input, for exemple, getfirefox.com without www. prefix, enter won't work. The same apply to a IP without protocol:// prefix.
(In reply to comment #69)
> I found a similar problem. If you input, for exemple, getfirefox.com without
> www. prefix, enter won't work. The same apply to a IP without protocol://
> prefix.
> 

Interesting.  I haven't had that particular problem, at least that doesn't seem to cause the problem to crop up for me any more often than when I do add the prefix (I just tested it and it worked fine).
For me this bug has only appeared when I have 7+ tabs open simultaneously. Though closing tabs doesn't help either.
FF1.5
FF2, Win XP sp2
FF3, Win XP sp3
+ delicious
Hey it the moment of truth for me after some days!Here it is the bug! Having open 1 tab-> mobile.me 2nd tab -> google reader for .a couple of hours , when I tried to inster on a new tab http://youtube.com the browser just did not fetch the page.
If we want to make any progress on this bugger we need to gather more info than just "happened again". I'm no expert but I think maybe something would show under Tools > Error Console (Ctrl+Shift+J) somebody more seasoned on this can please provide the "must gather" information so we can help nail this one for good.
I'm not running the delicious extension and I run in to this bug (or perhaps the bug I see should be separate. It used to be known as bug 441317, but that got merged with this bug). I see this about once a day running 3.0.1 on Mac OS X. Randomly after about a day of surfing clicking a url stops working, as well as newly typed in urls. Sometimes things are only half broken, so one click does nothing, but click a few more times and then it works. In all cases, the little progress thing flashes briefly at the lower right. Much of the time, menu commands stop working at the same time. Selecting them does nothing. In particular, I tried selecting Tools-ErrorConsole, and nothing happened. Often for me the window close box and the Quit menu command also stop working.

Since something about my surfing/time-wasting pattern seems to trigger this bug pretty regularly, I'd be happy to install some debug/dump tool to try to capture what the heck is going on once the thing gets in this bad state.

Something you can do to get useful information for this bug:
1) Go to about:config (click through the warning), search for "javascript.options.showInConsole", set the pref to true.
2) When you hit this problem, go to Tools -> Error Console, click on "Errors", and then copy any errors that have a chrome:// URL underneath them, and paste them in a comment here.

A friend of mine is experiencing this problem, and here's an exception from his error console (typed by hand from a screenshot, so excuse any typos):

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: :: line 644" data: no]
chrome://global/content/bindings/browser.xml Line 650

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/content/widgets/browser.xml&rev=1.118&mark=642-644#642

I don't know what would be failing there. Gavin: any clue?
- javascript.options.showInConsole true 
- paste an address into address bar and address bar's throbber works
- in console we see

Error: yAddBookMark is not defined
Source File: chrome://ybookmarks/content/yAddBookMark.js
Line: 1524

yAddBookMark is related to del.icio.us
Yeah, actually I saw that in my friend's error console as well, right after a few errors from Greasemonkey (although the exception I listed was first). I thought maybe they were just fallout from something else being broken, but they could certainly be the culprit.
Flags: blocking1.9.0.2?
I've also seen this exception thrown when I can no longer enter and load URLs:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFileOutputStream.init]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///Users/stephend/Desktop/Shiretoko/Shiretoko.app/Contents/MacOS/components/nsSessionStore.js :: sss_writeFile :: line 2127"  data: no]
Source File: file:///Users/stephend/Desktop/Shiretoko/Shiretoko.app/Contents/MacOS/components/nsSessionStore.js
Line: 2127
Severity: normal → major
I am unable to reproduce this bug in Ubuntu Linux 8.04 and 8.10(devel sysle rease in ovct.)
Hi everyone --

This is Stephen from the Delicious team.  Just wanted to confirm what Andrew said earlier -- we've investigated this issue and think we have a fix for it.  We have been testing an experimental build of Delicious Bookmarks (2.0.73) with users on our discussion forum (http://tech.groups.yahoo.com/group/delicious-firefox-extension/) and so far it looks good.  If all continues to go well we will launch this officially very soon.  In the meantime you can get a copy of the experimental build from our discussion group if you want to try it out...

Thanks and sorry for the trouble...

On comment #80: note that this bug includes people who see these symptoms but are not running the Delicious extension. If this bug is going to refer to the Delicious one, then I suspect somebody more experienced than me with bugzilla should split out another bug number for the more generic problem.

On comment #75: I've tried a couple times to pull up Tools:Error-Console once the bug appears, but in both cases, clicking that menu item does exactly nothing. I guess it gets caught up in the general brokenness of this bug, where urls stop working, but at least when I see it, other UI elements, such as the Quit menu item often also stop working.
(In reply to comment #81)
> On comment #80: note that this bug includes people who see these symptoms but
> are not running the Delicious extension. If this bug is going to refer to the
> Delicious one, then I suspect somebody more experienced than me with bugzilla
> should split out another bug number for the more generic problem.

It's hard to say which since Thomas (comment #0) never responded to the bug he reported. Judging by the original version and date reported, my own hunch is that it's Delicious-related, but IANAD. :)
I think the problem is that a bunch of other bugs with similar symptoms got marked as dups of this bug, and many of those bugs don't have anything to do with Delicious.

So if this bug is the official Delicious one, I think the some sort of de-duping needs to happen where one bug gets revived as the official urls-stop-working bug and the others point to it. Note that 14 bugs were duped to this bug (listed below). I looked through the most recent of those, and most of them don't mention any extension, and they appear on Windows, Mac, and Linux, although I've only seen it on the Mac myself. This all suggests to me that the urls-stop-working bug is not that uncommon in the wild, but it doesn't reproduce well, with the common theme in the bug reports that it appears after many hours of use.

Here's the bugs, just scraped from above.

Bug 433487
Bug 436985
Bug 437241
Bug 438932
Bug 439233
Bug 440769
Bug 441502
Bug 443235
Bug 443409
Bug 443924
Bug 444336
Bug 444789
Bug 445144
Bug 445351

I dont use the Delicious extension and cant reproduce it, makes me think it is the extension 
(In reply to comment #84)
> I dont use the Delicious extension and cant reproduce it, makes me think it is
> the extension 
> 

Part of the problem is that even those with the extension couldn't reproduce the problem; it does seem random.

I upgraded awhile ago to the experimental version, and so far, it has not reoccurred. Not to say 100% it fixes the problem, but so far so good.
A new bug should be created if this also affects users that see this and never used the delicious extension.
But maybe there is another extension with the same bug.(In reply to comment #86)
> A new bug should be created if this also affects users that see this and never
> used the delicious extension.
> 

But maybe there is another extension with the same bug.
I tried disabling the one extension I was running, FlashBlock, and now 48 hours later I have not seen the problem once. I used to see it pretty reliably about once a day, so this does suggest to me that although it's not the Delicious extension exactly, it maybe has a similar root extension bug that causes the urls-don't-work symptom. Could some of the other non-Delicious reporters try disabling extensions to see if that clears it up for them?
I've stopped seeing this behavior since I disabled Firebug.
I too am exhibiting this behavior but I also made a rather interesting observation that I wonder if is true for other users. My primary [ENTER] key fails to invoke 'Go', but the [ENTER] key on my numpad DOES work as intended...
Anybody agrees that is an add-on compatibility problem?

Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

I met a similar issue.
In my work PC, each time when I add google tool bar and IE tab to my FF2, the system crash. And I do not know why. The crash does not happen immediately, but randomly after 1 hours, several days or even 1 week.
My PC will be stable without any FF add-ons.
(In reply to comment #1)
> Please retest in -safe-mode, with a new profile or with a
> reinstallation in a new empty directory.
> http://kb.mozillazine.org/Safe_Mode_(Firefox)
> http://kb.mozillazine.org/Profile_Folder

It surely might be. Can we come full-circle and get anyone to try to reproduce it in safe mode? :)

For some reason flashblock has problems from upstream and/or Mozilla addons page.
We package it for Ubuntu and it seems to not have alot of the issues that the above has. AFAIK we didnt patch it.
This bug is apparently referring both to a problem that has been linked directly to a specific add-on and to a problem that is apparently unrelated. I suggest splitting the bug / filing one specifically for the del.icio.us add on and leaving this for the semi-confirmed general case, with perhaps a dependency set?

Anyway, since it seems add-on related and no-one has yet confirmed this in safe-mode, I know it doesn't block and wonder why it's CONFIRMED.
Flags: blocking1.9.0.2? → blocking1.9.0.2-
(In reply to comment #94)
> Anyway, since it seems add-on related and no-one has yet confirmed this in
> safe-mode, I know it doesn't block and wonder why it's CONFIRMED.

(Comment #8)
> Confirming, component -> location bar, OS -> all
Having encountered this problem for some time (on and off), it happened again this morning. Someone a while ago suggested that the FF error console may provide useful information; so I attach a copy of mine here.  I don't know how much help it will be. I also don't know how much of it is relevant, but I've only had FF open this morning about 10 minutes.

To summarise:

Typing URL and pressing RETURN, ENTER or clicking GREEN ARROW all don't work.
Closing / opening a TAB has no impact (still same issue).
Opening a new WINDOW causes the problem to disappear, but ONLY on the NEW window.
Links that open in a new tab still work OK, as do bookmarks.

I'm running:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Delicious Bookmarks 2.0.72
Firebug 1.1.0b12
HTML Validator 0.8.52
Live HTTP headers 0.14
Screen grab! 0.95
StumbleUpon 3.26
User Agent Switcher 0.6.11
Web Developer 1.16
When this problem (as described in #96) occurs on my system, I've the feeling that I recently opened a pop-up window.

Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
AdblockPlus [de] 0.7.5.5
Clear Cache Button 0.7
Customize Google [de] 0.73
Delicious Bookmarks 2.0.72
DownThamAll! [de] 2.0.72
PasswordMaker 1.7.2
RefControl 0.8.11
Secure Login [de] 0.9.2.8
Ubuntu Firefox Modifications 0.5
I haven't experienced this problem since upgrading to the latest Delicious release, as I previously mentioned: 

(In reply to comment #66)
> As far as Delicious goes, this was ostensibly fixed in the latest
> *experimental* version (i.e. not released on a.m.o yet). More info and link to
> the XPI here:
> http://tech.groups.yahoo.com/group/delicious-firefox-extension/message/3016.

I'm pretty sure *my* problem was because of Delicious, so I haven't done any further testing, but it's not doing any good to mention the same behavior without testing in Safe mode/without extensions; it's going to be more difficult to find the problem among a set of a dozen extensions.
I now can reproduce the bug. But if I start firefox in safe mode there is no problem. If I restart in normal mode the problem is there again. Perhaps someone can tell me, what I can do in order to identify the reason for the bug. (Informations about my system in comment #97)
You can disable all addons and try with only one addon at the time. And write all Addons that create that bug
As there are various assumptions, that "Delicious Bookmarks 2.0.72" cause the bug, I concentrated on this addon:
1. Having only Delicous deactivated (my other addons s. comment # 97) I could not reproduce the failure.
2. Having only Delicous deactivated I could reproduce the failure.
From my point of view this is a strong evidence that Delicious is at least a great part of the problem.
Please give me a hint, if I can continue to help.
(In reply to comment #101)
> As there are various assumptions, that "Delicious Bookmarks 2.0.72" cause the
> bug, I concentrated on this addon:

No need, it's already fixed, as I posted above:

(Comment #66)
> As far as Delicious goes, this was ostensibly fixed in the latest
> *experimental* version (i.e. not released on a.m.o yet). More info and link to
> the XPI here:
> http://tech.groups.yahoo.com/group/delicious-firefox-extension/message/3016.
In attempt to reduce confusion, let me try to summarize what's going on with this bug:

The symptoms of this bug, url's stop working etc., is due to a coding error in an extension.

Apparently this coding error is pretty easy to make, because many extensions have the same error, and the Delicious Bookmarks extension is just the most prominent one where they've figured it out and fixed it.

I've been in contact with the Delicious guys, and they're going to write a little summary of what the coding error looks like to make this bug, and I'll make sure that summary gets posted to this bug.

Once that's done, my hope is that we can contact the various extensions and point them to this bug saying something like "hey, look towards the bottom of this bug, there's a little code snippet which shows a problem which apparently your extension has". Also, obviously, the mozilla extension docs should get updated to point out this apparently easy error to make.

In the meantime, an excellent test to do is run your Firefox with just one extension and wait to see if this bug is present in that extension, so we figure out the list of extensions to contact.

I'm fairly certain that FlashBlock and Firebug both have this bug, but I'm sure there are more.
Sorry, but in my case it is not being caused by an extension, because no extensions are installed, much less turned on.  This seems to be something with all Firefoxes attempted to be run on this system, packaged or no...
> Sorry, but in my case it is not being caused by an extension,
> because no extensions are installed, much less turned on.

Sorry, I should have used more careful language. Not 100% of the reports here concern bad extensions, but it seems that the majority do, so I suspect this bug # should refer to the extension case. Many bugs have been duped onto this bug # so at some point there'll have to be a de-duping to separate out the different bugs. I suspect it's going to be easiest to deal with the extension related reports first.
Warning: Use this extension at your own risk, the standard disclaimers around backing up your data and unpredictable results all apply, Try it on a test setup profile only.
Steps to reproduce this problem (In FF3): 
    
1. Install Tab Mix Plus extension from  
               http://tmp.garyr.net/forum/viewtopic.php?t=7031
2. Install the test extension above.
3. Tools->Tab Mix Plus Options -> Enable Single Window Mode.
4. In about:config, set javascript.options.showInConsole to true
5. Try opening new Firefox windows (not tabs), (You can do this via FF shortcut in windows) awesome bar stops responding.See Error console messages.

Fix for this problem is to add the handlers in the window only once.
Delicious Extension was incorrectly adding the handler twice. Please unzip the above xpi to see the code.

Thanks to http://tech.groups.yahoo.com/group/delicious-firefox-extension/message/3000 for reporting this scenario with Tab Mix Plus extension and delicious extension.

Warning: Use the above extension at your own risk, the standard disclaimers around backing up your data and unpredictable results all apply, Try it on a test setup profile only.

--
sibil mohammed
delicious dev
Duplicate of this bug: 451425
Hardware: PC → All
Version: unspecified → Trunk
Have you tried uninstalling, and removing ALL traces of FireFox, then reinstalling with a fresh download after checking the CRC values?
Duplicate of this bug: 457477
Duplicate of this bug: 458053
Have updated delicious plugin, and didn't see the problem for a long time, probably several months. Then this morning after 3.03 installed, I had the same problem again.  Typing URL into URL Bar wouldnt' let me open a new page... Will try to keep an eye on things and see if it crops up again and if I can figure out any sort of pattern.
I exchanged email with the Flashblock devs, and they say the window-handler issue does not happen in the Flashblock sources. That agrees with #112 above ... something other than the window-handler issue can cause this bug. I've tested Firefox 3.03 (the latest at this moment), and the bug appears after a few hours with Flashblock installed, and I never see the bug if Flashblock is not installed, so the problem is something to do with the Firefox/extension interaction.
Using Shiretoko for last couple of weeks and it been lovely. Then I installed AVG Free and it added little addon to firefox called "AVG Safe Search"

Just after reading all comments here and seeing that Delicious addon is making problem i decided to track down what's causing problem for me cause enter key keep failing for me also.

For me problem was this AVG addon that can't be uninstalled but can be disabled.
Gonna ditch AVG completely cause of this, if i can't uninstall/remove part of it there's no point in using it anyway.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081005 Minefield/3.1b1pre - Build ID: 20081005033754
I'm experiencing this bug too.  I have never had the Delicious extension installed on this machine (and did not carry over my old profile).  I do not have FlashBlock installed.  I do not have AVG installed.

I have:
AdBlock Plus
All in One Sidebar
Digg Toolbar
Download Statusbar
Email This
Firebug
Greasemonkey
URL Link
I have also experienced this bug now and then. Both on Windows XP and on Linux Kubuntu. Here is a film of it, it shows how it works ok to press enter in Notepad and in the search field, but not in the url field:

http://kristofer.jansater.se/20081010009.mp4
(In reply to comment #115)
> I have:
> AdBlock Plus
> All in One Sidebar
> Digg Toolbar
> Download Statusbar
> Email This
> Firebug
> Greasemonkey
> URL Link

Can you please disable all extensions step by step to find the one which causes this problem? That would be great.
(In reply to comment #117)
> (In reply to comment #115)
> > I have:
> > AdBlock Plus
> > All in One Sidebar
> > Digg Toolbar
> > Download Statusbar
> > Email This
> > Firebug
> > Greasemonkey
> > URL Link
> 
> Can you please disable all extensions step by step to find the one which causes
> this problem? That would be great.

Greasemonkey and All in One Sidebar were only added in the last few weeks, but I've been having this bug much longer than that, so I can rule those out straight away.  But yeah, I'll try disabling the ones I don't generally use and see wait a few weeks to see if it pops up again.
I have Greasemonkey and i dont have that bug.
Hi!

Same bug after update from 3.0.3 to 3.1.b1.
Disabling "AVG safe search 8.0" enter key work ok.
Using 3.0.3 all components works without problems
Quick note to add that I also had this issue on:
 "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre" nightly Build 20081027034223 

Disabling AVG safe search cured the problem.
Duplicate of this bug: 462267
I keep seeing this one randomly on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081207 Shiretoko/3.1b3pre ID:20081207035151

Adblock Plus 1.0
Adblock Plus: Element Hiding Helper 1.0.5
Delicious Bookmarks 2.1.011
Diccionario español Argentina 1.1 [DISABLED]
FoxyTunes 3.0.5.1 [DISABLED]
Mozilla QA Companion 0.1.18
Nightly Tester Tools 2.0.2

Would try a clean profile, but this one is rather difficult to reproduce, it's very random.

Has anyone looked into the suggestions from del.icio.us team (comment #107)?
Inconsistent - a restart can fix the problem without disabling any extensions. 

Add-ons present: 
ColorZilla 2.0
Delicious Bookmarks 2.1.018
Firebug 1.2.1
Google Gears 0.5.4.2
Greasemonkey 0.8.20080609.0
is.gd Creator 0.2.2
Remember the Milk 1.0.3
Work Offline 1.4

Seen on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4  on  Mac OS X 10.5.5 (Build 9F33).
Duplicate of this bug: 473519
Firefox/3.0.5 on Gentoo 20090115 also has the same bug:

*** Bug 473519 has been marked as a duplicate of this bug. ***

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; zh-TW; rv:1.9.0.5)
Gecko/2009011315 Gentoo Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; zh-TW; rv:1.9.0.5)
Gecko/2009011315 Gentoo Firefox/3.0.5

Details:

1. open a new tab, input a new url or paste a new url from the clipboard;
2. press [Enter] or click the green arrow;
3. the window doesn't respond, like [Enter] never pressed or arrow never
clicked;

Reproducible: randomly.

the phenomena doesn't happen very often, hard to reproduce, and I have used
firefox prepackaged by several linux distro (Gentoo, Ubuntu, Fedora, )

but it's only restricted in a firefox window, if open a new firefox window,
this bug won't happend in the new window, only happend in the old window; so
this seems a variable bind to the whole window, not the tabpage.

it maybe caused by a webpage, but I can't know what URL cause to this problem.

Reproducible: Sometimes
(In reply to comment #126)
<snip>
> the phenomena doesn't happen very often, hard to reproduce, and I have used
> firefox prepackaged by several linux distro (Gentoo, Ubuntu, Fedora, )
> 
> but it's only restricted in a firefox window, if open a new firefox window,
> this bug won't happend in the new window, only happend in the old window; so
> this seems a variable bind to the whole window, not the tabpage.
> 
> it maybe caused by a webpage, but I can't know what URL cause to this problem.
> 
> Reproducible: Sometimes

I can confirm that this is exactly how the problem affects me, too.

It is only restricted to a single window, so no need to restart firefox (for those of us who spread multiple windows around on different desktops :). Closing it and opening a new one resolves it. It happens rarely, but not rarely enough to be able to forget about it. It occurs on all Ubuntu 8.10 installations I have, and it has been a problem (albeit small) for a long time. I do not think it is related to Delicious, as I've also experienced the problem with a clean browser profile (IIRC) and I always update to latest version of Delicious (now at v2.1.018).

Mozilla/5.0 (X11; U; Linux x86_64; nb-NO; rv:1.9.0.5) Gecko/2008121623 Ubuntu/8.10 (intrepid) Firefox/3.0.5

Regards,
Øyvind S
The past seven months of comments have all come about since the release of 3.0. Can a few people try to reporduce the problem using a recent nightly trunk build (3.2a1pre)? Trying to see is this could be isolated to the 3.0.x branch. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(In reply to comment #128)

Haven't tried it on 3.2a1pre, but I am getting the issue with 3.1b2 on mac. Here's my user agent
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
The reason I'm not particularly looking for 3.1b users is because, bar blockers/etc, it's already been branched and updates on trunk could have had an effect.

Thanks for the quick feedback, though. :)
This issue happens in FF for me each day and right now in fact. I find that every time I open the 4th or 5th tab in FF, the URL entered in the address bar will not load after clicking "green arrow" or pressing enter. Even entries in the Google Search bar to the right of the address bar will not load. However, within the same "non-functional" tab, clicking a bookmark will allow the bookmarked page to load, but you still can't change to a different URL from that tab. So, I've added Google as a bookmark; this allows entry of the desired URL into Google search to proceed. 

Windows XP: Reproducible daily.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
I didn't read the whole thread here, only the first post.

I have this bug using Firefox 3.1 beta 2 on Windows 7 beta build 7000.

The OP reports he only has this bug happening every now and then and that the bug includes the little arrow button.

This isn't the case for me.

Entering a url in the awesome bar and pressing enter does nothing. When I first starting using the beta it worked perfectly. However now for a week or two this never works, not ever. 

Pressing the arrow key allows works.
This does not sound like the same bug. This bug seems, so far, random and possibly related to a plugin. The arrow does not work when this bug strikes. I suggest comment 132 is spun off as a separate bug.  

(In reply to comment #132)
> I didn't read the whole thread here, only the first post.
> 
> I have this bug using Firefox 3.1 beta 2 on Windows 7 beta build 7000.
> 
> The OP reports he only has this bug happening every now and then and that the
> bug includes the little arrow button.
> 
> This isn't the case for me.
> 
> Entering a url in the awesome bar and pressing enter does nothing. When I first
> starting using the beta it worked perfectly. However now for a week or two this
> never works, not ever. 
> 
> Pressing the arrow key allows works.
You were right, the "bug" was caused by the AVG safe search plugin.

(In reply to comment #133)
> This does not sound like the same bug. This bug seems, so far, random and
> possibly related to a plugin. The arrow does not work when this bug strikes. I
> suggest comment 132 is spun off as a separate bug.  
> 
> (In reply to comment #132)
> > I didn't read the whole thread here, only the first post.
> > 
> > I have this bug using Firefox 3.1 beta 2 on Windows 7 beta build 7000.
> > 
> > The OP reports he only has this bug happening every now and then and that the
> > bug includes the little arrow button.
> > 
> > This isn't the case for me.
> > 
> > Entering a url in the awesome bar and pressing enter does nothing. When I first
> > starting using the beta it worked perfectly. However now for a week or two this
> > never works, not ever. 
> > 
> > Pressing the arrow key allows works.
using the middle mousebutton works, as a lazy workaround for me, but only because I've got cybersearch installed. So i can type, cybersearch loads a list of pages, and then the middle mousebutton works when clicking on any links from that list (enter still does not, of course)
just occurred for me again. I'd just restarted firefox, 20 tabs were reloading and I was trying to type an address.

error data collected as per Ted Mielczarek's instructions (hope i got them all... was searching manually... is there any search option in the error console?)

chrome errors occurring when address bar fails to respond:

Error: this.GP_DOCUMENT.location is null
Source File: chrome://googlepreview/content/browserOverlay.js
Line: 703

Error: e.originalTarget.location is null
Source File: chrome://customizegoogle/content/browser.xul
Line: 14

Error: yAddBookMark is not defined
Source File: chrome://ybookmarks/content/yAddBookMark.js
Line: 1511

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 909

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 909

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 909


Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 909

Warning: Unknown namespace prefix 'html'.  Dangling combinator.  Ruleset ignored due to bad selector.
Source File: chrome://ybookmarks/skin/yAddBookMark.css
Line: 106
FYI, please try on the 3.2 branch.

(In reply to comment #128)
> The past seven months of comments have all come about since the release of 3.0.
> Can a few people try to reporduce the problem using a recent nightly trunk
> build (3.2a1pre)? Trying to see is this could be isolated to the 3.0.x branch.
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

(In reply to comment #130)
> The reason I'm not particularly looking for 3.1b users is because, bar
> blockers/etc, it's already been branched and updates on trunk could have had an
> effect.
(In reply to comment #136)
> chrome errors occurring when address bar fails to respond:
> 
> Error: this.GP_DOCUMENT.location is null
> Source File: chrome://googlepreview/content/browserOverlay.js
> Line: 703
> 
> Error: e.originalTarget.location is null
> Source File: chrome://customizegoogle/content/browser.xul
> Line: 14
> 
> Error: yAddBookMark is not defined
> Source File: chrome://ybookmarks/content/yAddBookMark.js
> Line: 1511
It looks to me like an add-on is at fault here...
This happens to me to every time now.
Duplicate of this bug: 476583
Please try in safe mode or at least disable AVG if it is installed. 

I believe the original report for this is not the AVG bug 475653. (I could be wrong)
This seems to be caused by Delicious v. 2.0.64 
A recent version of Delicious(2.1.018)doesn't cause this.  I see report in an unconfirmed bug 380314, that it works in Linux with Delicious V. 2.0.72

Anyone seeing this bug, please upgrade to latest version of Delicious.
Duplicate of this bug: 380314
marking Invalid as it is caused by an extension.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Summary: Clicking or Pressing enter after entering URL in address bar doesn't work. → Clicking or Pressing enter after entering URL in address bar doesn't work. (caused by old version of Delicious add-on)
I am using Delicious v. 2.1.018 and still occasionally get this problem. It seems to be less frequent than it used to be, but I'm unsure if the update to the extension is the reason or if various updates to Firefox are the reason that the problem crops up less frequently.  It does however still happen.
Stephen, do you by chance have AVG as well?
I do not have AVG installed (in fact Delicious is the only extension I have installed).
this version I used also has the same problem,

Mozilla/5.0 (X11; U; Linux x86_64; zh-TW; rv:1.9.0.5) Gecko/2009011315 Gentoo Firefox/3.0.5
Please remove all your extensions and see if you can reproduce it. I agree with Tracy that this is only confirmed using extensions.
After 6 months without this problem, I've noticed that it started again.

I believe that this is a problem related with an extension as it was related with an old version of Delicious but, is it possible to protect Firefox against this?
I think it's unacceptable to see Firefox halting because of a problem in an extension as I see in every software. Example: is unacceptable to see X server crashing because I started a program. In this case, even if there is an error in the program, it's obviously a problem with X server too.

Best regards,

Tulio Magno
(In reply to comment #150)
> After 6 months without this problem, I've noticed that it started again.
> 
> I believe that this is a problem related with an extension as it was related
> with an old version of Delicious but, is it possible to protect Firefox against
> this?
Actually, that is not reasonable. Mozilla can't be expected to ensure complete functionality of thousands of 3rd party extensions.  In this case, the Delicious extension developers need to be made aware of the issue so they can fix the bug on their end.
(In reply to comment #151)
> Actually, that is not reasonable. Mozilla can't be expected to ensure complete
> functionality of thousands of 3rd party extensions.  In this case, the
> Delicious extension developers need to be made aware of the issue so they can
> fix the bug on their end.

I completely agree with you. It's impossible do correct communities addon's, but I think that Mozilla can try to make architectural modifications in Firefox to protect against these problems.

The fact is: addon developpers are going to make errors. It's natural. But I think that it's unacceptable that Firefox crash because of these errors. Can you understand me?

Thank for you answer.
Tulio: where did Firefox crash?
Sorry.

Crash = lock the URL address bar

At least once a week firefox crashes here. But it is not related to this bug and it's probably related to another addon or plugin failure.
Túlio: The bug you're looking for is bug 156493 (at least partly).
That is really amazing, Natch. Thanks!

But, is it possible to try something like this, but adapted to this kind of problem?
Let's specify that "this kind of problem" is "lock the URL address bar"
Túlio:
If you look at how addons are made, I really really doubt they could stop them.  Firefox is written, in large part, entirely in Javascript.  The addons have to have access to Chrome to be able to even put a button on a toolbar or an entry in a menu.  If they have access to Chrome through Javascript, they've got access to all of it.  To block it would be like....telling Greasemonkey "you can modify this website in Javascript, but *not* the navigation bar"
The truth is that in this case it wouldn't help you much even if plugins _and_ addons were in a separate process. Here the addon is doing valid stuff invalidly :) . In other words, once the user gives the addon permission to run, the addon has access to Chrome (conceivably to _enhance_ the UI). If it does something that isn't supported it may break the UI. To guard against every possible outcome of poor coding in addons is impossible. I think the resolution for this bug is accurate being that:

1) Mozilla provides a "Safe Mode", allowing you to use Firefox without any addons.
2) You can always disable/uninstall addons.
3) The addon developer is the one at fault, and should be the one to fix this.

In direct answer to your question: "lock the address bar" is very generic, afaik there are numerous ways this effect can be achieved, none of which can be guarded against. Say, for example, an addon developer decides to replace all addresses typed in the address bar that aren't valid urls with an about: page explaining to the user how to correctly navigate the internet. Say the about: page isn't properly registered with firefox, now every time the user types in "google", which default handling sends you to a search page with that search term, in this case the user will get an alert that firefox doesn't recognize the protocol. Who's fault is that? Now just remember, this is only one possibility (although highly improbable) out of dozens of other mistakes extension other can make.

On another note: this bug has been marked INVALID, and this is generally considered bugspam, so I'll discontinue discussing this any further here. If you'd like to propose ideas, a better place would be the newsgroups http://www.mozilla.org/community/developer-forums.html .
Duplicate of this bug: 485957
Duplicate of this bug: 486439
I'm using 3.5 Beta 3. I'm unable to use enter button after typing url in address bar. In Private Browsing sometimes enter key works but not all time.
I've been keeping a careful eye on this bug on my OS X 10.4 intel machine, and here's what I've seen:

-Something about my machine made this bug happen pretty easily -- just a few hours running FlashBlock and Firefox versions 3.0.8 and earlier. So I ditched Flashblock.

-Without any plugins, I still saw exactly this bug --  hitting return in the url bar does nothing -- maybe about once a month for a total of 3 times. That was Firefox 3.0.8 and earlier. Though very rare, that obviously suggests that the bug is not exclusively a plugin problem, although obviously plugins can do something to trigger it. The Flashblock authors claimed their code did not have the window flaw associated with this bug.

-I've been running 3.0.9 and later both with and without Flashblock, and I have not seen the bug since. I used to see the bug in just a few hours, and now it's been a week and I have not seen it. Therefore, I think there's a real chance that the underlying flaw got fixed in Firefox 3.0.9 or later.

So if you have a favorite plugin that has problems with this bug... you might want to try it again with the latest firefox and see if the plugin now works right.

Moving forward, I think "invalid" is a reasonable state for this bug unless someone sees it happening with Firefox 3.0.10 or later and no plugins. In reality, I think there was an underlying Firefox bug and it got fixed.

I agree with the sentiments above that Firefox cannot get sucked into handling bugs in plugins. However, that means Firefox will have a sort of blind spot where bugs that for whatever reason are associated with plugins tend to be ingored. I don't know for sure, but I suspect that's what happened here.
I for one have this happening right now on 3.0.10 on Ubuntu 9.04 Hitting <Enter> or <Ctrl>+<Enter> on the address bar won't do anything and the only way to navigate is by using the search bar and clicking on links.

Will try to get somebody on IRC to help me gather needed info because this one is a difficult one to replicate but is still there hiding somewhere.

Plugins:
Adblock Plus 1.0.2
Adblock Plus: Element Hiding Helper 1.0.5
Delicious Bookmarks 2.1.018
Diccionario español Argentina 1.1.1
FireGPG 0.7.5
Ubuntu Firefox Modifications 0.7
I filed bug 490834 about blocklisting Delicious 2.0.64
This is still an issue for me without any of the named extensions installed.

Whenever this happens to me in the search bar, I get the following error in the Error console (Ubuntu Jaunty, Firefox 3.0.11):

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatementWrapper.step]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///usr/lib/firefox-3.0.11/components/nsSearchService.js :: epsGetAttr :: line 2921" data: no]
Source File: file:///usr/lib/firefox-3.0.11/components/nsSearchService.js
Line: 2921

This happens after the following error appears:

Error: Permission denied to call method Location.toString

The address bar does not work either, but no error is returned when I try to use it. The only extension installed is the Ubuntu Firefox Enhancements.
(In reply to comment #166)
> Whenever this happens to me in the search bar, I get the following error in the
> Error console (Ubuntu Jaunty, Firefox 3.0.11):

This looks like bug 433129. Please head over there. Thanks.
Status: RESOLVED → VERIFIED
Component: Location Bar and Autocomplete → Extension Compatibility
QA Contact: location.bar → extension.compatibility
I had exactly the problem outlined in this bug thread. However, by a process of elimination, I located the offending file. In my case the offending file that caused Firefox's "spasm" (a term given by this bug thread starter) was "search.json" located in Firefox’s Profile directory.

Upon renaming the Profile directory to something, and then executing Firefox, Firefox is forced to create a new profile. The "spasm" was confirmed not to occur in the new profile.

Exiting Firefox and replacing the "search.json" with the offending "search.json" into the new profile directory, then firing-up Firefox, the dreaded Firefox "spasm" once again takes hold.

As stated earlier, it was by a process of elimination that found the offending file. In this process, I tested other files such as, content-prefs.sqlite, cookies.sqlite, downloads.sqlite, formhistory.sqlite, localstore.rdf, permissions.sqlite, search.sqlite, webappsstore.sqlite, in a similar manner, but none of them could replicate the "spasm".

I presume the file "search.json" gets corrupted and some how incapacitates the address bar.

User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
You need to log in before you can comment on or make changes to this bug.