Closed Bug 271895 Opened 15 years ago Closed 15 years ago

Exporting an address book doesn't work (Not enough arguments [nsIAddressBook.exportAddressBook])

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, major)

1.7 Branch
x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: evert.verhellen, Assigned: standard8)

References

Details

(Keywords: fixed1.7.6, regression, verified1.7.6)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041126

Exporting an address book doesn't work. A dialog with failure code 0x80004005
(NS_ERROR_FAILURE) is displayed instead.

Reproducible: Always
Steps to Reproduce:
1. mozilla -addressbook
2. Tools > Export ...
Actual Results:  
A window entitled "Export Failed" is displayed.

Expected Results:  
It should work as before.

Importing an address book still works.
Attached image Export Failed
Evert, if you want to e-mail me your AB, I can try exporting it and see what's
going on in the code. (I promise to delete it after I find out what's going
on...) Or, you could try copying the cards in your AB into another AB and try
exporting that. If that doesn't work, you could try to create a minimal AB that
fails to export.
The problem doesn't seem to be related to any specific address book. It even
happens when the address book is completely empty, e.g. in a fresh environment.
Maybe this bug is specific to Fedora Core 3. A few weeks ago, I already filed a
bug against Red Hat's Bugzilla:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138934
ah, then never mind. Do you get to the file picker and pick a file to export to,
or does it fail before then?
I don't see those dialogs when exporting an address book, it stops right there
at the "Export Failed" dialog. Exporting bookmarks still works fine.
Exporting an addressbook still fails with Mozilla 1.7.5, although the message
displayed has changed. It now says: "Not enough arguments
[nslAddressBook.exportAddressBook]".
Attached image Export Failed 1.7.5
*** Bug 275652 has been marked as a duplicate of this bug. ***
OS: Linux → All
I can confirm the same behaviour with mozilla 1.7.5 here on RH8 Linux machines.
Oddly enough we *don't* get the error with mozilla 1.7.3 though, so maybe there
is some library version issue involved.
(In reply to comment #9)
> I can confirm the same behaviour with mozilla 1.7.5 here on RH8 Linux machines.
> Oddly enough we *don't* get the error with mozilla 1.7.3 though, so maybe there
> is some library version issue involved.

I can add this info - it is not *nix specific. Same thing is happening to me on
Win98SE, Mozilla 1.7.5. Message box titled 'Export Failed' with message text
"Not enough arguments [nslAddressBook.exportAddressBook]". I have also been able
to export successfully on prior versions.
Also happens on Windows XP with Mozilla 1.7.5.
*** Bug 275792 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20041228

Confirming after having tried on latest trunk build, and having found various
duplicates on different platforms.

Also nominating that this should block 1.7.6 release as it's missing functionality.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.7.6?
Version: unspecified → 1.7 Branch
This patch fixes the problem - it looks like changes from bug 240723, 44494(?),
240723 didn't get applied fully/properly, and hence the extra parameter is
missing in the 1.7.x branch. It is fine in the main trunk.
Assignee: sspitzer → mark
Status: NEW → ASSIGNED
Attachment #169704 - Flags: review?(neil.parkwaycc.co.uk)
Did you mean bug 242291?
(In reply to comment #15)
>Did you mean bug 242291?
Did I mean bug 242991 :-[
Yes, I did mean bug 242991 - must have got my numbers confused.
Comment on attachment 169704 [details] [diff] [review]
Patch to apply missing change

This looks reasonable, although I don't have a 1.7.5 build. I wish I'd never
looked at bug 44494 though, that code is indescribable...
Attachment #169704 - Flags: review?(neil.parkwaycc.co.uk) → review+
Attachment #169704 - Flags: superreview?(bienvenu)
Attachment #169704 - Flags: superreview?(bienvenu) → superreview+
Attachment #169704 - Flags: approval1.7.6?
*** Bug 276331 has been marked as a duplicate of this bug. ***
Comment on attachment 169704 [details] [diff] [review]
Patch to apply missing change

ARGH
Attachment #169704 - Flags: approval1.7.6? → approval1.7.6+
Fix checked in to 1.7.

Thanks
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
*** Bug 276640 has been marked as a duplicate of this bug. ***
*** Bug 276753 has been marked as a duplicate of this bug. ***
Keywords: regression
Summary: Exporting an address book doesn't work → Exporting an address book doesn't work (Not enough arguments [nsIAddressBook.exportAddressBook])
*** Bug 277047 has been marked as a duplicate of this bug. ***
*** Bug 277213 has been marked as a duplicate of this bug. ***
(In reply to comment #21)
> Fix checked in to 1.7.

So this can get the "fixed1.7.6" keyword?
*** Bug 277590 has been marked as a duplicate of this bug. ***
*** Bug 277739 has been marked as a duplicate of this bug. ***
*** Bug 277776 has been marked as a duplicate of this bug. ***
*** Bug 278441 has been marked as a duplicate of this bug. ***
*** Bug 278722 has been marked as a duplicate of this bug. ***
Keywords: fixed1.7.6
*** Bug 278863 has been marked as a duplicate of this bug. ***
*** Bug 279462 has been marked as a duplicate of this bug. ***
*** Bug 280022 has been marked as a duplicate of this bug. ***
Flags: blocking1.7.6?
*** Bug 281194 has been marked as a duplicate of this bug. ***
*** Bug 281194 has been marked as a duplicate of this bug. ***
*** Bug 282062 has been marked as a duplicate of this bug. ***
*** Bug 282585 has been marked as a duplicate of this bug. ***
*** Bug 282885 has been marked as a duplicate of this bug. ***
*** Bug 282977 has been marked as a duplicate of this bug. ***
*** Bug 283011 has been marked as a duplicate of this bug. ***
*** Bug 284495 has been marked as a duplicate of this bug. ***
*** Bug 284563 has been marked as a duplicate of this bug. ***
*** Bug 284906 has been marked as a duplicate of this bug. ***
*** Bug 285328 has been marked as a duplicate of this bug. ***
verified fixed using 2005031011-1.7 mozilla bits on linux fc3. I tested export
and import of .csv, .txt and .ldif addressbooks.
Status: RESOLVED → VERIFIED
mistakenly removed fixed1.7.6 --pardon the bugspam. set your filter/quicksearch
to "ZippidityDooDahHey" to catch these for easy removal/etc/
Keywords: fixed1.7.6
*** Bug 285688 has been marked as a duplicate of this bug. ***
*** Bug 285685 has been marked as a duplicate of this bug. ***
*** Bug 287079 has been marked as a duplicate of this bug. ***
*** Bug 287364 has been marked as a duplicate of this bug. ***
*** Bug 287423 has been marked as a duplicate of this bug. ***
*** Bug 290171 has been marked as a duplicate of this bug. ***
*** Bug 294008 has been marked as a duplicate of this bug. ***
*** Bug 294008 has been marked as a duplicate of this bug. ***
*** Bug 295270 has been marked as a duplicate of this bug. ***
*** Bug 298263 has been marked as a duplicate of this bug. ***
*** Bug 314973 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.