Last Comment Bug 269664 - 'loadOnNewTab' or similar should be reimplemented
: 'loadOnNewTab' or similar should be reimplemented
Status: RESOLVED WONTFIX
[parity-IE]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- enhancement with 33 votes (vote)
: Future
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
:
Mentors:
: 237230 253880 309231 345743 374586 427238 440036 460132 462510 493148 494770 498067 511453 524286 593284 759430 (view as bug list)
Depends on:
Blocks: 164421
  Show dependency treegraph
 
Reported: 2004-11-13 09:35 PST by Pierre S.
Modified: 2015-09-23 14:01 PDT (History)
41 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Pierre S. 2004-11-13 09:35:05 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0

In french Firefox 1.0 for Windows.
Setting 'browser.tabs.loadOnNewTab' to 1 or 2 always open a blank page when
opening new tab.
Tested with Win 2000 pro and Win XP home.

Reproducible: Always
Steps to Reproduce:
1. type about.config in URL bar, and set 'browser.tabs.loadOnNewTab' to 1 (open
home page on new tab)
2. quit Firefox and restart, type about.config in URL bar to verify that
browser.tabs.loadOnNewTab is set to 1 (or 2)
3. go to any other URL
4. Do 'File > New Tab' or Ctrl+T

Actual Results:  
The new tab is blank.

Expected Results:  
The new tab should display the home page (or the last visited page). Like it is
specified in 'http://preferential.mozdev.org/preferences.html':
<<
browser.tabs.loadOnNewTab
What should be displayed in a newly created tab
    * -1 : Browser startup page
    * 0 : Blank page
    * 1 : Your homepage
    * 2 : Last visited page
>>

Set as mjor because the tab browsing differienciates Mozilla and Firefox to IE
Comment 1 Mike Connor [:mconnor] 2004-11-14 15:34:59 PST
Near as I can tell, someone finally removed this pref, although its still
floating in the globalhistory impl.

Marking this INVALID.

Filed Bug 269852 on removing the support in our history impl for saving the last
visited page, since we don't use those prefs

Filed Bug 269854 on moving the prefs out of all.js and into the Seamonkey
browser prefs so they doesn't show in about:config

Comment 2 Nickolay_Ponomarev 2005-02-04 21:03:17 PST
*** Bug 253880 has been marked as a duplicate of this bug. ***
Comment 3 Jason K Carter 2005-03-18 08:35:15 PST
Personally, I think the user should get to choose what gets loaded in a new tab,
just like they do for a new window.  Please add this feature.
Comment 4 Tim 2005-03-24 11:10:42 PST
I have always found it strange and annoying that a new tab
doesn't do the same as a new window. I finally went to find
out how to change this behaviour and find it is be removed?
Very strange. I'm okay with the default being blank, but
there should be a way to change this!
Comment 5 frederik 2005-04-19 20:15:46 PDT
Why was this feature removed? We're sliding backwards. Please explain.
Comment 6 Aaron Kemp 2005-09-09 17:04:13 PDT
It's really unfortunate that this was removed.  Please change it back.  I like
having a home page, but hate having it open in every new tab I create.
Comment 7 Zachariah 2005-09-09 18:39:01 PDT
(In reply to comment #6)
> It's really unfortunate that this was removed.  Please change it back.  I like
> having a home page, but hate having it open in every new tab I create.

A workaround is to middle-click or CTRL+click the Home icon -- that will create
a new tab which is not blank, but rather goes to your home page (but, yeah, it
would at least be nice to be able to set this in about:config).
Comment 8 Aaron Kemp 2005-09-10 10:04:06 PDT
> A workaround is to middle-click or CTRL+click the Home icon -- that will create
> a new tab which is not blank, but rather goes to your home page (but, yeah, it
> would at least be nice to be able to set this in about:config).

Thanks for the suggestion, but I actually wanted the opposite: to open a *blank*
tab... My homepage takes a fair amount of time to load and the page grabs focus
if I am typing the URL I actually *wanted* to go to in the address bar when it
loads.  It seems that adding this back into about:config can't hurt novice users
(they won't know about it) and will make advanced users happy.
Comment 9 tim.howe 2006-09-15 10:08:02 PDT
browser.windows.loadOnNewWindow needs to work too.

I don't want the home page loading every time I make a new window.
Comment 10 tamagotchi 2006-11-11 16:17:50 PST
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5)
> Gecko/20041108 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5)
> Gecko/20041108 Firefox/1.0
> 
> In french Firefox 1.0 for Windows.
> Setting 'browser.tabs.loadOnNewTab' to 1 or 2 always open a blank page when
> opening new tab.
> Tested with Win 2000 pro and Win XP home.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. type about.config in URL bar, and set 'browser.tabs.loadOnNewTab' to 1 (open
> home page on new tab)
> 2. quit Firefox and restart, type about.config in URL bar to verify that
> browser.tabs.loadOnNewTab is set to 1 (or 2)
> 3. go to any other URL
> 4. Do 'File > New Tab' or Ctrl+T
> 
> Actual Results:  
> The new tab is blank.
> 
> Expected Results:  
> The new tab should display the home page (or the last visited page). Like it is
> specified in 'http://preferential.mozdev.org/preferences.html':
> <<
> browser.tabs.loadOnNewTab
> What should be displayed in a newly created tab
>     * -1 : Browser startup page
>     * 0 : Blank page
>     * 1 : Your homepage
>     * 2 : Last visited page
> >>
> 
> Set as mjor because the tab browsing differienciates Mozilla and Firefox to IE
> 

I was always wondering why a new tab opens blang and was always angry that I have to push on home again. Then I was lucky to find out that you can change this - and now it doesn´t work! Please make it work!!

A good idea would be if the user can choose different homepages for new window and for new tab (for example if in new window several tabs shall open (realized by pipes), but in new tab only one)
Comment 11 Stuart Halliday 2006-11-16 04:07:38 PST
In FF 1.5 I could simply choose whether or not I wanted a new tab to have a blank or home page (I like to see a home page).

In my viewpoint a new tab should behave exactly like a new window.

Now in FF 2.0 this option has been removed and therefore the users of 1.5 who used this option feel annoyed at finding it missing and are probably irritated to find that this feature was deliberated removed!

I strongly urge the FF developers to add this useful option back in.

Lastly - IE7 offers this feature. 

We wouldn't want a good feature that used to be in FF1.5 and that is now in IE7 to be left out of FF 2.0 now do we? ;-)

Lets move forward, not backwards.
Comment 12 ztk 2006-11-17 09:41:52 PST
i found an extension to fix this bug, anyone interested should take a look at this : https://addons.mozilla.org/firefox/1122/
after you install it you can configure it from the tools -> options -> tabs -> tab mix plus options.
Comment 13 Nicolas Turcot (:nico@nc) 2007-02-15 01:12:05 PST
Lighter than TabMix+ suggested above, this extension can be interesting : NetTabUrl | https://addons.mozilla.org/firefox/2221/
Comment 14 Bob Clary [:bc:] 2007-03-20 03:15:24 PDT
*** Bug 374586 has been marked as a duplicate of this bug. ***
Comment 15 Jesse Ruderman 2008-04-05 16:38:37 PDT
*** Bug 427238 has been marked as a duplicate of this bug. ***
Comment 16 Damian Shaw [Quan] 2008-04-05 16:47:02 PDT
IE now offers a similar feature and I've come across a few users who are confused why Firefox doesn't by default. This should be re-implemented. I'm tempted to re-open this bug myself but I'll chat to a couple of developers first and gather some opinions. 
Comment 17 Damian Shaw [Quan] 2008-04-05 19:54:13 PDT
Changing the bug title to reflect the arguments in the bug and the similar duplications it has had.
Comment 18 Amoun 2008-04-06 01:44:23 PDT
Just sent this email to *ben/at/mozilla/dot/org* 

Hi Ben

I'm wondering if you are still involved with Mozilla s this bug seems very old and a bit odd as it seems largely a feature that Firefox had and lost and now IE has it.

My thinking is that there has been no one working on it for the past 3 to 4 years, as I can't believe it can take this long to sort it.

All the best

Roger Lovejoy 
Comment 19 John McCormick 2008-04-10 15:36:41 PDT
I was quite annoyed to find this feature missing when switching from Netscape to Firefox (3 Beta 4).

Anyone that is interested in searching doesn't want to waste time on the toolbar search which is severely limited. For that reason, my home page is the advanced Google search page.

In Netscape, it would pop up whenever I opened a new tab. Since Netscape has been discontinued, I've changed to Firefox, which doesn't have this simple but very useful feature. Bring back loadOnNewTab!!!
Comment 20 Damian Shaw [Quan] 2008-04-10 15:51:13 PDT
I had a lengthy discussion the the #developers channel of irc.mozilla.org. The main objection wasn't so much about the feature suggestion as it was about reopening a bug decided to be invalid, though I argued there was cause for change because IE7 had adopted a similar feature and it makes transition easier from IE to Firefox.

Anyway, basically to reopen the bug legitimately (as apposed to just doing it any annoying devs), someone needs to convince one of the higher ups like beltzner or mconnor. Might give it a go in the mean time, if people want this bug otherwise vote for it and see if you can get hold of one of them in a polite way and constructively explain why it would be good to have it now rather than when this bug was marked invalid.
Comment 21 David McRitchie 2008-05-25 08:10:19 PDT
Even though I think it should be available, I can only think that anyone who does that is working very inefficiently; however, there is an small  extension (4KB) that will do that.  That means  12-16KB wasted as installed as opposed  to testing a bit in Firefox.
   New Tab Homepage :: Firefox Add-ons    (4KB), Ben Basson
   https://addons.mozilla.org/en-US/firefox/addon/777
Comment 22 Thomas Oskk 2008-05-26 00:46:56 PDT
(In reply to comment #21)
> Even though I think it should be available, I can only think that anyone who
> does that is working very inefficiently; however, there is an small  extension
> (4KB) that will do that.  That means  12-16KB wasted as installed as opposed 
> to testing a bit in Firefox.
>    New Tab Homepage :: Firefox Add-ons    (4KB), Ben Basson
>    https://addons.mozilla.org/en-US/firefox/addon/777
> 

Hey David, 
thanks for the link. Unfotunately it does not work with FF2, even though there seems to be a version for it.
Although I dont understand why you think this makes working inefficient. I rather think it makes working more efficient. I use a self made "home" page, where I store all the links I frequently need, so if I open an new tab/window, it's most likely I need exactly one of those links. So it makes working rather more efficient than the opposite. 
However, nevermind. Doesnt work with 2.x, anyway.
Comment 23 Aditya 2008-05-26 00:56:23 PDT
(In reply to comment #22)
> (In reply to comment #21)
> > Even though I think it should be available, I can only think that anyone who
> > does that is working very inefficiently; however, there is an small  extension
> > (4KB) that will do that.  That means  12-16KB wasted as installed as opposed 
> > to testing a bit in Firefox.
> >    New Tab Homepage :: Firefox Add-ons    (4KB), Ben Basson
> >    https://addons.mozilla.org/en-US/firefox/addon/777
> > 
> 
> Hey David, 
> thanks for the link. Unfotunately it does not work with FF2, even though there
> seems to be a version for it.
> Although I dont understand why you think this makes working inefficient. I
> rather think it makes working more efficient. I use a self made "home" page,
> where I store all the links I frequently need, so if I open an new tab/window,
> it's most likely I need exactly one of those links. So it makes working rather
> more efficient than the opposite. 
> However, nevermind. Doesnt work with 2.x, anyway.
> 

I agree with Thomas... I use a similar page of links as my homepage and I find it very useful for the new tab to default to this homepage.

However, Thomas, I use New Tab Homepage v3.0 with FF2 and it works fine. I've been using it for last few months now infact (since FF 2.0.0.8 I think)
Comment 24 Amoun 2008-05-26 04:33:03 PDT
Hi Thomas and Aditya
Yeap I've no idea on this inefficiency idea that David mentioned, and I'm sure a) it is a very useful option to be able to set the content of a new tab, and b)probably uses less memory than an extension.

Anyway for now thanks for the pointer to
https://addons.mozilla.org/en-US/firefox/addon/777 
Comment 25 Steve Pedersen 2008-06-08 11:23:53 PDT
I registered just so i could vote for this.
Why didn't the person responsible for removing this feature remove the "browser.tabs.loadOnNewTab" setting as well?
My guess is laziness.

Please fix this, or i will. Just in spite.
Although I'll have to teach myself programming first. =P

Thanks for developing a great browser though!
Comment 26 Ria Klaassen (not reading all bugmail) 2008-06-18 11:52:56 PDT
*** Bug 440036 has been marked as a duplicate of this bug. ***
Comment 27 Damian Shaw [Quan] 2008-06-18 12:07:53 PDT
*** Bug 345743 has been marked as a duplicate of this bug. ***
Comment 28 Damian Shaw [Quan] 2008-06-19 04:58:52 PDT
*** Bug 309231 has been marked as a duplicate of this bug. ***
Comment 29 Damian Shaw [Quan] 2008-06-19 04:59:10 PDT
*** Bug 237230 has been marked as a duplicate of this bug. ***
Comment 30 Damian Shaw [Quan] 2008-06-19 05:06:23 PDT
Also bugs:
bug 280530
bug 269716
bug 200956

Are the same, but the first 2 are already marked as duplicates of bug 237230 and and the last one is still new and assigned and older than this bug, so wasn't sure whether to mark as a duplicate.

Changing status to WON'TFIX as it's not a more appropriate status for this bug. Someone feel free to correct me or even better someone feel free to reopen this bug.
Comment 31 Damian Shaw [Quan] 2008-06-19 05:14:59 PDT
Also bug 187573 which is older than this bug and has many many duplicates set to it.

I thought this was the unifying bug but that's even older, has more duplicates but less votes (it's not quite as explicit as this one).
Comment 32 Bruce A. Wittmeier 2008-06-26 13:34:52 PDT
There are a few options available in Tab Mix Plus that I would love to see incorporated into the Firefox standard tab options.  One in particular is 'Open all links, bookmarks, application links, search in new tabs".

The std FF is so close to containing all I need for the 'perfect' browser, Id love to see this implementation.

It is amazing that people all over the world can contribute to this effort. The Mozilla team is doing a great job!

Thanks,
Bruce
Comment 33 Dotan Cohen 2008-08-12 07:30:21 PDT
@Damian Shaw:
Why did you mark this bug WONTFIX? Please mark in NEW. There is no reason not to reimplement this. Thanks.
Comment 34 Damian Shaw [Quan] 2008-08-12 07:51:37 PDT
(In reply to comment #33)
> @Damian Shaw:
> Why did you mark this bug WONTFIX? Please mark in NEW. There is no reason not
> to reimplement this. Thanks.
> 

Because I've not found a developer from Mozilla yet who agrees this should be fixed. In fact while discussing this on the #developer channel of Mozilla irc, one of them was vehemently against it being reimplemented. 

I was basically told to get one the higher ups to agree this should be reimplemented before marking it new, I've yet to do that.
Comment 35 Dotan Cohen 2008-08-12 10:01:11 PDT
In Comment #20 you mention that the bug was marked WONTFIX because it was deemed a better conclusion than INVALID. However, why was it marked INVALID? It was invalidated four years ago without explanation, and since then users have been crying for this feature's return.

The request to add back the loadOnNewTab functionality certainly is a valid request. And there are now five extensions that reenable this feature, including two that are dedicated to this feature exclusively! Furthermore, every major browser (IE, Opera, Konqueror, Safari) support the loading of the homepage automatically in a new tab, as do other Gecko-based browsers.

The whole problem seems to stem from the original INVALID designation, which was done without explanation and seemingly without thought. Please ask the devs to reconsider the original INVALID designation and reassign as necessary. Thanks.
Comment 36 Damian Shaw [Quan] 2008-08-12 11:01:23 PDT
Oh, I couldn't find this feature in Opera or Safari, if you can give me details on them I'll add that to the white board.

I obviously agree this bug should be marked new, that's why I've done so much preparation on the bug to make it in to a state where it can be picked up by someone. The original bug "'loadOnNewTab' option not taken in acount in Firefox version 1.0" was marked invalid because that was intended behavior. But that quickly was not the purpose of the bug, but rather to add back loadOnNewTab, which is why I changed the title of the bug to what it is.
Comment 37 Dotan Cohen 2008-08-12 11:22:29 PDT
Opera: On the SpeedDial page, click "Hide Speed Dial". For me on Opera 9.50 I cannot get it to show the homepage, but previous 9.x versions did. I'll upgrade to the latest and dig around the preferences.

Safari: I don't have a Mac, but I was actually introduced to this behaviour on a friend's Mac running Safari. He has his homepage as a custom HTML page with Wikipedia and Google forms, and links to several select websites. So it's definetely possible.

I also have seen elsewhere in Bugzilla that this is the default behaviour of IE 7, though I do not have a Windows machine to check.
Comment 38 Damian Shaw [Quan] 2008-08-12 11:49:48 PDT
(In reply to comment #37)
> Opera: On the SpeedDial page, click "Hide Speed Dial". For me on Opera 9.50 I
> cannot get it to show the homepage, but previous 9.x versions did. I'll upgrade
> to the latest and dig around the preferences.
> 
> Safari: I don't have a Mac, but I was actually introduced to this behaviour on
> a friend's Mac running Safari. He has his homepage as a custom HTML page with
> Wikipedia and Google forms, and links to several select websites. So it's
> definetely possible.
> 
> I also have seen elsewhere in Bugzilla that this is the default behaviour of IE
> 7, though I do not have a Windows machine to check.
> 

Yes, I know it works in IE7, which is why I've put [parity-IE] on the whiteboard, I'll take another look at Opera and Safari for Windows.
Comment 39 Michael Monreal [:monreal] 2008-09-12 01:51:02 PDT
Wow... I just build myself a nice "New Tab" page a la Chrome and now I find that it is not possible to use it in firefox without a hack¹. Bad.

[1] https://addons.mozilla.org/en-US/firefox/addon/777
Comment 40 Damian Shaw [Quan] 2008-09-12 02:19:18 PDT
I've been meaning to contact Aza Raskin to see if he'll pick up or superseed this bug with another one. There are new design proposals for a newtab page:

http://www.vimeo.com/1474467?pg=embed&sec=1474467
Comment 41 Damian Shaw [Quan] 2008-10-08 14:23:37 PDT
Looks like work is being done in bug 455553 to spice up the new tab page.
Comment 42 Dave Townsend [:mossop] 2008-10-15 14:42:37 PDT
*** Bug 460132 has been marked as a duplicate of this bug. ***
Comment 43 Matthias Versen [:Matti] 2008-10-16 09:04:45 PDT
*** Bug 460132 has been marked as a duplicate of this bug. ***
Comment 44 Dave Townsend [:mossop] 2008-10-31 05:26:32 PDT
*** Bug 462510 has been marked as a duplicate of this bug. ***
Comment 45 Henk Koning 2008-10-31 06:09:16 PDT
thanks for the pointer to
https://addons.mozilla.org/en-US/firefox/addon/777 
it does just what I need!
Comment 46 Matthias Versen [:Matti] 2009-05-15 14:12:36 PDT
*** Bug 493148 has been marked as a duplicate of this bug. ***
Comment 47 Mardeg 2009-05-25 06:23:16 PDT
*** Bug 494770 has been marked as a duplicate of this bug. ***
Comment 48 Matthias Versen [:Matti] 2009-06-13 02:52:08 PDT
*** Bug 498067 has been marked as a duplicate of this bug. ***
Comment 49 chris 2009-08-14 08:42:41 PDT
I've been complaining about this "feature" for literally years! "Won't fix" is an absurd non-resolution for a perfectly legitimate complaint. The fact that it's been addressed by multiple add-ons proves that users want it fixed, and also proves that it can't be that difficult to do. We're talking about one extra checkbox in the options dialog, I mean come on now!
Comment 50 Ria Klaassen (not reading all bugmail) 2009-09-09 09:20:39 PDT
*** Bug 511453 has been marked as a duplicate of this bug. ***
Comment 51 [not reading bugmail] 2009-09-09 11:18:37 PDT
Ok, I'm going to vote for this, but not for any reason I seen here, not even just for IE-parity:

But the real reason is this is used by any organization trying to give users their own consistent user experience via a portal or landing or intranet zone and first point of contact site.  So this is a legitimate need in say your local library, your workplace, your corporation, or just for any non-techie who rely solely thinking the internet is MSN.com and always use it as their internet landing zone.  But it should be optional like IE via preference.  

The default behavior in IE loads a blank new tab also and IE is no better and
loads about:blank, but can be changed by their UI preference and it gets used.

Until I looked at the IE options for Tab Browsing, I didn't know this was an
option in IE7.  They have a preference to also 'open homepage for new tabs
instead of a blank page'.  

Organizations would probably give FF a bit more legroom if got this one in there.
Comment 52 PROTO57 2009-09-09 19:48:32 PDT
My homepage is a list of links, and I rely on it appearing in each new tab. This was simply one of the key features of previous versions of firefox... I am dumbfounded why it is gone. 

The ability to customize is the reason, IMO, for the existence of firefox... why degrade it's core purpose? From the previous posts, it seems clear it would not a problem to add this option back in, nor that there is any important reason it was canned.

If I cannot re-install and run my old, earlier version of firefox with this feature, it looks like I'll be back to I.E...
Comment 53 Thomas Oskk 2009-09-10 02:29:34 PDT
I can't see what problem there should be reimplementing this very useful and numerously recommended feature. And it seems to me that there is no reasonable argument to explain the removal, is there? It appears kind of blinkered to ignore the large number of users who really would like to have the feature back, for several practical reasons. And switching back to IE, if the feature won't be reimplemented, should alone be a strong motivation for the developers.
Comment 54 Stuart Halliday 2009-09-10 10:26:08 PDT
I think the issue probably is that the developers don't want to add a feature that is currently added via a Add-on?

I use 'New Tab Homepage 0.41' to do this.
https://addons.mozilla.org/en-US/firefox/addon/777

But NewTabURL 1.6.2 
https://addons.mozilla.org/en-US/firefox/addon/2221
does it too.


Also the developers probably don't read these comments... ;-)
Comment 55 Balin Hansen 2009-09-27 01:11:58 PDT
To summarize this issue:

Obviously the reason that this issue is labelled "WONTFIX" is because middle-clicking or Ctrl-clicking the Home button gives you a new tab of your homepage. The fact that you can install Addons that will create the desired functionality makes this even less of an issue.

I suspect that the only good reason for taking the checkbox out of the Options->Tabs dialog would have been a cease and desist from a company like Micrsoft of Opera who would lay claim to having invented said functionality. This is just a theory but I'm sure it's something that Mozilla is mindful of. Anything they'd have to get a lawyer involved with to figure out probably gets removed ... pronto, hence "WONTFIX" seems like a pretty good response to this bug report.

I didn't even notice this issue until *just* recently ... in fact, I'm tempted to say this functionality still exists in  some version of 2.x ... Now that I'm up to 3.5 I'm sort of vexed by this. They didn't have a hard time removing the checkbox in the Options->Tabs dialog so it certainly wouldn't be hard to put it back. I'm not going to tell the Firefox guys that they should do this for any other reason than because people like me would really appreciate it.

Sometimes I'll be reading something and want to look something up so before I use the little Google search field up in my toolbar I create a new tab. This is about the only good time to have a blank page and hey, I just learned that Ctrl-clicking or Middle-clicking the search icon performs that search in a new tab. Go me! I also just figured out that typing in a URL in the address bar and Ctrl/Middle-clicking the little "Go" arrow icon sends me to the URL in a new tab as well. Yay, I'm learning! ... However, this just makes the blank page thing seem even even more and more useless.

Why is it Ctrl/Middle-click anyway? That's so unintuitive compared to the good old fashion right-clicking, imo ... I digress

Perhaps the developers feel that a blank page is more efficient than sending users to URL( http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official ) all day long. I guess that's a valid point but only if users were forced to go to their homepage every time but that's why the blank page was an option in the first place, some people's homepage is AOL.com and they're on dial-up connections at 14.4kbps.

I run a web server out of my home and one of my web sites has a page dedicated to all of my favorite links which are sorted by how often I use them. It loads lightning fast without even so much as a query to an outside DNS server and I use it an absurd number of times every day.

Here's a though: if I already have to hit Ctrl-T to open a new tab because "track pads" on laptops are annoying both for cursor movement and for their lack of a third mouse button ... what's the keyboard-exclusive hotkey for opening a new Tab that takes me to my homepage? That would indeed be useful to me.

I spent hours trying to figure out *why* I could no longer even find the option in the Options->Tabs dialog box, hours researching the about:config feature of Firefox, hours reading online forums like this now 11-page bug fix and still more hours trying to articulate the problem in an effort to make that little bit of difference we're all asking for. I'm glad that I learned some things along the way like how useful middle-clicking really is but the fact remains that giving users the option to default new tabs to their homepage in Firefox was appreciated, continues to be appreciated by users of other browsers and will continue to be appreciated in Firefox if you hear us out.

To Conclude:

END USERS - Ctrl+Left-Clicking or Middle-Clicking is your friend! Try it on the Address bar, the Search bar or Home button ... it does everything in new Tabs! I think we all agree that the "blank page" serves absolutely no purpose at this point.

MOZILLA DEVELOPERS - while this isn't necessarily a "bug" per se I feel that it should be reclassified. This is the sort of functionality the end users have learned to expect from their browsers and those that haven't are missing out. I miss having the option myself ... The fact that it could be perceived as "inefficient" is why it was an originally an option and not mandatory because as we all know "inefficient" is just an opinion and in cases like mine it couldn't be further from the truth. Please consider returning this functionality to the Firefox browser.

EVERYONE - thank you for contributing to Firefox, it wouldn't be as hugely popular as it is without the help of classy, high-caliber ladies and gentlemen such as yourselves!
Comment 56 Jo Hermans 2009-10-24 11:59:31 PDT
*** Bug 524286 has been marked as a duplicate of this bug. ***
Comment 57 Hubert 2009-12-21 15:01:19 PST
Just want to agree to Balin.

I never could understand why such a feature is missing in Firefox and 
searching for it took me several hours. 

In my point of view Firefox developpers do an excellent job (!) but for this feature something goes wrong. Just the amount of duplicate bugs and the number of browsers implementing this feature should give a clear indication.
Comment 58 Oskar Ivanić (:icecold) 2010-03-16 12:33:05 PDT
I agree with Hubert. This and some of others simple features (like past and go) should be added to Firefox. It makes surfing faster and easier. Why do we need to use addons if we can have it integrated?
Comment 59 Sadata 2010-10-04 07:39:10 PDT
I just wasted the last half-hour implementing the 'browser.tabs.loadOnNewTab' fix to find out it doesn't work in Firefox and, upon more time wasted researching the issue, come upon this page and the nonsense explanation of why it won't be fixed. Seriously??? This feature is a no-brainer.

Firefox developers, quick wasting everyone's time and just implement it. This is almost a sick joke. There's obviously some stubborn, mule-like personality behind this decision. They should be embarrassed that they've perpetrated this crime for so long (since 2004!). Unbelievable.
Comment 60 Stuart Halliday 2010-10-04 11:41:55 PDT
(In reply to comment #59)

> Firefox developers, quick wasting everyone's time and just implement it. This
> is almost a sick joke. There's obviously some stubborn, mule-like personality
> behind this decision. They should be embarrassed that they've perpetrated this
> crime for so long (since 2004!). Unbelievable.

You took the words right out of our mouths....

I wonder if the developers are trying to mimic IE and its brain-dead method of opening a new Tab perhaps?
Comment 61 Dotan Cohen 2010-10-04 12:12:26 PDT
> I wonder if the developers are trying to mimic IE and its
> brain-dead method of opening a new Tab perhaps?

Obviously not. IE has this feature.
Comment 62 Jo Hermans 2010-10-04 13:21:00 PDT
*** Bug 593284 has been marked as a duplicate of this bug. ***
Comment 63 Thomas Oskk 2010-10-04 14:21:38 PDT
Keeping this opinion, FF is no longer an alternative towards IE. 
It's getting more and more blown up and source consuming without real benefits from that.
The Devs maybe should go "back to the roots" and remember what FF was made for: a convenient tool, easy to use, with small resource consumption, user friendly, providing all you need to surf the web, but in a safe way. 
This path has been left, if you need an addon to give you the convenience the browser should offer.
Maybe it's time for a new start. 

And I want my old Netscape back.
Comment 64 Bleddle 2011-08-24 00:07:13 PDT
It's seven years now and this still isn't fixed. Would a dev please implement this ? It can't be that hard.
Comment 65 Matthias Versen [:Matti] 2012-05-29 14:35:00 PDT
*** Bug 759430 has been marked as a duplicate of this bug. ***
Comment 66 t8av 2012-05-29 18:22:01 PDT
I totally agree, it is ridiculous that this feature does not exist yet. Even in IE they implemented it.

I think that maybe part of the reason that it takes so long to fix this bug, is that the title of this bug is not clear enough. The title should be something like: "Firefox should go to home page when opening a new tab".
Comment 67 mjh563 2012-05-29 20:17:28 PDT
Starting in Firefox 13, you can set the page that opens in a new tab by changing 'browser.newtab.url' in about:config.
Comment 68 t8av 2012-05-29 20:42:41 PDT
Should be in a human-interface (tools->options->Tabs), not in a config application.
Comment 69 Thomas Oskk 2012-05-30 03:29:06 PDT
I totally agree with #68. Common users normally don't dig the 'bowels', even more because they are warned not to do so unless they're absolutely sure about.
Comment 70 R Pruitt 2015-09-23 14:01:26 PDT
(In reply to mjh563 from comment #67)
> Starting in Firefox 13, you can set the page that opens in a new tab by
> changing 'browser.newtab.url' in about:config.

Starting in Firefox 41, sadly, you can't.

Note You need to log in before you can comment on or make changes to this bug.