Multiple back/forward buttons in toolbar

VERIFIED FIXED in Firefox 3

Status

()

P2
normal
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: jst, Assigned: dao)

Tracking

Trunk
Firefox 3
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(13 attachments)

(Reporter)

Description

11 years ago
Created attachment 311662 [details]
Screenshot showing too many back/forward buttons.

See attached screenshot, I've seen this twice within the last few days, restarts between. I can remove the duplicates one by one if I go to customize my toolbars, but that customization only affects the window in which I customize the toolbar, all other windows still have 3 sets of back/forward buttons :(

Not sure if this is just me, or just this one profile. Nominating to make sure this is on the radar if others see it too.
Flags: blocking-firefox3?
I'm pretty sure this is related to Bug 423770. At least before, Firefox was checking to make sure this didn't happen.
See also bug 424600.
Duplicate of this bug: 425254
(Assignee)

Comment 4

11 years ago
Interesting... based on <http://mxr.mozilla.org/seamonkey/search?string=unified-back-forward-button>, I don't see where the duplicate unified-back-forward-button entries are coming from.
Could someone attach localstore.rdf from a busted profile?
Do you have Adblock Plus (the only extension that I have in common with Bug 424600)?
Duplicate of this bug: 425410
The new highscore from bug 425079 is now 4 ! :-)
(Assignee)

Comment 8

11 years ago
I suppose the steps to reproduce could be like this:

1. run Firefox 2.0.0.13 (contains attachment 305153 [details] [diff] [review]) and customize the toolbar
2. run a pre-attachment 307803 [details] [diff] [review] trunk build (beta 4)
3. run a post-attachment 310627 [details] [diff] [review] trunk build

I don't understand bug 425410. You shouldn't see this in beta 4, because it contains attachment 300406 [details] [diff] [review].
(Assignee)

Updated

11 years ago
Assignee: nobody → dao
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 9

11 years ago
Created attachment 312108 [details] [diff] [review]
don't create duplicate items, round two

this time only within a single toolbar so that we don't regress bug 423770
Attachment #312108 - Flags: review?(gavin.sharp)
jst, were you running builds from different branches with the same profile?
(Reporter)

Comment 11

11 years ago
It's certainly possible that I've done that, but I'm pretty sure that didn't happen around the time when this happened.

Now I haven't seen this problem again since I filed this bug, so it may very well be that this was fixed already. Not sure.
Duplicate of this bug: 425571
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Whiteboard: [has patch][needs review gavin]

Comment 13

11 years ago
Gavin, I've been definetly running multiple versions of firefox with the same profile:
1. is it related to the reported problem ?
2. is it something I should prevent from ? since this is the default way minefield is installed. 

 
(Assignee)

Comment 14

11 years ago
(In reply to comment #13)
> Gavin, I've been definetly running multiple versions of firefox with the same
> profile:
> 1. is it related to the reported problem ?

Probably. I don't see another way how this could happen.

> 2. is it something I should prevent from ? since this is the default way
> minefield is installed.

No, such scenarios need to be tested. But you should probably backup your profile regularly if you're using nightlies.
Keywords: qawanted
(In reply to comment #14)
> > Gavin, I've been definetly running multiple versions of firefox with the same
> > profile:
> > 1. is it related to the reported problem ?
> 
> Probably. I don't see another way how this could happen.

Haven't seen any problem here while doing regression tests the last hours. I used several trunk versions from the last month and cannot see multiple instances of the buttons on the toolbar.
(Assignee)

Comment 16

11 years ago
Ok, thanks. If anyone is able to reproduce this, please comment and attach your localstore.rdf (shouldn't contain any private data). If there's a bug in the current code (e.g. post-attachment 307803 [details] [diff] [review]; seems unlikely though, since the bug is said to disappear after a while), I'd like to fix that. Also, please comment if you see this bug on branch.
Otherwise I think the attached patch is the way to go. After all, having the element more than once in the toolbar set is not as bad as losing it (bug 417421).
Keywords: qawanted
Attachment #312108 - Flags: review?(gavin.sharp) → review+
Keywords: checkin-needed
Whiteboard: [has patch][needs review gavin]

Comment 17

11 years ago
Just installed Firefox 3 Beta 5 and immediately had this problem.  Closed and restarted firefox several times and the backX3 appeared every time.
Duplicate of this bug: 426548
Duplicate of this bug: 426595
Duplicate of this bug: 426595
Created attachment 313168 [details]
localstore.rdf (double keyhole)

Doubled keyhole, see: http://pics.livejournal.com/xb95/pic/002ha8dk.png

I installed Beta 5 today and suddenly have two.  I have AdBlock Plus, AdBlock Filterset.G Updater, and Web Developer - none of which are up to date/active.  I have used nightlies on this machine before, but not since Beta 4 IIRC.

Let me know if you need anything else!

Comment 22

11 years ago
Created attachment 313170 [details]
Another example of duplicated buttons.

Comment 23

11 years ago
Created attachment 313173 [details]
This is my localstore.rdf

Note I just had issues after disabling the compatibility check and had to disable some addons via safe mode so it may not reflect how it was just after upgrading to 3b5.
Duplicate of this bug: 426591
Duplicate of this bug: 426618
Duplicate of this bug: 426620

Comment 27

11 years ago
I have used every FF3 beta and have a heckuvalot of extensions installed including Adblock Plus which I installed recently under b4 (until then I'd been using Adblock but then I decided I should use a more recently updated extension).  I upgraded to b5 today.  I haven't noticed anything odd with my back/forward buttons.  Hope this helps you guys figure it out.

Comment 28

11 years ago
Starting firefox in safe mode and selecting 
Reset toolbars and controls

fixed this issue for me

Comment 29

11 years ago
Created attachment 313208 [details]
localstore.rdf - Double keyhole

Upgraded to b5 today, got the double keyhole. The only extension that made it through the update was noscript. Previously I had been running Adblock Plus, Forecastfox Enhanced, Image zoom, and User Agent Switcher. Previously ran some nightly builds around FF3a3-a5. Need anything else, let me know!

Comment 30

11 years ago
I had Firefox 3 Beta 4 installed without the triple Back/Forward issue and,
trying to see if the latest Minefield resolved a FoxMarks beta issue, installed
the latest Minefield yesterday.  I exhibited the triple B/F issue in the
Minefield, but not Beta 4 and as a result uninstalled the Minefield figuring it
was an issue with it.  With Beta 5 coming out today, I uninstalled Beta 4 and
installed Beta 5, which also exhibits the triple B/F issue the same as the
Minefield release did.

Comment 31

11 years ago
(In reply to comment #28)
> Starting firefox in safe mode and selecting 
> Reset toolbars and controls
> 
> fixed this issue for me
> 

thanks, worked for me! :)

Comment 32

11 years ago
Created attachment 313211 [details]
David Evans localstore.rdf

Comment 33

11 years ago
(In reply to comment #32)
> Created an attachment (id=313211) [details]
> David Evans localstore.rdf
> 

I customized the Toolbars and removed two of the B/F's.  After restarting Firefox Beta 5 only one remains and when customizing the toolbars, the additional two B/F's no longer appear in the available items.  I like this better as I did not have to reset how I had things customized.  Unfortunately I think this makes my localstore.rdf file rather useless as it no longer had the problem.
Duplicate of this bug: 426642
Duplicate of this bug: 426645

Comment 36

11 years ago
Created attachment 313220 [details]
Only two back/forward buttons on mine
Whiteboard: [has patch][has reviews]
Duplicate of this bug: 426662

Comment 38

11 years ago
(In reply to comment #7)
> The new highscore from bug 425079 is now 4 ! :-)
> I've got 6!

Duplicate of this bug: 426667

Updated

11 years ago
Duplicate of this bug: 426707

Updated

11 years ago
Duplicate of this bug: 426687

Comment 42

11 years ago
Changing summary to hopefully make it easier to search for and reduce duplicates.
Summary: Back/forward buttons x3 :( → Multiple back/forward buttons in toolbar
Duplicate of this bug: 426765
Duplicate of this bug: 426769

Comment 45

11 years ago
Created attachment 313344 [details]
windows xp screenshot

Comment 46

11 years ago
Created attachment 313359 [details]
screenshot after 3.0b5 upgrade from 3.0b4

Hello,
I just had the same problem on my firefox. I upgraded from 3.0b4 which was working perfect to 3.0b5 - I kept my open windows when I restarted firefox. I tried making a new session and unisntalling/reinstalling firefox minus my profile. I will next attach my localstore.rdf and then try removing all profile information. My profile should have been carried over from v2
I have adblock plus installed as well and it was the only working non disabled plugin in my 3.0b4 at the time.

Comment 47

11 years ago
Created attachment 313360 [details]
localstore.rdf file from v2 profile failing on 3.0b5

Comment 48

11 years ago
I have attached both files
I have now uninstalled firefox including all personalization and profile information. I reinstalled b5 and now it appears to look fine. Definitely must have been related to some sort of customization or profile remnant
Duplicate of this bug: 426796

Comment 50

11 years ago
After upgrading to beta five got a quadruple keyhole.  I have the Web Developer plug in and two profiles.

>Starting firefox in safe mode and selecting 
>Reset toolbars and controls

worked for me too!  Thanks David.

Comment 51

11 years ago
I was on b4 and upgraded to b5, closed and saved the windows, when it opened it had 6 back/fwd buttons. I went to customize the toolbar and removed the 5 extra sets. I had AdBlock, but it is not compatible with b5.

Updated

11 years ago
Duplicate of this bug: 426809

Comment 53

11 years ago
(In reply to comment #51)
> I was on b4 and upgraded to b5, closed and saved the windows, when it opened it
> had 6 back/fwd buttons. I went to customize the toolbar and removed the 5 extra
> sets. I had AdBlock, but it is not compatible with b5.
> 

worked for me also.

I made my own report before I found this one. The search sucks.

Comment 54

11 years ago
on second thought I'm just downgrading to ff3b4, no adblock functionality is painful.
Duplicate of this bug: 426843
Duplicate of this bug: 426848

Updated

11 years ago
Duplicate of this bug: 426848

Comment 58

11 years ago
(In reply to comment #54)
> on second thought I'm just downgrading to ff3b4, no adblock functionality is
> painful.
> 

Use
extensions.checkCompatibility
in about:config, set as false in a boolean.

Comment 59

11 years ago
(In reply to comment #58)
> (In reply to comment #54)
> > on second thought I'm just downgrading to ff3b4, no adblock functionality is
> > painful.
> > 
> 
> Use
> extensions.checkCompatibility
> in about:config, set as false in a boolean.
> 

Or open the xpi as an arichive with 7-zip and adjust the install.rdf to show <em:maxVersion>3.0b5</em:maxVersion> under the Firefox section.
Duplicate of this bug: 426877
Duplicate of this bug: 426911
Duplicate of this bug: 426926

Comment 63

11 years ago
Created attachment 313528 [details]
Macs too!
Checking in toolkit/content/widgets/toolbar.xml;
/cvsroot/mozilla/toolkit/content/widgets/toolbar.xml,v  <--  toolbar.xml
new revision: 1.47; previous revision: 1.46
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
Target Milestone: --- → Firefox 3
Created attachment 313563 [details]
Screen shot posted by a user on digg

Here is a screen shot linked from a comment on digg
http://digg.com/software/Firefox_3_Beta_5_Final_beta_released?t=14151212#c14151212

Comment 66

11 years ago
two sets of back/forward are still showing in the mac version of beta 5.
why is this marked as resolved?
The patch to fix the multiple back/forward buttons when upgrading from beta4 to beta5 was checked in *after* beta5 was released. So it won't work with the beta5 release.

Please do not comment anymore to confirm this behavior. This issue will be fixed in the upcoming RC1 release.
Whiteboard: See comment 67 before adding a new comment
Duplicate of this bug: 427000
Duplicate of this bug: 427190
Duplicate of this bug: 427192
Duplicate of this bug: 427228

Updated

11 years ago
Duplicate of this bug: 427339
Duplicate of this bug: 427356
Duplicate of this bug: 427383
Duplicate of this bug: 427548
Duplicate of this bug: 427751
Duplicate of this bug: 427799
Duplicate of this bug: 427900
Duplicate of this bug: 427964

Comment 80

11 years ago
(In reply to comment #0)
> Created an attachment (id=311662) [details]
> Screenshot showing too many back/forward buttons.
> 
> See attached screenshot, I've seen this twice within the last few days,
> restarts between. I can remove the duplicates one by one if I go to customize
> my toolbars, but that customization only affects the window in which I
> customize the toolbar, all other windows still have 3 sets of back/forward
> buttons :(
> 
> Not sure if this is just me, or just this one profile. Nominating to make sure
> this is on the radar if others see it too.
> 

Comment 81

11 years ago
I just got Beta 5 today, and got 5 back buttons! Re-installing did not solve the bug.
(In reply to comment #38)
> (In reply to comment #7)
> > The new highscore from bug 425079 is now 4 ! :-)
> > I've got 6!
> 

...and I got 8!!!  The strange thing is that I installed 3b5 on two machines.  One is absolutely fine and the other gets 8 occurrences of the buttons!  The addons I have are Google Notebook and IE Tab.  My other machine has no addons.
Duplicate of this bug: 429490

Updated

11 years ago
Duplicate of this bug: 432024

Updated

11 years ago
Duplicate of this bug: 432557
Duplicate of this bug: 432855
Each time i click on the Gmail Notification Icon in the Taskbar to check email, Firefox will come up with all forwards and backwards navigation buttons repeated across the bar, in an old school style not the new round one, and does not load gmail properly.  When I go back to Firefox after doing this, I have a new set of forwards and backwards navigation buttons added to my nav bar.  There are now 4 sets of forwards and backwards navigation buttons in my nav bar of the Firefox 3 beta 5 release.  Thought you should know.

Comment 88

11 years ago
it seems most of the folk here have had this problem on linux/ mac. im on vista (bless it) and have two forward/back buttons.
(Assignee)

Updated

10 years ago
Whiteboard: See comment 67 before adding a new comment
Verified FIXED on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b4pre) Gecko/20090403 Shiretoko/3.5b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.