All users were logged out of Bugzilla on October 13th, 2018

Menus are nonfunctional when 'tools' have focus (Downloads / Extensions / Theme Managers, JavaScript Console and Page Info window)

RESOLVED FIXED in Firefox1.5

Status

()

P1
normal
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: kaldari, Assigned: mano)

Tracking

unspecified
Firefox1.5
PowerPC
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 8 obsolete attachments)

25.87 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
18.05 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When any of the items in the Tools menu are open and focused (except the DOM
Inspector) the menubars don't work (nor do they appear to be disabled).

Reproducible: Always
Steps to Reproduce:
1.Go to the tools menu and select Downloads, JavaScript Console, or Page Info.
2.Go to the File menu and select New Window.

Actual Results:  
Nothing happens.

Expected Results:  
Created a new browser window and changed focus to the new window.

Related to bug 232673.

Comment 1

15 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040404
Firefox/0.8.0+

I see the same behaviour.

Ben.

Comment 3

15 years ago
Isn't this basically bug 21296
(Reporter)

Comment 4

15 years ago
Bug 21296 is about menus not being active when modal dialog boxes are displayed. In this bug, menus 
are active, but they don't work.

I could see this bug being a broader case of bug 228615, but I don't think either this bug or bug 
228615 are duplicates of bug 21296.
(Reporter)

Comment 5

15 years ago
Actually, I could be wrong. I'm not exactly sure what bug 21296 encompasses. Nor does it seem that 
many of the people discussing that bug know what it emcompasses. Without knowing more about the 
back-end of things I can't tell if these bugs are really related or not. Maybe a developer would have 
more insight on this.

Comment 6

15 years ago
Updating the summary so this bug can be found with a simple search...

Also noteint bug 245206 was opened noting that the menu bar fails to work if it
has focus.
Summary: menus don't work when tools are open → Menus are nonfunctional when 'tools' have focus (Download Manger, DOM Inspector and JavaScript Console)

Comment 7

14 years ago
*** Bug 255658 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 259553 has been marked as a duplicate of this bug. ***
*** Bug 262020 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Would it be possible to fix this for Mac 1.0?
Flags: blocking-aviary1.0mac?

Comment 11

14 years ago
> Would it be possible to fix this for Mac 1.0?

Just noting that this bug is still present in 1.0...  

Updated

14 years ago
Flags: blocking-aviary1.0mac?

Comment 12

14 years ago
*** Bug 263434 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 245206, 249003

Comment 13

14 years ago
bug 273217 will partially fix it (disabling the items that should not be
accesible). But the problem remains that some items aren't accessible, although
they shouldn't.

Updated

14 years ago
Flags: blocking-aviary1.1?
i'm on it
Assignee: firefox → bugs.mano
Target Milestone: --- → Firefox1.1
Blocks: 237584
Status: NEW → ASSIGNED
Summary: Menus are nonfunctional when 'tools' have focus (Download Manger, DOM Inspector and JavaScript Console) → Menus are nonfunctional when 'tools' have focus (Downloads / Extensions / Theme Managers, JavaScript Console and Page Info window)
Created attachment 172619 [details] [diff] [review]
patch v1

*extra fun*.

There are still some nits to fix (such as not opening the openlocation window
on mac), but this is the first 'big' step.
Attachment #172619 - Flags: review?(mconnor)

Updated

14 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1+
*** Bug 282431 has been marked as a duplicate of this bug. ***
Mike, I understand that this patch is somewhat a bloat; but really, this is our
most annoying visible issue on mac, it worths the Xks it would take (the scripts
are not included per window...).
Priority: -- → P1
No longer depends on: 245206
*** Bug 245206 has been marked as a duplicate of this bug. ***
*** Bug 283033 has been marked as a duplicate of this bug. ***
*** Bug 283263 has been marked as a duplicate of this bug. ***
*** Bug 283254 has been marked as a duplicate of this bug. ***
*** Bug 283630 has been marked as a duplicate of this bug. ***
*** Bug 284468 has been marked as a duplicate of this bug. ***
*** Bug 284945 has been marked as a duplicate of this bug. ***
*** Bug 286819 has been marked as a duplicate of this bug. ***

Comment 26

14 years ago
*** Bug 287432 has been marked as a duplicate of this bug. ***
*** Bug 288388 has been marked as a duplicate of this bug. ***
Comment on attachment 172619 [details] [diff] [review]
patch v1

better fix on the way...
Attachment #172619 - Flags: review?(mconnor)
Created attachment 179309 [details] [diff] [review]
part 1....

Mike, I would like to get this in before I continue to hack this ****.

This:
  * Get rid of macBrowserOverlay-on-browser.xul
  * Make macBrowserOverlay window-independent
Attachment #172619 - Attachment is obsolete: true
Attachment #179309 - Flags: review?(mconnor)
Comment on attachment 179309 [details] [diff] [review]
part 1....

baah, wrong diff.
Attachment #179309 - Flags: review?(mconnor)
Created attachment 179310 [details] [diff] [review]
part 1...

...see comment 29
Attachment #179309 - Attachment is obsolete: true
Attachment #179310 - Flags: review?(mconnor)
Comment on attachment 179310 [details] [diff] [review]
part 1...

hmm, not enough.
Attachment #179310 - Attachment is obsolete: true
Attachment #179310 - Flags: review?(mconnor)
*** Bug 232673 has been marked as a duplicate of this bug. ***
Comment on attachment 179370 [details] [diff] [review]
more...

I will patch other windows once this one is in.
Attachment #179370 - Flags: review?(mconnor)

Comment 38

14 years ago
*** Bug 289277 has been marked as a duplicate of this bug. ***
Attachment #179370 - Attachment is obsolete: true
Attachment #180278 - Flags: review?(mconnor)
okay, so other than renaming Startup() and Shutdown() which I'm not sure is a
good plan, where is this browserMountPoints.inc?
and downloadManagerOverlay.xul too.
*** Bug 290549 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 240696
Created attachment 180965 [details] [diff] [review]
[checked in] well-diffed patch
Attachment #180278 - Attachment is obsolete: true
Attachment #180965 - Flags: review?(mconnor)
Comment on attachment 180965 [details] [diff] [review]
[checked in] well-diffed patch

>@@ -1558,18 +1562,18 @@ function openLocation()
> {
>   if (gURLBar && !gURLBar.parentNode.parentNode.collapsed &&
>       !(window.getComputedStyle(gURLBar.parentNode, null).display == "none")) {
>     gURLBar.focus();
>     gURLBar.select();
>   }
>   else {
> #ifdef XP_MACOSX
>-    if (window.location.href == "chrome://browser/content/hiddenWindow.xul") {
>-      // If no windows are active, open a new one. 
>+    if (window.location.href != getBrowserURL()) {
>+      // If it's not a browser window, open a new one. 
>       window.openDialog("chrome://browser/content/", "_blank", "chrome,all,dialog=no", "about:blank");
>     }
>     else
> #endif
>       openDialog("chrome://browser/content/openLocation.xul", "_blank", "chrome,modal,titlebar", window);
>   }
> }

I'd rather fix openLocation.xul to open a new window if needed than
automatically open a new browser window, but I'll let this go in assuming you
file a followup bug on making this saner and respecting the single-window
behaviour some people rely on.

Please make sure the other windows get hooked up ASAP.
Attachment #180965 - Flags: review?(mconnor) → review+

Comment 45

14 years ago
Comment on attachment 180965 [details] [diff] [review]
[checked in] well-diffed patch

a=asa
Attachment #180965 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
Checking in base/jar.mn;
/cvsroot/mozilla/browser/base/jar.mn,v  <--  jar.mn
new revision: 1.87; previous revision: 1.86
done
Checking in base/content/aboutDialog.xul;
/cvsroot/mozilla/browser/base/content/aboutDialog.xul,v  <--  aboutDialog.xul
new revision: 1.22; previous revision: 1.21
done
Checking in base/content/browser-sets.inc;
/cvsroot/mozilla/browser/base/content/browser-sets.inc,v  <--  browser-sets.inc
new revision: 1.45; previous revision: 1.44
done
Checking in base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.409; previous revision: 1.408
done
Checking in base/content/browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.259; previous revision: 1.258
done
RCS file: /cvsroot/mozilla/browser/base/content/browserMountPoints.inc,v
done
Checking in base/content/browserMountPoints.inc;
/cvsroot/mozilla/browser/base/content/browserMountPoints.inc,v  <-- 
browserMountPoints.inc
initial revision: 1.1
done
Checking in base/content/contents.rdf;
/cvsroot/mozilla/browser/base/content/contents.rdf,v  <--  contents.rdf
new revision: 1.6; previous revision: 1.5
done
RCS file: /cvsroot/mozilla/browser/base/content/downloadManagerOverlay.xul,v
done
Checking in base/content/downloadManagerOverlay.xul;
/cvsroot/mozilla/browser/base/content/downloadManagerOverlay.xul,v  <-- 
downloadManagerOverlay.xul
initial revision: 1.1
done
Checking in base/content/hiddenWindow.xul;
/cvsroot/mozilla/browser/base/content/hiddenWindow.xul,v  <--  hiddenWindow.xul
new revision: 1.4; previous revision: 1.3
done
Checking in base/content/macBrowserOverlay.xul;
/cvsroot/mozilla/browser/base/content/macBrowserOverlay.xul,v  <-- 
macBrowserOverlay.xul
new revision: 1.6; previous revision: 1.5
done
Checking in base/content/pageInfo.xul;
/cvsroot/mozilla/browser/base/content/pageInfo.xul,v  <--  pageInfo.xul
new revision: 1.23; previous revision: 1.22
done
Whiteboard: FIXED: download manager, about dialog, page info
Attachment #180965 - Attachment description: well-diffed patch → [checked in] well-diffed patch
Created attachment 181160 [details] [diff] [review]
extensions / themes manager  + js console

Those are the last windows i'm going to fix here.

We still need to [find a way to] fix the preferences window, but i'm going to
move that part to a new bug.
Attachment #181160 - Flags: review?(mconnor)
Created attachment 181233 [details] [diff] [review]
final bits
Attachment #181160 - Attachment is obsolete: true
Attachment #181233 - Flags: review?(mconnor)
Comment on attachment 181233 [details] [diff] [review]
final bits

r=me, as long as you change the comments referring to browser-scripts.inc to
read global-scripts.inc
Attachment #181233 - Flags: review?(mconnor) → review+

Comment 50

14 years ago
Comment on attachment 181233 [details] [diff] [review]
final bits

a=asa
Attachment #181233 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
Checking in base/jar.mn;
/cvsroot/mozilla/browser/base/jar.mn,v  <--  jar.mn
new revision: 1.88; previous revision: 1.87
done
Removing base/content/browser-scripts.inc;
/cvsroot/mozilla/browser/base/content/browser-scripts.inc,v  <-- 
browser-scripts.inc
new revision: delete; previous revision: 1.8
done
Checking in base/content/browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.260; previous revision: 1.259
done
Checking in base/content/contents.rdf;
/cvsroot/mozilla/browser/base/content/contents.rdf,v  <--  contents.rdf
new revision: 1.7; previous revision: 1.6
done
RCS file: /cvsroot/mozilla/browser/base/content/extensionsManagerOverlay.xul,v
done
Checking in base/content/extensionsManagerOverlay.xul;
/cvsroot/mozilla/browser/base/content/extensionsManagerOverlay.xul,v  <-- 
extensionsManagerOverlay.xul
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/base/content/global-scripts.inc,v
done
Checking in base/content/global-scripts.inc;
/cvsroot/mozilla/browser/base/content/global-scripts.inc,v  <--  global-scripts.inc
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/base/content/jsConsoleOverlay.xul,v
done
Checking in base/content/jsConsoleOverlay.xul;
/cvsroot/mozilla/browser/base/content/jsConsoleOverlay.xul,v  <-- 
jsConsoleOverlay.xul
initial revision: 1.1
done
Checking in base/content/macBrowserOverlay.xul;
/cvsroot/mozilla/browser/base/content/macBrowserOverlay.xul,v  <-- 
macBrowserOverlay.xul
new revision: 1.7; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Whiteboard: FIXED: download manager, about dialog, page info

Comment 52

14 years ago
*** Bug 293443 has been marked as a duplicate of this bug. ***

Comment 53

14 years ago
*** Bug 293644 has been marked as a duplicate of this bug. ***

Comment 54

14 years ago
*** Bug 294706 has been marked as a duplicate of this bug. ***
*** Bug 295923 has been marked as a duplicate of this bug. ***
*** Bug 297021 has been marked as a duplicate of this bug. ***
*** Bug 298294 has been marked as a duplicate of this bug. ***
*** Bug 301840 has been marked as a duplicate of this bug. ***

Comment 59

13 years ago
*** Bug 303831 has been marked as a duplicate of this bug. ***
*** Bug 310106 has been marked as a duplicate of this bug. ***

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.