Bug 133627 (prefsfit)

Ensure all Preferences panes fit entirely within the pane area using all bundled themes

NEW
Unassigned

Status

17 years ago
4 years ago

People

(Reporter: bugmail, Unassigned)

Tracking

(Depends on: 2 bugs, Blocks: 1 bug, {helpwanted, polish})

Trunk
helpwanted, polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031005

Certain Preferences panes don't properly fit into the Prferences window. The
offenders are:

Navigator/History
Composer/New Page Settings
Mail & Newsgroups/Message Display
Advanced/Cache
Debug
Debug/Networking

Reproducible: Always
Steps to Reproduce:
1. Open the Mozilla Preferences dialog
2. Access each pane listed above

Actual Results:  For each pane, some part of its' content exceeds the dimensions
of the Preferences dialog.

Expected Results:  Every Preferences pane should fit entirely into the
Preferences dialog.
*** Bug 133628 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
WFM on a slightly later nightly (2002032808) - all the panes mentioned fit
completely (and tidily) in the preferences window. Can't find an obvious bug
that fixed this so will wait for someone else to comment. (And reporter, please
can you see if a later nightly works.)
(Reporter)

Comment 3

17 years ago
Using FizzillaCFM/2002032915 under the Modern skin, all but the Advanced/Cache
pane now fit entirely in their allotted space.
(Reporter)

Comment 4

17 years ago
Using the same build (FizzillaCFM/2002032915) and the Classic theme, all the
original problem panes still exceed their allotted display box.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0

Comment 5

17 years ago
Also applies to Win32.  Nightly build 0408-09, but observed it in the main 0.9.9
build as well.  Running ME here, but observed the same thing on my Win2K
notebbook at work.

I observe it in the following panes:

Navigator (too short)
History (too narrow)
Languages (too short)
Smart Browser (too short)

Colors (too short)
Languages (too short)
Composer (too short)

Message (too short and too narrow)
Send Format (too short)
Addressing (too short)
Return Receipt (too narrow)

Images (too short)
Forms (too narrow)
Master Passwords (too short)
SSL (too short)
Certificates (too short)
Validation (too short)

Advanced (too short)
Cache (too short and too narrow)
Proxies (too short)
Mouse Wheel (too narrow)
DOM Inspector (too short)

Debug (too narow)
Events (too short)

The obvious solution is to allow the Preferences window to be user-resizeable,
so that platform variability is irrelevant;  if the window's too small, the user
can make it big enough.




Comment 6

17 years ago
Updating: the problems I described in Comment #5 remain in 1.0 Release Candidate
1 (Build ID: 2002041617).

A large number of the preferences are just invisible and unreachable.
(Reporter)

Comment 7

17 years ago
Marking Confirmed per Comment #5. (Also marking All/All and revising Summary to
be a directive rather than an observation.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Certain Preferences panes don't fit in the Preferences window → Ensure all Preferences panes fit entirely within the pane area
(Reporter)

Updated

17 years ago
Summary: Ensure all Preferences panes fit entirely within the pane area → Ensure all Preferences panes fit entirely within the pane area using all bundled themes
i have been using bug 80392 as a meta/tracking bug for this issue... true, it's
been marked verified fixed.

marlon / ben, should this bug be made into the (more recent, and open) tracking
bug for this issue? if yes, i don't mind moving over open bug as blockers to
this (there are quite a few of 'em, already noted). if not, should this be
marked a dup of bug 80392? i'm leaning towards the former ('yes') choice, but
let me know which you'd prefer. thanks!
tentatively nominating... not sure if what (if any) near-term plans there are to:

a. fix the content (time consuming, many ppl potentially involved, but ideal), or,

b. increase size of the pref window (non-ideal, i know, but perhaps a temp
workaround for the 1.0.0 branch?), or,

c. make the pref window resizeable (again non-ideal, like (b))?

after a couple of queries, i couldn't quite find bugs that'd cover either (b) or
(c).
Keywords: nsbeta1, polish

Comment 10

17 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 11

17 years ago
This is still very much a problem in RC2 on win98.  I think a resizable prefs
window would be the best thing to do, but then I don't really know.

Updated

17 years ago
Blocks: 80392
(Reporter)

Comment 12

17 years ago
*** Bug 146493 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
This is *Still* broken in RC3!	This must be fixed before 1, it just isn't good
enough to release a browser with a bug so messy as this left in!

Comment 14

17 years ago
*** Bug 134174 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 137281 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 137967 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 139183 has been marked as a duplicate of this bug. ***
I fail to see how this bug differs from bug 80392. I think it should be marked 
as a dup.

Comment 19

17 years ago
bug 80392 is a tracking bug, this (and its duplicates) were reports of a more
general problem.  I think "ensure all preferences panes fit within the window"
is the problem that needs fixing - bug 80392 may not fully address this.  I can
see that it's pointless having both bugs though.  I think sairuh's suggestion in
comment 8, that bug 80392 is marked as a duplicate of this bug, and the blockers
are moved over, makes sense.

Comment 20

17 years ago
*** Bug 154116 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
*** Bug 156166 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
*** Bug 157855 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 23

17 years ago
*** Bug 130353 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 24

17 years ago
*** Bug 149028 has been marked as a duplicate of this bug. ***
nominating for buffy (here we go again ;)...
Keywords: nsbeta1- → nsbeta1

Comment 26

17 years ago
*** Bug 165784 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
This problem can also be created in Windows 2000 by changing the font for
message boxes in the display properties to a larger size or type.  

The screenshots i uploaded show the preferences box for Mozilla 1.1 on Win2k
Pro SP2.  The first screenshot (right to left) shows the Orbit 3 theme with MS
Sans Serif, the next is after changing the font to Verdana, and the third shows
Verdana with the Classic theme.

Comment 28

17 years ago
I am still getting panes too big in Moz 1.1 (20020826) on Win98. It affects:
Navigator/History
Navigator/Helper Applications
Mail & Newsgroups
Mail & Newsgroups/Message Display
Mail & Newsgroups/Send Format
Mail & Newsgroups/Return Receipts
Privacy & Security/Master Passwords
Advanced/Cache

Comment 31

17 years ago
This has got to be a simple fix? It is in 1.0.1 on win98 too. If I knew how to
fix I would. 
Status: NEW → ASSIGNED

Comment 32

17 years ago
any single example would probably not too much trouble to fix. but each panel
needs to be fixed to fit, on the full range of platforms, fonts and resolutions,
and as I understand it, the various people responsible for each of the pref
settings would need to be involved as well, to make sure nothing got broken.  so
while the code changes are probably simple, there needs to be a lot of people
interaction, and that's a hassle...

and please don't change bugs to ASSIGNED unless you are the owner of the bug...
Status: ASSIGNED → NEW
Keywords: mozilla1.0 → mozilla1.2

Comment 33

17 years ago
*** Bug 171029 has been marked as a duplicate of this bug. ***

Comment 34

17 years ago
*** Bug 171470 has been marked as a duplicate of this bug. ***

Comment 35

17 years ago
*** Bug 174526 has been marked as a duplicate of this bug. ***

Comment 36

17 years ago
A number of Preferences texts still don't fit into the pages in Build
2002101703. (Modern or Classic theme.  G3 (old beige), OS 9.2.2.)

Comment 37

17 years ago
*** Bug 150406 has been marked as a duplicate of this bug. ***

Comment 38

17 years ago
*** Bug 157362 has been marked as a duplicate of this bug. ***

Comment 39

17 years ago
nsbeta1=/adt3 per the nav triage team.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
No longer blocks: 80392

Comment 40

17 years ago
*** Bug 180506 has been marked as a duplicate of this bug. ***

Comment 41

17 years ago
*** Bug 160149 has been marked as a duplicate of this bug. ***

Comment 42

17 years ago
*** Bug 185543 has been marked as a duplicate of this bug. ***

Comment 43

17 years ago
Over to Shuehan.
Assignee: ben → shliang

Comment 44

16 years ago
*** Bug 189050 has been marked as a duplicate of this bug. ***

Comment 45

16 years ago
From bug reports for my localization, I often see that buttons and other widgets
are bigger in Windows XP, which also can cause such problems. Therefore, you
should try Windows XP Classic theme to be sure everything fits there...
I fixed the helper apps panelf or another bug - is a there a list with allthe
problem panels?

Comment 47

16 years ago
Doron - well helper apps is a good start :)  for a list there's comment 5 here,
but I think the clearest/best list is in bug 134174 comment 3.
the blocker list in bug 80392 is also a good place to look.

Updated

16 years ago
Blocks: 80392
No longer blocks: 80392
(Reporter)

Comment 49

16 years ago
So should this finally just be duped to bug 80392? I'm weary of seeing bugmails
from this one.

Comment 50

16 years ago
think it should be the other way around - see comment 19.
i don't mind either way --but if bug 80392 is dup'd to this one, its blocker
list will need to be moved here (more bugmail).

shuehan, do you care either way?

Comment 52

16 years ago
sarah: no, that's fine, you can go ahead and dupe bug 80392 to this one if it 
makes more sense.
*** Bug 80392 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: --- → mozilla1.4beta
Depends on: 180364

Updated

16 years ago
Alias: prefsfit
Keywords: mozilla1.2
Depends on: 199990

Updated

16 years ago
Depends on: 199721

Comment 54

16 years ago
What about adding bug 189786 to the list?

Comment 55

16 years ago
bug 189786 is still unconfirmed - I'll believe it's real though I can't check it. 

Is this bug going to cover prefs panel fit issues with international language
packs though?  If so, bug 189786 belongs here.  If not, then bug 194711 is also
a language pack issue and shouldn't be here (and the dependency seems to be
backwards).
No longer blocks: 194711
Depends on: 189786

Comment 56

16 years ago
The problem with bug 189786 is that the translated text is longer than the
original english one, so it's getting truncated instead of wordwrapped. If
another translator can check this for another language, we can confirm the bug.
Don't know how to solve the dependecy tho.
Depends on: 144688

Comment 57

16 years ago
I would like to chime in w/some of the previous posters suggesting that the
setup dialg shoudl be user-resizeable.  If I remember correctly, it was
resizeable in some of the very early builds, and then changed at some point
prior to 1.0.

I notice the problem most often on Windows systems running at higher resolutions
(1280x1024 and above).  It's annoying enough with stuff that just doesn't "fit
well,"  it's much worse when there are options that you can't even reach.  (And
makes me wonder if there're more that I don't even see  :)

Comment 58

16 years ago
Another chimer here.  Even if the prefs content is fixed, any time preferences
are changed or added, this bug will likely resurface.  Why not make prefs
resizable, save the programmers from a lot of headache, and give the users the
opportunity now to use/configure the settings that don't currently fit in their
prefs window?

Here's a list of subs that are resizable, and that everyone can use/view in
mozilla 1.4b (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507):

Cookie Manager
Image Manager
About Popups
Password Manager
Customize Character Coding
Page Info

I found a few more that I would like to resize, but Preferences is my biggest
dissapointment.
Yes, I agree with Damian.  If the dialog can be resized, and then _remember its
size the next time it's opened_, then the problem is solved.

This seems like a simple issue to me, and a simple fix.  I commented on it 9
months ago or so, in one of the other bugs that's now been subsumed into this
one.  But we're still waiting.

I don't like to complain, because I'm not doing any of the work.  But come on,
this has gone on long enough.  Let's finish it off.

Comment 60

16 years ago
Preferences -> ChatZilla , click on the "What do these mean?" button.
The bottom of the page now moves outside of the view.

I wonder what is the benefit of preventing the user from resizing windows...

Comment 61

15 years ago
*** Bug 220984 has been marked as a duplicate of this bug. ***

Comment 62

15 years ago
This bug used to exist, and now IT'S BACK in both 1.6beta AND the nightly of
1/7/04 with mathml etc. for w32.

You can't deal with preferences with this bug happening (pinball theme, no fancy
fonts). Much as I LOVE Seamonkey, this thing is horrendous.

I really don't know why it is not obvious that the ONLY way to fix this is for
the preferences dialog EITHER to be resizeable OR to have elevators. You cannot
size for x platforms with x themes with x fonts/x character sets in x languages
-- the very thought is absurd. It has to auto-adjust OR be adjustable OR have
elevators. And, it has to be fixed.

If you ask me, this should have been a blocker since year zero !!

Updated

15 years ago
Flags: blocking1.7a?
Flags: blocking1.6?
Flags: blocking1.4.2?

Comment 63

15 years ago
to late for 1.6.  try for 1.7.
Flags: blocking1.6? → blocking1.6-

Comment 64

15 years ago
*** Bug 183533 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.7a? → blocking1.7a-

Updated

15 years ago
Flags: blocking1.4.2? → blocking1.4.2-

Comment 65

15 years ago
requesting for 1.7f
Flags: blocking1.7?

Updated

15 years ago
Depends on: 241229

Updated

15 years ago
Depends on: 182715
please nominate specific bugs with specific preference panels and not metabugs
like this one. thanks.
Flags: blocking1.7? → blocking1.7-

Comment 67

15 years ago
Could this be related to a problem I'm having with Page Setup.  I have a
(mostly) RedHat installation that came with Mozilla 1.2.1 .  I recently
downloaded Mozilla 1.7 and installed it in a different place to try it out.

When I go into File/Page Setup the dialog is very tall, as in the bottom is
below the screen -- way below.  I can do a lot of moving and resizing to get the
dialog to fit but the border in the content runs off the right and bottom of the
dialog so there's no way to see the OK or Cancel buttons.  If I switch to the
Margins & Header/Footer I just see the left-top corner of the page and can't get
to the margin settings.

My preferences dialogs seem to fit fine.
Product: Browser → Seamonkey
Keywords: helpwanted
Target Milestone: mozilla1.4beta → ---

Updated

14 years ago
Depends on: 293427

Comment 68

13 years ago
   When I click icon on desktop the page that comes up is enlarged at lease
ten times normal page Thank You if you can tell me what is going on, I have removed and reinstalled item.Thanks Clifford Newbold

Comment 69

11 years ago
sadly, a long standing bug - obvious fix mentioned in eg #62:

Thunderbird 2.0.0.9 (20071031)
- Preferences: all panes in prefs window have no scrollbars/
  elevators, so if the window+screen+fontsize+translation 
  combination yields too small a window, part of the controls
  are out of reach. Only way out is, enlarge the window beyond
  screen limits, via some WM trick and pane around.
- Accounts setup window pops up without regard to actual screen 
  size and/or WM constraints. On WM with no window move/resize 
  key-binding, it's nearly unusable. 

Firefox 2.0.0.11 (20071127)
- Preferences: like above 

Seamonkey 1.1.7 2007112809
- Preferences: like above 
Assignee: shliang → nobody
QA Contact: bugzilla → prefs

Comment 70

11 years ago
Reporting additional incomplete text displays in Options panels

Build Date: Thunderbird 2.0.0.14 (20080421) 
FRENCH port (translation folks referred me to bugzilla)
or
Firefox 2.0.0.15

OS: Windows XP SP2  with Fly-a-kite interface installed
using NON-STANDARD Font settings, ie in Display -> Appearance:
	Windows and buttons: Tiger
	Color scheme: Apple Blue
	Font size: Lucida Grande

Summary: In some Firefox & Thunderbird Option panels, text runs outside of viewable window when using a non-standard system font.

Description: In some Firefox/Thunderbird windows that can be resized, the text sometimes is wider/longer than the window so we can't read the end of line and/or 
see the button's completely. Does not occur when using Tahoma as System wide 
font.

Steps to Reproduce: 

1. In Windows XP, go to Pref Panel Display  -> Appearance

2. In Font size, choose Lucida Grande, click Apply.

3. In Firefox, go to Options -> Main -> Systems Defaults (this part does not 

appear completely, and we only see the top half of the 'Check Now' button, cf 

attached screencap firefox_option1.gif)

4. In Firefox, go to Options -> Content -> Colors (the sentence 'Allow pages...' 

does not appear completely, cf attached screencap firefox_option1.gif)

5. In Thunderbird, french version, go to Outils -> Options -> General. The last box 'Quand un message arrive' does not display completely and we only see the top half of the button (cf attached screencap Tbird_FR_option1.gif)

6. In Thunderbird, french version, go to Outils -> Options -> Affichage -> Formatage. The 'Polices et encodage' box does not display completely and we only see the top half of the button (cf attached screencap Tbird_FR_option2.gif)


Actual Results:  
The messages/buttons do NOT appear completely.

Expected Results:  
The messages/buttons SHOULD appear completely.

Reproducible: Always

Note: this is not a problem when using Tahoma as System wide font.

Comment 71

11 years ago
This is a bug about SeaMonkey / Mozilla Application Suite. Please report Firefox bugs in the Firefox product.

Updated

4 years ago
Depends on: 1215150
You need to log in before you can comment on or make changes to this bug.