drop down/context menus show up on the primary screen not over the window in two/dual/multiple screens/monitors/displays setup

VERIFIED FIXED in mozilla1.9alpha5

Status

Core Graveyard
GFX: Mac
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: klk19, Assigned: Josh Aas)

Tracking

Trunk
mozilla1.9alpha5
All
Mac OS X
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fixed for Fx3, WONTFIX for Fx2)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

drop down menues show up on the wrong screen
This is similar to Bug#: 245418 which was *originally* reported on Mac but was found and fixed on PC

If the bowser is started with one monitor, and converted to a two monitor configuration, drop down menus ALWAYS appear on the primary monitor. If the window is moved to the secondary monitor, drop down menus will appear on the wrong monitor; similar to Bug#: 245418.

If the browser is started with both monitors active, the pull down menus appear on the correct screen, over the window, whether the window is on the primary, secondary or spans the monitors. If the machine is converted to one monitor and back to two screens the drop down menus to behave in both modes.


Reproducible: Always

Steps to Reproduce:
1.Start browser on a single screen
2.put machine in a two monitor format
3.move window to the secondary monitor.
4. access some drop down menu like the back list or URL completion list.

Actual Results:  
drop down menus appear on the primary screen

Expected Results:  
menus should appear over the window 

First reported on builds as old as 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
  the drop down menue appears on the wrong screen, not over the window

the bug is still present in latest daily DeerPark build:
[Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1]


shifting the primary screen moves the drop down menus to the new primary.
Assignee: nobody → joshmoz
Component: Menus → GFX: Mac
Product: Firefox → Core
QA Contact: menus → mac
Summary: drop down menues show up on the primwindowary screen not over the → drop down menues show up on the primwindowary screen not over the
Version: unspecified → Trunk
(Reporter)

Updated

12 years ago
Summary: drop down menues show up on the primwindowary screen not over the → drop down menus show up on the primary screen not over the window
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: drop down menus show up on the primary screen not over the window → drop down menus show up on the primary screen not over the window in dual / multilple monitor setup

Updated

12 years ago
Summary: drop down menus show up on the primary screen not over the window in dual / multilple monitor setup → drop down menus show up on the primary screen not over the window in two/dual/multiple screens/monitors/displays setup

Comment 1

12 years ago
Created attachment 203269 [details]
A screenshot demonstrating the behavior

Comment 2

12 years ago
Workaround:
Restarting the browser after two monitors are connected.

Comment 3

12 years ago
FYI: Bug and workaround both present in 1.5.

Comment 4

12 years ago
Created attachment 213211 [details]
jpg illustrating the bug 

two screens, with the secondary one to the left and slightly above the primary.
this is a 12"pb sitting on a desk with a 17" lcd plugged into the external video
port, sitting on the left of the pb.

Updated

12 years ago
Attachment #213211 - Attachment description: png illustrating the bug → jpg illustrating the bug

Comment 5

12 years ago
related to 245418?

this bug is still present in 1.5.0.1 osx
although i note it's fixed on xp ...

even though somewhere in the comments for 245418, it says that the mac code doesn't do caching of screen info at startup, perhaps there is something about
adding and removing second monitors while the app is running.  i have a 12"pb, and sometimes i'm at a desk with a 2nd monitor att'd, and sometimes i'm sitting on the couch.  i leave the machine running all the time, so firefox is running for days and days across multiple (re)connections of the 2nd monitor.

Comment 6

12 years ago
*** Bug 330275 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
*** Bug 331201 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 334492 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
*** Bug 334921 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
*** Bug 251927 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
*** Bug 254882 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
*** Bug 138905 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago
*** Bug 269509 has been marked as a duplicate of this bug. ***

Comment 14

12 years ago
*** Bug 275399 has been marked as a duplicate of this bug. ***

Comment 15

12 years ago
*** Bug 275395 has been marked as a duplicate of this bug. ***

Comment 16

12 years ago
*** Bug 275755 has been marked as a duplicate of this bug. ***

Comment 17

12 years ago
*** Bug 280853 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
*** Bug 281422 has been marked as a duplicate of this bug. ***

Comment 19

12 years ago
*** Bug 283320 has been marked as a duplicate of this bug. ***

Comment 20

12 years ago
*** Bug 285638 has been marked as a duplicate of this bug. ***

Comment 21

12 years ago
*** Bug 295242 has been marked as a duplicate of this bug. ***

Comment 22

12 years ago
*** Bug 300378 has been marked as a duplicate of this bug. ***

Comment 23

12 years ago
*** Bug 303653 has been marked as a duplicate of this bug. ***

Comment 24

12 years ago
*** Bug 309238 has been marked as a duplicate of this bug. ***

Comment 25

11 years ago
When will this bug be fixed without having to restart Firefox.  This problem was fixed properly on the PC...when will someone fix it on the Mac.  Seriously it's been like almost a year now.  Please someone fix this problem.

Updated

11 years ago
Flags: blocking1.9a2?

Comment 26

11 years ago
*** Bug 340947 has been marked as a duplicate of this bug. ***

Comment 27

11 years ago
*** Bug 345911 has been marked as a duplicate of this bug. ***

Comment 28

11 years ago
Josh or Mark, any ideas on this one?

Comment 29

11 years ago
Right now, this is Carbon-only (Firefox 1.x, Firefox 2.x will be based on Cocoa).

Since I think context menus don't ever show up (yet) in Cocoafox, we can't yet know if it'll be fixed there. See bug 344323 for implementing that.
This should be fixed with the patch for 344323.
Depends on: 344323
Flags: blocking1.9a2? → blocking1.9+

Comment 31

11 years ago
*** Bug 353483 has been marked as a duplicate of this bug. ***
*** Bug 355009 has been marked as a duplicate of this bug. ***

Comment 33

11 years ago
*** Bug 355392 has been marked as a duplicate of this bug. ***

Comment 34

11 years ago
*** Bug 358906 has been marked as a duplicate of this bug. ***

Comment 35

11 years ago
*** Bug 331834 has been marked as a duplicate of this bug. ***

Comment 36

11 years ago
*** Bug 360546 has been marked as a duplicate of this bug. ***

Comment 37

11 years ago
STILL not fixed as of ff 2.0

comments below say something about it being a cocoa/carbon issue, 
and that ff 2.0, which is supposed to be cocoa (is it?) is supposed
to maybe fix it?  well, it's not fixed.

Comment 38

11 years ago
(In reply to comment #37)
> STILL not fixed as of ff 2.0
> 
> comments below say something about it being a cocoa/carbon issue, 
> and that ff 2.0, which is supposed to be cocoa (is it?) is supposed
> to maybe fix it?  well, it's not fixed.

This is fixed on the trunk, which is what becomes Firefox 3. Firefox 2 uses carbon whereas Ff 3 will be cocoa. It's not fixed in Carbon.
Duplicate of this bug: 366915
Duplicate of this bug: 362615
Duplicate of this bug: 368381
Summary: drop down menus show up on the primary screen not over the window in two/dual/multiple screens/monitors/displays setup → drop down/context menus show up on the primary screen not over the window in two/dual/multiple screens/monitors/displays setup

Updated

11 years ago
Duplicate of this bug: 368791

Updated

11 years ago
Duplicate of this bug: 372473
Duplicate of this bug: 316615
Duplicate of this bug: 365887

Updated

11 years ago
Duplicate of this bug: 340171
Target Milestone: --- → mozilla1.9alpha6
Target Milestone: mozilla1.9alpha6 → mozilla1.9alpha5
Can someone mark this FIXED if it is indeed fixed?
Duplicate of this bug: 380076
> This is fixed on the trunk, which is what becomes Firefox 3. Firefox 2 uses
> carbon whereas Ff 3 will be cocoa. It's not fixed in Carbon.

Works fine now with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070512 Minefield/3.0a5pre

Do you have a bug # where the patch is attached which solves this issue? 

=>FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 50

10 years ago
Without a definitive fix (bug / patch) this should be re-resolved as WORKSFORME.
Duplicate of this bug: 365659
This was fixed between these two versions:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20061121 Minefield/3.0a1

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20061122 Minefield/3.0a1

There are a lot of check ins at this time. Bug 323934 was the only one I could find which is related to Cocoa/Mac. Switching from default toolkit cocoa to cairo-cocoa fixed this issue.
Duplicate of this bug: 380634
Duplicate of this bug: 381452
Duplicate of this bug: 382357
Duplicate of this bug: 385907

Updated

10 years ago
Duplicate of this bug: 388475

Updated

10 years ago
Duplicate of this bug: 389560
Duplicate of this bug: 393588

Updated

10 years ago
Duplicate of this bug: 357290
Duplicate of this bug: 396454
I've seen this on Trunk within the last two weeks. Someday we should fix this.
Al filed bug 396614 for his comment 62. If this is present on trunk, it's likely a regression.
Duplicate of this bug: 396956

Updated

10 years ago
Duplicate of this bug: 399184
This bug is still the case in Firefox 2.0.0.8

Mac OS X 10.4.10

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
(In reply to comment #66)
> This bug is still the case in Firefox 2.0.0.8

It won't be fixed for Firefox 2.0.0.x. You have to wait for Firefox 3. See also comment 38 where it was already told.
Duplicate of this bug: 402856

Updated

10 years ago
Duplicate of this bug: 406397

Updated

10 years ago
Duplicate of this bug: 406737

Updated

10 years ago
Duplicate of this bug: 408464
Duplicate of this bug: 420214
Duplicate of this bug: 396614
Duplicate of this bug: 423615

Updated

10 years ago
Duplicate of this bug: 426473

Comment 76

10 years ago
Edited whiteboard to note that this will not be fixed in Fx2 as per confusion like in comment #66.
Whiteboard: Fixed for Fx3, WONTFIX for Fx2
Duplicate of this bug: 432796
Duplicate of this bug: 435382
Marking verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052104 Minefield/3.0pre ID:2008052104
Status: RESOLVED → VERIFIED
Hardware: Macintosh → All
Duplicate of this bug: 362223
Duplicate of this bug: 472301
Product: Core → Core Graveyard

Comment 82

9 years ago
Created attachment 360139 [details]
Firefox menus display in wrong position when window is across multiple screens

I am still seeing this in the latest beta binary ( Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b2) Gecko/20081201
Firefox/3.1b2 )

I have Xorg configured with 2 monitors.
I have one xorg screen configured to span across the two monitors (twinview/xinerama).
The second monitor is configured to be to the right of the first monitor.
When the Firefox window is on both the left and right monitor AND 50% or more of the window is on the left monitor, the menus (File/Edit/View/etc) do not display in the proper location on the left screen. They are displayed at the left-most position on the second screen.

The red line I drew on the screenshot is the last pixel on the left monitor.

This also happens with Thunderbird.
Jeremy, can you please file it as a new bug? Please make it blocking this bug. Thanks.
(In reply to comment #82)
> Created an attachment (id=360139) [details]
> Firefox menus display in wrong position when window is across multiple screens

This happens on all platforms. See bug 466169. It's definitely not related to this bug.
Duplicate of this bug: 520749
You need to log in before you can comment on or make changes to this bug.