Closed Bug 354527 Opened 14 years ago Closed 2 years ago

Incompatible add-ons list during install : scroll bar for list is not working properly

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rob_mct, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [testday-20110930])

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

The scroll bar for the "Incompatible addins" list does not work properly. I had a list containing 8 addins that are not compatible with the new version (2.0RC1). The last item on the list was cut off at the bottom. The scroll bar was displayed but when I tried to move it (by clicking and dragging) so I could see the last item it would not move.

Reproducible: Didn't try



Expected Results:  
Scroll bar "Incompatible addins" list should work.
Scroll bar in the picture did not work at the time I took the screen shot.
Component: Installer → Extension/Theme Manager
QA Contact: installer → extension.manager
*** Bug 354715 has been marked as a duplicate of this bug. ***
Summary: "Incompatible addins" list during install : scroll bar for list is not working properly → Incompatible add-ons list during install : scroll bar for list is not working properly
I can confirm this, also problem on Thunderbird 2 (maybe this bug is core, but i can`t find the correct component at the moment).
Status: UNCONFIRMED → NEW
Component: Extension/Theme Manager → Startup and Profile System
Ever confirmed: true
QA Contact: extension.manager → startup
Version: unspecified → 2.0 Branch
Like other bugs show this also happens on trunk. Resetting version number. Cannot test on Linux/Mac to to missing number of extensions. :)
Component: Startup and Profile System → Software Update
QA Contact: startup → software.update
Version: 2.0 Branch → Trunk
Component: Software Update → Extension/Theme Manager
QA Contact: software.update → extension.manager
i cc mscott, since this problem also occur on thunderbird 2
Does the scrollbar not move at all or is it only that it cannot be moved further down?
It cannot be moved further down.

It is always the last item which is cut off. I wasn't able to create a testcase with the problem, but it seems as scrollToIndex() doesn't work in my testcase. Furthermore, the "++i" in update.js should be replaced with "i++".

It seems as the applications thinks that the list has one item less and because the list always starts showing a complete listitem, it usually leaves the space less than a listitem at the bottom free, but not in this case.
Component: Extension/Theme Manager → XP Toolkit/Widgets: XUL
Product: Firefox → Core
QA Contact: extension.manager → xptoolkit.xul
Let's keep this in Firefox -> Extension / Theme Manager.

The wizard is displayed early during startup which has historically caused problems for widgets in the wizard and we'll most likely have to hack around this as we've had to do previously for other bugs
Component: XP Toolkit/Widgets: XUL → Extension/Theme Manager
Product: Core → Firefox
QA Contact: xptoolkit.xul → extension.manager
Ok, sorry about that. You can also later open chrome://mozapps/content/extensions/update.xul to test it.
Duplicate of this bug: 391932
Duplicate of this bug: 401147
sethb showed me this on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007102204 Minefield/3.0a9pre

"At start-up, a Minefield Add-on Update window checking for compatibility.  When
I scroll down, the thumb in the scroll section cannot reach the bottom.  It
appears that I have 9 add-ons that Minefield is searching for compatibility. 
Whether I scroll down or grab the thumb and drag down, I cannot reach the
bottom.  Also, when I get to the eighth add-on, the list of add-ons becomes
very "jumpy", meaning it shifts up-and-down very quickly, causing a very blurry
list of add-ons.  When I release my scroll, it stops, and the list reappears."
OS: Windows XP → All
Hardware: PC → All
Also found this to be true in the new beta of firefox,

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Duplicate of this bug: 404562
Duplicate of this bug: 404568
I also found this in Firefox Beta 1.  The scrollbar seems to skip and jump if I try to scroll all the way to the bottom.  It never gets all the way to the bottom.  It's almost like what you'd use to get if you didn't close the </html> tag properly and the browser wouldn't know where the end of the page was.
Sorry I mean Firefox 3 Beta 1.
This bug has been confirmed and no additional confirmations are needed. Thanks!
Duplicate of this bug: 406759
Looking at the number of dupes, and the fact that many many people will see this once they update to Firefox 3... Requesting blocking.
Flags: blocking-firefox3?
Duplicate of this bug: 409134
Duplicate of this bug: 409164
Duplicate of this bug: 409368
Flags: blocking-firefox3? → blocking-firefox3+
Duplicate of this bug: 412779
Depends on: 413336
Filed bug 413336 which is the widget bug that causes this problem. If that isn't to be fixed however we can work around this. A couple of options come to mind:

1. Remove the label underneath the list, or move it above.
2. Change the listbox from flexing to fixed height, this would likely mean changing the wizard to variable height which I understand is against platform guidelines.

cc'ing madhava for thoughts.
It is unlikely that bug 413336 will get fixed so we should try to rework the UI here.
Keywords: uiwanted
Priority: -- → P4
Duplicate of this bug: 417150
The same issue occured on FF 3 beta 3.
Duplicate of this bug: 417891
Flags: blocking-firefox3+ → wanted-firefox3+
Duplicate of this bug: 421262
I think this bug should have higher priority and block Firefox 3. This is indeed a very minor bug but it have great exposure.

For a lot of people upgrading from Firefox 2 to Firefox 3 the Incompatible add-ons dialog will be the first thing they will see.

Here the reaction I got when I first tried Firefox 3:

"This is great, I just hit a bug after 5 seconds of use"
Duplicate of this bug: 422613
Duplicate of this bug: 423466
Duplicate of this bug: 424049
Duplicate of this bug: 424664
Duplicate of this bug: 426636
I agree that this is a very minor bug, but it's one of the first things you see when upgrading.  I am humbly requesting a higher priority.  It would be nice to see this fixed when FF3 final is released.
Duplicate of this bug: 427453
Duplicate of this bug: 436738
I ran into this bug with the FF3 release and agree with François Gagné and Joe that the bug should be given a priority boost because it gives a poor first impression. Admittedly, this bug will only be seen by advanced users with many add-ons, but they are the ones most likely to be vocal.
Duplicate of this bug: 445809
Product: Firefox → Toolkit
I can confirm also.  I have a video capture (if wanted/needed) but I can't attach here (3mb zip file of an AVI file) due to size constraints.  Email me if you'd like a copy. ;-)
This bug is well known and its cause even identified, additional information is not necessary
Duplicate of this bug: 459976
Duplicate of this bug: 465051
Duplicate of this bug: 466316
>uiwanted

comment #30
>If that
>isn't to be fixed however we can work around this. A couple of options come to
>mind:

>1. Remove the label underneath the list, or move it above.
>2. Change the listbox from flexing to fixed height, this would likely mean
>changing the wizard to variable height which I understand is against platform
>guidelines.

Neither of those is great, but I think 2 is probably the best choice between the two. The description sets he context of the action button "check now", and we are after string freeze so we can't reword the directions into a single statement to place above the listbox.
Keywords: uiwanted
Couldn't the available height be used to set the height for the listbox in JavaScript?
Wouldn't the easiest fix (hack) be to add a blank entry to the bottom of the displayed list?
Duplicate of this bug: 483876
Priority: P4 → --
Duplicate of this bug: 491148
Duplicate of this bug: 492591
Duplicate of this bug: 495540
(In reply to comment #47)
> I can confirm also.  I have a video capture (if wanted/needed) but I can't
> attach here (3mb zip file of an AVI file) due to size constraints.  Email me if
> you'd like a copy. ;-)

I have also recorded a video of this bug.

Here is the link to that video (no download):
http://tinypic.com/player.php?v=2zoc42h&s=5

Mine is 4 MB in AVI format but zipped is ≈300 kB ;)
Please, there really is no need for additional screenshots and demonstrations, this the problem here is easily reproducable.
Duplicate of this bug: 497851
Duplicate of this bug: 499139
Duplicate of this bug: 499109
Duplicate of this bug: 512962
Same problem on my machine.  Can't scroll through the add-ons at all.  Also the new interface takes up too much space.
Dave, is this a wontfix now regarding our work for new add-ons manager and lesser distractions during the start-up process?
(In reply to comment #66)
> Dave, is this a wontfix now regarding our work for new add-ons manager and
> lesser distractions during the start-up process?

We have no replacement UI for this yet so it may end up coming back so I'd rather keep this open for now.
Duplicate of this bug: 591309
This issue is still being experienced in 4.0b5.

Is it intended for the replacement UI to be created prior to the production release or will that be for a 4.1 update?
There is going to be no replacement for 4.0
Duplicate of this bug: 597033
Duplicate of this bug: 626063
Duplicate of this bug: 640532
Duplicate of this bug: 641923
Duplicate of this bug: 642724
Version 4.2 does the same thing...
Duplicate of this bug: 644673
Duplicate of this bug: 644937
Duplicate of this bug: 650270
Duplicate of this bug: 658531
Why is it taking FIVE YEARS to fix a scroll bar issue?  As evidenced in comment 48, if the cause is known, why can't a small patch be written?  Why not just use the operating system default scroll bar, which takes into account how many items are popularized in the list and generates the scroll bar only when necessary?  This is a dialog box that many users see when starting Firefox for the very first time and I agree with comment 42 that this bug should have a higher priority rating, since on this page alone there are 46 instances of "Bug ###### has been marked as a duplicate of this bug."  Don't you think that is cause for concern if there are that many bug reports on this one issue?
(In reply to comment #81)
> Why is it taking FIVE YEARS to fix a scroll bar issue?

You might want to review the Bugzilla Etiquette page. https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

I suspect the large number of duplicates reflect the fact that it is an easy bug to notice, not that it is a major problem. It does make Mozilla look sloppy, but users can still use Firefox, it doesn't leak memory, it doesn't cause crashes, it doesn't lose data.

And if you are really annoyed, feel free to grab the Firefox source and fix the issue yourself. I'm sure the developers would be glad to accept a patch. (You might want to start with the hack I suggested in comment 54.)
(In reply to comment #54 and comment #82)
That'd be adding the code to add an unlabeled item at line 195 in omni.jar\chrome\toolkit\content\mozapps\extensions\update.js

The problem is: this would create an selectable item which might be reported as bug again. Imagine you get a blank item, you'd also wonder what it is for, if that's an add-on or what. And maybe you'd even think it's responsible for the scrolling problem. No, instead of searching any hacks for this bug, I'd rather try to fix Bug 413336 as it is the real source. (I already dug into the code deeply and will continue to do so.)
Duplicate of this bug: 668904
Can't the box just be autosized to the number of lines without any scrollbar at all?  I am just thinking past the two suggestions made in 2008 (#30).
(In reply to comment #85)
> Can't the box just be autosized to the number of lines without any scrollbar
> at all?  I am just thinking past the two suggestions made in 2008 (#30).

You can never guarantee that a list (any particular list) will never be longer than the height of your screen, so if you don't want scrollbars you'll have to put scroll buttons at top and bottom, which is worse, especially for long lists.
Can't the box be autosized to the necessary number of columns as well?  I am sure that a max of three columns screen height would solve the problem for 99.9% of the people and fit the screen just fine.
Duplicate of this bug: 689587
I just saw the same problem in newest Firefox 7.0 (Windows Vista 64 Bit).
Scroll bar in "Incompatible add-ons" can be moved to bottom.
Just jumps up a bit when moving to bottom. 
I attach a screenshot.
Same in 7.0.1 (Windows XP)


Just put the list in a regular text area, for Christs sake!
It seems to be replaced with a different UI in 8.0b1.
Depends on: 596343
Whiteboard: [wontfix? for Firefox per 596343][testday-20110930]
Bug 596343 is a one time only UI, it doesn't replace this.
Whiteboard: [wontfix? for Firefox per 596343][testday-20110930] → [testday-20110930]
Duplicate of this bug: 703233
Hasn't this box gone away with the streamlined/silent updates?

I can't test right now, but maybe we could close the bug?
(In reply to Jack from comment #95)
> Hasn't this box gone away with the streamlined/silent updates?
> 
> I can't test right now, but maybe we could close the bug?

No this UI still exists
Duplicate of this bug: 589321
Duplicate of this bug: 610220
This UI is going away in 57
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.