Card preview pane contents can't be selected for copy to clipboard

RESOLVED FIXED in Thunderbird 61.0

Status

RESOLVED FIXED
18 years ago
7 months ago

People

(Reporter: apa3a, Assigned: furyinbox)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 61.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird60 fixed, thunderbird61 fixed)

Details

(Whiteboard: [workaround: https://addons.mozilla.org/en-US/thunderbird/addon/select-address-book-text/ ])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3+) Gecko/20010824
BuildID:    2001082421

When address card is selected in the card list pane, the content of the card is
displayed below - in preview pane. I can't select the text with mouse on this
pane and copy it to clipboard.

Reproducible: Always
Steps to Reproduce:
1. Launch address book, click on an address card
2. Press mouse button over text in the right lower pane and move the mouse over
the text
3.

Actual Results:  Nothing happens

Expected Results:  The text should be highlighted for copying to clipboard

Possibility of copy text from that pane to clipboard is very important for
exchanging data with other applications.

Updated

18 years ago
QA Contact: fenella → nbaca

Comment 1

18 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Confirmed Linux 2001110908
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
reassigning to racham.
Assignee: chuang → racham

Comment 5

18 years ago
Marking nsbeta1 because you should be able to highlight items in the card pane,
right click and Copy. Bug# 35837 covers the case where a Copy would take all the
contents of the card, not just the highlighted region.
Keywords: nsbeta1

Updated

18 years ago
Whiteboard: nab-copy

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2

Updated

17 years ago
Blocks: 156960

Updated

17 years ago
Keywords: nsbeta1- → nsbeta1
Whiteboard: nab-copy → nab-copy, [ue2]

Comment 6

17 years ago
I think this should be slove as people can have their Needed information being
copy. And it wouldn't hurt any thing for doing so.

May I know the status now?

Comment 7

16 years ago
Mail triage team: nsbeta1+/adt3
Assignee: racham → cavin
Status: ASSIGNED → NEW
Keywords: nsbeta1 → nsbeta1+
Whiteboard: nab-copy, [ue2] → [adt3] nab-copy, [ue2]

Comment 8

16 years ago
Correction to last comment: 
Mail triage team: nsbeta1-
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: [adt3] nab-copy, [ue2] → nab-copy, [ue2]

Comment 9

16 years ago
Mozilla Thunderbird 0.2 (2003090) - Bug still there... :(

Comment 10

16 years ago
This would be a *huge* help in my job (even more than real vCard support). I can
work around this limit by clicking the get-map button and copying the address
out of MapQuest, but that procedure is pretty much the definition of "kludge."
Being able to edit an address-book entry in this preview page would be even
better, but I'd be content for a while if I could just copy this text--just as I
can in almost every other application that presents text fields. (Yes, I'm kind
of amazed that this wasn't built in from the start.) 

Comment 11

15 years ago
dup of bug 35837?

Comment 12

15 years ago
*** Bug 138161 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Assignee: cavin → sspitzer
QA Contact: nbaca

Comment 13

15 years ago
*** Bug 236944 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 210275 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
Changing hardware/OS to All
OS: Linux → All
Hardware: PC → All

Comment 16

15 years ago
*** Bug 254198 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
Shouldn't there is a way to send an Address book? 
E.g I want to send someone on my Addressbook on the email using vcard?

I think that is the very good way and This Copy on the address book will ease
our problem when we want to put them in the online address book somehow.
Product: Browser → Seamonkey
*** Bug 172294 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
Requesting blocking-aviary1.1 flag

Since can't forward VCards yet, there is currently no easy way to copy an
address into an email or other document - you have to either retype the
information (!?!) or copy and paste each line (line 1, line2, city, state...)
separately from the card properties window.  This is basic functionality
currently missing from the address book.

If the card preview window was selectable/copyable, this would make the window
function the way a user would expect, and provide a way to easily extract
address information.
Flags: blocking-aviary1.1?

Comment 20

14 years ago
Today a field representative called me and asked how to forward a Mozilla
address book entry to someone. He is accustomed to Micrsoft Outlook, so he
expected a button to forward as a vCard.

After checking it out, I was disappointed to discover no support of any kind for
forwarding address book entries. (that would be bug 11406 and bug 20304 and bug
176803)

I then started to walk him through copying-and-pasting the address book entry to
the body of an e-mail, which I figured was a decent workaround... but it is
impossible to copy text-- impossible even to select it!

Updated

14 years ago
Assignee: sspitzer → mail

Updated

14 years ago
Flags: blocking-seamonkey1.0a+

Comment 21

14 years ago
Don not ever set bug flags to + if you are not in any special group that manages
releases, please.
Many Mozilla suite versions have shipped with that, SeaMonkey will not block a
release for that.
Also unsetting bogus (very old) target milestone of unassigned bug.
Flags: blocking-seamonkey1.0a+ → blocking-seamonkey1.0a-
Target Milestone: mozilla1.2alpha → ---

Comment 22

14 years ago
*** Bug 301230 has been marked as a duplicate of this bug. ***
*** Bug 266553 has been marked as a duplicate of this bug. ***
Despite being a Suite bug, TB bugs are being duped against this (following 
Scott's lead at comment 16).  Presumably that means this feature is actually 
Core.

This bug is actually an RFE, but I'm not going to change the severity.
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: addressbook
Keywords: helpwanted

Comment 25

14 years ago
*** Bug 319151 has been marked as a duplicate of this bug. ***
*** Bug 346073 has been marked as a duplicate of this bug. ***

Comment 27

12 years ago
This behavious bugs the hell out of me, any sign of it getting fixed? It was first reported five years ago!

Comment 28

12 years ago
See related Bug 365421 ... is it a dupe?
(In reply to comment #28)
> See related Bug 365421 ... is it a dupe?

not a dupe.  this is about copying selected text. 365421 is about extracting data from a clickable field.
Duplicate of this bug: 406185
Duplicate of this bug: 361895
Product: Core → MailNews Core
I could use several times a week
Flags: wanted-thunderbird3?
Duplicate of this bug: 468091

Comment 34

10 years ago
I could also use this about every day. Going to the edit screen, then the notes, then scrolling to find text, then copying is a bit tedious.

Comment 35

10 years ago
This has been reported at https://launchpad.net/bugs/235101.  Any word on where this fits in the grand scheme of things?

Comment 36

10 years ago
The ability to copy the total contents of an address card in one operation is TOTALLY essential.
This is particularly so because it is impossible to highlight the address card name in one list, then copy it to the clipboard and add the address card to another list

A much more sensible solution would be to allow the link to an address card to be used in 1 or more lists to enable that card to be used by all the selected lists.
Currently a new card has to be opened in each list and the required contents have to be tediously filled in. This causes not only much frustration but also errors and omissions.
The result is that the several cards (in different lists) my not contain the same data. Indeed some may contain out of date phone numbers or email addresses.

Comment 37

10 years ago
This has been an issue for me for years now. I use the address book as my central repository of contact information and not being able to copy & paste is a HUGE inconvenience. PLEASE, Please, please someone take this on and fix it! I will name my first child in your honor if you do.

Another alternative might be to keep the address books in XML or LDIF format, or any other HUMAN READABLE format, so that I can create my own tools to manage the books. The MORK format is ubiquitous inside Mozilla and I've rarely seen anything more useless. How about moving into the 21st century with XML?

Comment 38

10 years ago
(In reply to comment #37)
> This has been an issue for me for years now. I use the address book as my
> central repository of contact information and not being able to copy & paste is
> a HUGE inconvenience. PLEASE, Please, please someone take this on and fix it! I
> will name my first child in your honor if you do.
> 
> Another alternative might be to keep the address books in XML or LDIF format,
> or any other HUMAN READABLE format, so that I can create my own tools to manage
> the books. The MORK format is ubiquitous inside Mozilla and I've rarely seen
> anything more useless. How about moving into the 21st century with XML?

It is high time that such a simple fix is carried out.
How about gettingmit done!
Duplicate of this bug: 557148

Comment 40

9 years ago
there is add on that brings needed functionality
https://addons.mozilla.org/cs/thunderbird/addon/7065
Duplicate of this bug: 561757

Comment 42

9 years ago
I had thought or hoped opensource software had matured.  Apparently not.  This issue has been around for almost 10 years and nothing done about it.  Microsoft is lovin' it.

Comment 43

9 years ago
John Vivirito added the following comment to Launchpad bug #235101:

File a bug upstream. Saying things like you did
should be posted somewhere else as it does not
have anything to do with the bug.

On 04/26/2010 04:55 AM, Wazz wrote:
> I had thought or hoped opensource software had matured.  Apparently not.
> This issue has been around for almost 10 years and nothing done about
> it.  Microsoft is lovin' it.
> 

-- 
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III



-- 
http://launchpad.net/bugs/235101
Duplicate of this bug: 635496
Duplicate of this bug: 735365

Updated

7 years ago
Summary: On the card preview pane I can't select text and copy it to clipboard → On the card preview pane I can't select text or address and copy it to clipboard
Duplicate of this bug: 698183

Comment 47

7 years ago
Thank you Frantisek for advising about the add-on. (I nearly missed it)
This solved the problem for me (on Mac) it is a great help.
Could this feature be incorporated into the main application?

Updated

6 years ago
Duplicate of this bug: 849506

Comment 49

5 years ago
Oh good, I'm not the only one desiring this functionality. Of course, 20 versions, 12 years and 18+ duplicate bug filings later, I'm not very hopeful. 

Then again, why fix what can be worked around with a 3rd party add-on? /s 

Sorry to be so demanding :( I just want to copy-n-paste.

Updated

5 years ago
Duplicate of this bug: 224852

Updated

5 years ago
See Also: → bug 365421

Updated

5 years ago
Blocks: 92321

Updated

5 years ago
See Also: → bug 284148

Updated

5 years ago
Duplicate of this bug: 733062

Updated

4 years ago
Duplicate of this bug: 1036626

Updated

4 years ago
Summary: On the card preview pane I can't select text or address and copy it to clipboard → Card preview pane contents can't be selected for copy to clipboard

Updated

3 years ago
Flags: wanted-thunderbird3?

Updated

3 years ago
Duplicate of this bug: 1250481

Updated

3 years ago
Duplicate of this bug: 1222489

Updated

3 years ago
Component: Address Book → Address Book
Keywords: helpwanted
Product: MailNews Core → Thunderbird
Whiteboard: nab-copy, [ue2] → [workaround: https://addons.mozilla.org/en-US/thunderbird/addon/select-address-book-text/ ]

Updated

2 years ago
Duplicate of this bug: 1331247
(Assignee)

Comment 56

a year ago
The patch makes text in ab card view selectable. 
It's pretty straightforward, just one css line. 

The patch is pretty useful for me as well... so I guess I have to vote for the bug too :D

Please let me know what do you think. 

P.S.
Jorgk, again, I'm setting you as a reviewer since I see your name most of the time in hg log of the file I've changed. Let me know if I should ask for review from someone else.
Attachment #8965043 - Flags: review?(jorgk)
(Assignee)

Comment 57

a year ago
I have to mention, context menu is not there. I'm not really sure how good it is from UX standpoint. CTRL+C works of course.
(Assignee)

Comment 58

a year ago
One more thing I have to mention is addon suggested as a workaround cannot be installed in latest TB. So it is not a workaround anymore.

Comment 59

a year ago
Comment on attachment 8965043 [details] [diff] [review]
make-ab-view-text-selectable.patch

CSS is something for Richard ;-)
Attachment #8965043 - Flags: review?(jorgk) → review?(richard.marti)
Comment on attachment 8965043 [details] [diff] [review]
make-ab-view-text-selectable.patch

Thanks, Ruslan.
Attachment #8965043 - Flags: review?(richard.marti) → review+

Comment 61

a year ago
Actually, this is a good step forward, but the header is still not selectable. Perhaps another line of CSS missing.
Is the header really needed? When you select all the content (without the headers) the formatting isn't like the card view. But if you really want the headers, you need to add ".CardViewHeading".

Comment 63

a year ago
Guys, guys! It seems that this bug is about to be solved! Don't you think, you should wait one more year? At least, it'd be an adult then! :D

No, seriously. Nice to see that you're working on it. Thanks!
(Assignee)

Comment 64

a year ago
(In reply to Jorg K (GMT+1) from comment #61)
> Actually, this is a good step forward, but the header is still not
> selectable. Perhaps another line of CSS missing.

Honestly I didn't even think about making header selectable. But it should be pretty easy to do. Let me know if I should provide you with patch for this.

Comment 65

a year ago
Well, the first thing I tried to select was the header and it didn't work. There's no reason why that text shouldn't be selectable, so let's fix it while we're here and not wait another 17 years ;-(
(Assignee)

Comment 66

a year ago
It's now possible to selected basically everything in the card view. There is card header which is display name by default. It's also possible to selected subheaders ("contact", "phone", etc...). They are not useful to select by their own but it's a good context if select them together with other contact info. 

Excuse me, I'm still not really good at understanding the review process, so I'm asking for review from both of you, since Richard is good at CSS and Jorgk should check if selection is working as expected.
Attachment #8965043 - Attachment is obsolete: true
Attachment #8965427 - Flags: review?(richard.marti)
Attachment #8965427 - Flags: review?(jorgk)
Assignee: nobody → furyinbox
(Assignee)

Comment 67

a year ago
and here is screenshot for everyone else to see what is selectable.
Comment on attachment 8965427 [details] [diff] [review]
make-ab-view-text-selectable.patch

Yes, everything can be selected. But I think it makes not much sense to select the whole pane as the output isn't well formed to use directly.

Better all can be selected than nothing how it is now.
Attachment #8965427 - Flags: review?(richard.marti)
Attachment #8965427 - Flags: review?(jorgk)
Attachment #8965427 - Flags: review+

Comment 69

a year ago
I've played with this during a fair amount of time. The only perfect solution would be to format the selected content nicely in the clipboard. As Richard said in comment #68, the text currently placed on the clipboard doesn't lend itself to pasting in a formatted way. I tried omitting headers (CardViewHeading), but then the selected text loses its context. So let's land it as proposed.

Comment 70

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4d7274e18df2
make text in AB card view selectable. r=Paenglab
Status: NEW → RESOLVED
Last Resolved: 18 years agoa year ago
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: --- → Thunderbird 61.0

Updated

a year ago
Attachment #8965427 - Flags: approval-comm-beta+

Comment 71

11 months ago
Beta (TB 60 beta 3):
https://hg.mozilla.org/releases/comm-beta/rev/d265c609707c59469473b13bf50b24cf7616e1e6
status-thunderbird60: --- → fixed
status-thunderbird61: --- → fixed

Updated

7 months ago
Duplicate of this bug: 1484323
You need to log in before you can comment on or make changes to this bug.