cannot add links to personal toolbar after deleting personal toolbar folder

VERIFIED INVALID

Status

SeaMonkey
Bookmarks & History
P2
normal
VERIFIED INVALID
17 years ago
8 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you delete everything in your bookmarks, Mozilla no longer allows you to
add anything to your Personal Toolbar.
(Reporter)

Comment 1

17 years ago
I suppose that I could say that this is build id: 2001062815, or Mozilla 0.9.2.
(Reporter)

Comment 2

17 years ago
The only way to fix this is to go into the Manage Bookmarks screen and add a new
folder called Personal Toolbar Folder and restart Mozilla.

Comment 3

17 years ago
I'm seeing this JavaScript Error when dragging to the Personal Toolbar after 
deleting the folder:

Error: uncaught exception: [Exception... "Component returned failure code: 
0x80004005 (NS_ERROR_FAILURE) [nsIBookmarksService.insertBookmarkInFolder]"  
nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: 
chrome://navigator/content/navigatorDD.js :: anonymous :: line 327"  data: no]
Source File: chrome://global/content/nsDragAndDrop.js
Line: 106


What should happen when that folder gets deleted?  Should Mozilla create a new 
one?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
I think Mozilla should recreate it in the event that it is deleted, to keep 
people from having to go in an manually recreate it.

Comment 5

17 years ago
*** Bug 93369 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
tweaking summary since it is the deletion of the ptoolbar folder that is itself the sufficient condition.
Summary: cannot add links to personal toolbar after deleting all bookmarks → cannot add links to personal toolbar after deleting personal toolbar folder

Comment 7

17 years ago
Setting "personal toolbar folder" in "Manage bookmarks" DOES NOT allow me add
bookmarks to my personal toolbar folder.

Mozilla build ID: 2001091003
OS: win98
0. Before I Installed this build, I exported my bookmarks, and deleted al my
profile information (and all the traces of the older build I had).
1. Installed Mozilla
2. Imported my saved bookmarks.
3. Whent in to "Manage bookamrks" and set my imported "personal toolbar folder"
as my personal toolbar folder.

My personal toolbar folder is still blank (except for the "home" and "bookmarks"
icon, even after re-starting Mozilla.

Comment 8

17 years ago
just to clarify the behaviour of this bug a little:

When recreating pt folder it must be named 'Personal Toolbar Folder', using
lower case wont work. 
Once it has been recreated the behaviour is strange as well. 
 - sometimes links can be droped straight onto it
 - sometime you need to open a new browser window before it will work 
 - some times you need to restart the browser.

Further if you delete the folder the links in it dont automaticaly disapear from
your personal toolbar, even after create a new browser window, you can also
still drop new links onto the toolbar. You have to restart the browser to make
them totaly disapear.

Comment 9

17 years ago
*** Bug 100893 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla1.0
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 11

16 years ago
moving to mozilla1.1
Target Milestone: mozilla1.0 → mozilla1.1

Comment 12

16 years ago
My personal toolbar folder is in the bookmarks (with the correct case "Personal
Toolbar Folder"), but no longer displays in the browser personal toolbar line. I
can restart til the cows come home and can't get it to display my folders
again., The personal toolbar folder area just has "Bookmarks".

I also compared the presentation in "manage Bookmarks" on my two PCs and they
appear identical. So, how do I get the personal toolbar folders to redisplay? I
have of course restarted, and also just upgraded to 0.9.6. No joy.

When I export the bookmarks, I get cryptic message popups like "NC:BVookmark
Root #$8967ea59"

Comment 13

16 years ago
*** Bug 112278 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Status: NEW → ASSIGNED
Keywords: nsbeta1

Comment 15

16 years ago
Nav triage team: if the ``Personal Toolbar Folder'' doesn't exist when the user
drags a bookmarks/link to the Personal Toolbar we should create a new ``Personal
Toolbar Folder''.  nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 16

16 years ago
1. I have a similar problem on Linux. I renamed the "Personal Toolbar Folder" to
another name, created a new PTF, and then found that I could not drag/drop to
the toolbar or add bookmarks (via manage) directly to the folder.

2. Futhremore, I tried to drag/drop an item from the Bookmarks sidebar to the
toolbar.Instead of appearing on the toolbar, or showing up in the PTF, or
failing, the item I dragged there disappeared entirely from the Bookmarks file.
It's simply  and silently gone.

3. I am using 0.9.8, build ID 2002020415, on Linux, Mandrake 8.1, KDE.

Comment 17

16 years ago
Re-reading my previous comment, #16, I see that my language was inexact; my
apologies. I re-state the first paragraph:

I can add items to the file named "Personal Toolbar Folder" using the "manage"
function, by working in the Bookmarks sidebar, or by dragging them into the
folder in the sidebar from the location box, but the items that I add to the
sidebar's PTF do not appear on the toolbar. Dragging and dropping bookmarks from
the location box directly to the toolbar does not add them to the PTF or to the
toolbar. (And the error noted in the 2nd paragraph still stands.) Opening
windows, closing windows, and/or restarting Mozilla has no effect -- an item
placed into the PTF does not display on the toolbar.

Comment 18

16 years ago
*** Bug 124644 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 127242 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
removing self from cc list

Comment 21

16 years ago
*** Bug 134023 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
*** Bug 136582 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
I have the same problem (build 2002041103, Windows 2000). I deleted my PTF and
imported my regular Mozilla bookmarks from another machine, including one named
"Personal Toolbar Folder". Choosing "View | Set as Personal Toolbar Folder" has
no apparent effect.

Comment 24

16 years ago
I had a bit of confusion when I accidentally deleted the ptf. I couldn't
understand why nothing dragged onto the pt would stay, then just happened to
remember that a ptf was always in the bookmarks dir, but never really knew what
it did. What would have made everything clean would be something like a popup
when dragging items to the pt and no ptf exists. It would prompt to create a
ptf, solving the functionality prob and informing the user as to what the ptf is
for. 

Comment 25

16 years ago
*** Bug 141799 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
*** Bug 143443 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
*** Bug 150553 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
*** Bug 151052 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
*** Bug 150425 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
Well I've found a work around for this that seems to fix it.  If you create a
folder first using manage bookmarks, then go view->set as personal toolbar, you
seem to be able to drag items from the location bar to the toolbar.  I hope this
helps anyone until a proper fix is made for it.

Comment 31

16 years ago
*** Bug 153988 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
*** Bug 144804 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
taking
Assignee: ben → chanial
Status: ASSIGNED → NEW
Depends on: 160019

Comment 34

16 years ago
*** Bug 162784 has been marked as a duplicate of this bug. ***

Comment 35

16 years ago
*** Bug 141877 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
*** Bug 170451 has been marked as a duplicate of this bug. ***

Comment 37

15 years ago
*** Bug 171717 has been marked as a duplicate of this bug. ***

Comment 38

15 years ago
*** Bug 145484 has been marked as a duplicate of this bug. ***

Comment 39

15 years ago
I see this bug on OS/2, and others have seen it on Mac OS 9.  It is not specific
to Windows 2000.  Someone shoudl change the Hardware/OS to ALL/ALL.

Personally, I think the Personal Toolbar folder should be recreated only if
someone tries to drag something to the Personal Toolbar.

Comment 40

15 years ago
OS->All
Platform->All
OS: Windows 2000 → All
Hardware: PC → All

Comment 41

15 years ago
*** Bug 180653 has been marked as a duplicate of this bug. ***

Comment 42

15 years ago
*** Bug 174691 has been marked as a duplicate of this bug. ***

Comment 43

15 years ago
*** Bug 189657 has been marked as a duplicate of this bug. ***

Comment 44

15 years ago
*** Bug 166731 has been marked as a duplicate of this bug. ***

Comment 45

15 years ago
Found a workaround for this:  In Manage Bookmarks, put a folder called Personal
Toolbar Folder at the very top of the list.  Create a subfolder also called
Personal Toolbar Folder.  Add bookmarks to the subfolder and view->set as
Personal Toolbar Folder.

Comment 46

15 years ago
I've reconfirmed this bug in
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210

Additionally, I found this to work for restoration of the Personal Toolbar
Functionality:
1. I deleted all my bookmarks (after a backup)
2. I created a folder named "Personal Toolbar Folder"
3. With that folder selected, I used the "view->set as
Personal Toolbar Folder" menu option.

After this, I imported my backed-up bookmarks and found the Personal Toolbar
folder still working.

Comment 47

15 years ago
*** Bug 192804 has been marked as a duplicate of this bug. ***

Comment 48

15 years ago
*** Bug 195674 has been marked as a duplicate of this bug. ***

Comment 49

15 years ago
*** Bug 198058 has been marked as a duplicate of this bug. ***

Comment 50

15 years ago
I believe the reason mozilla is confused is that it ends up with a bookmarks.html 
with a personal toolbar folder that has attribute PERSONAL_TOOLBAR_FOLDER="true"
but ID="BookmarksRoot#nnn". It is not recognized as a personal toolbar folder 
because it does not have ID="NC:PersonalToolbarFolder".

Behavior in this case is, you have a blank personal toolbar folder, and View ->
Set as Personal Toolbar Folder will not cause items to appear in a personal
toolbar, even after a restart.  
(Visual clue if you are testing this further- When choosing "Set as Personal
Toolbar Folder", if it is going to work, the folder selected will open,
showing an open folder icon.  If it is going to fail, the folder will remain
closed.)

Bug owner: Bug 139136 is a dupe of this bug

Solving this bug may also solve bug 146391

Comment 51

15 years ago
*** Bug 199187 has been marked as a duplicate of this bug. ***

Comment 52

15 years ago
I fought this problem in Mozilla 1.3 running on RedHat Linux 8.0. I tried all
the suggestions in this thread, creating a "Personal Toolbar Folder" and setting
it as the Personal Toolbar Folder. Tril O. Byte identified the problem. I edited
my bookmarks.html file and set ID="NC:PersonalToolbarFolder" on the "Personal
Toolbar Folder". My "link bar" is working again. Whew!

Comment 53

15 years ago
I'm running Mozilla 1.4a and I'm having the same trouble. I've tried entering
bookmarks.html and editing the ID but that doesn't work either, and i've tried
'set as personal toolbar folder' - but i still can't get my PT back. My OS is WinXP.

Comment 54

15 years ago
*** Bug 202290 has been marked as a duplicate of this bug. ***

Comment 55

15 years ago
It's still a problem with both 1.3 and the 1.4 beta, and the solution of "go
into the Manage Bookmarks screen and add a new folder called Personal Toolbar
Folder and restart Mozilla" doesn't work.

I go to Bookmarks | Manage Bookmarks | View | Set as Personal Toolbar Folder,
and it looks like it worked except that the toolbar remains empty of bookmarks
and when I go to Manage Bookmarks again, the folder has lost it's designation as
the Personal Toolbar Folder.

Silly me for deleting the personal toolbar folder.  I've even tried uninstalling
and reinstalling Mozilla, but that didn't change anything.

Comment 56

15 years ago
I was able to workaround this problem using the technique suggested in comment
45.  Creating a Personal Toolbar Folder didn't work.  Creating a Personal
Toolbar Folder with a subfolder called Personal Toolbar Folder _did_ work for me.

I did that before comments 50 and 52 were entered - which look like they give an
even better workaround, or maybe 46, which also looks good.

People who tried the simple fix without success should try the techniques in
50/52 or, if no luck there, 45 or 46, before giving up.  Read the comments
carefully.  There are multiple workarounds described here, not just one!  I bet
at least one of them will work for you.

Comment 57

15 years ago
*** Bug 211220 has been marked as a duplicate of this bug. ***

Comment 58

15 years ago
*** Bug 211162 has been marked as a duplicate of this bug. ***

Comment 59

15 years ago
*** Bug 214913 has been marked as a duplicate of this bug. ***

Comment 60

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Updated

14 years ago
Target Milestone: Future → ---

Comment 61

14 years ago
*** Bug 224112 has been marked as a duplicate of this bug. ***

Comment 62

14 years ago
*** Bug 214155 has been marked as a duplicate of this bug. ***

Comment 63

14 years ago
*** Bug 221932 has been marked as a duplicate of this bug. ***

Comment 64

14 years ago
*** Bug 205664 has been marked as a duplicate of this bug. ***

Comment 65

14 years ago
I've had problems in recent versions of Mozilla and Camino for Mac OS X with the
contents of the Personal Toolbar Folder not showing up in the Personal Toolbar
after importing my old bookmarks containing a Personal Toolbar Folder. I tried
consolidating down to one Personal Toolbar Folder, putting the contents of the
old Personal Toolbar Folder in the new one and deleting the old one. Didn't
work. Found a quick workaround: Select some other folder, like the Mozilla.org
Folder. Designate it as the Personal Toolbar Folder from the menu. Then reselect
the Personal Toolbar Folder as the Personal Toolbar Folder, and it works again.
You can't simply select it in the first place, as the menu is grayed out when
it's selected. Somehow Mozilla's confused about which folder is the Personal
Toolbar Folder, although it still recognizes the name. 

Comment 66

14 years ago
The solution in comment 46 worked for me.  Good to note that the folder did not
have to be at the top-level of the bookmarks, which would have been annoying.  I
stuck it nested a couple folders down, where it won't get in the way during
normal bookmark hunting.

I can now drag things to the personal toolbar again.

The bookmarks.html file correctly had the attributes mentioned in comment 50 (I
checked just in case).

This bug should probably be getting some more attention... it's a freakishly
confusing bug with non-obvious behavior.

Comment 67

14 years ago
The solution in comment 46 worked for me.  Good to note that the folder did not
have to be at the top-level of the bookmarks, which would have been annoying.  I
stuck it nested a couple folders down, where it won't get in the way during
normal bookmark hunting.

I can now drag things to the personal toolbar again.

The bookmarks.html file correctly had the attributes mentioned in comment 50 (I
checked just in case).

This bug should probably be getting some more attention... it's a freakishly
confusing bug with non-obvious behavior.

Using 1.7 on Linux.

Comment 68

14 years ago
*** Bug 254889 has been marked as a duplicate of this bug. ***

Comment 69

14 years ago
The instructions in
Help/Help Contents/Contents tab/Customizing Mozilla/Toolbars/Personal
Toolbar/Adding Personal Toolbar Bookmarks
file could be improved. There is even a step where the helpfile is not accurate
and is misleading.
Generally speaking, how to set and and how to identify/locate a folder acting as
the Personal Toolbar Folder could be improved in Mozilla.

With Opera 7.x, one does not have to create or assign a folder to act as the
Personal Toolbar Folder nor does he have to name such "Personal Toolbar Folder"
or some other name; bookmarks are always draggable to the Personal Bar. Each
properties window for individual bookmark has a "Show on personal bar" checkbox.
That is another implementation. Here, the personal bar always exists, can not be
deleted. You can drag url icon to it or you can check the "Show on personal bar"
checkbox of any existing bookmark. X bookmarks coming from Y bookmark folders
could be shown in the Personal bar without necessarly being listed as such into
a defined/pre-determined personal toolbar folder.

The fact that this bug is now in the top 25 most frequently reported bugs
suggests that Mozilla should consider rethinking its implementation.

My 2 cents
Product: Browser → Seamonkey

Comment 70

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody

Comment 71

10 years ago
lol ;)
(Reporter)

Comment 72

10 years ago
Why is the status on this still set to NEW after almost 7 years?
QA Contact: claudius → bookmarks
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 73

8 years ago
The Personal Toolbar Folder has become delete protected.

VERIFIED
Status: RESOLVED → VERIFIED
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.