Open Bug 1855907 (select_translations_mvp) Opened 9 months ago Updated 4 days ago

[meta] Select Translations MVP

Categories

(Firefox :: Translations, task, P2)

Firefox 118
task

Tracking

()

People

(Reporter: ben, Assigned: nordzilla)

References

(Depends on 2 open bugs)

Details

(Keywords: feature-testing-meta, meta)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Steps to reproduce:

I often use machine translation to help me understand a difficult sentence in a web page in a language that I know. I don't need to translate the whole page, so I would like to use the Firefox private translations feature to translate just that one sentence.

Similarly, my Mastodon timeline contains posts in many different languages. Here again, I would like to use the Firefox private translations feature to translate a single post, rather than the whole page.

For these use cases, it would be helpful to have a menu option "translate selection" in the right-click menu.

The Bugbug bot thinks this bug should belong to the 'Firefox::Translation' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Translation
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1858413

Additional to "right click -> translate selected text", a hotkey could be useful for quicker action.

Also, using a hotkey - would it be possible to translate a single word under the cursor? Then you don't even need to select it, which saves additional time.

Duplicate of this bug: 1858955

Erik, let's use this bug to track the implementation.

Assignee: nobody → enordin
Summary: Translate selected text rather than whole page → [meta] Translate selected text rather than whole page

Sounds good! I've got it bookmarked.

Thanks Tom S for the clean up. I'm sorry you had to do it, but I searched the same text I later used as the bug's subject ("Translate selected text") and for some reason it didn't find this bug.

Depends on: 1865002
Depends on: 1868679
Depends on: 1866827
Summary: [meta] Translate selected text rather than whole page → [meta] Select Translations MVP
Depends on: 1870298
Depends on: 1870300
No longer depends on: 1870300
Depends on: 1870300
Depends on: 1870304
Depends on: 1870305
Depends on: 1870306
Depends on: 1870307
Depends on: 1870311
Depends on: 1870314
Depends on: 1870316
Depends on: 1870320
Depends on: 1870327
Type: enhancement → task
Depends on: 1870332
Depends on: 1870334
Depends on: 1870338
Priority: -- → P2
Depends on: 1870341
Depends on: 1870343
Depends on: 1870349
Depends on: 1870352
Depends on: 1870354
Depends on: 1870357
Depends on: 1870358
Depends on: 1870359
Depends on: 1870360
Depends on: 1870361
Depends on: 1870363
Depends on: 1870364
Depends on: 1870366
Depends on: 1870367
Depends on: 1870368
Depends on: 1870369
Depends on: 1871642
Depends on: 1871645
Depends on: 1875383
Depends on: 1878721
Depends on: 1834380
Depends on: 1880357
Depends on: 1882835
Depends on: 1882884
Depends on: 1886276
Depends on: 1886753
Depends on: 1887953
Duplicate of this bug: 1888111
Depends on: 1890299
Depends on: 1890404
No longer depends on: 1870338
No longer depends on: 1870341
No longer depends on: 1870343
Depends on: 1867825
Depends on: 1891528
Depends on: 1891782
Depends on: 1891792
Duplicate of this bug: 1892215
Depends on: 1892359
No longer depends on: 1891792
Depends on: 1892546
Depends on: 1892836
Depends on: 1892846
Depends on: 1892848
Depends on: 1892853
Depends on: 1892931
Depends on: 1893022
Depends on: 1893060
Depends on: 1893062
Depends on: 1893100
Depends on: 1893336
Depends on: 1893345
Depends on: 1893471
Depends on: 1893776
Depends on: 1894091
Depends on: 1894094
Depends on: 1894098
Depends on: 1894101
Depends on: 1894271
Depends on: 1894484
Depends on: 1894575
Depends on: 1894935
Depends on: 1894989
Alias: select_translations_mvp
Depends on: 1895036
Depends on: 1893958
Depends on: 1894008
Depends on: 1894029
Depends on: 1894224
Depends on: 1897482
Depends on: 1899354
No longer depends on: 1866827
Depends on: 1900023
Depends on: 1900006
Depends on: 1894233
Depends on: 1900127
Depends on: 1900432
No longer depends on: 1894094
No longer depends on: 1894233
No longer depends on: 1900006
No longer depends on: 1900023
No longer depends on: 1894224
Status: NEW → RESOLVED
Closed: 18 days ago
Resolution: --- → FIXED

Resolved the wrong bug by accident. We're close, but not quite yet :)

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Regressions: 1902254
Depends on: 1902711
Depends on: 1903087
Depends on: 1903391
Depends on: 1903392
Depends on: 1903393
Depends on: 1901888
Depends on: 1901314
Depends on: 1900023
Depends on: 1894233
Depends on: 1894094
Depends on: 1901351
Depends on: 1903092
Depends on: 1903838
You need to log in before you can comment on or make changes to this bug.