Last Comment Bug 208923 - minimize to system tray icon/icon menu
: minimize to system tray icon/icon menu
Status: RESOLVED WONTFIX
[duptome][gs][workaround:https://addo...
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All All
-- enhancement with 88 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://getsatisfaction.com/mozilla_me...
: 214240 214648 217185 225609 226309 235890 235946 256740 272244 276788 286293 312640 314656 320987 360618 390772 450399 453911 460038 467164 493105 493180 528858 534450 540071 546061 651833 693176 802533 854067 1312282 1317934 1344146 1350727 1464201 1490360 1490368 (view as bug list)
Depends on: 325353
Blocks: 528858
  Show dependency treegraph
 
Reported: 2003-06-10 07:37 PDT by Robert Accettura [:raccettura]
Modified: 2019-01-04 00:00 PST (History)
125 users (show)
mscott: blocking‑aviary1.0-
mkmelin: wanted‑thunderbird3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposition 1 of possible implementation (14.12 KB, image/png)
2003-08-03 11:46 PDT, Robert Accettura [:raccettura]
no flags Details

Description User image Robert Accettura [:raccettura] 2003-06-10 07:37:59 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030609
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030609

Thunderbird should adopt the icon tray... but better than mozilla has/did.

Use it similar to how AIM or MSN use it, allowing for easy access to common
functions like "Check Mail", "Open Mail Window", "Compose Mail", etc.

It would be nicer to minimize the mail window to the system tray, rather than
the task bar.  Saves space and looks nicer.  Most people like their mail client
open all day... so it saves for those people.

Secondly, it could show how many messages are in the inbox by right clicking on
the icon...

"Inbox (5)" perhaps?

Something similar to how Mail.app has that menu when open in the doc. (BTW the
feature on the Mac side would be good).

Would be nice and convient for all


Since It's going to get a nice overhaul so it looks pretty... and is easier to
use... why not make it the perfect mail client?

Reproducible: Always

Steps to Reproduce:
Comment 1 User image Jason M. Abels 2003-06-10 07:57:20 PDT
Good idea, but thunderbird is not yet posting bugs in Bugzilla. Please report on
the forums at http://www.mozillazine.org/
Comment 2 User image Matthias Versen [:Matti] 2003-06-10 09:35:08 PDT
v invalid
Comment 3 User image Robert Accettura [:raccettura] 2003-06-10 16:06:02 PDT
Anyone know if an when there will be thunderbird in bugzilla?

I would hope so... perhaps then open the bug up again.

My mistake... sorry.
Comment 4 User image timeless 2003-07-25 13:07:19 PDT
.
Comment 5 User image timeless 2003-07-25 13:29:53 PDT
.
Comment 6 User image Jo Hermans 2003-07-29 02:00:53 PDT
*** Bug 214240 has been marked as a duplicate of this bug. ***
Comment 7 User image Jason M. Abels 2003-07-31 11:03:45 PDT
Confirming. I like this idea.
Comment 8 User image Jason M. Abels 2003-07-31 11:47:52 PDT
*** Bug 214648 has been marked as a duplicate of this bug. ***
Comment 9 User image Robert Accettura [:raccettura] 2003-08-03 11:46:19 PDT
Created attachment 129111 [details]
Proposition 1 of possible implementation

This is my first concept drawing of possible implementation.  Note there isn't
even an icon (I just used AIM).

To exmplain Functionality...

Send & Recieve Mail does just as the button does.  Sends and Recieves all mail.
 Possibly put an arrow to specify the specific account.

Compose a Message - self explanatory ;-)

Go To Inbox - goes to the first inbox in your profile.	Arrow allows you to
choose which inbox to go to.

Notifications -  Still to file a bug for this.	But it should give you the
option of turning notifications on/off.  Good for gamers.  Often the Mozilla
notifications cause game slowdowns if I forget to shutdown Mozilla.  Disabling
notification would be good.  Easy access makes it simple to do.

Address Book - Easy access to the good old Address Book

Switch Profiles - Says it all

Settings - Need I say more?

Exit - I wonder what this could do ;-D


Anyway... just to give an idea of what I was thinking.	Would be nice if it
also give Mozilla style notifications of Messages ("You have 1 new message").  


And of course an option to have it remain open and checking email when all
windows are closed.  So I don't need to have my email window open all day in
the taskbar.  Just keep it in the System Tray.	I'll open the window only when
I want to read my email.
Comment 10 User image Bryan 2003-08-04 18:39:56 PDT
I think the Proposition 1 of possible implementation would be perfect. The
reason it'd be nice to have in the system tray is because if you have it
checking for new mail every say 30 minutes then it has to be running which mean
it takes up more space then it would need to.
Comment 11 User image Oleg Sidletskiy 2003-08-14 06:57:34 PDT
I hope that this system tray client doesn't use much memory (right now TB is
open and is using around 25 MB of RAM). It should provide minimal mail checking
functionality and ability to launch real TB app. But if it does use more memory
(and there's no way around it) it'd be good if it acted partly like quick launch
on mozilla suite.
Comment 12 User image Jennifer Fackler 2003-08-24 00:01:22 PDT
This is a great idea; I was just about to suggest this myself when I found this.
 I really hope this makes it in.
Comment 13 User image Gilles Durys 2003-11-13 14:31:06 PST
*** Bug 225609 has been marked as a duplicate of this bug. ***
Comment 14 User image Robert Accettura [:raccettura] 2003-12-02 09:30:21 PST
CC --> mscott

I think there is enough backing in forums, and this bug.  Not to mention, the
functionality is pretty useful (especially on windows).  Being able to minimize
to the tray, and access popular features with ease is important.

I remember the mozillazine forum having a discussion on using third party
software to allow you to minimize to the tray (for those interested, search there).

Could we possibly target this bug?  I think this would prove to be a very useful
feature to many users/potential users.  I know I hate always having a window in
my taskbar on windows.  Waste of space.  Especially since my email is *always* open.
Comment 15 User image Jesse Ruderman 2003-12-06 22:06:36 PST
*** Bug 226309 has been marked as a duplicate of this bug. ***
Comment 16 User image Marc Richards 2003-12-07 10:56:53 PST
Sorry for the bug spam but I figure people might be interested in an interim
solution.  There is freeware application called trayit that lets you minimize
any application to the taskbar by right-clicking the close button.  This gives
you the best of both worlds in that you can choose to minimize to taskbar,
minimize to tray, or close the application. http://www.teamcti.com/trayit/trayit.htm

It only works on windows, it doesn't give any application options while
minimized and it doesn't reduce the memory footprint...but it's a start.
Comment 17 User image M.A. Oude Kotte 2003-12-16 05:53:29 PST
The sole purpose I registered here at bugzilla was to reqeuest this enhancement.
I really would love to see this feature implemented :) 
Comment 18 User image Richard Fine 2004-02-10 02:44:02 PST
I'd very much like to see this implemented, particularly the 'no appearance on
taskbar' side of thing. Another application I have open all day is Winamp, and
it allows me to set it not to take up any taskbar real-estate.

With regards to the eventual behaviour, I could see it as an extension to the
New Mail Notification icon thing - have one icon in the system tray when there's
no new mail, and a different icon when there is. Left-clicking on the icon
always brings up the TB main window, and right-clicking gives a context menu.
Comment 19 User image Amos Shapira 2004-02-24 06:04:34 PST
Just wanted to add support for this request. For all the good reasons already
given in its favour.
Comment 20 User image Kevin Teuscher 2004-02-27 20:00:28 PST
*** Bug 235890 has been marked as a duplicate of this bug. ***
Comment 21 User image Rene Pronk 2004-02-29 07:03:16 PST
*** Bug 235946 has been marked as a duplicate of this bug. ***
Comment 22 User image DiLDoG 2004-03-11 07:44:23 PST
thundertray does this trick for now:
http://fileforum.betanews.com/detail.php3?fid=1063659252

bould be nice to have it integrated in feature releases. (with the extra stuff
mentioned above)
Comment 23 User image Guillermo Cortes 2004-04-11 01:46:14 PDT
I think this is the only feature that is missing in thunderbird project, in 
fact it should be obligatory, but not only in microsoft plataforms but in all 
plataforms, mainly in linux or every OS that has a graphic enviroment.
Comment 24 User image Olaf van der Spek 2004-05-13 15:50:00 PDT
I want to add a "me too" to this feature request.
And I'd like to propose an (optional) shortcut key for the minimize to tray 
function: Escape.
Comment 25 User image Martin Meyer 2004-05-13 16:28:07 PDT
Wow, what a mind-reader you are! I was just thinking about that as I saw the new
mail icon in my system tray.  I think being able to set a global hotkey would be
a nice feature.  It should be configurable to whatever you want, and the same
key should either minimize or restore the window, whichever would be the oposite
of its current state.  However, this should probably be filed as a seperate bug.

I used Thundertray for a while (see comment 22) to have this functionality, but
it stopped working with one of the recent nightlies and I don't know if it's
just a problem with me or if something became incompatible.  Does anyone else know?

Also, any idea when this feature might make it in?  It would be a very useful
feature.
Comment 26 User image Zarco Zwier 2004-06-02 02:44:31 PDT
Thundertray has stopped working for me as well for the creator of Thundertray. 
I mailed him about this, but sadly, I have to announce, he won't be updating 
Thundertray anymore.
I'll be adding my vote for this bug, hoping someone will find the time for 
creating this very handy dandy feature :)
Comment 27 User image Teune van Steeg 2004-06-16 14:09:26 PDT
I just wanted to add a vote for this bug. I was sad to see it was not in the 0.7
release, hope it will be added by 1.0
Comment 28 User image Jakub Klawiter 2004-07-04 06:22:12 PDT
CC
Comment 29 User image Tommy Becker 2004-07-08 06:44:16 PDT
I too would like to vote for this "bug", I think it would be a great feature. 
For some reason, I can't seem to vote for it however.  What exactly is it that
makes a bug "voteable"?
Comment 30 User image Nickolay_Ponomarev 2004-07-27 10:38:06 PDT
See http://forums.mozillazine.org/viewtopic.php?t=104670
first *extension* that implements minimizing to systray (no context menu yet).
Comment 31 User image Olaf van der Spek 2004-08-12 04:57:48 PDT
The current (new mail) icon allows you to open the main window after a double 
click. How about opening it after just a single (left) click?
And about closing it if it's open already?
Comment 32 User image Jo Hermans 2004-08-24 13:26:11 PDT
*** Bug 256740 has been marked as a duplicate of this bug. ***
Comment 33 User image Michael Favia 2004-09-03 13:18:58 PDT
With no voting system implemented in this version of bugzilla. At least i dont
see it in here anywhere. I would like to add my name to the list of eager
systrayers. I dont even care if the memory foot print is reduced in the short
time frame. Removing the taskbar clutter alone would be nice.
Comment 34 User image Mikhail Lapkin 2004-09-15 01:46:09 PDT
"Me Too" comment.
Comment 35 User image Csaba Lack 2004-10-16 11:44:27 PDT
I think it would be the best if there is an option like in winamp where the user
can set which way he/she prefer.
Maybe: 
'Show icon in [] taskbar | [X] tray'
and ability to minimize to tray if it is checked. It can be both as well (not
radio button). It can be also a possiblity if both are checked... it could only
be minimized to taskbar.

Please sign this bug as will fix or won't fix! :) (I hope the first one)
Comment 36 User image Csaba Lack 2004-10-16 11:58:18 PDT
Finally I found this:
http://minimizetotray.mozdev.org/
It seems to me fine, but this is only another extension. Is it possible that
Thunderbird 1.0 include something similar?
Comment 37 User image Scott MacGregor 2004-10-25 13:56:41 PDT
not a 1. stop ship bug.
Comment 38 User image Davor Cubranic 2004-11-17 11:42:00 PST
I'm assuming the tray icon will keep the current "new mail" notification
functionality? Ideally, the icon could have a hover showing a quick overview of
the state of folders (e.g., read/total messages, like "Inbox 3/20") or subjects
and senders of new mail. PARC and MSR have had a number of research prototypes
with this kinds of notification in the last few years, and I think such features
are really useful.
Comment 39 User image Kyle Krafka 2004-11-18 20:37:01 PST
Even just minimizing Thunderbird to the tray (like Notepad2 can do, if you've
ever used it) would be useful.  A seperate client that uses less RAM would be
nicer.  Something like Gmail notifier.
Comment 40 User image Jo Hermans 2005-01-02 14:21:27 PST
*** Bug 276788 has been marked as a duplicate of this bug. ***
Comment 41 User image Doug Wright 2005-01-09 13:30:45 PST
*** Bug 272244 has been marked as a duplicate of this bug. ***
Comment 42 User image Brad Peterson 2005-01-17 15:32:34 PST
For what it's worth, many many hours have been spent on the design issues and
potential problems, and we've handled many of them in the MinimizeToTray extension. 
http://minimizetotray.mozdev.org/   If this feature ever gets worked on again,
contact me or Mook at the link I provided, and we can help you with what we've
seen so far.
Comment 43 User image Marek 2005-01-18 07:16:09 PST
(In reply to comment #42)
> For what it's worth, many many hours have been spent on the design issues and
> potential problems, and we've handled many of them in the MinimizeToTray
extension. 
> http://minimizetotray.mozdev.org/   If this feature ever gets worked on again,
> contact me or Mook at the link I provided, and we can help you with what we've
> seen so far.

the biggest problem with this solution (same with powermenu) is that if you have
just one firefox window and have firefox as default browser, if you click a link
for example in outlook, the link will open in that minimized to tray window
without any visual indication where it was opened (the window doesn't popup or
anything), if I didn't know that, I would say that default browser failed to
start and open that window. I switched back to mozilla where such problems don't
exist.
Comment 44 User image Jan Duchacek 2005-03-14 04:18:25 PST
It could be nice to similarly like MS Outlook when minimize to have onlz an icon
in the tray.
Comment 45 User image Mike Cowperthwaite 2005-03-15 13:35:08 PST
*** Bug 286293 has been marked as a duplicate of this bug. ***
Comment 46 User image Jeroen 2005-03-17 09:38:03 PST
I think more effort should go into implementing this feature in the upcoming
thunderbird release. The initial bugreport is almost 2 years old. Even MS
Outlook has this feature.

These kind of features determine how much the userbase will grow.

The plugin from minimizetotray.mozdev.org is a nice patch, but has very limited
features and should not be a plugin, it should be a standard feature of thunderbird.

Comment 47 User image Ankit Singla 2005-07-14 13:04:06 PDT
i agree with everyone on this. it should be a basic feature of thunderbird. and
i would like to recommend you make a feature request page for "bugs" like this
as gaim did on sourceforge.net because it's not really a bug.
Comment 48 User image Dima Kovalenko 2005-07-14 13:19:33 PDT
Yes, in the mean time i have found an alternative. There is this app called
"TrayIconizer". You can put the launch string for it in the shortcut of thunder
bird(or any other app) and when you minimize it,  the application goes straight
to the tray icon.
Comment 49 User image Matthew 2005-09-14 08:28:30 PDT
Yes I would also like a feature like this.
But also for sunbird because I use both Sunbird and Thunderbird but they take up
to much space ( I use linux)
Comment 50 User image Adam Guthrie 2005-10-16 11:30:13 PDT
*** Bug 312640 has been marked as a duplicate of this bug. ***
Comment 51 User image Josh Birnbaum 2005-11-01 16:57:25 PST
*** Bug 314656 has been marked as a duplicate of this bug. ***
Comment 52 User image Jo Hermans 2005-12-20 15:39:55 PST
*** Bug 320987 has been marked as a duplicate of this bug. ***
Comment 53 User image brian 2006-04-12 01:39:02 PDT
How about another option of closing Thunderbird completely leaving only a tray icon to notify you of new email?

The tray program can poll the mail servers at set intervals and notify you of new email on the server

It's only once when you double click the tray icon, it opens up the full-blown Thunderbird and downloads all your email.

The benefits of implementing this:
1. Minimal memory usage when Thunderbird is not in use.
2. Have control of when you download your emails.
3. Only download emails when you view them, so it does not suck up bandwidth in the middle of streaming/playing games thus causing lag when you dont want to.

Comment 54 User image Daniel Glazman (:glazou) 2006-05-03 07:26:44 PDT
This is perfectly feasible with the patch attached to bug 325353
Comment 55 User image Phil Ringnalda (:philor) 2006-11-13 17:18:38 PST
*** Bug 360618 has been marked as a duplicate of this bug. ***
Comment 56 User image Jonathan Pritchard 2007-04-21 15:56:54 PDT
I too think this is a vital feature. MinimizeToTray does the job to a degree but at present (Thunderbird 2.0) it does not work, and is inconsistent across Firefox/Thunderbird/Sunbird. Perhaps this feature should be integrated into the backend. I certainly see usage of this for Calendaring and Email, less so for web browsing.

If implemented wholesale it should allow for faster startup of the application, but reduced memory footprint when minimised to the tray.
Comment 57 User image bj3john4 2007-06-13 09:56:28 PDT
I am glad to find I am not alone on this one.  Being able to keep thunderbird open all day but in the systray would be a huge help.  Keeping it open on the task bar is cumbersome and outdated.  People with smaller monitors don't have room for this and shouldn't have to.
Comment 58 User image Magnus Melin [:mkmelin] 2007-08-03 09:38:09 PDT
*** Bug 390772 has been marked as a duplicate of this bug. ***
Comment 59 User image M. LaPlante 2007-12-25 22:18:03 PST
+100
Comment 60 User image Gary Kwong [:gkw] [:nth10sd] 2008-03-13 12:05:46 PDT
Nominating wanted-thunderbird3 due to number of dupes.
Comment 61 User image Alexander Wicht 2008-05-23 12:40:18 PDT
Still nothing to see from this feature in version 3.0a1.
I'd really appreciate having something like this in the future releases.
Comment 62 User image Henrik Skupin (:whimboo) [⌚️UTC+1] 2008-05-24 04:14:49 PDT
(In reply to comment #61)
> Still nothing to see from this feature in version 3.0a1.
> I'd really appreciate having something like this in the future releases.

Bug 325353 has to be fixed first before any work can be done here.
Comment 63 User image Wayne Mery (:wsmwk) 2008-06-24 13:28:28 PDT
*** Bug 423145 has been marked as a duplicate of this bug. ***
Comment 64 User image Tim 2008-07-30 16:48:59 PDT
I vote for this feature!

I want to know at any time, if I receive a new mail. And it's very annoying to have Thunderbird in the taskbar all the time
Comment 65 User image Mark Banner (:standard8) 2008-08-13 05:36:01 PDT
*** Bug 450399 has been marked as a duplicate of this bug. ***
Comment 66 User image Joshua Cranmer [:jcranmer] 2008-09-05 17:30:37 PDT
*** Bug 453911 has been marked as a duplicate of this bug. ***
Comment 67 User image jouan.y 2008-09-20 23:39:19 PDT
Hi all,

I absolutely agree with you.
I had this feature in Microsoft Outlook and I do not understand that Thunderbird wait so long to do it.

Bye
Comment 68 User image Armond Avanes 2008-10-02 00:28:12 PDT
Will we see this feature on v3.0 ?
Comment 69 User image Mark Banner (:standard8) 2008-10-15 07:37:13 PDT
*** Bug 460038 has been marked as a duplicate of this bug. ***
Comment 70 User image Magnus Melin [:mkmelin] 2008-10-23 11:57:43 PDT
wanted‑thunderbird3-; isn't likely to happen without bug 325353.
Comment 71 User image Tyler Downer [He/Him] 2008-11-29 10:18:55 PST
*** Bug 467164 has been marked as a duplicate of this bug. ***
Comment 72 User image u321714 2008-12-03 22:43:03 PST
any news? any progress?
guys, can we finally expect this feature for Thunderbird 3?
i´ve jsut read changes in Thunderbird 3.0 Beta 1 (http://www.rumblingedge.com/2008/11/26/thunderbird-30-beta-1-released/)and it´s not included, so far.
Comment 73 User image Marcin Nowak 2009-02-07 04:36:40 PST
I am trying out Thunderbird 3 Beta 1 - and I am really dissapointed that nobody works over that issue :/ still... it was created in 2003 - a long time ago - does any developer reading that? Could anybody post anything about reasons why that issue is still new/open? Even if it is hard to implement tray functionality, any information about that would nice.. Could it be included to thunderbird milestone?
Comment 74 User image u294409 2009-02-07 05:24:50 PST
Sorry if I sound rude, but... Don't spam.

If a developer will be interested, he'll/she'll do something then.
If noone is doing anything, you can just wait or vote (yes, there's such functionality in bugzilla).

Until Thunderbird gets official tray icon support, install FireTray extension.
Comment 75 User image Joshua Cranmer [:jcranmer] 2009-05-14 18:18:08 PDT
*** Bug 493105 has been marked as a duplicate of this bug. ***
Comment 76 User image Mark Banner (:standard8) 2009-05-15 01:21:31 PDT
*** Bug 493180 has been marked as a duplicate of this bug. ***
Comment 77 User image David Robert Lewis 2009-05-15 11:56:15 PDT
Firetray extension does not add any functionality. Thunderbird already minimises to the "tray" and this is surely a misunderstanding of the feature we are requesting in Ubuntu. Ubuntu Linux users would like to nest the application in the toolbar, which is in the top Gnome panel. Please see http://www.ubuntu.com
Comment 78 User image Minh Nguyễn 2009-05-15 12:04:18 PDT
If I'm not mistaken, "tray" in this bug refers to the Windows system tray.
Comment 79 User image David Robert Lewis 2009-05-15 12:39:17 PDT
Yes, Ubuntu has two panels in the default Gnome desktop. The top panel is a toolbar and the lower panel is where application "windows" sit. Minimising Thunderbird to the lower panel as a window, takes-up too much space on either one or more of the desktop's provided, and is not ideal. Very easy to loose Thunderbird and the application quits, or is closed by the user who then has to reopen, wasting time and energy and making nonesense of the notifications.

http://www.teamcti.com/trayit/trayit.htm
http://minimizetotray.mozdev.org/
http://fileforum.betanews.com/detail/Thundertray/1063659252/1#reviews

All of the above are Windoze solutions. Where is the Ubuntu Linux solution for
the Third World Ubuntu Community?

Any help on this, appreciated.
Peace.
Comment 80 User image David Robert Lewis 2009-05-15 12:46:54 PDT
Yes, Ubuntu has two panels in the default Gnome desktop. The top panel is a toolbar and the lower panel is where application "windows" sit. Minimising Thunderbird to the lower panel as a window, takes-up too much space on either one or more of the desktop's provided, and is not ideal. Very easy to loose Thunderbird and the application quits, or is closed and quit by the user who then has to restart, wasting time and energy in the process and making nonsense of the notifications. Solutions would be similar to Amarok or Transmission Bit-Torrent.

http://www.teamcti.com/trayit/trayit.htm
http://minimizetotray.mozdev.org/
http://fileforum.betanews.com/detail/Thundertray/1063659252/1#reviews


All of the above are Windoze solutions. Where is the Ubuntu Linux solution for
the Third World Ubuntu Community?

Any help on this, appreciated.
Peace.
Comment 81 User image Marcin Nowak 2009-05-15 22:57:41 PDT
I am looking into this issue and its... old... Created in 2003 - it is stated there that help is wanted :) anybody knows what is the problem with that issue? anything blocks implementation of that? I could help - maybe any of the watchers too - could someone provide technical description of difficulties making that issue unresolved so long? Maybe now is the time to focus on it - as I said I could help - but I need an introduction as I am new to Mozilla API :)
Comment 82 User image Steffen Wilberg 2009-05-16 00:24:29 PDT
(In reply to comment #80)
> Where is the Ubuntu Linux solution for the Third World Ubuntu Community?
The Firetray extension is for Linux:
http://code.google.com/p/firetray/

(In reply to comment #81)
> I am looking into this issue and its... old... Created in 2003 - it is stated
> there that help is wanted :) anybody knows what is the problem with that issue?
See bug 325353: Prism has already implemented this, but the code needs to be ported to toolkit, where it can be used by Firefox/Thunderbird etc.
http://svn.mozilla.org/projects/webrunner/trunk/components/src/windows/nsNotificationArea.cpp
Comment 83 User image Ludovic Hirlimann [:Usul] 2009-05-16 02:26:39 PDT
(In reply to comment #81)

> making that issue unresolved so long? Maybe now is the time to focus on it - as
> I said I could help - but I need an introduction as I am new to Mozilla API :)

Some instructions are provided at https://developer.mozilla.org/en/Comm-central . You can join the developers on http://irc.mozilla.org in #maildev.
Comment 84 User image David Robert Lewis 2009-05-19 05:38:00 PDT
I also requested this feature on launchpad, and you can follow the discussion here:

https://bugs.launchpad.net/ubuntu/+source/mozilla-thunderbird/+bug/376715
Comment 85 User image Phil Ringnalda (:philor) 2009-12-12 14:52:16 PST
*** Bug 534450 has been marked as a duplicate of this bug. ***
Comment 86 User image Mark Banner (:standard8) 2010-01-15 14:56:46 PST
*** Bug 540071 has been marked as a duplicate of this bug. ***
Comment 87 User image a_lipford 2010-01-15 15:41:43 PST
What is the deal with this? Is Mozilla just going to ignore this altogether? If Mozilla wants to pick up any market share, they should at least try and CATCH UP TO THE COMPETITION i.e. Outlook! Oh well I guess Thunderbird will always have to look up to Outlook in terms of features. What's new...
Comment 88 User image zug_treno 2010-02-14 07:15:39 PST
*** Bug 546061 has been marked as a duplicate of this bug. ***
Comment 89 User image LION 2010-05-27 02:46:22 PDT
I'm completely agree with a_lipford@yahoo.com. When really this simple function will be available. Thunderbird wants to be in first place, but it doesn't do anything.
Comment 90 User image Jim Porter (:squib) 2010-05-27 13:57:04 PDT
For Windows, as of Win7, Microsoft explicitly recommends *against* doing this:

"In this example from Windows Vista, Outlook and Windows Live™ Messenger are single-instance applications that minimize to notification area icons. ... Note: This icon pattern is no longer recommended for Windows 7. Use regular taskbar buttons instead if your program has desktop presence." [1]

Granted, Thunderbird currently doesn't have a lot of support for Windows 7 features (mostly because Gecko 1.9.1 doesn't support them either), but I think it would make more sense to put effort into Windows 7 support these days.

[1] http://msdn.microsoft.com/en-us/library/aa511448.aspx
Comment 91 User image Rimas Kudelis 2010-06-26 14:31:31 PDT
Jim,
for one, Thunderbird still supports older versions of Windows,
and then, this bug is still valid for Linux too.
Comment 92 User image Jim Porter (:squib) 2010-06-26 17:16:03 PDT
Even on Linux, this isn't always the right way to do it. As of Ubuntu Lucid, the recommended strategy is to use the Messaging Menu (this works on KDE and Gnome, assuming you have the menu installed) as opposed to the system tray. There are some guidelines for doing this here: https://wiki.ubuntu.com/MessagingMenu#Recommended%20behavior%20for%20e-mail%20clients

I don't know if the Messaging Menu dictates a particular behavior with regard to minimizing, but I do know that Evolution doesn't minimize to the tray/Messaging Menu, even though it does support the latter.

That's not to say that I think this should be WONTFIX, but rather that I think the other ways (that target newer platforms) should be prioritized.
Comment 94 User image Ludovic Hirlimann [:Usul] 2011-04-21 04:58:29 PDT
*** Bug 651833 has been marked as a duplicate of this bug. ***
Comment 95 User image spaceshipgalore 2011-07-31 01:21:38 PDT
please add this functionality guys, its annoying trying to find addons that work with new versions of thunderbird. Outlook has minimise the tray icon, so should thunderbird!
Comment 96 User image spaceshipgalore 2011-07-31 05:22:26 PDT
the source code for the add-on that adds support for minimising to tray icon is here, please integrate it into the thunderbird source code: https://tn123.org/mintrayr/
Comment 97 User image Blake Winton (:bwinton) (:☕️) 2011-08-05 14:06:11 PDT
I've been using Thunderbird on Windows for a long time now, and have always been annoyed by the need to get a third-party program to minimize it to the system tray.  Having said that, that option was always available, and recently the Thunderbird and Ubuntu developers have done a bit of work integrating Thunderbird into Ubuntu's messaging menu, so that platform is getting better, too.

I guess what I think I'm saying is that the people who are paid to work on Thunderbird are working on more important things, but I would love to see a patch from the community that fixes this.

(And now, hopefully everyone else who wants this feature but can't or doesn't want to do the work can stop commenting in this bug.  ;)

Thanks,
Blake.
Comment 98 User image Wayne Mery (:wsmwk) 2011-08-09 04:45:42 PDT
*** Bug 528858 has been marked as a duplicate of this bug. ***
Comment 99 User image Jim Porter (:squib) 2011-10-09 11:26:02 PDT
*** Bug 693176 has been marked as a duplicate of this bug. ***
Comment 100 User image Olaf van der Spek 2012-03-29 09:56:04 PDT
(In reply to Jim Porter (:squib) from comment #90)
> For Windows, as of Win7, Microsoft explicitly recommends *against* doing
> this:

MS is silly :p
I'm using Windows 7 and I'd still like to see a minimize to tray (with Escape as shortcut). I don't want to clutter my taskbar and alt-tab switcher.
Comment 101 User image Matthias Versen [:Matti] 2012-10-17 11:40:18 PDT
*** Bug 802533 has been marked as a duplicate of this bug. ***
Comment 102 User image spaceshipgalore 2014-05-27 01:56:25 PDT
Why has this feature still not been added, we've asked for this useful feature that all other email clients have for 11yrs now.
Comment 103 User image Wayne Mery (:wsmwk) 2014-05-27 04:53:46 PDT
Windows users can get this with https://addons.mozilla.org/en-us/thunderbird/addon/minimizetotray-revived/

If you are interested in this functionality but not interested in coding it the proper way to do this in bugzilla is to cc on the bug and/or vote without comment please
Comment 104 User image Wayne Mery (:wsmwk) 2016-10-23 14:53:23 PDT
*** Bug 854067 has been marked as a duplicate of this bug. ***
Comment 105 User image Wayne Mery (:wsmwk) 2016-10-23 14:54:38 PDT
*** Bug 1312282 has been marked as a duplicate of this bug. ***
Comment 106 User image Wayne Mery (:wsmwk) 2017-02-14 05:50:15 PST
*** Bug 1317934 has been marked as a duplicate of this bug. ***
Comment 107 User image Wayne Mery (:wsmwk) 2017-03-03 03:46:35 PST
*** Bug 1344146 has been marked as a duplicate of this bug. ***
Comment 108 User image Wayne Mery (:wsmwk) 2017-03-27 09:40:11 PDT
*** Bug 1350727 has been marked as a duplicate of this bug. ***
Comment 109 User image u592660 2017-03-28 06:18:09 PDT Comment hidden (abuse-reviewed, me-too)
Comment 110 User image u592660 2017-03-28 06:53:16 PDT
For all people bothering you need:

First (for minimizing to system tray at all):

https://addons.mozilla.org/en-us/thunderbird/addon/minimizetotray-revived/

Second (for minimizing to tray on startup):

https://addons.mozilla.org/de/thunderbird/addon/minimize-on-start-and-close/

Third (for starting thundebird with windows):

Under Win 10 use "Windows-Button + R" then type "shell:startup" then create a shotcut (e.g. to desktop) of Thunderbird and copy  it in the previously opened startup folder

For other OS google how to add a program to startup.

And fast as this Thunderbird doesn't even need to be on your taskbar at all!

PS.: I know its not a support forum but after 14 years maybe it's nice someone clears it up, as beeing the most easy and intuitve thing a program has to offer (start).
Comment 111 User image Mike Hoye [:mhoye] 2017-03-28 07:30:24 PDT
Old bug or not, Bugzilla is our professional working environment as much as it is our issue tracker, and abusive comments will not be tolerated.  Thunderbird is an entirely community-driven effort at this point, and abusive comments asking people who are volunteering their already-scarce time to build "this stupiditly nonsence easy feature" are not going to move a new feature forward so much as an inch, much less carry it over the finish line. 

I encourage you to read our etiquette and contributor guidelines, linked below the comment boxes in all Bugzilla bugs, and take them to heart. Should you decline to do so, my next step will be suspending your account.
Comment 112 User image spaceshipgalore 2017-03-28 07:37:12 PDT Comment hidden (advocacy)
Comment 113 User image u592660 2017-03-28 16:30:48 PDT Comment hidden (offtopic)
Comment 114 User image Wayne Mery (:wsmwk) 2017-09-03 08:14:34 PDT
*** Bug 217185 has been marked as a duplicate of this bug. ***
Comment 115 User image Zereges 2017-12-04 13:38:16 PST
All extension providing this functionality are no longer supported and their development is discontinued. Are there any updates on this feature?
Comment 116 User image dpolivaev 2017-12-23 03:20:22 PST
Add-on FireTray allowed not only to see the number of new mails but also informs about bew incoming chat messages. (https://foudfou.github.io/FireTray/)  Unfortunately this add-on is discontinued too. I really hope that this functionality can become natively supported by Thunderbird when the old add-ons stop working there.
Comment 117 User image spaceshipgalore 2018-05-07 04:05:29 PDT
Please add this functionality. Thunderbird 60 drops .xpi support, there are no longer any addons that work with thunderbird 60. The addon "Minimize to tray (revived)" (https://addons.mozilla.org/en-GB/thunderbird/addon/minimizetotray-revived/) is the 12th most popular addon. This very simple functionality needs adding to thunderbird.
Comment 118 User image Jim Porter (:squib) 2018-05-07 11:11:45 PDT
> Thunderbird 60 drops .xpi support

Where did you hear this? That's not true, and in fact I have a number of old-style extensions I develop that work just fine in Thunderbird 60+. However, add-ons will likely need some small updates for TB 60, so they've been marked as incompatible by default.
Comment 119 User image dpolivaev 2018-05-07 12:17:02 PDT
It would be great if somebody could port https://github.com/foudfou/FireTray which works under different OS (Linux and Windows) and is very easy and comfortable in use. Currently, AFAIK there is no solution for TB 60.
Comment 120 User image Wayne Mery (:wsmwk) 2018-05-24 18:08:18 PDT
*** Bug 1464201 has been marked as a duplicate of this bug. ***
Comment 121 User image ann0 2018-08-10 12:00:32 PDT
Just a reminder, as there is currently no working AddOn for Tray-Support anymore (all stopped working as of Thunderbird 60), this bug is still relevant, 15 years later. :)
Comment 122 User image meffovic 2018-08-19 00:19:57 PDT
I've been searching like crazy for a native "minimize to tray" function in TB 60, since the last version of 'MinimizeToTray' is deprecated - but i soon realized that there's no such function added.

So if there's someone that got the time (and the will ofc) and knowledge that could port https://github.com/foudfou/FireTray - i would be very happy, and i guess a lot of other ppl would be too!

I'm sorry for the echo, but i felt the thread needed a "bump".

Best regards, meffe
Comment 123 User image mkkot 2018-08-24 10:00:10 PDT
This is why author of FireTray deprecated the addon:
https://foudil.fr/blog/209/the-web-is-not-the-platform/

I looked at the source code and there are far more lines than I expected. I think there is a way to make this feature happen, and the way is to talk with the author if he accepts money for doing it. If yes, we could make a fundraiser. I think it happened many times before in open source. Since this ticket is so popular, we may have actually gather some considerable sum.
Comment 124 User image DoTheEvo 2018-08-29 13:36:19 PDT
Its incredible.
I can not understand this, do people around thunderbird actually use it?
Are they really running it just minimized or run it when they need it instead of in the background?
how can they just not have tray extension ready, or feature already build in?
Comment 125 User image ao 2018-08-29 13:43:09 PDT
It seems like tray icons may not be "modern enough" - see the link mkkot recently posted:
"GtkStatusIcon has been deprecated in 3.14. You should consider using notifications or more modern platform-specific APIs instead."
(Which is why raising money probably wouldn't help.)
Comment 126 User image james 2018-08-30 17:59:21 PDT
Is there any official acknowledgement from the TB team that this is a highly requested feature? If so, is there a response? Unfortunately the developers of the third party plugins have stopped supporting their extension. This is an important feature to me.
Comment 127 User image Magnus Melin [:mkmelin] 2018-08-30 23:24:01 PDT
Yes, the Thunderbird team is aware that many people want this.

Given Microsoft is recommending *against* doing this nowadays (comment 90), and on linux this isn't really a thing - I think reality is this is not going so happen.

Sorry, it's a thing of the past.
Comment 128 User image Robert Pollak 2018-08-31 00:49:02 PDT
Does anyone know of services that sit in the system tray, check IMAP servers for new mail and launch Thunderbird on double click? I'd need that for Windows 7+10 and Cinnamon Desktop.
Comment 129 User image Magnus Melin [:mkmelin] 2018-08-31 11:13:52 PDT
Got this from Clemens W:

Possible workaround: If you're using a window manager with workspaces and if you can live with Thunderbird sitting on its own workspace, maybe devilspie is a solution for you!

Example configuration file:
; ~/.devilspie/thunderbird.ds
( if
( is ( application_name ) "Thunderbird" )
( begin
( maximize )
( skip_tasklist )
( set_workspace 2 )
)
)
Comment 130 User image Wayne Mery (:wsmwk) 2018-09-11 10:46:30 PDT
*** Bug 1490360 has been marked as a duplicate of this bug. ***
Comment 131 User image Rimas Kudelis 2018-09-11 23:09:11 PDT
*** Bug 1490368 has been marked as a duplicate of this bug. ***
Comment 132 User image Andrei Hajdukewycz [:sancus] 2018-09-12 14:00:29 PDT
For those who really need this on Windows, https://github.com/benbuck/rbtray with the 'winkey+alt+down arrow' combination works  for minimizing Thunderbird to system tray.
Comment 133 User image :aceman 2018-09-17 05:17:09 PDT
This can also be set via GUI (System settings) in KDE desktop, to always open and keep Thunderbird on a specific virtual desktop (workspace), maximized. Then there is a setting to not show apps from other desktops in the taskbar. But TB icon will be present in the systray on all desktops.

On Windows this may be useful (and Outlook supports it at least up to version 2013), I'm not sure how the new "virtual desktops" in Windows 10 work.
Comment 134 User image :aceman 2018-09-17 12:22:10 PDT
Sorry, there would be no systray icon in my scenario.

Note You need to log in before you can comment on or make changes to this bug.