Bug 905436 (e10s-addons)

[Tracking] Add-on compatibility in electrolysis

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: billm, Unassigned)

Tracking

(Depends on 2 bugs, {addon-compat, meta})

unspecified
Points:
---
1257617, 1271553, 673569, 729662, 905439, 905441, 905443, e10s-abp, 930788, e10s-FVD, 946739, 946905, 946932, 947030, 952201, 972507, 980161, 987937, 990599, 990729, 996785, 997325, 998078, 999241, 1001746, 1002880, 1003653, 1003654, e10s-sdk, 1006330, 1008435, e10s-lastpass, 1012871, 1012883, 1014196, 1014227, 1014904, 1014986, 1017109, e10s-shims, 1027299, 1027967, 1037186, 1037190, 1037193, 1037197, 1037198, 1037200, 1040158, 1041071, 1041137, 1041139, 1041334, 1041457, e10s-1password, 1042587, 1042653, 1042675, e10s-tree-style-tab, 1042710, 1042712, 1042786, 1042965, 1043081, 1043297, 1043301, 1045971, 1045984, 1046044, 1046053, 1046157, 1046426, 1046526, 1047175, 1047248, 1047257, 1047422, 1047432, 1047547, 1047558, 1047587, 1047608, 1047615, 1047654, 1047656, 1047657, 1047669, 1047789, 1047797, 1048057, 1048164, 1048511, 1048755, 1048968, 1049284, 1049928, 1049959, 1049962, 1049968, 1049970, 1050869, 1053007, 1053063, 1054094, 1054737, 1055019, 1055659, 1056318, 1056609, 1057105, 1057107, 1057467, 1057574, 1057776, 1058320, 1058448, 1058496, 1058513, 1058525, 1058530, 1058532, 1058538, e10s-noscript, 1058544, 1058594, 1058698, 1058824, 1058862, 1058866, 1059197, 1059199, 1059207, 1059210, 1059272, 1059412, 1059415, 1059855, 1059889, 1060367, 1060907, 1061277, 1062024, 1062199, 1062555, 1062742, 1063186, 1063221, 1065110, 1065778, 1065811, 1065881, 1066217, 1066223, 1066328, 1066355, 1066401, 1066598, 1066623, 1066683, 1066842, webext-port-avira, 1066983, 1066986, 1066987, 1067090, 1067184, 1067350, 1067615, 1068060, 1068369, 1068383, 1068385, 1068387, 1068391, 1068403, 1068404, 1068405, 1068406, 1068555, 1068824, 1068910, 1069505, 1069513, 1069524, 1070052, 1070449, 1070516, 1070726, 1070728, 1072028, 1072222, 1072228, 1072821, 1072980, 1073623, 1073817, 1074463, 1075249, 1075613, 1077185, 1077972, 1078121, 1081467, 1081468, 1081469, 1081471, 1081472, 1081474, 1081563, 1081856, 1081879, 1082532, 1082721, 1084318, 1085711, 1086647, e10s-lazarus, 1088309, 1091924, 1092558, 1094631, 1094636, 1095484, 1095501, 1095655, 1095748, 1095823, 1095945, 1096030, 1096056, 1096083, 1097155, 1097164, 1097172, 1097219, 1097530, 1097532, 1097612, 1097623, 1097720, 1098262, 1098688, 1098808, 1099476, 1099477, 1099508, 1099617, 1099976, 1100035, 1100254, 1100309, 1100312, 1100400, 1100743, 1100918, 1100948, 1100955, 1101154, 1101182, e10s-ghostery, 1101815, 1102373, 1102407, 1102410, e10s-wot, 1102552, 1102683, 1103458, 1103959, 1105236, 1105242, 1106244, 1106271, 1106486, 1106508, 1106535, 1106672, 1106708, 1107399, 1107467, 1108410, 1108491, 1108549, 1108827, 1110123, 1110706, 1111394, 1112766, 1113040, 1113294, 1113967, 1114946, 1114950, 1114953, 1114959, 1118289, 1118406, 1119592, 1121271, 1122083, 1122921, 1123061, 1123130, 1123152, 1123756, 1125257, 1125595, 1125897, 1126254, 1126421, 1127003, 1127744, 1127881, 1128137, 1129957, 1131065, 1134137, 1135311, 1135328, 1135381, 1137360, 1138105, 1138107, 1138108, 1138111, 1138113, 1138114, 1138116, 1138118, 1138706, 1142985, 1143041, 1143179, 1143228, 1145855, 1147327, 1147840, 1148819, 1150264, 1150395, 1151287, 1151335, 1153256, 1153430, 1153506, 1153977, 1154197, 1154662, 1155996, 1156116, 1156124, 1156616, 1157132, 1158480, 1160748, 1160910, 1161290, 1161418, 1161597, 1161798, 1163480, 1164014, 1165558, 1165638, 1165644, 1165714, 1165720, 1165847, 1165913, 1165916, 1165977, 1166137, 1166434, 1166453, 1166517, 1166642, 1166927, 1167362, 1167371, 1167424, 1167441, 1167609, 1167802, 1167810, 1167981, 1168384, 1168597, 1168713, 1168714, 1168768, 1168786, 1169841, 1171391, 1171545, 1171562, 1171589, 1172415, 1172592, 1173477, 1174433, 1174436, 1174451, 1174454, 1174456, 1174459, 1174513, 1174737, 1176660, 1177092, 1177151, 1177475, 1178000, 1178003, e10s-devdoc-lies, 1180473, 1180541, 1180817, 1181070, 1183430, 1183574, 1184304, 1184493, e10s-tab_mix_plus, e10s-stylish, e10s-µBlock, 1186190, 1186548, 1187065, 1187191, 1187365, 1187448, 1187580, 1188828, 1188835, 1188837, 1188912, 1189385, 1189419, 1189571, 1189779, 1189846, 1190714, e10s-flashblock, 1192585, 1193229, 1194942, 1194970, 1195148, 1195689, 1195963, 1195991, 1196270, 1197558, 1197583, 1198027, 1198032, 1198281, 1202125, 1202695, 1202894, 1207482, 1211043, 1212034, 1212804, 1213112, 1214032, 1215793, 1215867, 1215873, 1216032, 1220813, 1221148, 1224429, 1227839, 1228360, 1228979, 1229093, 1229463, 1230062, 1230650, 1230760, 1230870, 1231990, 1232052, 1232081, 1233713, 1237255, 1237884, 1238856, 1239767, 1242224, 1243035, 1243625, e10s-HUAC, 1246349, 1246906, 1246910, 1247402, 1247879, 1247918, 1248120, 1248143, 1248292, 1248394, 1249929, 1250140, 1250364, 1250469, 1252204, 1254924, 1255521, 1255523, 1256468, 1256602, 1257391, 1258058, 1259918, 1260462, 1261119, 1261221, 1261227, 1261315, 1261585, 1264383, 1264402, 1264896, 1265804, 1268063, 1268978, 1270924, 1271462, e10s-awesome, 1271845, 1272423, 1273187, 1274592, 1274594, 1275227, 1275277, 1278099, 1278213, 1278525, 1279094, 1279668, 1280068, 1280270, e10s-addons-deploy, 1282041, 1283342, 1284154, 1286015, triaged-tracking, 1287160, tabs-e10s, 1287626, 1287659, 1288874, 1293116, 1295198, 1299408, 1300829, 1301006, 1304359, 1308332, 1310316, 1315331, 1320470, 1322122, 1323358, 1328865, 1344007, 1344606, 1395437
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

It seems like a good idea to have a separate tracking bug for addon compatibility. All the hooks and stuff that we need to add for various addons can go here. Low-level CPOW stuff should still go in bug core-e10s.
Component: General → Extension Compatibility
OS: Linux → All
Hardware: x86_64 → All
Depends on: 673569
Depends on: 930164
Depends on: e10s-abp
Depends on: 930788
Depends on: e10s-FVD
Depends on: 946905
Depends on: 946932
Depends on: 947030

Updated

6 years ago
Depends on: 946739
Depends on: 952201
Depends on: 949079
Depends on: 972507
Depends on: 978961
Depends on: 978963
Depends on: 980161
Depends on: 987937
Depends on: 987949
Depends on: 990729
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
Depends on: 996785
Depends on: 997808
Depends on: 999241
Depends on: 1001746
Depends on: 1002880
Depends on: 1003653
Depends on: 1006330
Depends on: 1007978
Depends on: 1007982

Updated

5 years ago
Depends on: 690570

Updated

5 years ago
Depends on: e10s-lastpass

Updated

5 years ago
Duplicate of this bug: 1011927

Updated

5 years ago
Depends on: 1012871
InFormEnter addon crashes everytime one selects an option in a form on a Electrolysis page
Depends on: 1012883
Daniel: Thanks for reporting the InFormEnter crash. I filed a new bug report for your crash. If you have any crash report links in your Firefox about:crashes page, please share them on that bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1012883
Depends on: 998078
Depends on: 1013744
No longer depends on: 1007982
No longer depends on: 1007978
Depends on: 1014986
No longer depends on: 946739
No longer depends on: 978963
No longer depends on: 997808
No longer depends on: 978961
(In reply to Chris Peterson (:cpeterson) from comment #4)
> Daniel: Thanks for reporting the InFormEnter crash. I filed a new bug report
> for your crash. If you have any crash report links in your Firefox
> about:crashes page, please share them on that bug:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1012883

Thanks pal!
Depends on: 1014227
Depends on: 1014904
No longer depends on: 1013744
Depends on: 1027967

Updated

5 years ago
Depends on: 1037186

Updated

5 years ago
Depends on: 1037190

Updated

5 years ago
Depends on: 1037193

Updated

5 years ago
Depends on: 1037197

Updated

5 years ago
Depends on: 1037198

Updated

5 years ago
Depends on: 1037200
Depends on: 1041139
Depends on: 1041071
Depends on: 1041334

Comment 6

5 years ago
On arewee10syet.com, bug 1013744 is set as if Greasemonkey isn't working with e10s, but bug 1013744 comment 1 clarified that it's a Firefox-bug.

Which is correct?
Thanks, Elbart! It looks like bug 1013744 does not involve Greasemonkey so I remove that bug from the addon list on arewee10syet.com. If you find any Firefox problems with your Greasemonkey scripts, file a bug or drop by the #e10s IRC channel on irc.mozilla.org.

Updated

5 years ago
Depends on: e10s-1password

Updated

5 years ago
Depends on: 1041137

Updated

5 years ago
Depends on: 1042712

Updated

5 years ago
Depends on: 1042786

Updated

5 years ago
Depends on: 1043297

Updated

5 years ago
Depends on: 1043301
Depends on: 1042675
Depends on: 1042710
Depends on: 1043081
Depends on: 1014196

Updated

5 years ago
Depends on: 1045971
Depends on: 1045984

Updated

5 years ago
Depends on: 1046157
Depends on: 1046053
Depends on: 1046044
Depends on: 1046174
No longer depends on: 1046174

Updated

5 years ago
Depends on: 1046426
Depends on: 1046526
Depends on: 1047175
Depends on: 1047248

Updated

5 years ago
Depends on: 1047432

Updated

5 years ago
Depends on: 1047587
Depends on: 1047615
Depends on: 1047643
Depends on: 1047669
Depends on: 1047422
Depends on: 1047558
Depends on: 1047257
Depends on: 1047657
Depends on: 1047656
Depends on: 1047654
Depends on: 1047789
No longer depends on: 1047643
No longer depends on: 1047656
Depends on: 1048164
Depends on: 1048057
Depends on: 1047797
Depends on: 1048511
Depends on: 1047547
Depends on: 1047656
Depends on: 1048968

Updated

5 years ago
Depends on: 1048755

Updated

5 years ago
Depends on: 1049284
Depends on: 1049928
Depends on: 1049959
Depends on: 1049961
Depends on: 1049968
Depends on: 1049970
Depends on: 1049962
Depends on: 1050209
Depends on: 1053007
Depends on: 1053063
Depends on: 1003654

Updated

5 years ago
Depends on: 1054737

Updated

5 years ago
Depends on: 1055019

Updated

5 years ago
No longer depends on: 1054737

Updated

5 years ago
Depends on: 1054737

Updated

5 years ago
Depends on: 1056609

Updated

5 years ago
Depends on: 1051238
Depends on: 1057105

Updated

5 years ago
Depends on: 1057107

Updated

5 years ago
Depends on: 1057574
Depends on: 1057776
Depends on: 1058448

Updated

5 years ago
Depends on: 1058496

Updated

5 years ago
Depends on: 1058513

Updated

5 years ago
Depends on: 1058525

Updated

5 years ago
Depends on: 1058530

Updated

5 years ago
Depends on: 1058538

Updated

5 years ago
Depends on: 1058544

Updated

5 years ago
Depends on: e10s-noscript
Depends on: 1058824
Depends on: 1008435

Updated

5 years ago
Depends on: 1058862

Updated

5 years ago
Depends on: 1058866
Depends on: 1058594

Updated

5 years ago
Depends on: 1059197

Updated

5 years ago
Depends on: 1059199

Updated

5 years ago
Depends on: 1059207

Updated

5 years ago
Depends on: 1059210
Depends on: 1059272
Depends on: 1059855
Depends on: 1059412
Depends on: 1059415

Updated

5 years ago
Depends on: 1058698

Updated

5 years ago
Depends on: 1060907
Depends on: 1060367

Updated

5 years ago
Depends on: 1061277

Updated

5 years ago
Depends on: 1062199
Depends on: 1059889
Depends on: 1065811
Depends on: 1063221
Depends on: 1066223

Updated

5 years ago
Depends on: 1062024
Depends on: 1065110
Depends on: 1065778
Depends on: 1066328

Updated

5 years ago
Depends on: 1066401
Depends on: 1066355
Depends on: 1066598

Updated

5 years ago
Depends on: 1066623
Depends on: 1066842

Updated

5 years ago
Depends on: 1067184
Depends on: 1067615
Depends on: 1066986

Updated

5 years ago
Depends on: 1068060
Depends on: 1068406
Depends on: 1068405
Depends on: 1068404
Depends on: 1068403
Depends on: 1068391
Depends on: 1068387
Depends on: 1068385
Depends on: 1068383
Depends on: 1068369
Depends on: 1057467

Updated

5 years ago
Depends on: 1068555

Updated

5 years ago
No longer depends on: 690570
Depends on: 1069524
Depends on: 1067090
Depends on: 1069513

Updated

5 years ago
Depends on: 1069505
Depends on: 1068824
No longer depends on: 1068824

Updated

5 years ago
Depends on: 1070449

Updated

5 years ago
Depends on: 1070516

Updated

5 years ago
Depends on: 1070728

Updated

5 years ago
Depends on: 1070726
Depends on: 1067350

Updated

5 years ago
Depends on: 1070052
Depends on: 1072028

Updated

5 years ago
Depends on: 1072222

Updated

5 years ago
Depends on: 1072228
Depends on: 1073623

Updated

5 years ago
No longer depends on: 1049961

Updated

5 years ago
Depends on: 1073817
Depends on: 1074463

Updated

5 years ago
Depends on: 1075613
Depends on: 1077185
Depends on: 1075249
Depends on: 1081467

Updated

5 years ago
Depends on: 1081468

Updated

5 years ago
Depends on: 1081469

Updated

5 years ago
Depends on: 1081471

Updated

5 years ago
Depends on: 1081472

Updated

5 years ago
Depends on: 1081474

Updated

5 years ago
Depends on: 1081563
Depends on: 1081879
Depends on: 1081991

Updated

5 years ago
No longer depends on: 1081991

Updated

5 years ago
Depends on: 1082532

Updated

5 years ago
Depends on: 1082721
Depends on: 1083545

Updated

5 years ago
Depends on: 1086647

Updated

5 years ago
Depends on: 1089090
Depends on: 1088309

Updated

5 years ago
No longer depends on: 1089090
Depends on: 1058532
Depends on: 1077972
Depends on: 1091924

Updated

5 years ago
Depends on: 1094631
Depends on: 1072980

Updated

5 years ago
Depends on: 1095655

Updated

5 years ago
Depends on: 1096030

Updated

5 years ago
Depends on: 1096056
Depends on: 1095484
Depends on: 1095748
Depends on: 1095945
Depends on: 1097155

Updated

5 years ago
Depends on: 1097530
Depends on: 1097612
Depends on: 1097623
Depends on: 1098262
Depends on: 1097164

Updated

5 years ago
No longer depends on: e10s-lazarus

Updated

5 years ago
Depends on: e10s-lazarus

Updated

5 years ago
Depends on: 1099508

Updated

5 years ago
Depends on: 1099476
Depends on: 1099976

Updated

5 years ago
Depends on: 1100309
Depends on: 1095823

Updated

5 years ago
Depends on: 1100400

Updated

5 years ago
Depends on: 1100254
Depends on: 1099617

Updated

5 years ago
Depends on: 1100955
Depends on: 1100743

Updated

5 years ago
Depends on: 1101154
Depends on: 1099477
Depends on: 1100312
Depends on: 1100948
Depends on: 1100918
Depends on: 1102407
Depends on: 1102410
Depends on: e10s-wot

Updated

5 years ago
Depends on: 1101815

Updated

5 years ago
Depends on: 1103458

Updated

5 years ago
Depends on: 1103959
Depends on: 1102552

Updated

5 years ago
Depends on: 1105242

Updated

5 years ago
Depends on: 1105236

Updated

5 years ago
Depends on: 1106244
Depends on: 1106486
Depends on: 1106672

Updated

5 years ago
Depends on: 1106708
Depends on: 1107399
Depends on: 1040158
Depends on: 1108491
Depends on: 1106508
Depends on: 1106535
Depends on: 1108549

Updated

5 years ago
Depends on: 1110123
Depends on: 1108827
Depends on: 1111394
Depends on: 729662
Depends on: 1111484

Updated

5 years ago
Depends on: 1112611

Updated

5 years ago
Depends on: 1112766

Updated

5 years ago
Depends on: 1113040
No longer depends on: 1112611

Updated

5 years ago
Depends on: 1113967

Updated

5 years ago
Depends on: 1114946

Updated

5 years ago
Depends on: 1114950

Updated

5 years ago
Depends on: 1114953

Updated

5 years ago
Depends on: 1114959

Updated

4 years ago
Depends on: 1108410

Updated

4 years ago
Depends on: 1121271
Depends on: 1122083
Depends on: 1118406

Updated

4 years ago
Depends on: 1123061

Updated

4 years ago
Depends on: 1125257

Updated

4 years ago
Depends on: 1125595

Updated

4 years ago
Depends on: 1126421

Updated

4 years ago
Depends on: 1127003

Updated

4 years ago
Depends on: 1119592

Updated

4 years ago
Depends on: 1127881
No longer depends on: 930164
Depends on: 1129957
Depends on: 1131065

Updated

4 years ago
Depends on: 1134137
Depends on: 1137360

Updated

4 years ago
Depends on: 1138706

Updated

4 years ago
Depends on: 1142985

Updated

4 years ago
Depends on: 1143041
Depends on: 1143179
Depends on: 1143228
No longer depends on: 1143179

Updated

4 years ago
Depends on: 1143179

Updated

4 years ago
Depends on: 1145855
Depends on: 1147327
Depends on: 1148819
Depends on: 1150264

Updated

4 years ago
Depends on: 1153430
Depends on: 1153506

Updated

4 years ago
Depends on: 1153977
Depends on: 1151287
Depends on: 1153256

Updated

4 years ago
Depends on: 1155996

Updated

4 years ago
Depends on: 1156116

Updated

4 years ago
Depends on: 1156616

Updated

4 years ago
Depends on: 1078121
Depends on: 1156124

Updated

4 years ago
Depends on: 1158480

Updated

4 years ago
Depends on: 1160748
Depends on: 1160910

Updated

4 years ago
Depends on: 1161418
Depends on: 1161597

Updated

4 years ago
No longer depends on: 1161597
Depends on: 1161290
Depends on: 1163480

Updated

4 years ago
Depends on: 1165558

Updated

4 years ago
Depends on: 1165720

Updated

4 years ago
Depends on: 1165847

Updated

4 years ago
Depends on: 1165916

Updated

4 years ago
Depends on: 1165913
Depends on: 1165714
Depends on: 1165644
Depends on: 1165638

Updated

4 years ago
Depends on: 1166137
Depends on: 1165977

Updated

4 years ago
Depends on: 1166453
Depends on: 1166434
Depends on: 1166517
Depends on: 1167424
Depends on: 1167362

Updated

4 years ago
Depends on: 1167810

Updated

4 years ago
Depends on: 1167989

Updated

4 years ago
Depends on: 1167981
Depends on: 1166642
Depends on: 1168384

Updated

4 years ago
Depends on: 1168713

Updated

4 years ago
Depends on: 1168714

Updated

4 years ago
Depends on: 1168768
Depends on: 1168786

Updated

4 years ago
Depends on: 1169841

Updated

4 years ago
Depends on: 1171545

Updated

4 years ago
Depends on: 1172415

Updated

4 years ago
Depends on: 1173477
Depends on: 1174359

Updated

4 years ago
Depends on: 1174433

Updated

4 years ago
Depends on: 1174436

Updated

4 years ago
Depends on: 1174737

Updated

4 years ago
Depends on: 1174459

Updated

4 years ago
Depends on: 1174456

Updated

4 years ago
Depends on: 1174454

Updated

4 years ago
Depends on: 1174451

Updated

4 years ago
Depends on: 1174513
Depends on: 1177092
Depends on: 1177151